Répondre à la discussion
Affichage des résultats 1 à 26 sur 26

MOSFET en commutation, problème de MOSFET

  1. #1
    inspectah

    MOSFET en commutation, problème de MOSFET

    Bonjour,

    Dans le cadre de la construction d'un amplificateur HF, j'ai besoin de réaliser plusieurs montages avec des MOSFET utilisés en commutation. Pour le moment j'ai le montage très basique suivant, réalisé avec LTspice (sinus 10 Vpp 500Hz sur la grille, Vds = 25V) :

    fs1.png

    (en bleu l'entrée en vert la sortie)

    Théoriquement il n'y a pas de soucis, le MOSFET se sature et j'obtiens un signal carré d'amplitude 25V sur le Drain, tout va bien.

    Seulement quand je passe sur plaque d'essai j'obtiens des résultats très bizarres. J'utilise le montage suivant avec les mêmes valeurs pour Vgs et Vds et pour les résistances :

    (cable rouge pour l'alim continu, jaune pour alternatif)

    fs2.jpg

    Ce que je constate c'est que le transistor se comporte comme s'il n'était pas polarisé, j'obtiens un signal sinusoidal en sortie de très faible amplitude et avec la même phase que la sinusoïde de grille. Pas de saturation, en fait le transistor se comporte comme une grosse résistance.

    J'utilise un transistor FQP30N06L de Fairchild, qui a sensiblement les mêmes caractéristiques que le Mosfet utilisé dans Lt spice, voici le lien de sa notice :

    https://www.fairchildsemi.com/datash.../FQP30N06L.pdf

    A priori je pense que Vgs = 10 Vpp et Vds = 25V est largement suffisant pour le mettre en commutation... D'ou mon incompréhension. Et de toute façon je n'observe aucun autre effet...

    Est ce que quelqu'un peut m'aider ?

    Merci !

    -----

    Dernière modification par Antoane ; 10/05/2016 à 19h42. Motif: Rapatriement des PJ sur le serveur

  2. Publicité
  3. #2
    DAUDET78

    Re : MOSFET en commutation, problème de MOSFET

    Quelle est le signal sur la grille ? fabriqué par quoi ?
    Quelle est le signal sur le drain ?
    Dans le cadre de la construction d'un amplificateur HF
    500 Hz, c'est de la BF !
    Dernière modification par DAUDET78 ; 10/05/2016 à 16h10.
    L'age n'est pas un handicap .... Encore faut-il arriver jusque là pour le constater !

  4. #3
    inspectah

    Re : MOSFET en commutation, problème de MOSFET

    Oui je teste le montage en BF pour le moment, je débute avec les MOSFET et je préfère commencer simple.

    Le signal sur la grille est une sinusoide de 500 Hz que je fais varier entre 4 et 10Vpp qui provient d'un générateur de fonction Rigol.
    Le signal sur le drain est un signal continu de 25V qui provient d'un générateur continu National Instruments.

  5. #4
    DAUDET78

    Re : MOSFET en commutation, problème de MOSFET

    Donne des photos d'oscilloscope des deux signaux : sur la grille, sur le drain, versus la source
    L'age n'est pas un handicap .... Encore faut-il arriver jusque là pour le constater !

  6. #5
    inspectah

    Re : MOSFET en commutation, problème de MOSFET

    Merci pour ton aide.

    Alors voilà :

    Grille :
    fs1.png

    Drain :
    fs2.png

    Source :
    fs3.png

    Le tout avec un signal continu de 25V. Je ne comprends pas du tout pourquoi mes signaux de grille et de drain sont similaires ? Peut être ma polarisation qui est mauvaise ?

    Merci de ton aide
    Dernière modification par Antoane ; 10/05/2016 à 19h44. Motif: Rapatriement des PJ sur le serveur

  7. #6
    DAUDET78

    Re : MOSFET en commutation, problème de MOSFET

    - Ton signal sur la grille est insuffisant ( 4V crête, le NMOS ne le voit même pas)
    - Sur la source, tu devrais rien avoir. Elle est reliée au 0V

    PS : fait toujours tes mesures avec l'oscilloscope en position DC
    L'age n'est pas un handicap .... Encore faut-il arriver jusque là pour le constater !

  8. #7
    inspectah

    Re : MOSFET en commutation, problème de MOSFET

    Merci pr ta réponse.

    J'ai bien la tension que je t'ai montré sur ma source et cette dernière est bien câblée comme sur la photo de la plaque d'essai. Est ce un problème de masse du coup ?

    Pourquoi je dois mettre l'oscillo en position DC alors que je fais des mesures de signaux alternatifs ?

    Merci

  9. #8
    DAUDET78

    Re : MOSFET en commutation, problème de MOSFET

    Citation Envoyé par inspectah Voir le message
    J'ai bien la tension que je t'ai montré sur ma source et cette dernière est bien câblée comme sur la photo de la plaque d'essai. Est ce un problème de masse du coup ?
    Ben oui, tu as un problème de câblage

    Pourquoi je dois mettre l'oscillo en position DC alors que je fais des mesures de signaux alternatifs ?
    En position DC, tu vois exactement le signal, y compris la composante continue !
    - Sur la source , tu vas voir un signal alternatif avec valeur moyenne à 0V
    - Sur le drain, tu vas voir un signal patatoïde rectangulaire compris entre 0 et 24V
    L'age n'est pas un handicap .... Encore faut-il arriver jusque là pour le constater !

  10. #9
    HULK28

    Re : MOSFET en commutation, problème de MOSFET

    Tu as un générateur sinus ayant un pôle relié à la masse du générateur 25V, donc c'est normal que tu aies ce que tu visualises sur la source, elle suit le signal d'entrée.
    Il faut utiliser l'offset de ton géné pour être entre 0 et xV et ainsi que les 2 géné aient le même référentiel à 0.
    "Le temps met tout en lumière." Thalès

  11. #10
    DAUDET78

    Re : MOSFET en commutation, problème de MOSFET

    Citation Envoyé par HULK28 Voir le message
    donc c'est normal que tu aies ce que tu visualises sur la source, elle suit le signal d'entrée.
    La source devrait être au 0V . Voir le schéma en #1
    L'age n'est pas un handicap .... Encore faut-il arriver jusque là pour le constater !

  12. #11
    HULK28

    Re : MOSFET en commutation, problème de MOSFET

    Oui elle devrait mais il n'y est pas vu qu'elle est relié au géné qui lui est sinus, entre -5V et +5V...
    "Le temps met tout en lumière." Thalès

  13. #12
    HULK28

    Re : MOSFET en commutation, problème de MOSFET

    Si j'en crois son appli sous LTSpice qu'il a posté.
    "Le temps met tout en lumière." Thalès

  14. #13
    DAUDET78

    Re : MOSFET en commutation, problème de MOSFET

    Citation Envoyé par HULK28 Voir le message
    Si j'en crois son appli sous LTSpice qu'il a posté.
    Ben moi, je ne vois pas la même chose .
    Je vois une source au 0V qui est reliée au 0V du générateur et au 0V de l'alimentation 24V .
    L'age n'est pas un handicap .... Encore faut-il arriver jusque là pour le constater !

  15. #14
    HULK28

    Re : MOSFET en commutation, problème de MOSFET

    Oui en effet, au temps pour moi..

    Sur la photo de son montage je crois voir un anneau orange sur les 2 résistances, donc 10K, tu vois quoi toi?
    Si ce sont bien des 10K normal que ça ne fonctionne pas.
    "Le temps met tout en lumière." Thalès

  16. #15
    DAUDET78

    Re : MOSFET en commutation, problème de MOSFET

    10K ou 1K ? pas facile à lire. Mais ça change quasiment rien au fonctionnement .
    C'est la source qui est en l'air qui plante le montage
    L'age n'est pas un handicap .... Encore faut-il arriver jusque là pour le constater !

  17. #16
    HULK28

    Re : MOSFET en commutation, problème de MOSFET

    Si c'est bien 10K le simulateur indique un résultat identique à ce qu'il décrit.
    "Le temps met tout en lumière." Thalès

  18. #17
    HULK28

    Re : MOSFET en commutation, problème de MOSFET

    Sauf sur son relevé sur la source évidemment.
    En tout cas rien sur le drain ce qui se comprend, juste une ondulation résiduelle, le MOS n'a pas le temps de conduire avec une 10K à 500Hz et 5V, le courant de grille est bien trop faible pour charger la capa d'entrée.
    Dernière modification par HULK28 ; 10/05/2016 à 20h52.
    "Le temps met tout en lumière." Thalès

  19. #18
    DAUDET78

    Re : MOSFET en commutation, problème de MOSFET

    Citation Envoyé par HULK28 Voir le message
    le MOS n'a pas le temps de conduire avec une 10K à 500Hz
    Avec une capa d'entrée de 2nF pour le NMOS, on a un RC de 0,2ms . Ca ne gêne pas le 500Hz
    L'age n'est pas un handicap .... Encore faut-il arriver jusque là pour le constater !

  20. #19
    HULK28

    Re : MOSFET en commutation, problème de MOSFET

    Avec 500µA max de courant et avec 5V max en entrée un gros MOS comme ça sera mal commandé dans ces conditions, les capacités parasites vont freiner la conduction vu qu'elle ne seront pas chargées avec suffisamment de courant au moment voulu.
    Les valeurs dans la doc sont données selon une condition "normale" avec un modèle de test.
    La capa de grille est quasi constante,par contre pas celles entre grille et drain et entre drain et source, leurs valeurs dépendent de la tension, elles sont fortement non linéaires.
    La capa Miller en particulier ne sera pas chargée avec un si petit courant, donc pas de conduction du canal possible.
    C'est pour ça qu'un MOS se commande TOUJOURS avec une source de tension à basse impédance.
    Dernière modification par HULK28 ; 10/05/2016 à 21h47.
    "Le temps met tout en lumière." Thalès

  21. #20
    DAUDET78

    Re : MOSFET en commutation, problème de MOSFET

    Citation Envoyé par HULK28 Voir le message
    La capa Miller en particulier ne sera pas chargée avec un si petit courant, donc pas de conduction du canal possible.
    Bon, ce n'est qu'une simulation (MicroCap 9) avec un gros NMOS
    NMOS switch Rgrille 100 1000 10000_Simu_Schema.jpg
    C'est pour ça qu'un MOS se commande TOUJOURS avec une source de tension à basse impédance.
    Ca, c'est ben vrai !
    L'age n'est pas un handicap .... Encore faut-il arriver jusque là pour le constater !

  22. #21
    HULK28

    Re : MOSFET en commutation, problème de MOSFET

    Oui mais tu es à 10V sur la grille et 100 Ohms.
    Refait la même manip avec 10K et 5V pour voir.
    "Le temps met tout en lumière." Thalès

  23. #22
    DAUDET78

    Re : MOSFET en commutation, problème de MOSFET

    Voila voilou
    NMOS switch Rgrille 100 1000 10000_5V_Simu_Schema.JPG
    PS: Je suis avec une charge de 100 ohm . Avec 10K de charge , ça change quasiment rien
    L'age n'est pas un handicap .... Encore faut-il arriver jusque là pour le constater !

  24. #23
    HULK28

    Re : MOSFET en commutation, problème de MOSFET

    simu_MOS.jpg


    Regarde ces simus.
    Avec 10K dans la grille et quelque soit la tension Vgs pas de conduction à 500Hz sur un gros NMOS, comme prévu.
    Il faut bien descendre pour que ça commence à passer.
    C'est logique un MOS de 30A n'est pas conçu pour passer 2.5mA de charge avec 500µA de commande comme expliqué.
    Attendons que le demandeur nous dise quelles valeurs de résistance il a mis sur sa carte.
    Je parie sur 10K.
    "Le temps met tout en lumière." Thalès

  25. #24
    DAUDET78

    Re : MOSFET en commutation, problème de MOSFET

    Sorry, mais sur fond noir, c'est difficilement lisible !
    Une simu ( R2=100 1000 10000) avec le IXFX90N20 ( Je n'ai pas le IXFX90N30 )
    NMOS IXFX90N20 switch Rgrille 100 1000 10000_Simu_Schema.jpg
    L'age n'est pas un handicap .... Encore faut-il arriver jusque là pour le constater !

  26. #25
    HULK28

    Re : MOSFET en commutation, problème de MOSFET

    MOS_gate_5V_Rg_1K.jpg

    MOS_gate_5V_Rg_2K.jpg

    Moi je parle de l'influence de la résistance de gate et de la tension de gate.
    En dessous de 5K dans la gate ça commence à conduire mais avec 10V, il faut bien 3K sur la gate pour que Vds atteigne 0, au dessus ça ne fonctionne plus du tout.
    A 5V sur la gate (les 2 graphes au dessus) c'est pire évidemment, il faut 1K pour atteindre le 0V et très péniblement, on voit qu'avec 2K on est au fraise.
    Donc même si notre ami a mis 1K ça ne tournera pas correctement.

    Allez bonne nuit!
    "Le temps met tout en lumière." Thalès

  27. #26
    HULK28

    Re : MOSFET en commutation, problème de MOSFET

    Je n'ai pas son NMOS dans mon simu, possible que le sien conduise malgré tout à 5V mais c'est jouer avec le feu d'adopter 5V comme tu l'as déjà dit et d'attaquer la gate à si haute impédance d'entrée.
    Je crois que là dessus on est d'accord.

    Cette fois dodo.
    "Le temps met tout en lumière." Thalès

Discussions similaires

  1. commutation mosfet
    Par pyrosigma dans le forum Électronique
    Réponses: 4
    Dernier message: 20/02/2015, 16h45
  2. Courant de commutation MOSFET
    Par kevin8z dans le forum Électronique
    Réponses: 23
    Dernier message: 10/02/2015, 16h54
  3. commutation pwm mosfet
    Par pyrosigma dans le forum Électronique
    Réponses: 5
    Dernier message: 05/06/2014, 13h42
  4. Flyback 130W, problème de commutation MOSFET IRFP250
    Par Baboush93 dans le forum Électronique
    Réponses: 7
    Dernier message: 10/05/2014, 19h11
  5. MosFet en Commutation
    Par YoYo51 dans le forum Électronique
    Réponses: 4
    Dernier message: 07/06/2010, 08h37