Bonjour, cliquez-ici pour vous inscrire et participer au forum.
  • Login:



+ Répondre à la discussion
Affichage des résultats 1 à 9 sur 9

Parasites bizarres sur la sortie d’un Passe Bas à AOP

  1. AmigaOS

    Date d'inscription
    mars 2008
    Localisation
    Hérault
    Messages
    778

    Parasites bizarres sur la sortie d’un Passe Bas à AOP

    Bonjour

    Sur un circuit que j’ai fait il y a une structure avec un AOP qui me sert d’ampli et à la fois de filtre passe bas pour garder que la valeur moyenne du signal d’entrée amplifié x16.
    Mais en sortie j’ai des parasites triangulaires dont je ne vois pas d’où ils sortent.

    Sur l’alim j’ai quelques parasites (voir PJ) mais ça ne ressemble pas à ce que j’ai en sortie.
    L’AOP est un rail to rail en in et out.
    Le signal d’entrée fait 20kHz.
    J’ai fait quelques tests :
    Augmenter C ne change absolument rien à aucun signal.
    Rajouter des capas de découplage sur l’alime diminue les parasites sur l’alime mais en rajoute sur le signal de sortie.

    AOP pourquoi.PNG

    Une idée du problème ?

    Merci

    -----

     


    • Publicité



  2. f6bes

    Date d'inscription
    février 2005
    Localisation
    Nimes Age: 73000 millions de kms autour du soleil !!
    Messages
    51 536

    Re : Parasites bizarres sur la sortie d’un Passe Bas à AOP

    Bj r à toi,
    Je ne suis pas un "as" des AO, mais à mon avis tu as bien de l'amplification , mais ton filtre de sortie est probablement
    un peu trop succint pour éliminer tes pics. Il faudrait je pense plusieurs " cellules" d'atténuation pour raboter tout ça.
    Bonne journée
    Ce fut la goutte d'eau de trop qui mit le feu aux poudres!
     

  3. DAUDET78

    Date d'inscription
    septembre 2006
    Localisation
    Ile de France
    Âge
    74
    Messages
    63 344

    Re : Parasites bizarres sur la sortie d’un Passe Bas à AOP

    Citation Envoyé par AmigaOS Voir le message
    Mais en sortie j’ai des parasites triangulaires dont je ne vois pas d’où ils sortent.
    Avec un signal rectangulaire en entrée(un PWM ?) , c'est normal comme résultat ... avec un ampliOP réel !
    En effet, dans la bande passante (hélas pas infini !) de l'ampliOP , tu as un filtre passe-bas correspondant au calcul. Au delà, l'ampliOP est une passoire !
    Or ton PWM a un spectre très large . Donc il faut filtrer ton carré avec un réseau RC avant d'attaquer ton filtre actif.
    Dernière modification par DAUDET78 ; 07/09/2017 à 16h18.
    Bonjour et au revoir .... a remettre en début et en fin de réponse
     

  4. Antoane

    Date d'inscription
    août 2007
    Localisation
    IDF
    Âge
    26
    Messages
    12 248

    Re : Parasites bizarres sur la sortie d’un Passe Bas à AOP

    Bonjour,

    Quel est le gain HF de ton circuit (supposant l'AOP comme étant idéal) ?

    La mesure de la tension de masse est bruitée, ce qui montre que ta mesure n'est pas propre (e.g. mauvaise connexion de la masse) ou que ta carte n'est pas bien routée (masse à "forte" impédance). Tu es sur planche labdec ?
    La mesure de la tension alim est bruitée également. Cela peut venir du fait que :
    - l'alim 3.3 V est bruitée
    - et/ou : la mesure est mauvaise (e.g. mauvaise masse).

    Le premier cas se solutionne avec bon découplage, éventuellement aidé d'une perle de ferrite, et d'un bon routage.
    Deux pattes c'est une diode, trois pattes c'est un transistor, quatre pattes c'est une vache.
     

  5. Antoane

    Date d'inscription
    août 2007
    Localisation
    IDF
    Âge
    26
    Messages
    12 248

    Re : Parasites bizarres sur la sortie d’un Passe Bas à AOP

    L'effet du condensateur est négligeable jusqu'à ce que son impédance soit de l'ordre de grandeur de celle de R2 (puisque les composants sont en parallèle). Jusqu'à cette fréquence (qui vaut ~1/(6.28*C*R2)~88 Hz), le montage est un amplificateur de gain 16. Au delà, R2 a un effet négligeable sur le montage. Lorsque l'impédance de C devient négligeable devant celle de R1 (i.e. pour f>1/(6.28*C*R1)~1.3 kHz), le circuit fonctionne en suiveur.


    Comme la fréquence de ton carré est >> la fréquence à partir de laquelle le circuit fonctionne en suiveur, avec un AOP idéal, tu devrais retrouver en sortie la somme de :
    - 16 * la tension moyenne du signal d'entrée (ampli de gain 16);
    - la partie AC de la tension d'entrée (suiveur).

    Autrement dit, dans le cas (par exemple) d'un signal carré d'amplitude 0/100 mV et de rapport cyclique 20% :
    une tension dc de 16*(0.2*100) = 320 mV, superposée à un carré d'amplitude -20mV/80mV et de rapport cyclique 20 %
    C'est à dire un carré 300mV/400mV, avec rapport cyclique 20 %.

    Avec ce montage, tu ne diminues pas l'amplitude du signal alternatif.




    Si ce signal n'est pas celui que tu mesures, c'est parce-que, je pense, ton AOP est lent. C'est finalement son slew-rate (vitesse de balayage) qui fait que ce qui devrait être un carré en sortie se transforme en triangle.
    Deux pattes c'est une diode, trois pattes c'est un transistor, quatre pattes c'est une vache.
     


    • Publicité



  6. bobflux

    Date d'inscription
    août 2010
    Messages
    4 348

    Re : Parasites bizarres sur la sortie d’un Passe Bas à AOP

    C'est un AOP micropower (20µA) ultra-lent (GBW 300kHz et slew rate 0.15V/µs) donc conçu uniquement pour traiter des signaux très lents, genre du continu.

    Il faut un filtre RC passif pour arrondir les angles, suivi d'un filtre à AOP, pas un sallen-key qui se repose sur la bande passante de l'AOP pour filtrer la HF, mais plutôt un multiple-feedback.

    En plus, ton schéma n'est pas un filtre en HF, c'est un suiveur...
     

  7. AmigaOS

    Date d'inscription
    mars 2008
    Localisation
    Hérault
    Messages
    778

    Re : Parasites bizarres sur la sortie d’un Passe Bas à AOP

    Bon, ok j'aurai appris quelque chose de nouveau, et de jamais vu en cours sur une structure à AOP toute simple.
    Oui, avec filtrage en entrée ça marche de-suite mieux. ^^
    Pour la masse c'est juste que j'ai pris ma référence à 20cm, directement sur la batterie vu que c'était plus simple à relier. Du coup entre la batterie et le pin de l'AOP il y a eu quelques parasites.

    Merci
     

  8. Antoane

    Date d'inscription
    août 2007
    Localisation
    IDF
    Âge
    26
    Messages
    12 248

    Re : Parasites bizarres sur la sortie d’un Passe Bas à AOP

    Bonjour,

    > Pour la masse c'est juste que j'ai pris ma référence à 20cm, directement sur la batterie vu que c'était plus simple à relier. Du coup entre la batterie et le pin de l'AOP il y a eu quelques parasites.
    C'est donc probablement le signal carré qui pollue ta masse et fait que ta tension d'alim est moche.
    Ou bien : le signal carré qui pollue ta mesure (par induction dans la boucle créée par la masse de la sonde), ce qui explique que les tensions mesurées sur l'alim et le gnd de l'AOP soient aussi moches.

    Pour ce qui est de l'allure du signal de sortie : Bob et moi avons répondu : mauvaise topologie de filtre & slex-rate de l'AOP.
    Deux pattes c'est une diode, trois pattes c'est un transistor, quatre pattes c'est une vache.
     

  9. AmigaOS

    Date d'inscription
    mars 2008
    Localisation
    Hérault
    Messages
    778

    Re : Parasites bizarres sur la sortie d’un Passe Bas à AOP

    C'est donc probablement le signal carré qui pollue ta masse et fait que ta tension d'alim est moche.
    Oui surtout qu'il y a plusieurs ampères qui circulent à travers mes fils..

    Ou bien : le signal carré qui pollue ta mesure (par induction dans la boucle créée par la masse de la sonde), ce qui explique que les tensions mesurées sur l'alim et le gnd de l'AOP soient aussi moches.
    J'avais fais le teste en faisant une boucle avec la sonde et j'arrive bien à capter des petits pics avec. Mais ils sont très petits par rapport à ce qu'on vois sur l'image.

    Pour ce qui est de l'allure du signal de sortie : Bob et moi avons répondu : mauvaise topologie de filtre & slex-rate de l'AOP.
    Oui j'avais bien compris.
     


    • Publicité







Sur le même thème :





 

Discussions similaires

  1. [Analogique] Impédance de sortie filtre Passe bas Sallen Key avec Gain
    Par trendkiller dans le forum Électronique
    Réponses: 14
    Dernier message: 27/06/2016, 14h07
  2. [Verger] Parasites bizarres sur mes poiriers
    Par consavert dans le forum Jardinage
    Réponses: 2
    Dernier message: 25/04/2016, 10h46
  3. Réponses: 20
    Dernier message: 28/05/2014, 16h24
  4. Parasites sortie convertisseur Buck
    Par Tonave72 dans le forum Électronique
    Réponses: 10
    Dernier message: 11/06/2012, 11h56
  5. Parasites en sortie d'alim à découpage??
    Par chris51200 dans le forum Électronique
    Réponses: 14
    Dernier message: 21/04/2009, 13h26