Bonjour, cliquez-ici pour vous inscrire et participer au forum.
  • Login:



+ Répondre à la discussion
Page 1 sur 2 1 DernièreDernière
Affichage des résultats 1 à 15 sur 16

mesure courant

  1. achach

    Date d'inscription
    novembre 2017
    Âge
    30
    Messages
    102

    mesure courant

    Bonjour,

    j'ai essayé avec un capteur ACS710 +-25 à mesurer le courant consommé par par un moteur continu.
    j'ai branché le capteur comme suit :
    le (+) de l'alim de 13V à (IP+) du capteur
    (IP-) du capteur au (+) du moteur
    (-) du moteur au (-) de l'alim

    VCC à 5V
    VOC à 1.5V
    GND à la masse

    mais je mesure toujours 2.4V au niveau de Viout.

    sur l'afficheur de mon alimentation j'ai 13V et 1.2A.

    est ce qu'il manque une autre chose sur mon montage?

    Merci

    -----

     


    • Publicité



  2. f6bes

    Date d'inscription
    février 2005
    Localisation
    Nimes Age: 73000 millions de kms autour du soleil !!
    Messages
    51 734

    Re : mesure courant

    Bjr à toi,
    Ca serait bien si on avait u n lien sur les caractéristiques du produit ets ur la façon de l'employer. (notice)
    Bonne soirée
    Ce fut la goutte d'eau de trop qui mit le feu aux poudres!
     

  3. USMC

    Date d'inscription
    octobre 2007
    Messages
    198

    Re : mesure courant

    Bonsoir,

    Lien de la datasheet : http://www.allegromicro.com/~/media/...Datasheet.ashx

    Je peux raconter des conneries mais par rapport à la sensibilité, je pense que c'est normal.
    Pour le modèle +- 25, tu as 28 mV par Ampère de sensibilité.
    Donc pour 1,3A de courant de charge, tu aurais à peu près 2,428 V.
    Est-ce que l'instrument sur lequel tu rentres la mesure est assez sensible pour constater l'augmentation ?

    Bonne soirée.
     

  4. achach

    Date d'inscription
    novembre 2017
    Âge
    30
    Messages
    102

    Re : mesure courant

    Citation Envoyé par USMC Voir le message
    Bonsoir,

    Lien de la datasheet : http://www.allegromicro.com/~/media/...Datasheet.ashx

    Je peux raconter des conneries mais par rapport à la sensibilité, je pense que c'est normal.
    Pour le modèle +- 25, tu as 28 mV par Ampère de sensibilité.
    Donc pour 1,3A de courant de charge, tu aurais à peu près 2,428 V.
    Est-ce que l'instrument sur lequel tu rentres la mesure est assez sensible pour constater l'augmentation ?

    Bonne soirée.
    Bonjour,

    même en vitesse maximale, mon moteur consomme 3.4A, mais en sortie du capteur ça varie pas, elle est toujours à 2.4V.
    est ce qu'il manque une autre chose sur mon montage?
     

  5. achach

    Date d'inscription
    novembre 2017
    Âge
    30
    Messages
    102

    Re : mesure courant

    Bonjour,

    je ne sais pas si mon capteur fonctionne correctement, j'ai essayé de placer une charge dynamique pour que je puisse varier le courant.
    Mon montage :
    (+) Alim --> (IP+) capteur
    (IP-) capteur --> (+) charge
    (-) charge --> (-) Alim

    voilà ce que je mesure:
    à 0A --> 2.399Volts
    à 0.05A --> 2.4Volts
    à 0.5A --> 2.41Volts
    à 5A --> 2.533Volts
    à 10A --> 2.67Volts

    Cela vous parait'il raisonnable ?

    Merci
     


    • Publicité



  6. f6exb

    Date d'inscription
    avril 2011
    Âge
    66
    Messages
    1 682

    Re : mesure courant

    VIOUT ne doit-elle pas être reliée à la masse d'une manière ou d'une autre : résistance, zener ?
    Seuls les faucons volent. Les vrais restent au sol.
     

  7. paulfjujo

    Date d'inscription
    juillet 2004
    Localisation
    Dagneux 01120
    Âge
    67
    Messages
    2 152

    Re : mesure courant

    bonjour,

    delta de 270mV pour 10 Amp
    cela semble correspondre à la datasheet 28mV / Amps

    un ACS712-5 serait plus approprié pour un nominal de 3,.. Amps
    185mV/amps
    Dernière modification par paulfjujo ; 07/12/2017 à 15h37.
     

  8. achach

    Date d'inscription
    novembre 2017
    Âge
    30
    Messages
    102

    Re : mesure courant

    Citation Envoyé par f6exb Voir le message
    VIOUT ne doit-elle pas être reliée à la masse d'une manière ou d'une autre : résistance, zener ?
    oui j'ai rien relié à VIOUT.

    Mais après j'ai voulu amplifier la tension de sortie VIOUT avec un ampli LM358, j'ai fait un montage d'ampli non inverseur R1=1Kohm, R2=4.7Kohm.
    mais en mesurant la tension de sortie de l'ampli, elle ne varie pas, elle est fixé à 4.46Volts pour 0A et pour 10A

    https://www.jameco.com/Jameco/Produc...dDS/826793.pdf
     

  9. Antoane

    Date d'inscription
    août 2007
    Localisation
    IDF
    Âge
    26
    Messages
    12 353

    Re : mesure courant

    Bonjour,

    en complément de ce qu'indique paulfjujo :

    La tension réellement intéressante (car proportionnelle au courant de test) est celle disponible entre les broches VZCR (qui sert de référence) et Viout.
    Je n'ai pas lu la datasheet en détail mais n'ai pas saisi en quoi la tension appliquée sur l'entrée VOC affecte la polarisation du capteur...

    Mais après j'ai voulu amplifier la tension de sortie VIOUT avec un ampli LM358, j'ai fait un montage d'ampli non inverseur R1=1Kohm, R2=4.7Kohm.
    mais en mesurant la tension de sortie de l'ampli, elle ne varie pas, elle est fixé à 4.46Volts pour 0A et pour 10A
    Quelle est la tension d'alimentation du LM358 ?
    à 0A, tu as 2.4V en sortie du capteur, tu espères donc avoir ~6*2.4~15 V en sortie du LM358. Cela ne fonctionnera que si l'AOP est alimenté avec une tension d'au moins 18 V.
    Deux pattes c'est une diode, trois pattes c'est un transistor, quatre pattes c'est une vache.
     

  10. achach

    Date d'inscription
    novembre 2017
    Âge
    30
    Messages
    102

    Re : mesure courant

    Citation Envoyé par Antoane Voir le message

    Quelle est la tension d'alimentation du LM358 ?
    à 0A, tu as 2.4V en sortie du capteur, tu espères donc avoir ~6*2.4~15 V en sortie du LM358. Cela ne fonctionnera que si l'AOP est alimenté avec une tension d'au moins 18 V.
    j'ai alimenté le LM358 en 12V.......en entrée j'ai 2.4V et en sortie j'obtient 10V, je trouve que c'est pas mal comme amplification.
    mais ce que j'arrive pas à comprendre, pourquoi ma tension de sortie ne varie pas, elle reste fixe, et même la tension en sortie du capteur reste fixe quand je la connecte à l'entrée de l'Ampli.
     

  11. Antoane

    Date d'inscription
    août 2007
    Localisation
    IDF
    Âge
    26
    Messages
    12 353

    Re : mesure courant

    Bonjour,
    Citation Envoyé par achach Voir le message
    j'ai alimenté le LM358 en 12V.......en entrée j'ai 2.4V et en sortie j'obtient 10V, je trouve que c'est pas mal comme amplification.
    Théoriquement et connaissant les valeurs de tes deux résistances, quelle tension devrais-tu obtenir ?
    Deux pattes c'est une diode, trois pattes c'est un transistor, quatre pattes c'est une vache.
     

  12. achach

    Date d'inscription
    novembre 2017
    Âge
    30
    Messages
    102

    Re : mesure courant

    Citation Envoyé par Antoane Voir le message
    Bonjour,

    Théoriquement et connaissant les valeurs de tes deux résistances, quelle tension devrais-tu obtenir ?
    théoriquement, j'obtient 13.6V , si je prends R1=1k et R2=4.7K.
    reste le plus grand problème pour moi, pourquoi le capteur de courant ne fonctionne plus quand j'applique son tension de sortie à l'entrée du AOP.
     

  13. Antoane

    Date d'inscription
    août 2007
    Localisation
    IDF
    Âge
    26
    Messages
    12 353

    Re : mesure courant

    Citation Envoyé par achach Voir le message
    théoriquement, j'obtient 13.6V , si je prends R1=1k et R2=4.7K.
    Hors, alimenté en 12 V un AOP ne peut sortir plus de 12V - et même seulement 8 ou 9 V dans le cas du 358 (https://www.sparkfun.com/datasheets/...eral/LM358.pdf et FAQ: Questions souvent posées en électronique : "output voltage swing").
    Normal donc que ton montage amplificateur ne fonctionne pas. Il faudrait (par exemple) utiliser un ampli différentiel, référencé au VZCR.

    Citation Envoyé par achach Voir le message
    reste le plus grand problème pour moi, pourquoi le capteur de courant ne fonctionne plus quand j'applique son tension de sortie à l'entrée du AOP.
    C'est pas normal du tout. Quelques hypothèses :
    - il y a une erreur de câblage ;
    - le capteur est mort ;
    - le 358 est mort.
    Il faut également que le 2e AOP présent dans le 358 soit câblé, il ne doit pas rester en l'air. Tu peux, par exemple le câbler en suiveur et mettre son entrée + à la masse.

    Dans le doute, il serait bon de câbler la broche VOC à un potentiel fixe (voir son fonctionnement dans la datasheet du capteur).
    Deux pattes c'est une diode, trois pattes c'est un transistor, quatre pattes c'est une vache.
     

  14. achach

    Date d'inscription
    novembre 2017
    Âge
    30
    Messages
    102

    Re : mesure courant

    Citation Envoyé par Antoane Voir le message

    C'est pas normal du tout. Quelques hypothèses :
    - il y a une erreur de câblage ;
    - le capteur est mort ;
    - le 358 est mort.
    Il faut également que le 2e AOP présent dans le 358 soit câblé, il ne doit pas rester en l'air. Tu peux, par exemple le câbler en suiveur et mettre son entrée + à la masse.

    Dans le doute, il serait bon de câbler la broche VOC à un potentiel fixe (voir son fonctionnement dans la datasheet du capteur).

    j'ai changé l'AOP, j'ai essayé avec un TL081 en AOP non inverseur, alimenté par 12V avec R1=10K et R2=10K. théoriquement, je dois avoir VS =2Ve.
    et c'est ce que je trouve à la sortie de AOP, j'ai varié plusieurs fois la tension d'entrée, et tjrs j'ai Vs=2Ve.
    jusqu'à ici là pense que c'est raisonable.
    après en mettant le capteur, de nouveau la tension de sortie reste fixe, je pense pas que c'est lié au capteur, parce que j'ai utilisé deux sondes une entrée et l'autre en sortie de AOP, celle entrée varie correctement, mais celle en sortie reste tjrs fixe.

    je sais que c'est pas logique, mais c'est ce que j'ai mesuré

    http://www.ti.com/lit/ds/symlink/tl082.pdf
     

  15. Antoane

    Date d'inscription
    août 2007
    Localisation
    IDF
    Âge
    26
    Messages
    12 353

    Re : mesure courant

    Bonjour,

    Il faut que tu sois plus méthodique quand tu fais tes tests et/ou plus précis lorsque tu les rapportes ici :
    - quelles tensions d'entrées rendent ton montage à AOP fonctionnel ?
    - comment génères-tu cette tension ?
    - combien vaut la tension "fixe" de sortie ? quelle est alors la tension d'entrée ?
    - etc.
    Citation Envoyé par achach Voir le message
    après en mettant le capteur, de nouveau la tension de sortie reste fixe, je pense pas que c'est lié au capteur, parce que j'ai utilisé deux sondes une entrée et l'autre en sortie de AOP, celle entrée varie correctement, mais celle en sortie reste tjrs fixe.
    http://www.ti.com/lit/ds/symlink/tl082.pdf
    regarde la ligne "VCM Common-mode voltage" en page 5 : lorsque le TL08x est alimenté en 0/15V, il ne faut pas lui envoyer moins de 4V ou plus de 11 V en entrée (cf. FAQ: Questions souvent posées en électronique).

    Qu'as tu changé à ton montage, qui fonctionnait hier après-midi (message#5)
    Deux pattes c'est une diode, trois pattes c'est un transistor, quatre pattes c'est une vache.
     


    • Publicité







Sur le même thème :





 

Discussions similaires

  1. mesure courant 0 a 17 A 48v
    Par ludovtt44 dans le forum Électronique
    Réponses: 11
    Dernier message: 21/03/2015, 16h09
  2. ESD - Mesure de courant
    Par Nicocloud dans le forum Électronique
    Réponses: 13
    Dernier message: 12/03/2013, 11h33
  3. Mesure d'un courant.
    Par mdo100 dans le forum Électronique
    Réponses: 17
    Dernier message: 27/06/2012, 09h34
  4. mesure du courant de fuite d'une source de courant
    Par yaf dans le forum Électronique
    Réponses: 3
    Dernier message: 23/03/2012, 14h21
  5. mesure d'un courant
    Par pi1148 dans le forum Électronique
    Réponses: 44
    Dernier message: 26/12/2011, 15h08