Bonjour, cliquez-ici pour vous inscrire et participer au forum.
  • Login:



+ Répondre à la discussion
Page 1 sur 2 1 DernièreDernière
Affichage des résultats 1 à 15 sur 23

Algorithme de calcul de la puissance d'un nombre

  1. Sam*

    Date d'inscription
    juillet 2007
    Messages
    244

    Algorithme de calcul de la puissance d'un nombre

    Bonjour, j'ai écris un algorithme qui permet de calculer la puissance d'un entier naturel pn :

    Var i , exp , p , n : entiers

    Debut


    lire(p)
    lire(n)
    Si n=0 alors exp := 1
    Sinon
    exp:= 1
    pour i de 1 à n faire
    exp := exp * p
    Fin pour
    Fin si
    Fin

    PS : " := " signifie "reçoit".
    Merci de corriger cet algorithme.


     


    • Publicité



  2. Astérion

    Date d'inscription
    août 2008
    Localisation
    délocalisation
    Messages
    925

    Re : Algorithme de calcul de la puissance d'un nombre

    Re,

    Citation Envoyé par Sam* Voir le message
    Bonjour, j'ai écris un algorithme qui permet de calculer la puissance d'un entier naturel pn :

    Var i , exp , p , n : entiers

    Debut


    lire(p)
    lire(n)
    Si n=0 alors exp := 1
    Sinon
    exp:= 1
    pour i de 1 à n faire
    exp := exp * p
    Fin pour
    Fin si
    Fin

    PS : " := " signifie "reçoit".
    Merci de corriger cet algorithme.
    Je me demande... pourquoi ne pas le faire de manière récusive... plutôt que de faire une boucle...?

    M'enfin...

    A plus.
    "The more is different" P.W Anderson.
     

  3. Astérion

    Date d'inscription
    août 2008
    Localisation
    délocalisation
    Messages
    925

    Re : Algorithme de calcul de la puissance d'un nombre

    Re,

    exemple:

    var exp, n,p:entier
    [...]
    fonction(n,p) donne entier
    si n=0 alors exp:=0
    sinon exp:=fonction(n-1,p)*p
    fin si
    [...]

    Voilà, comment je ferai,...mais bon, je n'ai pas vraiment fait de cours d'algo de ma vie!

    A plus;
    "The more is different" P.W Anderson.
     

  4. Sam*

    Date d'inscription
    juillet 2007
    Messages
    244

    Re : Algorithme de calcul de la puissance d'un nombre

    Peut-etre mais moi on me demande d'utiliser une boucle , je ne sais pas ce que c'est que la récursivité .
     

  5. Coincoin

    Date d'inscription
    octobre 2003
    Localisation
    Paris
    Âge
    29
    Messages
    16 627

    Re : Algorithme de calcul de la puissance d'un nombre

    Salut,
    Citation Envoyé par Sam* Voir le message
    Merci de corriger cet algorithme.
    Ça me paraît bon, si n est un entier positif.

    Citation Envoyé par Astérion Voir le message
    Voilà, comment je ferai,...mais bon, je n'ai pas vraiment fait de cours d'algo de ma vie!
    Ce qui explique que tu ne connaisses pas l'exponentiation rapide...
    Encore une victoire de Canard !
     


    • Publicité



  6. whoami

    Date d'inscription
    janvier 2009
    Messages
    3 025

    Re : Algorithme de calcul de la puissance d'un nombre

    Bonjour,
    Citation Envoyé par Astérion Voir le message
    Je me demande... pourquoi ne pas le faire de manière récusive... plutôt que de faire une boucle...?
    Parce que utiliser la récursivité quand elle n'apparaît pas naturellement dans l'algorithme est une absurdité (et je pèse mes mots) : consommation mémoire, puissance processeur, risque de débordement de la pile du programme si on ne prend pas de précautions ...

    La récursivité, c'est beau en théorie, mais l'informatique ne se fait pas qu'avec de la beauté, il faut de l'efficacité.
    À part la mort et les impôts, tout n'est qu'incertitude.
     

  7. whoami

    Date d'inscription
    janvier 2009
    Messages
    3 025

    Re : Algorithme de calcul de la puissance d'un nombre

    Bonjour,
    Citation Envoyé par Astérion Voir le message
    Re,

    exemple:

    var exp, n,p:entier
    [...]
    fonction(n,p) donne entier
    si n=0 alors exp:=0
    sinon exp:=fonction(n-1,p)*p
    fin si
    [...]

    Voilà, comment je ferai,...mais bon, je n'ai pas vraiment fait de cours d'algo de ma vie!

    A plus;
    Ce qui est faux, bien entendu.

    Sans parler de la fonction récursive (voir ci-dessus).
    À part la mort et les impôts, tout n'est qu'incertitude.
     

  8. Astérion

    Date d'inscription
    août 2008
    Localisation
    délocalisation
    Messages
    925

    Re : Algorithme de calcul de la puissance d'un nombre

    Re,

    Citation Envoyé par whoami Voir le message
    Bonjour,

    Parce que utiliser la récursivité quand elle n'apparaît pas naturellement dans l'algorithme est une absurdité (et je pèse mes mots) : consommation mémoire, puissance processeur, risque de débordement de la pile du programme si on ne prend pas de précautions ...

    La récursivité, c'est beau en théorie, mais l'informatique ne se fait pas qu'avec de la beauté, il faut de l'efficacité.
    Pourtant pour des réaliser des tris... je trouve la méthode récursive très sympa.
    D'ailleurs, sans être malhonnête, elle apparait naturellement là.
    puis des gardes-fous, ça se met en place....
    d'ailleurs, ici, on parle d'algo... mais le message est bien reçu, c'est une absurdité

    Citation Envoyé par Coincoin
    Ce qui explique que tu ne connaisses pas l'exponentiation rapide...
    et bah non, je ne connais pas tout ... mais j'apprends beaucoup

    A plus.
    "The more is different" P.W Anderson.
     

  9. Astérion

    Date d'inscription
    août 2008
    Localisation
    délocalisation
    Messages
    925

    Re : Algorithme de calcul de la puissance d'un nombre

    Re,

    Citation Envoyé par whoami Voir le message
    Bonjour,

    Ce qui est faux, bien entendu.

    Sans parler de la fonction récursive (voir ci-dessus).
    erreur de frappe de ma part, bien entendu (mais bon, tu as envie de te montrer non indulgeant ...)
    Pour la récursivité... j'ai répondu.

    A plus.

    Rq: Heureusement que j'ai dit que je n'y connaissais rien (hé oui j'ai mis un garde fou! ) sinon, la vache! Autant aller se guillotiner avec toi!

    A plus.
    "The more is different" P.W Anderson.
     

  10. Astérion

    Date d'inscription
    août 2008
    Localisation
    délocalisation
    Messages
    925

    Re : Algorithme de calcul de la puissance d'un nombre

    Re,

    J'ai ça pour ceux que ça intéresse ( notamment moi...).

    http://www.developpez.net/forums/d20...s-recursivite/

    A plus.
    "The more is different" P.W Anderson.
     

  11. Jack

    Date d'inscription
    avril 2003
    Localisation
    Metz
    Messages
    13 424

    Re : Algorithme de calcul de la puissance d'un nombre

    Si n=0 alors exp := 1
    Sinon
    exp:= 1
    Donc dans tous les cas exp:=1

    On peut donc réduire à:
    Code:
    lire(p)
    Debut
        lire(n)
        exp:= 1
        Si n!=0 alors 
            pour i de 1 à n faire
               exp := exp * p
            Fin pour
        Fin si 
    Fin
    Note comme la balise code permet d'améliorer la lisibilité

    A+
     

  12. Sam*

    Date d'inscription
    juillet 2007
    Messages
    244

    Re : Algorithme de calcul de la puissance d'un nombre

    Citation Envoyé par Jack Voir le message
    Donc dans tous les cas exp:=1

    On peut donc réduire à:
    Code:
    lire(p)
    Debut
        lire(n)
        exp:= 1
        Si n!=0 alors 
            pour i de 1 à n faire
               exp := exp * p
            Fin pour
        Fin si 
    Fin
    Note comme la balise code permet d'améliorer la lisibilité

    A+
    Non la condition "si n:=0 alors exp:=1" est importante , j'ai testé l'algorithme sous maple et effectivement s'il n'y pas cette condition le programme n'arrive pas à calculer p0.
     

  13. Jack

    Date d'inscription
    avril 2003
    Localisation
    Metz
    Messages
    13 424

    Re : Algorithme de calcul de la puissance d'un nombre

    Non la condition "si n:=0 alors exp:=1" est importante
    Oui, mais avec l'algo que j'ai donné, si n est égal à 0, exp sera bien égal à 1 puisque la première chose que je fais est de mettre exp à 1 quelle que soit la valeur de n.

    Donc mon algo est bon.

    A+
     

  14. whoami

    Date d'inscription
    janvier 2009
    Messages
    3 025

    Re : Algorithme de calcul de la puissance d'un nombre

    Bonjour,
    Citation Envoyé par Jack Voir le message
    Oui, mais avec l'algo que j'ai donné, si n est égal à 0, exp sera bien égal à 1 puisque la première chose que je fais est de mettre exp à 1 quelle que soit la valeur de n.

    Donc mon algo est bon.

    A+
    Oui, mais on peut encore simplifier :

    Puisque exp est initialisé à 1, et qu'un boucle de 1 à n ne bouclera pas si n = 0.
    Code:
    Debut
        lire(p)
        lire(n)
        exp:= 1
        pour i de 1 à n faire
            exp := exp * p
        Fin pour
    Fin
    À part la mort et les impôts, tout n'est qu'incertitude.
     

  15. Jack

    Date d'inscription
    avril 2003
    Localisation
    Metz
    Messages
    13 424

    Re : Algorithme de calcul de la puissance d'un nombre

    Oui, mais on peut encore simplifier :

    Puisque exp est initialisé à 1, et qu'un boucle de 1 à n ne bouclera pas si n = 0.
    Je n'ai pas osé le proposer car si ça marche en C par exemple, ça n'est pas garanti en ALGO.

    A+
     


    • Publicité





 

Discussions similaires

  1. Calcul de la puissance d'un échangeur
    Par spoltibrun dans le forum Environnement, développement durable et écologie
    Réponses: 11
    Dernier message: 16/03/2012, 09h59
  2. puissance réel d'un nombre complexe
    Par Morghot dans le forum Mathématiques du supérieur
    Réponses: 8
    Dernier message: 28/08/2009, 20h40
  3. Puissance réelle d'un nombre complexe.
    Par invite43219988 dans le forum Mathématiques du supérieur
    Réponses: 3
    Dernier message: 03/04/2009, 20h22
  4. Puissance d'un nombre
    Par Seirios dans le forum Mathématiques du supérieur
    Réponses: 26
    Dernier message: 11/01/2009, 19h17
  5. Algorithme de calcul d'un déterminant de matrice
    Par Liv dans le forum Mathématiques du supérieur
    Réponses: 2
    Dernier message: 12/11/2006, 19h45

Les tags pour cette discussion