Bonjour, cliquez-ici pour vous inscrire et participer au forum.
  • Login:



+ Répondre à la discussion
Affichage des résultats 1 à 1 sur 1

SCICOS pb de variables defini dans CONTEXT est non reconnu

  1. atosvq

    Date d'inscription
    janvier 2018
    Localisation
    Nimes
    Messages
    8

    SCICOS pb de variables defini dans CONTEXT est non reconnu

    Bonjour
    Nouveau sur ce forum , je me suis peut être mal pris ou au mauvais endroit.....

    Sous Scicos j'ai modélisé le comportement d'un bras de drone :celui ci est constitue de 2 moteurs électriques actionnant chacun une hélice à chaque extrémités. Le bras est articulé en son milieu.

    La simulation sous SCICOS consiste en un pb d'asservissement PID , la consigne étant l'angle que fait le bras avec l'horizontal.
    Je cherche donc les coefficients (P)roportionnel (I)ntegral, et (D)erivé pour assurer que la bras se positionne le plus rapidement possible à l'angle défini par la consigne

    Ce modèle SCICOS fonctionne super bien et me donne parfaite satisfaction

    CEPENDANT je rencontre un problème récurant !!!!!!!!!!!!!!!!!!!!!!!
    J'ai voulu ajouté une contrainte supplémentaire (un couple de redressement lie au fait que la rotation du bras ne se faisait plus par un axe passant par le centre de gravite), et la plus rien ne fonctionne .....!!!

    Résultat :SCICOS présente sur le schéma de simulation des petits triangle jaunes signalant des pb, ces problèmes sont déclarés comme des variables non définies ??????
    Cependant toutes mes variables sont définies dans "MODIFIER CONTEXT"

    Alors après un retour arrière je me retrouve dans la situation du départ qui fonctionnait parfaitement.....mais le problème subsiste !!!????

    Je supprime donc en plus dans "MODIFIER CONTEXT" toutes les nouvelles variables supplémentaires , je devrais donc me retrouvé dans la configuration de départ qui fonctionnait .....nouvel essai et toujours le même pb "VARIABLES NON DEFINIES" pourtant ces variables ne sont plus utilisées.....et de plus toutes les anciennes variables précédemment définies dans "MODIFIER CONTEXT" ne sont maintenant plus reconnues !!!!!

    L'impasse !!!!!!!!!!!!

    Cherche donc super gourou qui pourrait me donner une piste de solution ....il aura ma reconnaissance éternelle !!

    Merci infiniment d'avance pour celui qui aura parcouru ce courrier en entier !!!
    Dommage je n'ai pas pu joindre une image de la simulation sous SCICOS je n'ai pas les droits

    -----

     


    • Publicité







Sur le même thème :





 

Discussions similaires

  1. instruction non reconnu dans le langage fortran
    Par perfect_mind1 dans le forum Programmation et langages, Algorithmique
    Réponses: 6
    Dernier message: 18/01/2012, 18h43
  2. Problème compilateur (sdcc et context)
    Par stager dans le forum Électronique
    Réponses: 10
    Dernier message: 03/07/2008, 20h01
  3. Problème SDCC et context
    Par stager dans le forum Logiciel - Software - Open Source
    Réponses: 0
    Dernier message: 01/07/2008, 14h03
  4. DVD reconnu dans le bios mais pas dans windows ???
    Par fano dans le forum Matériel - Hardware
    Réponses: 8
    Dernier message: 04/04/2008, 13h30
  5. reconnu dans windows mais pas dans le bios
    Par ABN84 dans le forum Matériel - Hardware
    Réponses: 4
    Dernier message: 27/12/2006, 18h41