Bonjour, cliquez-ici pour vous inscrire et participer au forum.
  • Login:



+ Répondre à la discussion
Affichage des résultats 1 à 12 sur 12

Question sur montage contenant TL431 et BD139/140

  1. tofteur

    Date d'inscription
    septembre 2009
    Âge
    28
    Messages
    148

    Question sur montage contenant TL431 et BD139/140

    Bonsoir à tous.

    Petite explication du schéma (tiré du Liposave) :

    Le TL431 (datasheet ici) conduit lorsqu'il voit 2.495V sur sa PIN ref. Ceci permet de faire conduire les 2 transistors qui suivent tout en allumant la LED. Le potentiomètre permet de régler cette conduction lorsque l'on a 4,1V en entrée du montage. Le courant à shunter est de 0,5A. Le TL431 doit avoir un courant compris entre 1mA et 100mA sur sa cathode pour fonctionner.

    Mes questions sont :

    Puis-je utiliser 2 NPN comme sur le schéma en pièce jointe ou dois-je utiliser un BD140 (PNP) à la place de Q1 (et de Q2?)? Pourquoi?

    Concernant la LED, une LED rouge 20mA ne risque rien?


    Le montage présenté sur le site de l'inventeur est fonctionnel, je voudrais être certain que mes modifs sont correctes pour mon application.


    D'avance, merci


    Images attachées
     


    • Publicité



  2. tofteur

    Date d'inscription
    septembre 2009
    Âge
    28
    Messages
    148

    Re : Question sur montage contenant TL431 et BD139/140

    J'imagine que je suis obligé d'utiliser un PNP mais comme je n'ai pas la justification, je préfère poser la question
     

  3. tofteur

    Date d'inscription
    septembre 2009
    Âge
    28
    Messages
    148

    Re : Question sur montage contenant TL431 et BD139/140

    Personne ne sait m'aider?
     

  4. Tropique

    Date d'inscription
    juin 2005
    Localisation
    Entre Groland-Du-Haut et BXL-capitale
    Messages
    13 422

    Re : Question sur montage contenant TL431 et BD139/140

    Tu connais beaucoup de montages où on peut mettre indifféremment un NPN ou un PNP?

    Si tu as des exemples, ça m'intéresserait de les voir.
    Pas de complexes: je suis comme toi. Juste mieux.
     

  5. tofteur

    Date d'inscription
    septembre 2009
    Âge
    28
    Messages
    148

    Re : Question sur montage contenant TL431 et BD139/140

    Citation Envoyé par Tropique Voir le message
    Tu connais beaucoup de montages où on peut mettre indifféremment un NPN ou un PNP?

    Si tu as des exemples, ça m'intéresserait de les voir.

    Je n'ai jamais dit ça. Au lieu de répondre pour critiquer, réponds pour expliquer peu-être non?

    Si je pose la question, c'est que je n'ai pas la réponse. Ma connaissance des PNP est très limitée. Jamais utilisé à vrai dire.

    Donc, pourquoi dois-je utiliser un PNP?
     


    • Publicité



  6. alainav1

    Date d'inscription
    janvier 2005
    Localisation
    calais
    Âge
    65
    Messages
    4 167

    Re : Question sur montage contenant TL431 et BD139/140

    bonjour, sur ton schemas c'est un NPN ,le BD 139 est un NPN ?
    je ne compreb pas bien ce shemas quand le transistor est passant le + et le moins sont directement reliés au collecteur et l'emeteur du transistor (sans charge )?
    en commutation un NPN est passant quand la base est positive (l'emeteur est relié au negatif )un PNP est passant quand la base est negative (mais c'est l'emeteur est relié au positive )
    cordialement
    Alain
    Décider de faire c'est bien décider quand c'est mieux !
     

  7. tofteur

    Date d'inscription
    septembre 2009
    Âge
    28
    Messages
    148

    Re : Question sur montage contenant TL431 et BD139/140

    Citation Envoyé par alainav1 Voir le message
    bonjour, sur ton schemas c'est un NPN ,le BD 139 est un NPN ?
    Oui, le BD139 est un NPN.

    Citation Envoyé par alainav1 Voir le message
    je ne comprends pas bien ce schéma quand le transistor est passant le + et le moins sont directement reliés au collecteur et l'émetteur du transistor (sans charge )?
    Le but est de shunter un courant provenant d'une cellule li-ion une fois les 4,1V atteint entre + et -. Le second transistor évacue ce courant sous forme de chaleur. Cela évite à la cellule de dépasser les 4,1V que je ne veux pas qu'elle dépasse.


    Dans le schéma de base (ici) un PNP est utilisé. Comme je n'en ai jamais utilisé, je demandais pourquoi un PNP et non un NPN.

    J'espère que ma question est claire cette fois...
     

  8. alainav1

    Date d'inscription
    janvier 2005
    Localisation
    calais
    Âge
    65
    Messages
    4 167

    Re : Question sur montage contenant TL431 et BD139/140

    bonjour,
    voila un site qui explique tout ça
    http://xizard.chez.com/Cours/transistor_commutation.htm
    cordialement
    Alain
    Décider de faire c'est bien décider quand c'est mieux !
     

  9. tofteur

    Date d'inscription
    septembre 2009
    Âge
    28
    Messages
    148

    Re : Question sur montage contenant TL431 et BD139/140

    Merci pour le lien.

    Un PNP est bien obligatoire dans ce montage.

    Un NPN conduirait d'office dès que la tension entre + et - atteint 1,4V (Darlington --> 2*0,7V)

    Le PNP conduira dès que le TL431 sera passant car il y aura 2,5V sur la base de Q1 et 4,1V-2,5V est plus grand Vbe --> Q1 conduit.

    Dès que Q1 conduit, Q2 a un courant de base de (4,1-2,5)/820 * gain de Q1. Ce qui est largement suffisant pour faire conduire Q2.

    Il ne reste plus qu'une question, elle concerne la LED. Le gain de ses transistors variant de 25 à 250, comment puis-je être certain de ne pas la cramer?
     

  10. alainav1

    Date d'inscription
    janvier 2005
    Localisation
    calais
    Âge
    65
    Messages
    4 167

    Re : Question sur montage contenant TL431 et BD139/140

    bonjour,
    le Gain est de 200 en courant
    ta led est en serie entre 2 transistors passants donc perte de 1,2v environs
    ton circuit est alimenté en 4,5V il reste donc 4,5 - 1,2 =3,3v pour limiter à 10 mA ton courant
    led rouge =1,8V
    3,3-1,8=1,5V
    pour un courant limité a 10mA r=1,5/0,01=15 ohms
    cordialement

    Alain
    Décider de faire c'est bien décider quand c'est mieux !
     

  11. tofteur

    Date d'inscription
    septembre 2009
    Âge
    28
    Messages
    148

    Re : Question sur montage contenant TL431 et BD139/140

    Citation Envoyé par alainav1 Voir le message
    le Gain est de 200 en courant
    Comment en es-tu certain?

    Si c'est le cas, pas de soucis.

    Si malheureusement Q2 a un gain de 25, ca ne fonctionnera pas.

    Par contre, si je mets une LED de 20mA rouge en limitant le courant à 20mA, on aurait pour Q2 20mA*25=500mA. Comme Q2 doit shunter 0,5A, ca fonctionnerait.
    Il faudrait une résistance de 1,5/0,02=75ohms entre le collecteur de Q1 et l'anode de la LED.

    Est-ce bien ça?
     

  12. alainav1

    Date d'inscription
    janvier 2005
    Localisation
    calais
    Âge
    65
    Messages
    4 167

    Re : Question sur montage contenant TL431 et BD139/140

    bonjour,
    y a pas de risque a essayer ça doit marcher
    'j'ai pas regarder la datasheet du transistor pour le gain )
    cordialement
    Alain
    Décider de faire c'est bien décider quand c'est mieux !
     


    • Publicité




Poursuivez votre recherche :




Sur le même thème :




 

Discussions similaires

  1. question sur montage FX614
    Par yann85 dans le forum Électronique
    Réponses: 7
    Dernier message: 09/05/2010, 06h31
  2. [Univers] du contenant et du contenu, une question ?
    Par Gamedia dans le forum Astronomie et Astrophysique
    Réponses: 2
    Dernier message: 11/12/2009, 09h28
  3. Question sur montage avec ipod
    Par moimart1 dans le forum Électronique
    Réponses: 1
    Dernier message: 23/05/2009, 19h35
  4. Question ,montage sur accumulateur
    Par Boris591 dans le forum Technologies
    Réponses: 1
    Dernier message: 26/04/2008, 08h00
  5. question sur montage precis
    Par traxxa dans le forum Électronique
    Réponses: 1
    Dernier message: 31/05/2007, 13h06