Bonjour, cliquez-ici pour vous inscrire et participer au forum.
  • Login:



+ Répondre à la discussion
Affichage des résultats 1 à 5 sur 5

Probleme d'accent (seulement dans la sidebar de mon site)

  1. Chicago911

    Date d'inscription
    novembre 2016
    Messages
    11

    Post Probleme d'accent (seulement dans la sidebar de mon site)

    Bonsoir,
    Pour commencer je vous souhaite mes meilleurs vœux pour cette nouvelle année

    J'ai un petit problème avec mon site web des point d’interrogation remplace les accents. (Je précise que j'ai chercher sur plusieurs site via Google et je n'ai pas trouver de solution).
    Je bloque car cela concerne une partie de mon site (La sidebarre).
    En fet j'ai créer "un systeme" de news, toutes mes pages sont en php.
    Plutôt que de modifier toutes les page a chaque nouvelles "news" j'ai juste a éditer en manuel un fichier en ".TXT".
    Toutes les lettre avec un accent contenue dans ce fichier, sont remplacer par des point d’interrogation...
    Du coup je ne comprend pas.

    Si cela peux vous aider voici quelques infos:

    - Header de mes pages ".PHP"
    Code:
    <!DOCTYPE html>
    <html lang="fr">
    <head>
    <title>Titre du site..</title>
    <meta charset="utf-8">
    <meta name="Description" content="Description du site...">
    <meta name="Keywords" content="les mots clés...">
    <link rel="icon" type="image/png" href="img/favicon.ico" />
    <meta name="viewport" content="width=device-width; initial-scale=1.0">
    <meta name="viewport" content="width=device-width; initial-scale=1">
    <link rel="stylesheet" type="text/css" href="css/style.css">
    </head>


    Intégration des news dans les page PHP:

    Code:
    <?php
    $news="news/news.txt";
    readfile($news);
    ?>

    Contenue du fichier "news.txt"

    Code:
    <p><font color="#FFFF00"><strong>TITRE DE LA NEWS</strong></font> <small>( DATE )</small><br/>
    <font color="#FFFFFF">Contenue de la news</font></p>
    
    <p><font color="#FFFF00"><strong>TITRE DE LA  NEWS 2</strong></font> <small>( DATE )</small><br/>
    <font color="#FFFFFF">Contenue de la dexieme news</font></p>
    
    Etc....

    En espérant que vous puissiez me venir en aide
    merci

    -----

    Dernière modification par Chicago911 ; 02/01/2018 à 20h10.
     


    • Publicité



  2. Freemaster

    Date d'inscription
    octobre 2016
    Localisation
    Lille
    Messages
    259

    Re : Probleme d'accent (seulement dans la sidebar de mon site)

    salut,

    installes notepad++, et vérifies que tes fichiers, php et txt sont bien en utf-8 sans bom
    si ce n'est pas le cas, tu choisi convertir en utf-8 (sans bom), puis enregistrer
    et ré upload tes fichiers
    o_O
     

  3. Chicago911

    Date d'inscription
    novembre 2016
    Messages
    11

    Re : Probleme d'accent (seulement dans la sidebar de mon site)

    Salut FREEMASTER,
    J'utilise déjà notepad++, et les fichiers ont déjà étais convertie. Le problème concerne juste la partie news, sinon sur la meme page (autre que le partie news) les accents sonts bien présent.. Bizarre
     

  4. Freemaster

    Date d'inscription
    octobre 2016
    Localisation
    Lille
    Messages
    259

    Re : Probleme d'accent (seulement dans la sidebar de mon site)

    donc le fichier php est bien en utf-8, mais est-ce le cas du fichier txt ? lorsque tu le modifies notamment

    convertie le en ansi, puis reconvertie en utf-8 sans bom le fichier txt
    o_O
     

  5. Chicago911

    Date d'inscription
    novembre 2016
    Messages
    11

    Re : Probleme d'accent (seulement dans la sidebar de mon site)

    SUPER !!! merci beaucoups ça marche
     


    • Publicité




    • Publicité







Sur le même thème :


    301 Moved Permanently

    301 Moved Permanently


    nginx/1.2.1



 

Discussions similaires

  1. Problème avec mon Sidebar HTML CSS
    Par bledardubardo dans le forum Programmation et langages, Algorithmique
    Réponses: 0
    Dernier message: 01/11/2016, 16h16
  2. Problème d'accent circonflexe et de trëma
    Par wolf60240 dans le forum Sécurité et malwares : désinfectez votre machine
    Réponses: 5
    Dernier message: 03/10/2009, 12h51
  3. Problem de connection avec un site (seulement un)
    Par fino dans le forum Internet - Réseau - Sécurité générale
    Réponses: 15
    Dernier message: 18/06/2004, 13h33