Bonjour, cliquez-ici pour vous inscrire et participer au forum.
  • Login:



+ Répondre à la discussion
Page 1 sur 2 1 DernièreDernière
Affichage des résultats 1 à 15 sur 18

problème avec la fonction NB.SI d'excel

  1. haile

    Date d'inscription
    avril 2007
    Âge
    30
    Messages
    91

    problème avec la fonction NB.SI d'excel

    bonjour,

    j'ai un petit problème avec la fonction NB.SI d'excel:

    j'ai l'impression que le critère ne peut renvoyer à une cellule mais seulement à un nombre, me trompe-je?

    Je m'explique: je tape "=NB.SI(D3:D27; "<H53")" dans une cellule, la valeur de la cellule H53 est de -30.6, il est indiqué "0" dans la cellule lorsque je tape entrée. Mais si je remplace la formule par: "=NB.SI(D3:D27; "<-30,6")", le résultat me donne "1", et en effet, il y a bien une cellule dont la valeur est inférieure à -30.6 dans la plage "D3:D27".

    Donc j'en déduis que soit je n'ai pas trop saisi comment écrire la formule, soit il est impossible de donner une référence à une cellule, ce qui serait très génant pour ce que j'ai à faire (j'ai un grand nombre de feuille, et devoir rentrer à la main toutes les valeurs me prendrait beaucoup plus de temps, serait moins précis pour certains cas, et comporte un risque d'erreur)

    Je remercie ceux qui prendront la peine de me lire et de me répondre ;)

    -----

     


    • Publicité



  2. invite431

    Date d'inscription
    décembre 2006
    Messages
    0

    Re : problème avec la fonction NB.SI d'excel

    Bonjour,

    Dans NB.SI, le critère doit être exprimé sous forme de nombre, d'expression ou de texte, les adresses de cellule ne fonctonnent donc pas.
    Désolé.

    Amicalement
     

  3. haile

    Date d'inscription
    avril 2007
    Âge
    30
    Messages
    91

    Re : problème avec la fonction NB.SI d'excel

    mince :'(
    et il n'y a pas moyen de contourner cet obstacle?

    merci quand même
     

  4. Ciscoo

    Date d'inscription
    décembre 2006
    Localisation
    Albères 66
    Âge
    59
    Messages
    694

    Smile Re : problème avec la fonction NB.SI d'excel

    Bonjour Haile...

    Ci-joint un petit fichier qui te rendra peut être service.

    Si tu as besoin de beaucoup d'informations, de coups de main sur Excel, va donc faire un tour sur le forum Excel Downloads.

    Bonsoir.
    Fichiers attachés
    Cisco66
     

  5. haile

    Date d'inscription
    avril 2007
    Âge
    30
    Messages
    91

    Re : problème avec la fonction NB.SI d'excel

    merci beaucoup, ça m'a été très utile
     


    • Publicité



  6. halman

    Date d'inscription
    janvier 2003
    Âge
    56
    Messages
    906

    Re : problème avec la fonction NB.SI d'excel

    Dans l'aide d'Excel aussi c'est parfaitement bien expliqué.
     

  7. haile

    Date d'inscription
    avril 2007
    Âge
    30
    Messages
    91

    Re : problème avec la fonction NB.SI d'excel

    je ne connais pas ta version d'excel, mais dans la mienne, ce n'est pas expliqué
     

  8. halman

    Date d'inscription
    janvier 2003
    Âge
    56
    Messages
    906

    Re : problème avec la fonction NB.SI d'excel

    Office 2000

    NB.SI
    Voir aussi

    Compte le nombre de cellules à l'intérieur d'une plage qui répondent à un critère donné.

    Syntaxe

    NB.SI(plage;critère)

    plage représente la plage de cellules dans laquelle vous voulez compter les cellules.

    critère représente le critère, exprimé sous forme de nombre, d'expression ou de texte, qui détermine les cellules à compter. Par exemple, l'argument critère peut être exprimé sous une des formes suivantes : 32, « 32 », « >32 » ou « pommes ».

    Note

    Microsoft Excel offre des fonctions supplémentaires que vous pouvez utiliser pour analyser des données sur la base d'une condition. Par exemple, pour effectuer une addition basée sur une chaîne de texte ou sur un nombre à l'intérieur d'une plage, utilisez la fonction de feuille de calcul SOMME.SI. Pour faire en sorte qu'une formule renvoie une ou deux valeurs en fonction d'une condition telle qu'une prime à la vente basée sur un volume de ventes déterminé, utilisez la fonction SI. Voir Calcul d'une valeur en fonction d'une condition.

    Exemples

    Supposons que la plage A3:A6 contienne, respectivement, « pommes », « oranges », « pêches », « pommes » :

    NB.SI(A3:A6;"pommes") égale 2

    Supposons que la plage B3:B6 contienne respectivement 32, 54, 75 et 86 :

    NB.SI(B3:B6;">55") égale 2
     

  9. haile

    Date d'inscription
    avril 2007
    Âge
    30
    Messages
    91

    Re : problème avec la fonction NB.SI d'excel

    je pense que tu n'as pas bien lu mon problème...
     

  10. halman

    Date d'inscription
    janvier 2003
    Âge
    56
    Messages
    906

    Re : problème avec la fonction NB.SI d'excel

    Pas clair.

    NB.SI ne renvoit pas de valeur mais le nombre de cellules d'une plage qui contiennent la valeur cherchée.

    Si je comprend bien tu veux les noms des cellules concernées ?

    Peut être avec les fonctions recherche et recherchev.
     

  11. haile

    Date d'inscription
    avril 2007
    Âge
    30
    Messages
    91

    Re : problème avec la fonction NB.SI d'excel

    non, ce que je voulais, c'était pouvoir mettre comme critère une référence à une cellule
    ex: =NB.SI(A1:A25; ">B5")
    mais ça ne fonctionne pas comme ça, et je ne voulais pas avoir à recopier la valeur dans la formule pour chacune de mes formules (ex, ici: remplacer "B5" par sa valeur) car ce n'est pas pratique.

    mais Ciscoo m'a donné la réponse avec sa pièce jointe: pour mettre une référence à une cellule dans la formule, il faut écrire de la façon suivante:
    =NB.SI(A1:A25; ">"&B5)
    ainsi, il sera écrit dans la cellule le nombre de valeur dans la série A1:A25 qui sont supérieures à la valeur de B5
    voilà...
     

  12. zoup1

    Date d'inscription
    juillet 2004
    Localisation
    Paris
    Âge
    53
    Messages
    3 783

    Re : problème avec la fonction NB.SI d'excel

    Citation Envoyé par haile Voir le message
    non, ce que je voulais, c'était pouvoir mettre comme critère une référence à une cellule
    ex: =NB.SI(A1:A25; ">B5")
    mais ça ne fonctionne pas comme ça, et je ne voulais pas avoir à recopier la valeur dans la formule pour chacune de mes formules (ex, ici: remplacer "B5" par sa valeur) car ce n'est pas pratique.

    mais Ciscoo m'a donné la réponse avec sa pièce jointe: pour mettre une référence à une cellule dans la formule, il faut écrire de la façon suivante:
    =NB.SI(A1:A25; ">"&B5)
    ainsi, il sera écrit dans la cellule le nombre de valeur dans la série A1:A25 qui sont supérieures à la valeur de B5
    voilà...
    Je ne connaissais pas l'emploi du empersans (&) personnelement je faisais quelque chose comme
    =NB.SI(A1:A25; concatener(">";B5))

    Mais si je comprends bien & est un raccourci pour la fonction concatener... c'est bien cela ?
    Je te donne une idée, tu me donnes une idée, nous avons chacun deux idées.
     

  13. Ciscoo

    Date d'inscription
    décembre 2006
    Localisation
    Albères 66
    Âge
    59
    Messages
    694

    Smile Re : problème avec la fonction NB.SI d'excel

    Bonsoir à tous.

    Oui, le symbole & remplace la fonction concatener...

    @+
    Cisco66
     

  14. chathe56

    Date d'inscription
    décembre 2009
    Localisation
    Josselin
    Âge
    67
    Messages
    2

    Re : problème avec la fonction NB.SI d'excel

    Citation Envoyé par haile Voir le message
    bonjour,

    j'ai un petit problème avec la fonction NB.SI d'excel:

    j'ai l'impression que le critère ne peut renvoyer à une cellule mais seulement à un nombre, me trompe-je?

    Je m'explique: je tape "=NB.SI(D327; "<H53")" dans une cellule, la valeur de la cellule H53 est de -30.6, il est indiqué "0" dans la cellule lorsque je tape entrée. Mais si je remplace la formule par: "=NB.SI(D327; "<-30,6")", le résultat me donne "1", et en effet, il y a bien une cellule dont la valeur est inférieure à -30.6 dans la plage "D327".

    Donc j'en déduis que soit je n'ai pas trop saisi comment écrire la formule, soit il est impossible de donner une référence à une cellule, ce qui serait très génant pour ce que j'ai à faire (j'ai un grand nombre de feuille, et devoir rentrer à la main toutes les valeurs me prendrait beaucoup plus de temps, serait moins précis pour certains cas, et comporte un risque d'erreur)

    Je remercie ceux qui prendront la peine de me lire et de me répondre
    Bonjour,

    Il faut écrire la formule de la façon suivante:
    NB.SI(plage;"<"&H7) par exemple pour compter le nombre de résultats < au contenu de la cellule H7
     

  15. sitalgo

    Date d'inscription
    juin 2006
    Localisation
    La Réunion
    Messages
    4 494

    Re : problème avec la fonction NB.SI d'excel

    B'jour,
    Citation Envoyé par haile Voir le message
    mais Ciscoo m'a donné la réponse avec sa pièce jointe: pour mettre une référence à une cellule dans la formule, il faut écrire de la façon suivante:
    =NB.SI(A1:A25; ">"&B5)
    On peut aussi se référer au nom de la cellule
    =NB.SI(A1:A25; ">"&nom_cellule)
    Mais si t'as l'gosier, Qu'une armure d'acier, Matelasse. Brassens, Le bistrot.
     


    • Publicité







Sur le même thème :


    301 Moved Permanently

    301 Moved Permanently


    nginx/1.2.1



 

Discussions similaires

  1. probleme avec une fonction
    Par hammou dans le forum Mathématiques du supérieur
    Réponses: 14
    Dernier message: 17/08/2007, 13h14
  2. Comment utiliser la fonction LIEN_HYPERTEXTE d'excel
    Par vampyer972 dans le forum Logiciel - Software - Open Source
    Réponses: 9
    Dernier message: 01/12/2006, 23h46
  3. Un problème avec la fonction 1/(x²+1)
    Par jdh dans le forum Mathématiques du supérieur
    Réponses: 20
    Dernier message: 05/11/2006, 20h51
  4. problème demise à jour d'excel
    Par georges dans le forum Logiciel - Software - Open Source
    Réponses: 4
    Dernier message: 04/11/2004, 17h44
  5. Problème avec fonction Arc etc...
    Par Crono_post dans le forum Mathématiques du supérieur
    Réponses: 3
    Dernier message: 10/10/2004, 13h59