Répondre à la discussion
Affichage des résultats 1 à 13 sur 13

Panne carte ZL19N sur portail CAME FERNI à 2 battants



  1. #1
    meubeukeu

    Panne carte ZL19N sur portail CAME FERNI à 2 battants


    ------

    Bonjour,

    Mon terrain est équipé d'un portail CAME avec 2 moteurs FERNI, une carte de contrôle ZL19N, un boitier avec les batteries de secours et une carte radio AF43S

    Des limaces se sont introduites dans le boitier de commande de mon portail et ont provoqué des court-circuits sur la carte ZL19N. Les malheureuses ont grillé sur place.

    Résultat : fusible "Control Board" grillé et oxydation multiples sur la carte.

    J'ai nettoyé la carte, refait proprement les soudures oxydées et changé le fusible.

    A présent la diode rouge s'allume, en permanence, et rien ne se passe quoi que je fasse. Les boutons CH1 et CH2 ne font plus rien.

    J'ai tenté de désactiver les sécurités en mettant les DIP 8 9 et 10 sur ON, enlever la carte radio, mais rien n'y fait.

    J'ai tout examiné à la loupe, aucun composant ne semble détérioré visuellement.

    J'ai testé toutes les pistes à l'ohm-mètre ... rien à signaler.

    Pouvez vous m'aider à réparer cette carte ?

    Existe il un moyen de réinitialiser quelque chose ? avez vous un schéma électronique complet ?


    en pièce jointe, photo des dégâts (réparés) sur la carte, une 1ère limace est allée sur les relais de commande des moteurs, des accessoires et sur le connecteur vers la carte de commande, l'autre est allée sur les composants de régulation de l'alimentation ce qui a fait griller le fusible.

    Merci

    IMG_20170722_231219.jpg

    IMG_20170722_231137.jpg

    -----

  2. Publicité
  3. #2
    Jeryko

    Re : Panne carte ZL19N sur portail CAME FERNI à 2 battants

    Bonjour,

    Le fusible 5 "Control Board" 325 mA doit être celui qui alimente l'électronique de la carte.
    Donc le problème devrait être localisé sur la carte.
    Il va falloir sortir le "volto/Ohmmètre" mais sans schéma ?
    Là il faut commencer par les classiques (1) et avoir un peu d'expérience.

    (1) Déjà voir si en aval du fusible on ne détecte pas (Ohmmètre) un court-circuit,
    - Régulateur de tension ? Pont de diodes ? condensateurs ? etc... etc ...

    https://www.automatisme-online.fr/me...AME_notice.pdf

    Nota : à la fin, il serait bon de remettre un coup de bombe (vernis incolore) sur la face arrière de la carte pour
    éviter l'oxydation et améliorer l'isolement.
    Problème résolu : N'oubliez pas de préciser ce que vous avez trouvé et les mesures prises. Merci

  4. #3
    meubeukeu

    Re : Panne carte ZL19N sur portail CAME FERNI à 2 battants

    Bonjour Jeryko

    Merci beaucoup d'essayer de m'aider sur ce problème, c'est vraiment gentil.

    J'ai déjà étudié en long en large et en travers la notice.

    il y a une autre version avec quelques info complémentaires

    http://manuals.easygates.co.uk/PDF/misc/ZL19N.pdf

    cependant ces doc ne m'aident pas car elles décrivent comment installer la carte, mais pas de détails techniques ou de schéma ...

    Le fusible est changé, et le nouveau tient bon. L'alim est bonne elle sort du 12V et du 5V propre. La panne ne vient pas de ce côté.

    Le CPU (un ST62T65C6) est bien alimenté en 5V et semble fonctionner puisqu'il allume bien la diode rouge (point 13 en page 4)

    Cependant je n'ai aucune info sur le fonctionnement de la diode, à part quelle devrait clignoter lorsqu'on appuie sur CH1 ou CH2 et rester allumée après la prog d'une télécommande. mais doit elle rester allumée en permanence dès l'alimentation de la carte ? à elle un autre rôle ? je n'ai jamais vu une carte en fonctionnement je n'ai donc pas cette info.

    J'ai pensé à une non détection de la carte radio ... mais même la commande entre 2-7 2-3 ou 2-3P ne fait rien (en ayant bien entendu activé ces fonctionnalités sur le DIP10).

    Aucun relai ne s'enclenche. J'ai testé tout les relais et ils fonctionnent bien

    Je suppose que la première limace à fait un court circuit entre les relais de puissance et la carte CPU, et à cramé un truc sur la carte CPU, peut être endommager les entrées sortie du CPU et si c'est ça c'est mort car il faudrait pouvoir reprogrammer un nouveau CPU. je ne sais pas comment vérifier intégralement le CPU.

    La deuxième a fait sauter le fusible et a arrêté le massacre.

    Vu que la diode s'allume, je suppose donc que le CPU fonctionne, mais il doit bien y avoir un truc cramé. J'ai pensé éventuellement aussi au HEF4094BT (8-stage shift-and-store register) mais je n'ai pas encore compris son rôle ... et comme tu dis sans schéma c'est coton >_< !


    J'oubliais, lors de la panne, j'ai retrouvé la lumière du portail allumée, celle commandé par le CH2 sur le canal accessoire (B1-B2).
    Dernière modification par meubeukeu ; 23/07/2017 à 12h25.

  5. #4
    Jeryko

    Re : Panne carte ZL19N sur portail CAME FERNI à 2 battants

    Bonjour,

    Habituellement, une diode clignote si une commande est en cours ou si une sécurité est activée.

    Question : est-ce que les relais sont commandés par un CI ULN2003 ?
    Voila une piste car je pense que tu ne trouveras de schéma ! Si tu trouves un schéma, communique-le nous !

    Dans ce cas, t'inspirer du schéma ci-joint pour tester l'alimentation des relais et leur fonctionnement. (carte ZA3)
    - Vérifier d'abord que le principe utilisé est bien le même.
    - En mettant l'anode de la diode (celle en parallèle sur le relais) au 0V (borne 2 = 0VL en général),
    - En mettant une sortie de l'ULN 2003 au 0V ,
    ... le relais correspondant doit s'exciter. (voir le schéma)

    http://www.microfer.fr/geryko/telech...s/ZA3_CAME.jpg
    Problème résolu : N'oubliez pas de préciser ce que vous avez trouvé et les mesures prises. Merci

  6. Comparatifs

    Gagnez du temps et de l'argent grâce à nos comparatifs de produits de l'univers de la maison. Parmi nos sujets :
  7. #5
    Jeryko

    Re : Panne carte ZL19N sur portail CAME FERNI à 2 battants

    Re

    Voir aussi : (et participer à l'aventure en complétant)
    http://www.microfer.fr/geryko/telech...CAME_BX243.jpg (moteur 24V DC)
    - j'ai déjà eu le cas : pistes coupées entre relais et ULN 2003
    - déconnecter les moteurs pour tester le fonctionnement des relais.
    - ...

    Je ne possède pas de portail !
    Dernière modification par Jeryko ; 23/07/2017 à 14h55.
    Problème résolu : N'oubliez pas de préciser ce que vous avez trouvé et les mesures prises. Merci

  8. A voir en vidéo sur Futura
  9. #6
    meubeukeu

    Re : Panne carte ZL19N sur portail CAME FERNI à 2 battants

    Ah yes oui c'est le même principe merci pour ce schéma partiel ça aide à comprendre, et il y a effectivement 2 ULN2003 reliées justement là où la limace est allée.

    Ces composants sont fragiles ?

    cependant j'ai un doute que le problème vienne de là mais je vais vérifier ces points quand même, ce qui me chagrine c'est que la diode rouge reste allumée et ne clignote jamais, tu dis qu'elle clignote à chaque commande normalement ? vu qu'elle ne clignote pas, le CPU ne reçoit pas d'ordre ?! si c'était les ULN2003en cause, la diode clignoterait non ? je suis en train de vérifier comment sont cablées les commandes justement mais c'est pas simple a se repérer sur cette foutue carte

  10. Publicité
  11. #7
    meubeukeu

    Re : Panne carte ZL19N sur portail CAME FERNI à 2 battants

    Bon vu ... toutes les commandes, bouton CH1 CH2 1-2 2-3 2-3P 2-7 ... sont connectées sur le ST62T65C6, donc comme je n'ai aucune réaction ni changement d'état de la LED rouge qui reste allumée en permanence ... j'ai bien peur que ce soit le CPU HS et là c'est pas réparable sans reprog je vais avoir le droit d'en acheter une autre, bande de salles limaces.

  12. #8
    meubeukeu

    Re : Panne carte ZL19N sur portail CAME FERNI à 2 battants

    j'ai trouvé une anomalie à priori :

    court circuit sur le CPU entre VSS (PIN12 c'est la masse) et PA1 (PIN13) qui est relié au bouton CH2 alors que vu comme sont cablés CH1 et CH2, ils sont rélié au +5V par une resistance de 100ohm, leur rôle est de mettre les entrées su ST62 à l'état haut ... ce qui n'est plus possible ici. Je cherche voir si c'est à cause d'un autre composant ou si c'est le cpu HS.

    as tu un début de schéma de la carte de contrôle ?

  13. #9
    meubeukeu

    Re : Panne carte ZL19N sur portail CAME FERNI à 2 battants

    Bon, j'ai levé le PIN13 du ST62 ... c'est toujours en court-circuit avec VSS donc CPU HS, le court circuit est aussi ailleurs sur le circuit et en cherchant : sur le HEF4094BT court-circuit entre VSS QS1 OE QP0 QP5 D et STR !!

    donc affaire classée, CPU HS c'est pas la peine on ne peut pas remplacer sans avoir le prog d'origine

    en pièce jointe un début de schéma des connections des commandes si ça peut servir ...

    181835.JPG

  14. #10
    meubeukeu

    Re : Panne carte ZL19N sur portail CAME FERNI à 2 battants

    Pour les modérateurs, vous pouvez marquer ce sujet en "non résolu", je remplace la carte par une ZL19 d'occasion.

    Merci

  15. #11
    Jeryko

    Re : Panne carte ZL19N sur portail CAME FERNI à 2 battants

    Bonsoir,

    Vu ce que tu as fait, je suppose que tu n'es pas un débutant.
    Je suis quand même surpris qu'un micro-contrôleur (62T65) soit HS ?
    d'autant que le 4094 présente le même problème !
    Les 2 en court-circuit me semble impossible ! "y un truc ". Mais ne je peux t'aider plus à distance.

    Tu as un oscillo pour voir si l'horloge (quartz) fonctionne ? ou d'autres signaux ?
    La preuve que le micro est HS serait un peu plus nette.

    "as tu un début de schéma de la carte de contrôle ? " Je ne possède rien de plus qui pourrait t'aider.

    Bon courage
    Quel dommage d'enfermer des limaces ainsi ! bourreau !
    Dernière modification par Jeryko ; 23/07/2017 à 20h31.
    Problème résolu : N'oubliez pas de préciser ce que vous avez trouvé et les mesures prises. Merci

  16. #12
    meubeukeu

    Re : Panne carte ZL19N sur portail CAME FERNI à 2 battants

    Bonsoir,

    Effectivement je ne suis pas débutant mais je ne suis pas un pro non plus j'ai appris sur le tas et j'ai encore beaucoup de lacunes

    Y a (presque) pas de doute il est grillé le microcontrôleur, avec la patte dessoudée il ne devrait pas y avoir de liaison avec VSS car c'est un port d'I/O et c'est le seul PIN avec ce comportement. Il y a un autre PIN sur un Port B (je ne sais plus lequel) comme ça relié sur le PL des 2 HCF4021 qui est lié anormalement à VSS mais lorsque je le lève il n'y a plus de liaison avec VSS, et je n'ai pas regardé plus loin mais je pense que c'est le 4094 pour ce cas là qui fait le court jus.

    J'ai trouvé une carte d'occaz vraiment pas cher, je sais c'est la facilité mais au prix que je l'ai eu ça ne vaux plus le coup de s'embêter surtout avec un microcontrôleur certainement HS, et puis c'est vachement gênant un portail elec qui marche pas.

    J'essaierai de regarder plus tard un peu plus en détails pour vérifier le 4094 en le dessoudant complètement, mais ça ne m'étonnerais pas que tout ait cramé en même temps, la limace a fait un court jus entre le 24V des moteurs et la carte du contrôleur et ce n'est pas ce qui a fait sauter le fusible. les autres composants type R C et diodes sont tous bons et il n'y a aucun problème sur le PCB j'ai tout nettoyé et refait au propre.

    Pour le moment je n'ai plus oscillo sous la main, c'est ça lorsqu’on est en cours de déménagement ... je disséquerai la carte plus tard pour l’autopsie et j’alimenterai le sujet en tout cas, ça peut toujours servir.

    Pour ce qui est de la séquestration des limaces, chut, ne le dit pas à B.Bardot, mais avoue qu'elles l'ont bien mérité.

    Merci pour ton aide et franchement chapeau pour les schémas j'ai vu qu'ils sont de toi ! bravo il sont propres !

  17. Publicité
  18. #13
    Jeryko

    Re : Panne carte ZL19N sur portail CAME FERNI à 2 battants

    Bonjour meubeukeu,

    Merci.
    Non je ne le dirai pas à BB.
    Problème résolu : N'oubliez pas de préciser ce que vous avez trouvé et les mesures prises. Merci

Discussions similaires

  1. Réponses: 26
    Dernier message: 02/02/2016, 18h26
  2. carte de gestion portail a battants
    Par padepot89 dans le forum Dépannage
    Réponses: 0
    Dernier message: 21/01/2014, 20h09
  3. [Divers] Réglage fermeture portail motorisé Marque Came model Ferni
    Par dan54000 dans le forum Dépannage
    Réponses: 1
    Dernier message: 31/12/2012, 14h59
  4. motorisation came séri ferni ZA3 d'un portail 2 vantaux
    Par claudius62690 dans le forum Électronique
    Réponses: 0
    Dernier message: 27/03/2012, 09h05
  5. [Divers] Panne ouvre portail Ducati (2 battants)
    Par Flaromax dans le forum Dépannage
    Réponses: 2
    Dernier message: 27/11/2007, 09h04
Découvrez nos comparatifs produits sur l'univers de la maison