Répondre à la discussion
Affichage des résultats 1 à 11 sur 11

Problème d'alimentation d'un vibreur



  1. #1
    tonito53

    Problème d'alimentation d'un vibreur


    ------

    Bonjour,

    Dans le cadre d'un projet, j'ai un petit problème de dernières minutes...
    Une sortie d'un PIC18F4431 doit contrôler un vibreur, cette sortie envoie donc du 5Volt au vibreur, pour le faire vibrer.
    J'ai mis un AOP uA741 en montage suiveur, alimenté en +5 et 0, entre la sortie du PIC et le vibreur. Afin que le vibreur ne bouffe pas tout le courant.
    Mais le vibreur ne vibre pas et je ne vois pas le problème, car le signal en sortie du PIC est bon...

    Si quelqu'un avait une petite idée, cela me sortirait vraiment une épine du pied...

    Merci d'avance

    -----

  2. Publicité
  3. #2
    ordepedro

    Re : Problème d'alimentation d'un vibreur

    Bonjour,

    Citation Envoyé par tonito53 Voir le message
    Mais le vibreur ne vibre pas et je ne vois pas le problème, car le signal en sortie du PIC est bon...
    Et à la sortie de l'AO ça donne quoi ?
    Si tu alimentes l'AO en 0V - 5V tu n'auras jamais 5V ou 0V en sortie mais plutôt 1V - 4V ou pire...
    Un transistor ferait peut être l'affaire dans ce cas.

  4. #3
    tonito53

    Re : Problème d'alimentation d'un vibreur

    En sortie du transistor, j'ai un signal 0-3 Volt.
    Mais le vibreur doit marcher en 3 Volt, j'ai testé avec une alim.
    C'est que le aop ne délivre pas assez de courant je pense...

  5. #4
    ordepedro

    Re : Problème d'alimentation d'un vibreur

    Citation Envoyé par tonito53 Voir le message
    En sortie du transistor, j'ai un signal 0-3 Volt.
    transistor ou AOP ? Si c'est un transistor c'est étonnant: une chute de tension de 2V me paraît beaucoup.


    Citation Envoyé par tonito53 Voir le message
    C'est que le aop ne délivre pas assez de courant je pense...
    Le LM741 doit délivrer dans les 25mA. Regarde combien consome le moteur quand tu le branche avec l'alim

  6. #5
    tonito53

    Re : Problème d'alimentation d'un vibreur

    D'accord mais comment je fait pour voir ça?

  7. A voir en vidéo sur Futura
  8. #6
    ordepedro

    Re : Problème d'alimentation d'un vibreur

    Citation Envoyé par tonito53 Voir le message
    D'accord mais comment je fait pour voir ça?
    avec un amperemetre si t'en a un. Un volmetre et une petite résistance sinon.

  9. Publicité
  10. #7
    maxitec

    Re : Problème d'alimentation d'un vibreur

    Citation Envoyé par tonito53 Voir le message
    En sortie du transistor, j'ai un signal 0-3 Volt.
    Mais le vibreur doit marcher en 3 Volt, j'ai testé avec une alim.
    C'est que le aop ne délivre pas assez de courant je pense...
    quel transistor (NPN ou PNP )?
    Comment as tu branché le transistor et le vibreur ?
    si tu peux envoyer un petit schéma avec valeurs des composants, ça peut aider..

  11. #8
    ordepedro

    Re : Problème d'alimentation d'un vibreur

    R2 n'est pas critique comme valeure.
    Pour le transistor assure toi juste qu'il puisse laisser passer assez de courant, le 2N2222 monte jusqu'a 600mA, ça devrait suffire pour un vibreur de portable. Pour R1 c'est à calculer en fonction des caracteristiques du moteur (tension courant).

    voila un petit schéma:


    Ca doit se faire aussi en PNP et de pleins d'autres façons différentes...

  12. #9
    maxitec

    Re : Problème d'alimentation d'un vibreur

    Dans le schéma de ordepedro, je te suggère 1k pour R2 et de suivre les conseils de ordepedro pour le choix de R1.

  13. #10
    tonito53

    Re : Problème d'alimentation d'un vibreur

    D'accord je vais tester ça,
    ms sinon petite question pr le schéma du transitor, c'est une seule patte du vibreur seulement que l'on va connecter entre le collector et R1, et l'autre à la masse?
    C'est bien çela?
    merci

  14. #11
    ordepedro

    Re : Problème d'alimentation d'un vibreur

    Oui exactement, ton moteur n'a que 2 fils et il n'est pas polarisé je suppose. La patte du vibreur relié a R1 est celle que tu avais relié a la sortie de ton AO et celle qui était relié à la masse est maintenant relié au collecteur du transistor.

Discussions similaires

  1. Problème d'alimentation d'un point lumineux
    Par pjlt dans le forum Électronique
    Réponses: 6
    Dernier message: 17/09/2007, 20h26
  2. Calcul d'un schéma d'alimentation
    Par gaga2410 dans le forum Électronique
    Réponses: 4
    Dernier message: 15/08/2007, 10h59
  3. Tension d'alimentation d'un LM35 ?
    Par flyingman dans le forum Électronique
    Réponses: 1
    Dernier message: 06/02/2005, 19h48
  4. Tension d'alimentation d'un PC
    Par konkombre dans le forum Matériel - Hardware
    Réponses: 3
    Dernier message: 11/01/2005, 16h07
Découvrez nos comparatifs produits sur l'informatique et les technologies.