Répondre à la discussion
Affichage des résultats 1 à 4 sur 4

Parasite Servomoteur



  1. #1
    Magneau

    Exclamation Parasite Servomoteur


    ------

    Bonjour à tous,

    Voilà j'ai réalisé un robot et j'y ai implenté un servomoteur pour commander un bras.
    Quand le robot est à l'arrêt le servo se déplace sans problème mais quand les moteurs sont en marche, ils perturbent le servo qui se bloque en butée ou attrape la tremblote. Ce problème est assez génant puisque il est impossible d'utiliser le servoteur en marche.
    Les moteurs sont commandés par un pont en H et une PWM, à 100% aucun problème le servo tourne mais en dessous ca se complique.

    A l'oscillo on retrouve un parasite sur la masse, comment l'éliminer??
    Faut t'il placer un filtre sur les moteurs (condos)?

    Autre petite question, je commande mes moteurs à 20Khz mais j'ai l'impression qu'ils manquent de couple et ils ne démarent pas en dessous de 50% de rapport cyclique. Alors qu'a une fréquence plus basse il démarrent sans problème. A quoi cela est-il du? Quelle est la meilleur fréquence pour commander un moteur?

    Un grand merci à tous ceux qui sauront m'apporter des éléments de réponse.

    -----

  2. Publicité
  3. #2
    Magneau

    Re : Parasite Servomoteur

    Re
    Personne n'a une petite idée pour corriger le problème?

  4. #3
    F4DXU

    Re : Parasite Servomoteur

    Citation Envoyé par Magneau Voir le message
    Bonjour à tous,

    Voilà j'ai réalisé un robot et j'y ai implenté un servomoteur pour commander un bras.
    Quand le robot est à l'arrêt le servo se déplace sans problème mais quand les moteurs sont en marche, ils perturbent le servo qui se bloque en butée ou attrape la tremblote. Ce problème est assez génant puisque il est impossible d'utiliser le servoteur en marche.
    Les moteurs sont commandés par un pont en H et une PWM, à 100% aucun problème le servo tourne mais en dessous ca se complique.

    A l'oscillo on retrouve un parasite sur la masse, comment l'éliminer??
    Faut t'il placer un filtre sur les moteurs (condos)?

    Autre petite question, je commande mes moteurs à 20Khz mais j'ai l'impression qu'ils manquent de couple et ils ne démarent pas en dessous de 50% de rapport cyclique. Alors qu'a une fréquence plus basse il démarrent sans problème. A quoi cela est-il du? Quelle est la meilleur fréquence pour commander un moteur?

    Un grand merci à tous ceux qui sauront m'apporter des éléments de réponse.
    Bonjour Magneau,
    Pour ce genre de commande de moteur il est fortement conseillé d'utiliser des câbles blindés et correctement à une masse (CEM) unique. Certains moteurs sont équipés de filtres, voir avec le constructeur.
    A 20KHz, l'impédance du moteur augmente, par conséquent le courant diminue et le couple aussi. A cette fréquence, le moteur n'est pas bruyant mais il a beaucoup moins de couple, à utiliser si la charge est faible. En baissant la fréquence, le moteur sera plus bruyant mais le couple réapparaitra. Il faut trouver un compromis, mais avant tout on demande à un moteur d'emmener sa charge
    Cordialement, Jean-Marc de F4DXU (station radioamateur & pages web)

  5. #4
    PA5CAL

    Re : Parasite Servomoteur

    Bonjour

    Utiliser un condensateur en parallèle sur une sortie PWM est proprement catastrophique. On risque de griller les transistors du pont à cause d'une charge brutale du condensateur à chaque commutation.

    Il faut donc plutôt filtrer au moyen d'un réseau LC, en s'assurant préalablement que le pont est effectivement prévu pour fonctionner sur une charge très inductive. Dans le cas contraire, il faut:
    - monter des diodes rapides en inverse sur la sortie du pont, pour éliminer les surtensions,
    - vérifier que les transistors sont suffisamment dimensionner pour commuter à courant non nul (puissance dissipée élevée au moment de la commutation), et éventuellement en changer si ce n'est pas le cas.

    Il faut toutefois garder à l'esprit que ce type de filtrage, qui est très efficace pour éliminer les parasites, modifie le fonctionnement du montage. Il faudra dont faire particulièrement attention à la présence de fonctions électroniques supplémentaires au niveau du pont.

    Ci-joint les schémas correspondant à un pont en H et à une alimentation unipolaire.
    Images attachées Images attachées  

  6. A voir en vidéo sur Futura

Discussions similaires

  1. Servomoteur
    Par Adrien___ dans le forum Électronique
    Réponses: 3
    Dernier message: 23/06/2010, 20h35
  2. Commande ServoMoteur
    Par lafloettom dans le forum Électronique
    Réponses: 3
    Dernier message: 30/01/2007, 21h49
  3. Servomoteur
    Par tête de brique dans le forum Électronique
    Réponses: 2
    Dernier message: 03/12/2006, 10h34
  4. servomoteur DC
    Par ABN84 dans le forum Électronique
    Réponses: 5
    Dernier message: 21/07/2005, 18h45
  5. servomoteur
    Par rusty dans le forum Électronique
    Réponses: 5
    Dernier message: 17/04/2003, 16h22
Découvrez nos comparatifs produits sur l'informatique et les technologies.