Répondre à la discussion
Affichage des résultats 1 à 19 sur 19

Lutte anti-parasite HEEEEELP




  1. #1
    ronny

    Question Lutte anti-parasite HEEEEELP

    Bonjour à tous
    J’ai réalisé une petite alim à base d’un transfo 220V/18Volts suivi d’un pont redresseur, une capacité de filtrage de 470uF 63V en parallèle avec une céramique 150nf suivi d’un régulateur 12 Volts (7812CV) filtré en sortie par une cap de 100uF 63V en parallèle avec 10nF suivi enfin par un régulateur (7805) filtré en sortie par une cap de 220uF 63V. (Voir figure 1).

    Cette alimentation est destinée à alimenter une carte à base d’un microcontrôleur (constitué d’un clavier, des afficheurs à LED et un latch pour piloter les sorties. Tout cela est multiplexé sur un même bus de donnée. L’adressage se fait bien évidement à travers un autre bus dédié à cet effet) afin de commander à travers des relais de 12V des contacteurs aliumentés par du 220Vac. (Figure 2)

    noter (très importent) que le microcontrôleur effectue un balayage asynchrone constant des afficheurs et du clavier donc aucune perturbation d’alimentation n’est permise.

    Ma carte alimentée avec un bloque d’alimentation de labo fonctionne à merveille mais dés que j’ai tenté de placer mon alimentation, des misères sont apparus

    La genèse de mon alimentation :
    1- à la première mise en service de ma carte à uP sans les contacteurs de puissance (donc la carte à vide) avec ma carte d’Alimentation : dés que le relais commute (ferme) le uC délire et ne répond plus.
    Solution : j’ai omis les capacités de découplage de circuits logiques. Que j’ai vite placé et tout était rentré dans l’ordre….. mais c’est pas fini !

    2- la 2ème manip je branche le contacteur de puissance. Dés la fermeture du relais pour alimenter le contacteur 3 fois sur 4 le uC délire.
    Solution 1-> revue et modification du PCB de la carte logique de manière à isoler les pistes de puissance des pistes et circuits logiques (les inductions mutuelles obligent). Placement des cartes, d’alim et uC dans une cage de faraday reliée à la terre pour augmenter l’immunité au bruit. De là, 1 fois sur 2 le uC délire… donc c’est pas encor finis ?!

    Solution 2-> j’ai décidé d’utiliser deux prises électrique 220V distinctes (une pour alimenter ma carte d’alim et l’autre pour alimenter le contacteur). Miracle !!!!! ca fonctionne !!!!Fig 3

    Conclusion : ma carte d’alimentation et sensible au perturbations généré par le contacteur.

    3- j’ai donc cherché a comprendre pourquoi mon alimentation est ci sensible. Je me suis débrouillé un oscillo numérique pour observer ce qui se passe durant la phase de commutation (du contacteur bien évidement).
    - je configure l’oscillo en mode balayage unique
    - je place une sonde sur la sortie 12V du régulateur et l’autre sonde sur le 5V de l’autre régulateur sans oublier de relier la masse (GND) comme référence.
    - je configure le trigger (déclanchement) de l’oscillo sur le canal connecté au +5V, je règne le niveau de déclanchement à 4,2V sur front descendant
    Observations : à ma grande stupeur j’ai observé dés variation de science fiction au niveau de 12V et des variations effrayantes sur le 5V au point où je me dis que je risque la destruction pure et simple de mon uC
    Sur les 12V : la tension varie entre approximativement +25 et -10V sur une durée de 1,2ms
    Sur les 5V : la tension varie entre +15V et -1à-2V sur une durée également de 1.2ms

    4- j’ai soupçonné les relais de la carte uC. J’ais donc carrément débranché la carte CPU. Donc j’ai testé la carte d’alimentation à vide. Et j’ai placé en parallèle avec fils qui alimentent ma carte, mon contacteur (ma misère) commandé par un interrupteur pour simuler la fermeture ou l’ouverture du relais de la carte uC
    Observations à l’oscillo : Mille milliards de mille sabords !!!!!!!!! rien n’a changé les perturbation apparaissent toujours approximativement dans les mêmes proportions ! Figure 4

    Solus 1 :j’ai rajouté en vain des capacités de filtrage. Mais rien n’y fait …….
    Solus 2 : j’ai introduit une self ( autours d’une résistance de 220k j’ai enroulé du fil que j’ai retiré d’une bobine d’un relais et fait en 20ène de spires. Puis connecter les extrémités de part et d’autre de la résistance Figure 5) en entré du régulateur de 12V. Mais rien n’y fait …….
    Solus 3 : je déprime. … Mais ca ne marche pas non plus !!!!!!!




    En vous remerciant à premier abord d’avoir pris la peine de lire mon roman
    Et de plus merci d’avance pour toute contribution qui enrichira ce document et surtout qui m'aidera à régler ce problème

    Pour une lute sans apitoiement contre les parasite
    ronny

    -----

    Images attachées Images attachées

  2. Publicité
  3. #2
    ronny

    Re : Lutte anti-parasite HEEEEELP

    j'ai probablement découragé plus d'un. Désolé...
    je voudrais savoir SVP comment réaliser ou dimentionner un filtre secteur éfficace.
    merci et à binetôt

  4. #3
    Paulochon

    Re : Lutte anti-parasite HEEEEELP

    Bonsoir,

    Bonsoir en génral de nos jours il existe des prise secteur équipé de filte CEM permettant ce filtrage, Hors pour faire une filtre de secteur mais des Capa x et Y puis des self.

    Cordialement Paulochon
    Rien n'est plus proche du vrai que le faux ( Albert Einstein )


  5. #4
    Zig38

    Re : Lutte anti-parasite HEEEEELP

    Bonsoir:

    Puisque tout marche avec une alil extérieur, il y a un probléme avec ta carte alim.

    Je dirais à prmiéere vue, puisque

    "Observations : à ma grande stupeur j’ai observé dés variation de science fiction au niveau de 12V et des variations effrayantes sur le 5V au point où je me dis que je risque la destruction pure et simple de mon uC
    Sur les 12V : la tension varie entre approximativement +25 et -10V sur une durée de 1,2ms
    Sur les 5V : la tension varie entre +15V et -1à-2V sur une durée également de 1.2ms"


    Il y a peut-être un probléme de masse.

    A tu essayé de séparer les masses "petits signaux" des masses signaux de puissance pour les relier ensuite en étoile le plus prés possible de la masse amenée par le secteur?

    Je ne sais pas si ce que je te dit là te semble clair.

    Autre piste, mettre des diodes de roues libres sure les alimentations des relais pour la décharge des bobines dans celles-ci.

    Autre piste, parfois le régulateur le plus solicité chauffe et se met en limitation, ce qui cré des perturbations sur les alimentation, mets si necessaire un radiateur sur le 7805.

    A suivre...

  6. #5
    Paulochon

    Re : Lutte anti-parasite HEEEEELP

    Voici un lien que je vien de trouvé à l'insatant sur google,
    Mais il doit y en avoir encore plein d'autres sur le sujet

    http://www.sonelec-musique.com/elect...cteur_001.html

    Cordialement Paulochon
    Rien n'est plus proche du vrai que le faux ( Albert Einstein )

  7. A voir en vidéo sur Futura
  8. #6
    f6bes

    Re : Lutte anti-parasite HEEEEELP

    Bsr Ronny,
    On trouve généralement des filtres secteurs sur tous les TV , ordinateurs, etc...
    qui générent pas mal de signaux en tous genres.
    A récupérer sur un de ces appareils par exemple.
    Un filtre récupérer sur un ordianateur:
    Cordialement
    Images attachées Images attachées
    "Ce fut la goutte d'eau de trop qui mit le feu aux poudres!"

  9. #7
    ronny

    Re : Lutte anti-parasite HEEEEELP

    bjr
    avant tout je tient à vous remercier infiniment pour vaux orientations. je vais faire les ésssais ce soir et je vous rend les conclusion et les capteures d'oscillo avant et apres la pose des filtres.

    De Zig38 "A tu essayé de séparer les masses "petits signaux" des masses signaux de puissance pour les relier ensuite en étoile le plus prés possible de la masse amenée par le secteur?
    Je ne sais pas si ce que je te dit là te semble clair."
    recus 5/5 j'ai pas fait cette manip toutes les masses sont reliés en ligne et non en étoile.
    "...mettre des diodes de roues libres..."
    c'est déja fait. Là n'est pas le problème car l'alim est perturbé même à vide (à noter que la carte alimentation est séparé de la carte CPU )
    seul le régulateur de 12V chauffe et qui est mis sous radiateur

    OK finalement je vais opter pour un filtre de récup.

    Ps: ya t-il une méthode pour dimentionner les filtres selon les type de parasite ou bien c'est vrément standardisé. quels sont les critères qui permettent de déterminer l'éfficacité du filtre.

    à bientôt

  10. Publicité
  11. #8
    ronny

    Re : Lutte anti-parasite HEEEEELP

    désolé pour la question hative précédente. je fais un saut au site proposé par Paulochon

    http://www.sonelec-musique.com/elect...lisations_filt re_secteur_001.html

    puis si question je revient.
    merci...

  12. #9
    ronny

    Unhappy Re : Lutte anti-parasite HEEEEELP

    Bjr à tous.
    Comme promis j’ai amené avec moi les oscillogrammes.
    Les perturbations subsistent toujours. la pièce jointe comporte des captures d'écran d'oscilloscope.

    l'autre pièce jointe montre la photo du filtre anti parasite que j'ai utilisé (je l'ai récupéré d'une machine à laver.

    à noter depuis que j'ai placé le filtre les 12V sont moin instable.

    quels sont les autres oriontation à suivre pour cerner la source du problème?

  13. #10
    ronny

    Post Re : Lutte anti-parasite HEEEEELP

    les pièces jointes
    Images attachées Images attachées

  14. #11
    lempat

    Re : Lutte anti-parasite HEEEEELP

    Bonjour

    le 0v ("masse") il faut le soigner, il faut faire des plages à la place de faire des pistes
    je connais une collection (mr alain Charoy ed Dunod Tech) qui parle bien de tout cela

  15. #12
    abracadabra75

    Re : Lutte anti-parasite HEEEEELP

    Bonjour.
    Tu nous mets bien les schémas fonctionnels de ton alim, mais pas le schéma de réalisation. Il faut envisager l' erreur.
    Et comment es-tu passé du schéma de réalisation au typon de circuit imprimé?
    Pour que ton alim présente de telles anomalies, il doit y avoir une erreur de réalisation, ou de conception, ou de montage....
    Dans une transposition manuelle du schéma théorique à celui de conception du ciurcuit imprimé, une erreur de routage est vite arrivée. Et le réalisateur ayant dans la tête ce qu' il voudrait voir, voit diffiicilement la triste réalité de l' erreur commise. Un condo chimique monté à l' envers donne des resultats 'unpredictables' avant d' éclater.
    Je ne dis pas que tu as fait une erreur, mais il faut aussi envisager cette piste.
    J' espère que tu vas trouver la solution et que tu nous donneras la clé de ton énigme.
    A+
    Il n'y a que dans le dictionnaire où 'réussite' vient avant 'travail'.

  16. #13
    polo974

    Re : Lutte anti-parasite HEEEEELP

    En regardant les chronos, il semble que ton alim est à la limite de l'oscillation, une petite pichenette, et ça part pour un "certain temps"...

    De mémoire, un 78XX doit être chargé à un minimum de courant (20mA, je crois). Si ce courant n'est pas consommé, le 7805 ne peut plus réguler correctement.

    Donc une led avec une 150 ohm et hop...

    Ensuite, le filtrage et une masse soignée ne font jamais de mal...

    En espérant t'avoir aidé.

  17. #14
    ronny

    Re : Lutte anti-parasite HEEEEELP

    OK! je vais suivre les ocnseils.
    je vous tiend au courant demain

    "Je ne dis pas que tu as fait une erreur, mais il faut aussi envisager cette piste"
    l'erreur est humaine. elus pour pouvoir avancer dans la vie il faut accepter les critiques "constructive. de + je n'ai pas envisagé cette possibilité

    à demain!...

  18. #15
    lempat

    Re : Lutte anti-parasite HEEEEELP

    bonjour

    j'ai fait un copier coller de ce sujet

    il faudrait mesurer par rapport au 0v du condo de filtrage, les 0v au régulateur 7805, µp, ....

  19. #16
    ronny

    Re : Lutte anti-parasite HEEEEELP

    « il faudrait mesurer par rapport au 0v du condo de filtrage, les 0v au régulateur 7805, µp,
    .... »
    Merci ! j’ai pas pensé .
    .
    « le 0v ("masse") il faut le soigner, il faut faire des plages à la place de faire des pistes »

    Comme le PCB est déjà réalisé que diriez-vous de placer des shunts en cuivre ?

    « Et comment es-tu passé du schéma de réalisation au typon de circuit imprimé? »

    J’ai utilisé Protel et j’ai même vérifiée à l’œil (donc pas possible de ce tromper lors de la transposition) le schémas électrique et le pcb tel que je l’ai réalisé sont joint.

    « En regardant les chronos, il semble que ton alim est à la limite de l'oscillation, une petite pichenette, et ça part pour un "certain temps"... »

    Je n’ai pas très bien saisi. Tu voudrais dire qu’elle (l’alimentation ou la carte CPU ?) sera détruite ? Je me demande franchement comment mon uC n’est pas détruit ?



    Grand bonjour à tous.
    Je crois que mon problème est réglé.
    J’ai fait une découverte stupéfiante :
    Genèse :
    à noter :tous mes appareils sont connectés sur la même ligne.
    1- j’ai isolé le contacteur de puissance en utilisant un interrupteur extérieur. Donc plus de relation entre le contacteur et le relais de la carte logique.
    OBS- j’obtiens sur les 5V des oscillations quasi identiques aux chronogrammes précédents.
    2- pour le fun, j’ai décidé de débrancher la prise l’alimentation de ma carte électronique (donc ma carte est totalement isolée du secteur).
    OBS- à ma grande surprise j’observe des oscillations sur le 5V de +/- 10V!!!!!!!!!!!!!!!!!!!!!!!!!!! !!! ….Ok, vous me diriez que c’est l’oscillo qui ne va pas, étant donné qu’il est sur la même ligne que mon contacteur.
    3- je prend mon onduleur PC (bien chargé) je le débranche du secteur, je branche sur mon oscillo et je le met en service. Là j’ai un 220V 50hz totalement isolé.
    OBS- OUAouuuuuu….. c’est de la folie !!!! Les perturbations subsistent ! de même amplitude que précédemment. Bien que ma carte électronique soit complètement débranchée !

    CONCLUSION : je suppose que se sont les ondes électromagnétiques générées par le contacteur qui perturbent ma carte. Donc ma carte se comporte comme une antenne. D’autant plus que je n’ai pas mis de plan de masse.

    Dans mon cas pour réduire au max les effets :
    a- j’ai placé mes cartes dans un boîtier d’alimentation PC (cage de faraday)
    b- j’ai totalement isolé les câbles qui viennent du secteur des nappes
    c- j’ai doublé les capacité de découplage 10nF // 100n ou 350nF
    d- j’ai ajouté une résistance entre le +5V et Gnd de 330ohms. c’est efficace

    Depuis ma réalisation est fiable à 80% alors qu’elle était à 0%

    Leçon à retenir :
    Lors de la réalisation d’une carte électronique à base de uC faire très attention à la compatibilité électromagnétique.
    1- placer un plan de masse aussi large que possible
    2- isoler les pistes de puissance et de faible puissance
    3- isoler au max les nappes ou tout autre connectique
    4- attention lors de l’utilisation des circuits en haute impédance prévoir des filtres sur ces lignes.
    5- Ne pas oublier les capacités de découplage. Celles-ci sont indispensables. Evites les caps de récupération.
    Voilà pour mon expérience.

    Je tiens vivement à vous remercier pour vos orientations et idées.

    PS : y a-t-il d’autre sites qui traitent de tout ou en partie de cela en détail ?. Serai-il possible d’avoir les adresses ?. merci par avance


    ------------------------------------------------------------------------
    « La première faculté de l’homme ce n’est pas sa volonté mais son imagination »
    Images attachées Images attachées

  20. #17
    lempat

    Re : Lutte anti-parasite HEEEEELP

    peut etre, voir google......
    sinon la collection que je possèdes (5 tomes, auteur Mr alain Charoy, editions Dunod Technique), je ne regrette pas de l'avoir achetée
    si tu pouvais la trouver dans une bibli

  21. #18
    polo974

    Re : Lutte anti-parasite HEEEEELP

    Attention, la sérigraphie (jaune) indique + du maivais coté de cp3 et cp4, donc si tu t'es fié à ça pour les poser, c'est pas bon... pour ne pas dire mauvais...
    A priori, pour tes condos, le +, c'est la pastille carrée.

    Attention, un condo polarisé à l'envers, ça peut fuir, couler et puer (voir pire si affinité), si, si, j'ai déjà donné because pont de diode à l'envers...

    Bonne continuation

  22. #19
    abracadabra75

    Re : Lutte anti-parasite HEEEEELP

    Un truc pour ne pas (enfin moins....) se tromper: je commence par dessiner les lignes d' alimentation d' une autre couleur que celle de liaison entre composants, une couleur pour le (ou les) V+, et une autre pour le 0V.
    Quitte ensuite à faire un 2ème dessin monochrome au cas ou les plans de masses seraient difficiles à réaliser.
    Mais ça n' empêche pas totalement le montage d' un chimique à l ' envers.
    Quand on a la tête à l 'envers....
    A+
    Il n'y a que dans le dictionnaire où 'réussite' vient avant 'travail'.

Sur le même thème :

Discussions similaires

  1. Césium = anti-ionisant, anti-oxydant : pourquoi ?
    Par mainak29 dans le forum Chimie
    Réponses: 5
    Dernier message: 19/11/2007, 15h22
  2. [Blanc] problème anti-parasite lave linge
    Par coustif dans le forum Dépannage
    Réponses: 4
    Dernier message: 02/07/2007, 20h12
  3. anti septique bactéricide et anti-inflammatoire
    Par sosso1500 dans le forum Chimie
    Réponses: 0
    Dernier message: 31/01/2006, 17h12
  4. Anti parasite secteur
    Par NuklearStriker dans le forum Électronique
    Réponses: 9
    Dernier message: 02/12/2004, 09h12
  5. Anti-parasite
    Par MicroPuce dans le forum Électronique
    Réponses: 2
    Dernier message: 31/05/2004, 17h58