Répondre à la discussion
Affichage des résultats 1 à 20 sur 20

Sorties inactives ? d'un 74HC164



  1. #1
    thomasalbert1993

    Exclamation Sorties inactives ? d'un 74HC164

    Bonjour

    Désolé, je n'ai pas de schéma, mais j'ai 7 leds dont les anodes sont reliées au 5V, et dont les cathodes sont reliées à des résistances de 470Ohms dont l'autre patte est reliée à chaque sortie d'un 74HC164 (il s'agit en fait d'un afficheur 7 segments).

    Le pb, est qu'à la mise sous tension du montage, l'afficheur affiche une valeur quelque peu aléatoire, et reste souvent sur la valeur "6".
    J'ai essayé manuellement (en reliant data1 à la masse (data2 est au 5V) et en donnant des impulsions sur clock). Ainsi toutes mes segments devraient etre allumés, mais il y en a un qui ne l'est pas. J'ai un second montage identique, mais cette fois ci c'est un "0" qui s'affiche et qui reste. Ainsi le segment du milieu e s'allume pas.

    J4ai pourtant vérifié au voltmètre que les sorties soient bien à 0, c'est le cas.
    Donc s'agit il d'une sortie grillée sur chaque 74HC164 (j'en ai testé plusieurs, peut etre en ai-s je tous grillé une sortie ? d'autant pluq que j'obitnes toujours un "6" avec deux registrese differetns, et qu'il n'y a a priori aucun court circuit sur ma carte, et les afficheurs fonctionnent parfaitement)

    quelqu'un a til une idée d'où peut venir ce probleme ?

    -----


  2. Publicité
  3. #2
    DAUDET78

    Re : Sorties inactives ? d'un 74HC164

    Un 74HC164, à la mise sous tension est dans un état quelconque (fonction de l'échantillon, de la température, de la vitesse d'établissement du Vcc .....et de l'age du capitaine!) comme toutes bascules dans un circuit intégré
    Si tu veux "qu'il tombe" dans un état précis, il faut faire un Reset du circuit au PowerOn.
    Et tu ne peux faire qu'une mise à l'état "0" en mettant un "0" fugitif sur la borne Clear du 74HC164 (Pin 9)
    Comme tu pilotes sans doute ton 74HC164 par un µP (enfin j'imagine), tu peux , au PowerON, envoyer une rafale de "1" dans ton registre pour l'initialiser.

    PS : 470 ohms de charge pour un 74HC164 .....je pense que tu es "hors spécification" .....vérifie sur la datasheet du 74HC164 le Iol! Utilise plutôt un 74LS164
    L'age n'est pas un handicap .... Encore faut-il arriver jusque là pour le constater !

  4. #3
    Jack

    Re : Sorties inactives ? d'un 74HC164

    J'ai essayé manuellement (en reliant data1 à la masse (data2 est au 5V) et en donnant des impulsions sur clock). Ainsi toutes mes segments devraient etre allumés
    Pourquoi ne pas faire un reset?

    Si ton montage est celui que tu indiques, tu ne peux pas griller de sortie du 74HC164. Saches cependant que le courant de sortie dela famille 74HC est assez limité.

    Tu dois avoir un problème de câblage.

    A+

  5. #4
    thomasalbert1993

    Re : Sorties inactives ? d'un 74HC164

    oh mince je savais justement pas quelle technologie utiliser... Je vais essayer ac un LS mais j'en n'ai qu'un seul (mais avec mes HC ça fonctionne quand meme, ou est le probleme ? l'intensité tyrop grosse ? ça fait 10mA par led. c'zes trop ?)

    au fait, je viens de trouver apres maintes recherches la cause des segments eteints : les osudure etaient mal faites et il n'y avait pas de contact...

    sinon pour l'aléatoire, ok j'ai compris...

    Edit : je vois que Jack a trouvé le probleme plus vite que moi ... Je ne comprend pas trop pour ton histoire de courant de sortie : il doivent juste faire passer à 0 les cathodes des LEDs, donc le courant est fournit par le 5V, non ? les sorties jouent ici presque un role de "transistor"

  6. #5
    Jack

    Re : Sorties inactives ? d'un 74HC164

    donc le courant est fournit par le 5V
    oui, mais il passe par un des deux transistors de sortie du 74HC164. Plus tu lui fais passer de courant et plus la tension à ses bornes va augmenter. En fait tu n'auras plus 0V à la sortie, donc la tension aux bornes de la 470 ohm va diminuer et par conséquent le courant de la led aussi.

    A+

  7. A voir en vidéo sur Futura
  8. #6
    thomasalbert1993

    Re : Sorties inactives ? d'un 74HC164

    de toute maniere, je trouve que les leds brillent correctement, donc ce n'est pas un pb...

    bon ba en totu cas merci, me reste plus qu'à voir d'où vient le pb des signaux SPI (ils ne se font pas. serait-ce un crout circuit sur une carte ou le microcontroleur qui est mort... that is the question )

  9. Publicité
  10. #7
    DAUDET78

    Re : Sorties inactives ? d'un 74HC164

    Citation Envoyé par thomasalbert1993 Voir le message
    de toute maniere, je trouve que les leds brillent correctement, donc ce n'est pas un pb...
    C'est vous qui voyez ........
    Faire un schéma qui est hors spécification, c'est acheter une corde pour se faire pendre ......Les HC164 finiront par rendre l'ame
    L'age n'est pas un handicap .... Encore faut-il arriver jusque là pour le constater !

  11. #8
    thomasalbert1993

    Re : Sorties inactives ? d'un 74HC164

    le pb est que je n'ai pas le temps d'acheter un LS (j'en ai deja un) deepseul:

  12. #9
    Jack

    Re : Sorties inactives ? d'un 74HC164

    Faire un schéma qui est hors spécification
    De quelles spécifications parles-tu?

  13. #10
    DAUDET78

    Re : Sorties inactives ? d'un 74HC164

    De la spec du 74HC164 qui n'accepte pas une LED alimentée en 5V avec une résistance de 470 ohms (j'ai pas été voir mais je pense pas !)
    L'age n'est pas un handicap .... Encore faut-il arriver jusque là pour le constater !

  14. #11
    Jack

    Re : Sorties inactives ? d'un 74HC164

    Le courant sera peut-être un petit peu faible, mais rien n'empêche de commander une led à partir d'un 74HC. Les niveaux logiques n'ont pas à être garantis.

    J'ai retrouvé çà dans une note TI:
    Images attachées Images attachées

  15. #12
    DAUDET78

    Re : Sorties inactives ? d'un 74HC164

    Le courant Iol maximum garantie sur un 74HC164 est de 4mA. Toute autre affirmation est du typique qui n'est pas garantie. C'est vous qui voyez !
    http://www.datasheetcatalog.com/data.../74HC164.shtml
    L'age n'est pas un handicap .... Encore faut-il arriver jusque là pour le constater !

  16. Publicité
  17. #13
    Jack

    Re : Sorties inactives ? d'un 74HC164

    Le Iol est donné pour garantir un niveau logique bas. En l'occurrence, ça ne présente aucun intérêt puisque c'est le comportement analogique de la porte qui nous intéresse.

  18. #14
    DAUDET78

    Re : Sorties inactives ? d'un 74HC164

    Si on dépasse le Iol, on ne sait absolument pas quel est le comportement de la sortie (et cela peut varier énormément d'un fabriquant à un autre !). Utiliser un circuit dans une zone "hors spécification" c'est acheter une corde pour se faire pendre. Pour moi, je ne joue jamais à la roulette Russe ! En 12 ans de Hot line chez Texas Instruments, j'ai vécu trop de drame en direct ! Ca marche avec le circuit de XXXX et pas de Texas? Ca marchait avec le circuit de Texas avant et plus avec celui que je viens d'acheter?
    L'age n'est pas un handicap .... Encore faut-il arriver jusque là pour le constater !

  19. #15
    Jack

    Re : Sorties inactives ? d'un 74HC164

    Je sais bien, on en a déjà parlé. Ce n'est que l'alimentation d'une led. Un écart de spécification ne va pas avoir de grandes conséquences, surtout pour un montage amateur : ce n'est pas un montage destiné à Dassault.

  20. #16
    DAUDET78

    Re : Sorties inactives ? d'un 74HC164

    C'est pareil pour Dassault ou un montage de bidouilleur. Peux tu répondre à la question :
    Je fais passer 15 mA en Iol d'un 74HCxx, quelle est la tension de saturation? non? Forget it !
    L'age n'est pas un handicap .... Encore faut-il arriver jusque là pour le constater !

  21. #17
    Jack

    Re : Sorties inactives ? d'un 74HC164

    Pourquoi TI s'amuse-t-il à donner ce genre d'info alors si c'est inexploitable?

  22. #18
    DAUDET78

    Re : Sorties inactives ? d'un 74HC164

    Toust le monde peut écrire une anerie. tu as le lien sur ton document TI? c'est sur le site de TEXAS?
    L'age n'est pas un handicap .... Encore faut-il arriver jusque là pour le constater !

  23. Publicité
  24. #19
    Jack

    Re : Sorties inactives ? d'un 74HC164

    Voici le document complet:
    Fichiers attachés Fichiers attachés

  25. #20
    DAUDET78

    Re : Sorties inactives ? d'un 74HC164

    Merci Jack pour le document T.I.
    Je ne comprend pas comment ce document a pu être publié par Texas Instruments. Normalement il doit passer par les fourches Caudines du contrôle qualité (QA) et du laboratoire d'application qui donnent un "Bon à tirer". Il n'y a pas que les LED qui me posent problème, le schéma oscillateur de la figure 34 est mauvais, le VCO fig 36 est limite !
    Par contre, les 98% du document qui reste sont intéressants et instructifs
    L'age n'est pas un handicap .... Encore faut-il arriver jusque là pour le constater !

Sur le même thème :

Discussions similaires

  1. fonctions Win Xp inactives
    Par wakrime dans le forum Logiciel - Software - Open Source
    Réponses: 1
    Dernier message: 10/12/2007, 17h53
  2. Amplification de sorties µC
    Par Tony78 dans le forum Électronique
    Réponses: 2
    Dernier message: 31/10/2007, 09h15
  3. pic et 74hc164
    Par sdow dans le forum Électronique
    Réponses: 3
    Dernier message: 15/10/2007, 22h46
  4. Gènes non inactivés sur le corpuscule de Barr
    Par Vinc dans le forum Biologie
    Réponses: 2
    Dernier message: 07/03/2006, 21h50
  5. Amplifier les sorties d'un port parallèle
    Par Quicky dans le forum Électronique
    Réponses: 1
    Dernier message: 10/06/2005, 12h41