Répondre à la discussion
Affichage des résultats 1 à 6 sur 6

Probleme avec MPLAB.



  1. #1
    franck29

    Probleme avec MPLAB.

    Bonsoir !

    Je viens d'installer MPLAB 8.0 et CC5X pour programmer en C.

    J'ai charger un petit programme mais voila l'erreur que j'ai après avoir cliquez sur compilation:



    Il n'arrive pas à ouvrir le fichier "pic16f84a.h".

    Sur d'autre topic de ce forum j'ai pu lire que d'autre avez eu ce problème mais j'arrive pas à le résoudre.

    Merci pour votre aide.

    -----


  2. Publicité
  3. #2
    HULK28

    Re : Probleme avec MPLAB.

    Bonsoir,

    normal puisque tu déclares "16f84A.h" et que MPLAB ne le trouve pas.

    Essaye avec "C:\Pic\CC5X\16F84A.h", tu lui donneras ainsi le bon chemin.
    Tout est bien qui finit.

  4. #3
    franck29

    Re : Probleme avec MPLAB.

    J'ai déjà essayer sa, c'est bien dans "Projet" --- "build options" --- "projet" --- "Include Search path" que je doit entrer: "C:\Pic\CC5X\16F84A.h" ???

    Le probleme c'est que sa ne marche pas mieux. Je viens de supprimer du programme la fonction #include du programme et mis que "C:\Pic\CC5X" et la sa marche, allez comprendre pourquoi???

    Y'a une raison???

    Franck

  5. #4
    HULK28

    Re : Probleme avec MPLAB.

    le compilateur à besoin de connaitre le chemin du header (*.h) qui est normalement déclaré par ton #include <xxx.h>

    Si tu déclares:

    #include <16F84A.h>

    il va chercher ce header dans le même répertoire où se trouve ton compilateur, si tu déclares:

    #include "C:\......\16F84A" cela lui indique que le fichier est ailleurs et il va aller le chercher par le chemin indiqué entre guillemets.

    Si tu veux faire plus simple il suffit de copier le fichier 16F84A.h au même endroit que ton fichier C.
    Dernière modification par HULK28 ; 21/04/2008 à 19h59.
    Tout est bien qui finit.

  6. #5
    HULK28

    Re : Probleme avec MPLAB.

    Citation Envoyé par franck29 Voir le message
    J'ai déjà essayer sa, c'est bien dans "Projet" --- "build options" --- "projet" --- "Include Search path" que je doit entrer: "C:\Pic\CC5X\16F84A.h" ???

    Le probleme c'est que sa ne marche pas mieux. Je viens de supprimer du programme la fonction #include du programme et mis que "C:\Pic\CC5X" et la sa marche, allez comprendre pourquoi???

    Y'a une raison???

    Franck
    La raison est ici évidente, d'un coté tu lui dis qu'il doit chercher le .h par tel chemin et de l'autre tu lui indiques un include (dans le programme) qui ne correspond pas au même chemin...
    En enlevant le include du programme tu rétablis les choses puisque par défaut il va suivre le chemin que tu as entré dans le "projet build options....".
    Donc enlève le include de ton programme si tu as déjà renseigné le chemin tel que tu l'as fait avec "build options" --- "projet" --- "Include Search path"
    Dernière modification par HULK28 ; 21/04/2008 à 20h01.
    Tout est bien qui finit.

  7. A voir en vidéo sur Futura
  8. #6
    RISC

    Re : Probleme avec MPLAB.

    Frank,

    Pour que le compilateur trouve le fichier 16F84A.h, il y a plusieurs solutions.

    Une de ces solutions est de copier ce fichier dans le répertoire de ton projet ou se trouve ton/tes fichier(s) source(s) en C et de changer la ligne en :
    #include "16F84A.h" ( "xxxx" signifie cherche dans le répertoire du projet)

    a+

  9. Publicité

Sur le même thème :

Discussions similaires

  1. CCS avec mplab
    Par sdow dans le forum Électronique
    Réponses: 0
    Dernier message: 10/02/2008, 17h52
  2. Problème avec MPlab et Hitech PICC18
    Par Rémiz dans le forum Électronique
    Réponses: 3
    Dernier message: 07/03/2007, 20h15
  3. Debuggage avec MPLAB 7.20 ??
    Par Adrian1903 dans le forum Électronique
    Réponses: 2
    Dernier message: 06/05/2006, 07h45
  4. MPLAB - probleme avec mes ports
    Par Mendoza dans le forum Électronique
    Réponses: 9
    Dernier message: 06/12/2005, 20h24
  5. Problèmes MPLAB et ICPROG avec XP
    Par twinotter dans le forum Électronique
    Réponses: 3
    Dernier message: 07/02/2005, 13h24