Répondre à la discussion
Affichage des résultats 1 à 3 sur 3

Problème de configuration PIC 18F4431



  1. #1
    sébii

    Problème de configuration PIC 18F4431


    ------

    Bonjour à tous! Voila j'ai un problème de configuration de port, enfin je pense. Je m'explique quand j'utilise l'émuleur ICEPIC 3 pour émuler mon programme tout fonctionne mais quand je programme mon pic et que je l'utilise, la broche "RD7/PWM7" ne réagit pas alors qu'avec l'émuleur sa fonctionne bien. Je pense que c'est un problème de configuration du PIC.
    Si quelqu'un peut m'éclairer. MERCI DE VOTRE AIDE

    -----

  2. #2
    newguy

    Re : Problème de configuration PIC 18F4431

    Si tu crois que c'est un problème de configuration du PIC est-ce que tu pourrais nous montrer la partie de ton code où tu fais cette configuration.
    Il y a toujours un nouveau sur qui on peut mettre le blâme

  3. #3
    sébii

    Re : Problème de configuration PIC 18F4431

    Bonsoir, voila la configuration des "fusibles"
    LIST P=PIC18F4431
    #include p18F4431.inc
    ;***************************** *
    ;* Configuration des fusibles *
    ;***************************** *
    CONFIG OSC = HS
    CONFIG FCMEN = OFF
    CONFIG IESO = OFF
    CONFIG PWRTEN = ON
    CONFIG BOREN = OFF
    CONFIG WDTEN = OFF
    CONFIG WINEN = OFF
    CONFIG SSPMX = RD1 ; Selection sorties i2c
    CONFIG T1OSCMX = ON ; on = Inactive
    CONFIG HPOL = LOW ; High-Side Transistors Polarity: Active low ou Active high
    CONFIG LPOL = LOW ; Low-Side Transistors Polarity: Active low ou Active high
    CONFIG PWMPIN = OFF ; PWM output pins Reset state control:
    CONFIG MCLRE = ON
    CONFIG STVREN = OFF
    CONFIG LVP = OFF
    CONFIG DEBUG = OFF
    CONFIG CP0 = ON
    CONFIG CP1 = ON
    CONFIG CP2 = ON
    CONFIG CP3 = ON
    CONFIG CPB = OFF
    CONFIG CPD = OFF
    CONFIG WRT0 = ON
    CONFIG WRT1 = ON
    CONFIG WRT2 = ON
    CONFIG WRT3 = ON
    CONFIG WRTC = OFF
    CONFIG WRTB = OFF
    CONFIG WRTD = OFF
    CONFIG EBTR0 = ON
    CONFIG EBTR1 = ON
    CONFIG EBTR2 = ON
    CONFIG EBTR3 = ON
    CONFIG EBTRB = ON
    errorlevel -302 ;suppress "not in bank 0" message


    Voila ma configuration PWM

    ; Sorties PWM
    ;-------------
    movlw b'00001111' ; Config vitesse ; RB1 = PWM1
    movwf PTPERH ;RRRRxxxx ; RB3 = PWM2
    movlw b'11111111' ; RB4 = PWM5
    movwf PTPERL ;xxxxxxxx
    clrf PTCON0 ; config temps PWM
    movlw b'01111111' ; selection sorties PWM
    movwf PWMCON0
    clrf PWMCON1
    clrf PTMRH
    clrf PTMRL
    movlw b'00101010' ; selection sorties PWM
    movwf OVDCOND ; des sorties PWM
    movlw b'11010101' ; et
    movwf OVDCONS ; des sorties classique
    clrf FLTCONFIG ; pas detection erreur
    bsf FLTCONFIG,7
    clrf DTCON
    movlw b'10000000'
    movwf PTCON1 ; activation mode PWM


    Merci d'avance!

Discussions similaires

  1. probleme de configuration?? a l'aide...
    Par laurelac dans le forum Matériel - Hardware
    Réponses: 0
    Dernier message: 29/07/2007, 14h35
  2. aide à la configuration d"un pic
    Par alainav1 dans le forum Électronique
    Réponses: 0
    Dernier message: 05/05/2007, 17h36
  3. Problème de configuration de modem
    Par melekhb dans le forum Matériel - Hardware
    Réponses: 0
    Dernier message: 11/03/2007, 00h20
  4. problème configuration sesamTV
    Par airvan dans le forum Logiciel - Software - Open Source
    Réponses: 0
    Dernier message: 30/11/2006, 13h33
  5. probleme de configuration
    Par yoda1234 dans le forum Internet - Réseau - Sécurité générale
    Réponses: 3
    Dernier message: 25/10/2004, 20h19
Découvrez nos comparatifs produits sur l'informatique et les technologies.