Répondre à la discussion
Affichage des résultats 1 à 24 sur 24

Problème Alim stabilisée en courant à base d'un AOP et d'un MOSFET



  1. #1
    Eldindon

    Problème Alim stabilisée en courant à base d'un AOP et d'un MOSFET


    ------

    Bonjour bonjour,

    La personne qui m'as passé le schéma de cette alim m'ayant autorisé à le diffuser, je vais pouvoir vous demander un peu d'aide par rapport à ce dernier (si vous le voulez bien).


    Le but du montage:

    Apporter à la diode un courant constant de 1 A (sous 11.4V)


    Le schéma de principe:



    Le pont de diode (résistance 55K+potentiomètre 500 Ohm) apporte une tension variable de 0 à 0.1V à l'AOP, ce dernier étant câblé en suiveur.
    Du fait qu'il y a une boucle de rétroaction a travers le mos, on impose VR = VRef. Comme R = 0.1 ohm on a donc VR = Vref = I*0.1 c'est a dire I = Vref/0.1. on impose donc I grâce a Vref.

    La chute de tension du montage (mis à part la LED) étant de 0.370mV, on est sensé pouvoir obtenir 11.63V aux bornes de la LED.



    Les fiches techniques des composants utilisés:

    .LM201AN
    .IRF 520
    .LED 10w



    Le problème:

    Pour ne pas griller la LED (30€ pièce) je l'ai remplacé par une lampe halogène 12V 20V. Or au lieu d'avoir un courant variable pouvant aller jusqu'à un 1A, j'obtiens aux bornes de la lampe une valeur fixe de 1.43A pour 10,23V...

    Quel est le problème

    Merci d'avance pour votre aide.

    -----

  2. Publicité
  3. #2
    jiherve

    Re : Problème Alim stabilisée en courant à base d'un AOP et d'un MOSFET

    Bonjour
    Le LM201 ne peut pas fonctionner correctement dans cette configuration, il faut un ampli monotension avec entrée rail to rail.
    en restant chez NS LM7301 ou LM158.
    JR
    Dernière modification par jiherve ; 17/10/2008 à 19h47.
    l'électronique c'est pas du vaudou!

  4. #3
    Eldindon

    Re : Problème Alim stabilisée en courant à base d'un AOP et d'un MOSFET

    Super,
    Merci Jiherve de la réponse claire et rapide.
    En effet j'ai beaucoup de mal à déchiffrer les datasheets. Heureusement qu'il y a des personnes un peu plus "clairvoyantes" que moi.
    Je vais aller faire un petit tour au magasin d'électronique demain et je vous tiens au courant.
    D'ailleurs Jiherve, si tu veux 8 AOP LM201, je peux te les donner vu que j'en ai plus besoin.

    Merci encore.
    ++++

  5. #4
    jiherve

    Re : Problème Alim stabilisée en courant à base d'un AOP et d'un MOSFET

    Re
    Merci c'est sympa mais je n'en ai pas l'usage.
    JR
    l'électronique c'est pas du vaudou!

  6. A voir en vidéo sur Futura
  7. Comparatifs

    Gagnez du temps et de l'argent grâce à nos comparatifs de produits. Parmi nos sujets :
  8. #5
    electronsa

    Re : Problème Alim stabilisée en courant à base d'un AOP et d'un MOSFET

    bonsoir:bizarre car ce montage est un gene de courant! donc a priori le fait de remplacer la led par une ampoule est en cause: l'ampoule a une faible chute de tension,alors que la led non! :de 1.2v a 3v!. et +. a verifier!
    patou je sais! (proverbe de moutons)!

  9. #6
    jiherve

    Re : Problème Alim stabilisée en courant à base d'un AOP et d'un MOSFET

    l'électronique c'est pas du vaudou!

  10. Publicité
  11. #7
    DAUDET78

    Re : Problème Alim stabilisée en courant à base d'un AOP et d'un MOSFET

    Citation Envoyé par electronsa Voir le message
    l'ampoule a une faible chute de tension,alors que la led non! :de 1.2v a 3v!. et +. a verifier!
    L'ampoule chute 10V ..... c'est une forte chute de tension
    Citation Envoyé par Eldindon Voir le message
    La personne qui m'as passé le schéma de cette alim m'ayant autorisé à le diffuser
    Je comprend qu'il t'autorise !
    1/ Un schéma qui ne marche pas ..... (erreur sur le type d'ampliOP)
    2/ Un schéma ultra-classique
    3/ Qui devrait être alimenté en 6V (pour la LED) sinon, tu vas dissiper près de 10W dans le NMOS (et sans radiateur, il meurt)
    5/ Qui peut être alimenté en 6V pour l'AmpliOP avec un LM324 (ou autres) et un NMOS "logic" ou "TTL"

    Et si tu disposes de 6V, une simple résistance de 4 ohms 10W devrait faire l'affaire pour obtenir un courant de 1A. L'intérêt du montage avec NMOS, c'est de pouvoir facilement moduler la puissance de la LED avec une commande PWM ou analogique.
    J'aime pas le Grec

  12. #8
    tektro69

    Re : Problème Alim stabilisée en courant à base d'un AOP et d'un MOSFET

    Bonsoir

    Heuu je ne sais pas si tout le monde à lu les spec de la maxi LED

    j'ai cru comprendre qu'il preconise de monter les 4 LED (integrés) en series

    avec VFD global de 9.92V et 13.76V (dispersion) pour 700mA

    donc suivant la LED que tu as il faut mesurer la VFD à 700mA ou 1A (comme tu veux lui coller au cul)

    puis à partir de là faire un gene de courrant que si ton alim fluctue
    si alim stable un simple resistance de puissance comme a dit Daudet suffit

    @++ pour la suite

  13. #9
    DAUDET78

    Re : Problème Alim stabilisée en courant à base d'un AOP et d'un MOSFET

    Citation Envoyé par tektro69 Voir le message
    Heuu je ne sais pas si tout le monde à lu les spec de la maxi LED
    ben non, je viens de le faire ! effectivement, c'est plus proche de la lampe de phare que de la LED. Par contre, moi, je ne lui mettrais pas 1A aux fesses (maximum rating) mais 700 mA.

    Par contre, notre ami ElDindon en une ou plusieurs à allumer?
    J'aime pas le Grec

  14. #10
    Eldindon

    Re : Problème Alim stabilisée en courant à base d'un AOP et d'un MOSFET

    Bonjour à tous,

    Je ne comprends pas pourquoi le schéma ne s'affiche plus (je ne peux même pas éditer mon précédant message...). Je le remet donc ici:

    Alors pour que ce soit clair, la personne m'ayant donné ce schéma ne m'a pas précisé les composant à utiliser, donc l'erreur concernant le choix de ces derniers viens de moi.

    .La LED peut suporter 1A, après tout est une question de dissipation thermique (de ce coté j'ai ce qu'il faut). Par contre la courbe tension/courant varie en fonction de la température atteinte par la diode, c'est pour cette raison qu'il est plus que conseillé de l'alimenter en courant constant.

    .Effectivement je vais avoir plusieurs LEDs de ce type à alimenter (une LED par alim), je vais aussi en avoir des de 15W. J'ai déjà acheté tout les composants, donc si je pouvais rester sur ce montage ça m'arrangerais énormément....

    .Au magasin d'électronique ils n'avaient pas d'aop et mono tension et rail to rail.
    J'ai donc pris un LM324N qui n'est que monotension, je l'ai testé avec l'ampoule (avant que je ne lise tout ces messages) et le courant varie bien (mais que de 0 à 0.6A), par contre la tension augmente et n'arrive pas à ce stabiliser en partant de 0.4V. Comme le MOS chauffe énormément (normal dans cette configuration), je n'ai alimenté le montage que pendant 10s à chaque fois.

    Je vais donc essayer avec la led et je vous tiens au courant.

    Je n'ai pas compris pourquoi il fallait que l'AOP soit rail to rail, si quelqu'un pouvait m'expliquer ce serait gentil.

    Merci à tous.
    Dernière modification par Eldindon ; 18/10/2008 à 17h43. Motif: rajout image

  15. #11
    Eldindon

    Re : Problème Alim stabilisée en courant à base d'un AOP et d'un MOSFET

    Bonsoir,

    Alors j'ai branché une led avec en série un CL 160 (élément de protection).
    Les résultats sont surprenant...
    Pour 0.1V en entrée au niveau de l'AOP (normalement donnant 1A aux bornes de la LED), je me retrouve avec 0.4A pour 9.55V (valeurs qui augmentent avec le temps).

    Pour vous ces valeurs viennent du fait que l'AOP n'est pas rail to rail?

    Je vais sûrement faire une commande pour voir si j'arrive à atteindre les valeurs prévues.

    A bientôt

  16. #12
    DAUDET78

    Re : Problème Alim stabilisée en courant à base d'un AOP et d'un MOSFET

    Le montage actuel, c'est avec un LM201 ? C'est normal que ça ne marche pas . Tu n'as pas le droit de porter les entrées IN+ et In- a une tension voisine de son alimentation négative (paramètre Common-mode input voltage range)
    J'aime pas le Grec

  17. Publicité
  18. #13
    Eldindon

    Re : Problème Alim stabilisée en courant à base d'un AOP et d'un MOSFET

    Salut,

    Non j'utilise le LM324N que j'ai acheté tout à l'heure. Et j'arrive pas à trouver d'AOP rail to rail monotension disponibles et surtout pas trop cher; car à 5€ pièce, ça fait cher l'AOP... Si vous avez des pistes!

    +++

  19. #14
    DAUDET78

    Re : Problème Alim stabilisée en courant à base d'un AOP et d'un MOSFET

    le LM324 est correct pour ce montage. Tu as mis des condensateurs de découplage 470µF//0,1µF sur l'alimentation ?
    J'aime pas le Grec

  20. #15
    Eldindon

    Re : Problème Alim stabilisée en courant à base d'un AOP et d'un MOSFET

    L'alimentation est une de PC, mais non je n'ai pas mis de condensateurs. Il faudrait que je mette les 2 en parallèle (470µF et 0,1µF)?

    Pourquoi en mettre 2 s'il te plaît?

    Merci

  21. #16
    DAUDET78

    Re : Problème Alim stabilisée en courant à base d'un AOP et d'un MOSFET

    1/ Tu vires ton alimentation de PC qui n'est pas faite pour ça
    2/ Un pour les fréquences basses et un pour les fréquences élevés
    J'aime pas le Grec

  22. #17
    Eldindon

    Re : Problème Alim stabilisée en courant à base d'un AOP et d'un MOSFET

    Ok chef!

    Du coup ça attendra lundi (que les magasins soient ouverts).

    Je vous tiens au courant.
    Merci encore.

  23. #18
    DAUDET78

    Re : Problème Alim stabilisée en courant à base d'un AOP et d'un MOSFET

    Citation Envoyé par Eldindon Voir le message
    Du coup ça attendra lundi (que les magasins soient ouverts).
    Tu peux nous faire une p'tite photo de ton montage actuel ?
    J'aime pas le Grec

  24. Publicité
  25. #19
    Eldindon

    Re : Problème Alim stabilisée en courant à base d'un AOP et d'un MOSFET

    Salut,

    Voici quelques clichés:






    J'ai trouvé un condensateur 0.47µF que j'ai mis en // de l'alim, mais ça n'a rien changé aux valeurs.

    La "bonne" nouvelle:
    le cl160 produisait une chute de tension trop importante (5V sous 1A); après l'avoir enlevé, le courant dans la diode passe de 0.4A à 0.75A. Donc avec un AOP rail to rail, on devrait pouvoir atteindre 1A! Maintenant ça veut dire que si j'utilise une alim 12v je ne peux pas avoir de protection...

    Je m'en vais prospecter pour trouver un APO rail to rail pas cher...

    +++

  26. #20
    DAUDET78

    Re : Problème Alim stabilisée en courant à base d'un AOP et d'un MOSFET

    Citation Envoyé par Eldindon Voir le message
    Donc avec un AOP rail to rail, on devrait pouvoir atteindre 1A!
    le LM324 est parfait pour cette application. Par contre le câblage sur plaque à pince .... c'est pas génial pour faire de la puissance (0,1 ohm vis à vis de la résistance de contact ....). Utilise plutôt de la plaque à trou ou à bande
    J'aime pas le Grec

  27. #21
    Eldindon

    Re : Problème Alim stabilisée en courant à base d'un AOP et d'un MOSFET

    Hello,

    J'ai (encore) deux questions:

    1) Si, pour alimenter 4 leds (4 alims différentes) à 1A, j'utilise le même pont diviseur de tension, ça peut fonctionner? (voir schéma ci-après)

    En rouge c'est le circuit imprimé, en jaune ce sont des fils, en bleu c'est un potentiomètre.

    Car si ce n'est pas possible, ça va être le bazar au niveau câblage...


    2) Puis-je alimenter en parallèle 2 leds sur la même alim, de façon à ce que les 2 reçoivent un ampérage 2 fois moins élevé que si il n'y en avait qu'une? (voir schéma ci-après)

    En rouge c'est le circuit imprimé, en jaune ce sont des fils.


    Merci beaucoup

  28. #22
    DAUDET78

    Re : Problème Alim stabilisée en courant à base d'un AOP et d'un MOSFET

    Tu peux mettre une référence pour "X" générateurs de courant. Par contre la mise en parrallèle, je suis pas chaud .....
    Par contre tu peux les mettre en série et augmenter la tension.
    J'aime pas le Grec

  29. #23
    Eldindon

    Re : Problème Alim stabilisée en courant à base d'un AOP et d'un MOSFET

    Bonsoir,

    Merci Daudet pour la réponse (je suis rassuré)

    J'ai souder le montage sur une "vraie" plaque d'essai; on approche du but, mais c'est pas encore ça! (10.98v pour 0.87A)
    Je pense que la solution va être très simple: alimenter l'aop en 15V et le reste du montage en 12V! Car les aop "rail to rail" sont vraiment très cher...

    Je fais un test et vous dit si tout fonctionne!

    A+

  30. #24
    DAUDET78

    Re : Problème Alim stabilisée en courant à base d'un AOP et d'un MOSFET

    Pour la "Xème" fois le LM324 est Rail to Rail en entrée et en sortie pour le rail négatif, donc c'est bon. L'alimenter en 15V, je ne pense pas que ça change quelque chose.
    J'aime pas le Grec

  31. Publicité

Discussions similaires

  1. Courant de sortie d'un AOP
    Par la frite dans le forum Physique
    Réponses: 7
    Dernier message: 13/09/2008, 15h22
  2. Alim stabilisée
    Par élec49 dans le forum Électronique
    Réponses: 3
    Dernier message: 19/04/2008, 08h35
  3. Branchement et Alim d'un AOP
    Par SuperVolt dans le forum Électronique
    Réponses: 7
    Dernier message: 11/04/2008, 06h13
  4. Calcul d'un montage à base d'un FET
    Par schneiderj dans le forum Électronique
    Réponses: 15
    Dernier message: 08/11/2007, 20h44
  5. Crée une Alimentation 12va partir d'un ALIM d'UN PC
    Par jujux61 dans le forum Électronique
    Réponses: 5
    Dernier message: 28/11/2003, 13h16
Découvrez nos comparatifs produits sur l'informatique et les technologies.