Répondre à la discussion
Affichage des résultats 1 à 29 sur 29

Utilisation transistor en porte NON



  1. #1
    Defemo

    Utilisation transistor en porte NON


    ------

    Bonjour,

    J'ai tester ce montage sur ma plaque d'essai. Et je ne comprend pas pourquoi quand j'appuie sur l'interrupteur K le moteur ne s'arrête pas.

    Pourriez vous m'éclairer sur ce point s'il vous plait?

    -----
    Images attachées Images attachées

  2. Publicité
  3. #2
    gienas
    Modérateur

    Re : Utilisation transistor en porte NON

    Bonsoir Defemo et tout le groupe

    Citation Envoyé par Defemo Voir le message
    ... quand j'appuie sur l'interrupteur K le moteur ne s'arrête pas ...
    Je n'ai pas trouvé K

    Tel que le schéma est représenté, il est normal que le moteur tourne.

  4. #3
    DAUDET78

    Re : Utilisation transistor en porte NON

    Citation Envoyé par gienas Voir le message
    il est normal que le moteur tourne.
    Pour moi, il ne tourne jamais !

    Je pense qu'avec deux ou trois TIP122 de plus, ça marcherait mieux
    J'aime pas le Grec

  5. #4
    Defemo

    Re : Utilisation transistor en porte NON

    Voila le schéma complet, j'ai ipas choisi le bon desolé.

    Pour moi si l'interupteur k est fermé le premier TIP est saturé est donc le second TIPne reçoit pas decourant à sa base.

    Cependant mon moteur tourne!
    Images attachées Images attachées

  6. A voir en vidéo sur Futura
  7. Comparatifs

    Gagnez du temps et de l'argent grâce à nos comparatifs de produits. Parmi nos sujets :
  8. #5
    gienas
    Modérateur

    Re : Utilisation transistor en porte NON

    Citation Envoyé par DAUDET78 Voir le message
    Pour moi, il ne tourne jamais ! ...
    Tu as raison

    Je me suis laissé abuser par le fait qu'il tournait

  9. #6
    Defemo

    Re : Utilisation transistor en porte NON

    Donc selon ce montage, le moteur ne devrait pas tourner avec k fermé.

    J'ai pourtant vérifier mon montage plusieurs fois. Tous mes composant son bons. Mais avec l'interrupteur fermé, je n'ai pas de tension sur la résistance de 20KOhms. et le moteur continue de tourner

  10. Publicité
  11. #7
    DAUDET78

    Re : Utilisation transistor en porte NON

    Ton interrupteur ne joue pas sur la 2OK ... mais sur la 10K. Donc il y a une erreur de montage.
    Pourquoi un Darlington derrière la 10K ??? un 2N2222 est largement suffisant.
    Pourquoi un Darlington NPN (en haut à droite) en suiveur? Ce n'est pas avec la 100K que tu peux le saturer. Il faut mettre un Darlington PNP (et légèrement modifier le schéma).

    Bref, tu mets tout ça à la poubelle et tu expliques ce que tu veux faire .... J'ai deux entrées "A" et "B" 0/9V et je veux que le moteur tourne si ........
    J'aime pas le Grec

  12. #8
    Defemo

    Re : Utilisation transistor en porte NON

    A la base je veux faire un pont en H. Mais je n'ai que des npn. Donc j'ai décomposé mon pont en H. le premier Darlington ( qui peut etre remplacé par un 2n222) doit faire office de porte non.

    Je veux que mon moteur tourne dans un sens si je n'appuie pas sur l'interrupteur , et dans l'autre sens si j'appuie dessus.

  13. #9
    DAUDET78

    Re : Utilisation transistor en porte NON

    Tu ne peux pas faire un pont en "H" uniquement avec des NPN. Ou alors, il faut une tension plus grande que le Vcc pour alimenter la base des NPN du haut (et pas avec une 100K !!!)
    Donc tu laisses tomber et tu prends 2 NPN (TIP120) et deux PNP (TIP125)
    J'aime pas le Grec

  14. #10
    Defemo

    Re : Utilisation transistor en porte NON

    ok, je vais prendre des Tip 125. Encore merci Daudet pour ton aide précieuse.

  15. #11
    Defemo

    Re : Utilisation transistor en porte NON

    J'ai donc pris deux TIP 122 et deux Tip 127. Et j'ai monté un transistor en inverseur.

    J'aurais voulu que le moteur tourne dans un sens et qu'il change de sens lorsque j'appuie sur le bouton.

    Or le moteur ne tourne que lorsque j'appuie sur l'interrupteur et je ne comprend pas pourquoi.

    Quelqu'un pourrait m'aider?
    Images attachées Images attachées

  16. #12
    Jack
    Modérateur

    Re : Utilisation transistor en porte NON

    En mettant les NPN à la place des PNP et inversement, ça devrait commencer à s'arranger. Il faut les monter en émetteur commun pour pouvoir les saturer.

    Après inversion des transistors, il va aussi falloir revoir les commandes de base pour éviter que les jonctions BE et EB ne court-circuitent l'alim.

    A+

  17. Publicité
  18. #13
    Defemo

    Re : Utilisation transistor en porte NON

    Je vais inverser les Tip alors. Merci

  19. #14
    Jack
    Modérateur

    Re : Utilisation transistor en porte NON

    Montre-nous le nouveau schéma.

    A+

  20. #15
    Defemo

    Re : Utilisation transistor en porte NON

    Voila le montage modifié. Je ne l'ai pas encore testé.
    Images attachées Images attachées

  21. #16
    DAUDET78

    Re : Utilisation transistor en porte NON

    PNP en bas ...NPN en haut (et les émetteurs sur le moteur)
    J'aime pas le Grec

  22. #17
    Jack
    Modérateur

    Re : Utilisation transistor en porte NON

    Citation Envoyé par DAUDET78 Voir le message
    PNP en bas ...NPN en haut (et les émetteurs sur le moteur)
    Et pourquoi? J'ai justement demandé à adopter cette config qui permet de saturer les transistors.

    Il reste un petit problème à résoudre, je me cite:
    Après inversion des transistors, il va aussi falloir revoir les commandes de base pour éviter que les jonctions BE et EB ne court-circuitent l'alim.
    Il faudra des résistances dans toutes les bases des transistors. Il faudra aussi remplacer le transistor de commande par un couple NPN/PNP en push-pull.

    A+
    Dernière modification par Jack ; 21/03/2009 à 07h22. Motif: l'accord du participe passé est encore important pour moi

  23. #18
    polo974

    Re : Utilisation transistor en porte NON

    Citation Envoyé par Defemo Voir le message
    Or le moteur ne tourne que lorsque j'appuie sur l'interrupteur et je ne comprend pas pourquoi.

    Quelqu'un pourrait m'aider?
    Quand l'interrupteur est ouvert, rien ne permet de mettre en conduction le transistor en bas à droite.

    Il suffit d'ajouter une résistance entre la masse et l'interrupteur pour que ça commence à tourner.
    Ensuite suivant les gains min des transistors et le courant demandé par le moteur, il faudra peut-être réduire les valeurs de ces résistances.

    L'autre solution consistant à mettre les pnp en haut et les npn en bas nécessite un pilotage plus complexe afin d'éviter de mettre les 2 transistors en conduction simultanée (en tout cas pas les bases reliées si l'alimentation est supérieure à 1V...).

  24. Publicité
  25. #19
    Defemo

    Re : Utilisation transistor en porte NON

    Tu me propose de faire ce montage Polo?
    Je n'ai aucune idée de la résistance que je doit appliquer entre l'interrupteur et la masse.

    J'ai tenté avec 1, 10, 100kOhm mais le moteur ne tourne que lorsque l'interrupteur est fermé.

    Jack, je ne vois pas comment ce montage peut se retrouver en court circuit?

    Merci de m'accorder votre aide.
    Images attachées Images attachées

  26. #20
    Jack
    Modérateur

    Re : Utilisation transistor en porte NON

    Jack, je ne vois pas comment ce montage peut se retrouver en court circuit?
    Celui du message #19 non, mais celui du message#15 se retrouve avec 2 diodes entre le + et le - de l'alim. Je rappelle que la jonction entre base et émetteur est une diode.

    Tu es donc revenu à la config originale du pont en H. Elle est bien pour un ampli audio puisqu'on doit fonctionner linéairement, mais elle est mal adaptée à la commutation qui est pourtant ce que tu cherches.

    Avec ta config, les transistors ne seront jamais saturés et vont dissiper inutilement de la puissance. de plus ton moteur n'aura pas la pleine tension à ses bornes.

    A+

  27. #21
    Defemo

    Re : Utilisation transistor en porte NON

    Ok je vais tenter de faire un montage similaire au #15. Je le posterai dès que j'aurai réussi à faire un montage à peu près potable.

  28. #22
    Defemo

    Re : Utilisation transistor en porte NON

    Je rappele que je cherche à commander le sens d'un moteur.

    J'ai mis de coté le transistor en inverseur et je l'ai remplacé par deux interrupteurs. J'ai aussi mis une résistance à chaque bases. Mais dès que je branche le montage mes transistors chauffent. Est ce que c'est le court circuit EB BE? Comment faire en sorte que mon montage fonctionne.

    Merci de vos réponses.

  29. #23
    DAUDET78

    Re : Utilisation transistor en porte NON

    Redonne ton schéma. on ne sait pas si c'est le #15 ou #19
    Ton moteur demande quel courant?
    J'aime pas le Grec

  30. #24
    Defemo

    Re : Utilisation transistor en porte NON

    Oups j'ai oublié le schéma.

    C'est un moteur 5 volt et qui tourne à partir de 300mA environ.
    Images attachées Images attachées

  31. Publicité
  32. #25
    Defemo

    Re : Utilisation transistor en porte NON

    J'ai trouvé un schéma d'un pont en H en commutation dont je me suis inspiré.

    Du coups le montage avec interrupteur fonctionne, mais si quelqu'un veux apporter des amélioration c'est avec plaisir que je les lirai.

    Maintenant je vais refaire ce montage avec le transistor en inverseur.
    Je ne comprend pas l'intérêt du couple NPN/PNP en push-pull dont jack m'a parlé.
    Images attachées Images attachées

  33. #26
    DAUDET78

    Re : Utilisation transistor en porte NON

    Citation Envoyé par Defemo Voir le message
    C'est un moteur 5 volt et qui tourne à partir de 300mA environ.
    Il faut remplacer tes 10K par des 2,2K (pas assez de courant base) et mettre des 470 de tirages entre l'interrupteur et le 0V

    Attention, pendant la commutation, les deux transistors sont conducteurs en même temps, ce n'est pas bon du tout
    J'aime pas le Grec

  34. #27
    Defemo

    Re : Utilisation transistor en porte NON

    Daudet tu me dis qu'il faut remplacer mes 10K par des 2,2K (pas assez de courant base):
    Pourtant mes moteur tourne bien. Quel va être l'avantage d'effectuer ce remplacement.

    Mes transistor ne sont conducteur en même temps que si je ferme les
    deux interrupteurs. Sinon il n'y a pas de problème?

    Qu'est ce que c'est des 470 de tirage? Des résistances? A quoi elles servent.

    Voila le montage avec le transistor en inverseur à la place des deux interrupteurs

    Merci pour vos réponses.
    Images attachées Images attachées
    Dernière modification par Defemo ; 23/03/2009 à 12h52.

  35. #28
    Jack
    Modérateur

    Re : Utilisation transistor en porte NON

    Le montage du #25 va très mal fonctionner car ton inter n'alimente bien que les transistors du bas. Pour commander les transistors du haut, il faudrait que tu aies des inters aussi entre le commun des résistances de base et la masse, mais qui fonctionneraient en inverse des inters du haut. C'est la fonction réalisée par un push pull.

    A+

  36. #29
    polo974

    Re : Utilisation transistor en porte NON

    Ton montage du 27 a toujours le défaut de ne pas bloquer les npn connectés à l'interrupteur.

    Il faut mettre une 1k (à la louche) entre l'inter et la masse, ainsi le vbe est bien tiré à 0 quand l'inter est ouvert.

Discussions similaires

  1. Transistor MOS et porte logique
    Par zuccone dans le forum Électronique
    Réponses: 14
    Dernier message: 18/01/2008, 14h18
  2. Transistor: Porte NAND
    Par ifef dans le forum Électronique
    Réponses: 27
    Dernier message: 02/01/2008, 06h31
  3. utilisation d'un transistor
    Par lordofthunder dans le forum Électronique
    Réponses: 8
    Dernier message: 22/05/2007, 13h18
  4. porte ou avec transistor
    Par ludo3( dans le forum Électronique
    Réponses: 3
    Dernier message: 11/03/2007, 20h00
  5. Exo transistor + porte inverseuse
    Par Savidan dans le forum Électronique
    Réponses: 8
    Dernier message: 26/11/2006, 11h57
Découvrez nos comparatifs produits sur l'informatique et les technologies.