Répondre à la discussion
Affichage des résultats 1 à 18 sur 18

Problème Amplificateur Opérationnel : oscillations



  1. #1
    Peanuts88

    Problème Amplificateur Opérationnel : oscillations


    ------

    Je suis désolée de vous déranger mais j'aurai aimé avoir un conseil de
    votre part. Au cours de mon stage, je dois à un moment donné établir un
    montage électronique me permettant d'amplifier ou de réduire la tension
    source. Pour cela, j'ai donc utilisé deux AO, l'un en inverseur et l'autre
    en non inverseur (montage très simple donc).

    Le problème est que sur l'oscilloscope, on peut voir la présence
    d'importantes oscillations au niveau de la sortie de l'AO (que ce soit celui en
    inverseur ou non inverseur) (je vous ai joint une photo de l'écran de
    l'oscillo).

    J'ai mis un condensateur en parallèle, changé les résistances afin d'avoir
    un gain inférieur à 1, changer les fils, vérifié mon montage avec mon
    postdoctorant, cherché de la documentation chez le fabricant d'AO mais je
    n'ai pas trouvé de solutions à mon problème.

    Je vous remercie par avance

    -----
    Images attachées Images attachées

  2. Publicité
  3. #2
    Tropique

    Re : Problème Amplificateur Opérationnel : oscillations

    Bonjour Peanuts88, et bienvenue parmi nous,

    Il serait surtout important que tu postes ton schéma: c'est probablement là que se trouve la clé de l'énigme. N'oublie pas de spécifier chaque valeur de composant.
    Pas de complexes: je suis comme toi. Juste mieux.

  4. #3
    gcortex

    Re : Problème Amplificateur Opérationnel : oscillations

    un aop ne marche pas avec un gain inférieur à 1
    par contre tu peux utiliser un diviseur de tension avec un aop en suiveur

  5. #4
    Peanuts88

    Re : Problème Amplificateur Opérationnel : oscillations

    Merci beaucoup pour ces réponses rapides. J'ai joint mon schéma qui est très simple en fait, et donc c'est d'autant plus rageant pour moi de ne pas trouver la solution au problème.

    Cordialement,
    Images attachées Images attachées

  6. A voir en vidéo sur Futura
  7. Comparatifs

    Gagnez du temps et de l'argent grâce à nos comparatifs de produits. Parmi nos sujets :
  8. #5
    Tropique

    Re : Problème Amplificateur Opérationnel : oscillations

    Il manque le N° de type de l'AOP, c'est très important. Surtout avec des tensions d'alim de +/-25V, ils ne sont pas légions à le tolérer.
    Il faudrait également préciser le nature de la charge et de la source (impédance, ...?).
    Enfin, il y a-t-il des découplages d'alim?
    Pas de complexes: je suis comme toi. Juste mieux.

  9. #6
    Peanuts88

    Re : Problème Amplificateur Opérationnel : oscillations

    Alors le Numéro de l'AO c'est OPA552, j'utilise une tension continue de 1vpp et pour l'impédance, si tu veux dire par là l'impédance du circuit, il n'y a juste que les résistances, rien de plus.

    On m'a suggéré que la courbe que je vois sur l'oscillo pourrait n'être due qu'à un mauvais réglage de celui ci.

  10. Publicité
  11. #7
    Peanuts88

    Re : Problème Amplificateur Opérationnel : oscillations

    Et désolé pour le temps de réponse, je suis en stage à Toronto et avec le décalage, c'était l'heure du 'lunch',

    Merci beaucoup en tous les cas

  12. #8
    Peanuts88

    Re : Problème Amplificateur Opérationnel : oscillations

    Encore désolée, je n'avais pas vu la dernière question, non il n'y a pas de découplage d'alimentation, c'est vraiment un montage basique qui n'était pas censé poser de problème, avec juste une certaine tension qu'on voulait augmenter ou diminuer.

  13. #9
    Tropique

    Re : Problème Amplificateur Opérationnel : oscillations

    Ton AOP n'a rien du circuit pépère et anodin qui se laisse faire quoiqu'on lui fasse: c'est une bête de course, et il est exigeant, pour la stabilité de boucle, les découplages, et les impédances. Ca ne m'étonne pas que tu aies des problèmes si tu l'as utilisé sans précautions.
    En premier lieu, il n'est stable que pour des gains >5. Tu as moins, c'est donc forcé qu'il oscille.
    En plus, il faut des découplages soignés au ras du circuit.
    Il faut faire attention à ce qu'on met en entrée et en sortie: il y a-t-il des longs câbles connectés, etc.
    Il faut faire attention aux impédances du réseau de CR: je crois que tes valeurs sont un peu élevées.

    En tous cas, je te conseille de potasser sérieusement la section "APPLICATIONS INFORMATION" de la datasheet, à peu près toutes les réponses s'y trouvent.
    C'est d'ailleurs la première chose à faire pour la mise en oeuvre d'un IC. Si on s'en dispense, on risque d'aller droit dans le mur, et vite.
    Fichiers attachés Fichiers attachés
    Pas de complexes: je suis comme toi. Juste mieux.

  14. #10
    Peanuts88

    Re : Problème Amplificateur Opérationnel : oscillations

    Merci pour tes réponses, j'étais en train de tenter de déchiffrer la "datasheet" comme tu l'appelles lorsque tu m'as répondu.

    Autant c'est très sympa de ta part de me donner des conseils pour mon problème, autant je me suis peut être mal exprimée lorsque je parlais d'un montage simple,

    Mais je ne pense pas que tu aies besoin de me parler d'un ton si condescendant. A la base, je ne suis absolument pas spécialisée dans l'électronique, les "CR, IC, découplages" et compagnie que tu emploies sont du chinois pour moi. Je n'ai fais que suivre les directives de mon doctorant et n'arrivant pas à résoudre ce problème, je tente tant bien que mal de trouver une solution en parallèle.

    Je pensais que ce forum était là pour aider à la fois les cracks en électroniques mais aussi ceux qui balbutient.

    Apparemment j'ai fais erreur

    Merci quand même pour le temps que tu as consacré à m'aider, tu as du adorer pouvoir étaler ta "science" devant quelqu'un qui ne s'y connaissait pas.

  15. #11
    Tropique

    Re : Problème Amplificateur Opérationnel : oscillations

    Condescendant? Si tu le dis, pourquoi pas.
    Je suis modo et je n'ai pas à créer de polémique, surtout me concernant; je dirais pour ma part que mon approche est robuste et directe: si j'avais eu des réponses complètes et précises au #2, le problème aurait été réglé dès le quatrième message.

    L'idée générale, lorsqu'on va sur un forum spécialisé en étant novice est de se faire prendre par la main pour arriver au plus vite à une solution.
    Ici, il a fallu 9 messages pour cerner le problème, alors que 4 auraient suffi.
    C'est 5 de trop, mais cela reste très acceptable, il en faut parfois 55 pour commencer à comprendre de quoi il s'agit.

    Globalement, ton problème actuel devrait être résolu. S'il ne l'est pas complètement, n'hésite pas à continuer sur ce fil. Je n'interviendrai plus, mais il y aura certainement d'autres gentils participants (moins hautains que moi) qui se feront un plaisir de t'aider.
    Pas de complexes: je suis comme toi. Juste mieux.

  16. #12
    Peanuts88

    Re : Problème Amplificateur Opérationnel : oscillations

    Je n'ai rien à dire quant à ton aide qui fut précieuse pour moi, et la technicité des réponses qui m'ont permis d'avancer.

    Je sais que mes posts n'ont pas été efficaces vu ma pauvre connaissance en la matière. Je ne veux en aucun cas créer de polémique et encore moins sur toi et je n'attends pas de "gentils participants".

    Je pense juste que l'une de tes phrases était en trop, mais peu importe, grâce à toi mon problème est résolu, je te remercie encore une fois.

    Cordialement

  17. Publicité
  18. #13
    louloug60

    Re : Problème Amplificateur Opérationnel : oscillations

    Bonjour,


    J'utilise le meme AOP sur un étage suiveur suivi d'un étage non inverseur avec les deux mm AOP OPA551. Et rien qu'à la sortie du suiveur j'ai des oscillations pour un signal d'entrée propre carré de 100Hz. J'ai découvert via ce post et en regardant sur le forum de Texas Instruments que c'était du au caractéristiques de l'AOP qui est fait pour des gains G =5. J'aimerais savoir , si il y a possibilité d'y remédier en mettant tt simplement un filtre passe bas pour supprimer les oscillations, j'aimerais avoir votre avis.

    Cordialement merci d'avance

  19. #14
    DAUDET78

    Re : Problème Amplificateur Opérationnel : oscillations

    Et tu as besoin de ce circuit? avec le même ampliOP? pas un autre? c'est pourquoi faire ?
    J'aime pas le Grec

  20. #15
    pilatomic

    Re : Problème Amplificateur Opérationnel : oscillations

    La réponse est dans le datasheet, section "application information" !

  21. #16
    louloug60

    Re : Problème Amplificateur Opérationnel : oscillations

    futura.jpg

    Bonsoir,

    Voici mon schéma



    Je cherche à conditionner des signaux +/-10V en +/-30V pour un calculateur. Le but est d'utiliser deux étages ,un étage non inverseur de gain 1.5 pour avoir une tension

  22. #17
    louloug60

    Re : Problème Amplificateur Opérationnel : oscillations

    Bonsoir,

    Merci pour vos réponses. Je cherche à conditionner des signaux +/-10V provenant du carte Agilent. Le but est de conditionner le signal +/-10V d'une fréquence de 180kHz en signal de +/-30V. C'est pour cela que j'ai décidé d'utiliser deux étage: un inverseur de gain -1.5 et un non inverseur de gain +1.5 afin d'avoir deux tensions Va et Vb évoluant entre +/-15V mais étant inversé Va-Vb=+/-30V. J'ai utilisé des jumpers pour avoir des gains différents. Le soucis c'est que mon montage fonctionne très bien jusqu'à 20kHz. En entrée j'applique un signal d'entrée de 8V crête à crête, jusqu'à 20kHz ,j'obtiens 12V en sorti, ce que est normal gain de +1.5. Mais si je dépasse les 20kHZ mon signal de sortie dépasse les 12V et peut dépasser les 20V crête à crête. Autre remarque, il me semble que V+=V- en montage linéaire. Dans mon cas , V+=V- jusqu'à 20Khz, mais passé les 20Khz, V- décroit , et la forme d'onde de V- tend vers une charge décharge de condensateur pour tendre vers 0.

    Ouff

    Désolé pour mon écriture

  23. #18
    polo974

    Re : Problème Amplificateur Opérationnel : oscillations

    regarde le MAXIMUM OUTPUT VOLTAGE SWING vs FREQUENCY de la datasheet
    de la datasheet, et pleure...
    Jusqu'ici tout va bien...

  24. Publicité

Discussions similaires

  1. Amplificateur opérationnel
    Par gueddy dans le forum Électronique
    Réponses: 14
    Dernier message: 26/02/2010, 09h23
  2. Amplificateur Operationnel
    Par mikael83 dans le forum Électronique
    Réponses: 3
    Dernier message: 20/02/2010, 21h37
  3. Amplificateur operationnel
    Par kissmymouth dans le forum Électronique
    Réponses: 1
    Dernier message: 12/10/2008, 13h37
  4. Amplificateur opérationnel
    Par Seirios dans le forum Électronique
    Réponses: 3
    Dernier message: 21/02/2007, 15h14
  5. amplificateur operationnel
    Par simetoile dans le forum Électronique
    Réponses: 7
    Dernier message: 08/04/2006, 21h20
Découvrez nos comparatifs produits sur l'informatique et les technologies.