Répondre à la discussion
Affichage des résultats 1 à 13 sur 13

[URGENT]montage qui ne marche que théoriquement



  1. #1
    Tix

    [URGENT]montage qui ne marche que théoriquement


    ------

    salut

    voila ,je suis face à un probleme que je n'arrive pas à résoudre ...

    en fait ,j'ai tracer ce schéma pour traduire une fonction d'inversement bistable .

    :


    dans le simulateur que j'utilise ,tout va bien :

    un basculement quant j'appuie momentanément sur un contact ,inversement de la tention ...
    et tout me satisfait.

    mais quand j'ai réalisé le prototype ce matin ,le contacte momentané ne marchait pas.

    le premier état sortie du NAND, était par exemple 1.

    si je basculai l'entrée commandée à la masse ,l'état passait bien à 0 ,mais quand je relache le contact ,il repassait à 1 ... et ca ne me convien plus du tout

    pouver vous y jetter un coup d'oeuil ?

    merci ++ Tix.

    -----

  2. #2
    Tix

    Re : [URGENT]montage qui ne marche que théoriquement

    P.S: le simulateur online : DIGSIM

    et le montage :

    # Digsim file version 3.0
    ^
    ^[|Inverter|pos|45|13|rotation|3 |]
    ^[|Wire|pos|50|21|pos2|55|21|]
    ^[|Wire|pos|50|21|pos2|50|22|]
    ^[|Wire|pos|55|21|pos2|60|21|]
    ^[|Wire|pos|60|21|pos2|60|10|]
    ^[|LED|pos|50|4|rotation|2|color |green|]
    ^[|Wire|pos|50|6|pos2|52|6|]
    ^[|Wire|pos|50|10|pos2|50|12|]
    ^[|Wire|pos|58|10|pos2|60|10|]
    ^[|Wire|pos|60|10|pos2|60|6|]
    ^[|Wire|pos|50|21|pos2|50|20|]
    ^[|PushButton|pos|42|36|rotation |1|]
    ^[|PushButton|pos|48|36|rotation |1|]
    ^[|Vcc|pos|46|41|rotation|2|]
    ^[|GND|pos|51|42|rotation|0|]
    ^[|Wire|pos|59|6|pos2|60|6|]
    ^[|Wire|pos|46|35|pos2|46|34|]
    ^[|Wire|pos|46|34|pos2|49|34|]
    ^[|Wire|pos|52|34|pos2|49|34|]
    ^[|Wire|pos|49|34|pos2|49|30|]
    ^[|Wire|pos|52|35|pos2|52|34|]
    ^[|Vcc|pos|50|28|rotation|2|]
    ^[|Wire|pos|50|10|pos2|51|10|]
    ^[|Wire|pos|50|10|pos2|50|6|]
    ^[|TwoNandPort|pos|45|23|rotatio n|3|]
    ^[|LED|pos|40|4|rotation|2|color |green|]
    ^[|Wire|pos|40|6|pos2|42|6|]
    ^[|Wire|pos|40|10|pos2|40|21|]
    ^[|Wire|pos|48|10|pos2|50|10|]
    ^[|Wire|pos|49|6|pos2|50|6|]
    ^[|Wire|pos|40|10|pos2|41|10|]
    ^[|Wire|pos|40|10|pos2|40|6|]
    ^[|Wire|pos|50|21|pos2|40|21|]
    ^[|LED|pos|50|8|rotation|0|color |red|]
    ^[|LED|pos|40|8|rotation|0|color |red|]
    ^
    # eof Digsim
    puis ,fichier /importer et copier le code

  3. #3
    jps

    Re : [URGENT]montage qui ne marche que théoriquement

    Bonjour,
    Attention, que ce soit en logique TTL ou Cmos une entrée ne doit pas rester non connectée. Elle sera équivalente à 1 en TTL et indéterminée (1 ou 0) en Cmos. Dans les deux cas, une entrée non utilisée se comportera comme une antenne qui risque de capter des signaux parasites.
    Par ailleurs, lorsque l'une des deux entrées est forcée à la masse, je ne comprends pas pourquoi la sortie est à 0 (?). Le circuit utilisé est-il bien un NAND ?

  4. #4
    Tix

    Re : [URGENT]montage qui ne marche que théoriquement

    slt ,merci. mais , y'a pas de solution ? parce que la ... comment faut il que je fasse ?

    merci ++ Tix.

  5. A voir en vidéo sur Futura
  6. #5
    etronics

    Re : [URGENT]montage qui ne marche que théoriquement

    Salut

    un simulateur peux ce tromper , par contre je ne comprend pas ce que tu veux faire comme montage , va voir sur cette page pour plus d' infos sur les bascules bistable et les portes logiques ...

    http://etronics.free.fr/dossiers/init/inits16.htm

    @+++ dan

  7. #6
    Tix

    Re : [URGENT]montage qui ne marche que théoriquement

    bha ,le but exact du montage est d'inversé la polatité en sortie ,d'apres un changement d'état . c'est destiné à la robotique beam.

    merci pour le lien ^^

    ++ Tix.

  8. #7
    Tix

    Re : [URGENT]montage qui ne marche que théoriquement

    j'ai relus vos messages ,et revu mon montage ,avec quelques souvenirs du cour du Club électronique (sans oublier la lecture du lien de etronics ,

    et je me suis dit que peu etre que comme ca ,ca marcherai .

    les entrées étant apparement "stoquée" par le composant , ca devrais le faire ,qu'en pensent les experts ? ,est-ce bien correct ?

    le shéma :


    merci ,++ Tix.

  9. #8
    Ravaner

    Re : [URGENT]montage qui ne marche que théoriquement

    Si ja'i bien compris ton schéma, lorsque tu appuies sur l'inter, tu provoques une mise du + à la masse, cela s'appelle un court jus !

  10. #9
    Tix

    Re : [URGENT]montage qui ne marche que théoriquement

    bha ,un court jus ,que si on apuie sur les deux inter en meme temps ... est ce n'est pas le but.

    mais comment faut il que je m'y prenne ?

    mrci ,++ Tix.

  11. #10
    f6bes

    Re : [URGENT]montage qui ne marche que théoriquement

    Bjr Tix,
    Ne faudrait il pas mettre une résistançe (pull-up) entre
    ton entrée et la masse ? (4.7 k)
    Autre chose, ton schéma part ce soir.
    Cordialement

  12. #11
    Tix

    Re : [URGENT]montage qui ne marche que théoriquement

    merci pour le shéma f6bes ,

    oui ,j'y avais pensé ,mais je ne sait pas si c'était pour les memes raisons .. qu'est-ce donc que "pull-up" ? (tirer en haut ^.^...)

    Ps. Le montage marche !!!!
    mrci ++ Tix.

  13. #12
    f6bes

    Re : [URGENT]montage qui ne marche que théoriquement

    Bjr Tix,
    Comme te l'a dis JPS il ne faut laisser les entrées "flottantes".
    Il te faut choisir si , au repos, tu veux un état haut ou bas.
    Donc tu "forçes" ton entrée au niveau voulu.
    Si tu veux un niveau "1" tu relies l'entrée au positif à travers
    une résistançe. Tu la "tires au niveau haut".

    Si par "commande" tu relies l'entrée à la masse , tu obtiens
    un niveau bas (ton bouton poussoir).
    Bien sur le niveau revient à "1" dés que tu laches ton poussoir.
    (Ton premier dessin).
    Il faut, si tu veux conserver un "1" aprés avoir relaché ton BP,
    que tu envoies une tension positive sur ton entrée.
    (Ton deuxiéme dessin)
    Cordialement.

  14. #13
    Tix

    Re : [URGENT]montage qui ne marche que théoriquement

    lut ,

    hum hum hum .....

    et bien moi qui pensait que je faisait juste boucler l'éntrée à la sortie pour le maintien ^^

    merci pour l'explication

    ++ Tix.

Discussions similaires

  1. Normaliser son montage : URGENT
    Par thomasalbert1993 dans le forum Électronique
    Réponses: 16
    Dernier message: 14/10/2007, 19h43
  2. montage à transistors ???? urgent
    Par piergo dans le forum Électronique
    Réponses: 5
    Dernier message: 29/06/2007, 09h12
  3. tv qui marche pas et qui marche!!
    Par bobluc dans le forum Dépannage
    Réponses: 12
    Dernier message: 19/09/2006, 18h12
  4. salut, montage audio, urgent
    Par davbond001 dans le forum Électronique
    Réponses: 2
    Dernier message: 08/07/2006, 08h24
Découvrez nos comparatifs produits sur l'informatique et les technologies.