Répondre à la discussion
Affichage des résultats 1 à 5 sur 5

Erreur KiCad



  1. #1
    Flo7374

    Question Erreur KiCad


    ------

    Bonjour,

    J'ai un souci d'erreur sous KiCad que je n'arrive pas à résoudre :

    J'ai créé mon composant, un connecteur banane tout simple, donc avec une seule broche configuré en bi-dir (pour me débarrasser de quelques verifs' des ERC). Mon problème est que j'ai beau tout essayer, impossible d'y connecter réellement un fil (je dis réellement car graphiquement le fil y est, j'ai même ajouté une jonction). C'est à dire que quand je contrôle les règles de connexion (via l'outil de KiCad) l'erreur est la suivante :

    " Err Type (2) : Pin non connectée (pas de symbole de connexion trouvé sur cette pin "

    Afin d'être plus clair, je joint un screen.

    Il semblerait que l'erreur puisse aussi venir de mon label, j'ai tenté d'y mettre un power_flag ça ne change rien ...

    Merci pour votre aide
    Florian

    -----
    Images attachées Images attachées

  2. Publicité
  3. #2
    Ridezebigone

    Re : Erreur KiCad

    Bonjour
    Essaie d'utiliser un symbole pour les alimentations (triangle ou rond) et de nommer le potentiel.
    Sinon ces erreurs n'empeche pas forcément de faire le routage, vérifie dans la netlist que tes potentiels sont bien réliés aux différents composants...

    A+
    Rzbo

  4. #3
    Flo7374

    Re : Erreur KiCad

    Bonjour,

    Merci Rzbo pour cette réponse , oui j'ai tenté en vain de mettre un nom sur ces potentiels, mais l'erreur en question disparait et d'autres apparaissent à nouveau. La même erreur, même message sur d'autres broches qui n'ont aucun rapport avec celle montrée dans mon premier message.

    Ma question portait plus sur le principe, j'ai pris ces deux connecteurs comme j'aurais pu prendre une pin d'un ampli etc...
    Mon problème est que je ne comprend pas d'où elle viens puisqu'il est mentionné un problème de connexion entre une pin et un fil, que cette pin soit bidir ou pwr out.... même souci.
    Les pins en question ne sont donc pas connectées sur le PCB.

    Du coup, système D, je les notes et les roots "à la mano" sur mon PCB. J'ai 12 erreurs de ce type, ça va encore mais pour le futur je me vois mal avec un moitié de schéma à placer sans chevelu ...

    Ainsi je réitère ma question à tous, comment résoudre cette erreur (voir message au TOP) sans la contourner, d'où vient-elle ?

    Merci bien !
    Flo

  5. #4
    Ridezebigone

    Re : Erreur KiCad

    bonjour,

    lu sur ce site :
    http://www.elektronique.fr/logiciels...lectriques.php

    ajouter un pwr flag sur tes signaux d'alim ?

    A+

  6. #5
    Seb.26

    Re : Erreur KiCad

    Fais nous une copie d'écran de ton composant dans l'éditeur de module

    Le "rond vert" n'a rien à faire au bout de ta pin.

    Si la ligne bleue que l'on voit est un bus, pour te connecter dessus, il manque un connecteur "fil à bus".

    si tu mets ta pin en non définie, ça donne quoi ?
    Dernière modification par Seb.26 ; 29/11/2013 à 01h30.
    << L'histoire nous apprend que l'on apprend rien de l'histoire. >>

  7. A voir en vidéo sur Futura

Sur le même thème :

Discussions similaires

  1. kicad
    Par hagi dans le forum Électronique
    Réponses: 22
    Dernier message: 26/10/2012, 14h24
  2. erreur Kicad (PCBnew)
    Par lekkerding dans le forum Électronique
    Réponses: 2
    Dernier message: 24/06/2010, 09h02
  3. Erreur de raisonnement, erreur logique ou erreur tout court?
    Par babybirdhitz dans le forum Epistémologie et Logique
    Réponses: 7
    Dernier message: 03/02/2010, 13h32
  4. le KiCad
    Par roro1111 dans le forum Électronique
    Réponses: 17
    Dernier message: 06/08/2009, 14h28
  5. Kicad
    Par elsena dans le forum Électronique
    Réponses: 0
    Dernier message: 18/05/2009, 11h13