Répondre à la discussion
Affichage des résultats 1 à 16 sur 16

Simulation LTSpice



  1. #1
    ioro

    Simulation LTSpice


    ------

    Bonjour,
    J'utilise LTSpice pour faire de la simu et je la simu que je trouve ne donne pas le résultat prévu.

    Du coup, comme je ne connais pas trop LTSpice, peut être que ça vient de ça ou sinon c'est moi qui déconne ^^

    Voici le schéma :

    Simu.jpg

    A priori, je suis censé avoir 24V en sortie quand j'ai 5V en entrée et la simu montre 24V en sortie quand je suis entre 0 et 1.4V...

    Je ne comprend pas ce qui se passe....

    Merci pour votre aide.

    Ioro

    -----

  2. Publicité
  3. #2
    Antoane

    Re : Simulation LTSpice

    Bonjour,

    Quel est l'état du NPN lorsque la tension fournie par V1 est de 5V ? Donc quelle est la tension sur le collecteur de Q1 à ce moment là ?
    Conclusion ?
    Deux pattes c'est une diode, trois pattes c'est un transistor, quatre pattes c'est une vache.

  4. #3
    ioro

    Re : Simulation LTSpice

    Quand V1 = 5V, transistor bloqué et VQ1 = 0V, d'après la simulation.

    Ne doit-on pas avoir transistor passant et VQ1 = 24 si V1 = 5V?

  5. #4
    Antoane

    Re : Simulation LTSpice

    Si V1 = 5V, le NPN est passant, donc Vc(Q1) ~ 0.

    A la louche :
    Si V1 = 5 V, Ib(Q1) ~ 0.8 mA => gain * Ib(Q1)~80mA (à peu près, suivant les valeurs de gain choisies). Or Ic(Q1)max = V2/R2 = 24 mA. Comme Ic(Q1)max < gain * Ib(Q1), le transistor est saturé, et :
    Ic(Q1)~24 mA
    Vc(Q1)=Vce_sat ~ 0 V
    Deux pattes c'est une diode, trois pattes c'est un transistor, quatre pattes c'est une vache.

  6. #5
    ioro

    Re : Simulation LTSpice

    Bon ben je ne comprend pas.

    C'est pas ce qui est dit ici : https://wiki.mdl29.net/lib/exe/fetch...transistor.pdf

  7. A voir en vidéo sur Futura
  8. #6
    Antoane

    Re : Simulation LTSpice

    Il faudrait que tu sois un peu plus explicite
    il me semble que ce pdf indique la même chose que LTSpice et moi.

    Si V1 = 5V, le transistor est passant, donc la lampe (ou, dans ton cas, R2) est alimentée et il y a 24V à ses bornes. Mais la tension sur le collecteur de Q1 vaut bien 0 V : le NPN se comporte comme un court-circuit entre collecteur et emetteur.
    C'est la loi des mailles : V2 = V(R2) + Vc(Q1) <=> Vc(Q1) = V2-V(R2) = 24-24 ~ 0 V.
    Deux pattes c'est une diode, trois pattes c'est un transistor, quatre pattes c'est une vache.

  9. Publicité
  10. #7
    ioro

    Re : Simulation LTSpice

    Ok, donc c'est normal, je cherchais l'info au mauvais endroit...

    Donc si je mets une charge après Vc(Q1), j'aurais un interrupteur qui varie de 0 à 24 V quand V1 varie de 5 à 0V. C'est ça?

  11. #8
    Patrick_91

    Re : Simulation LTSpice

    hi,

    Si si , regardes bien les notions de 'bloqué' (pas de courant collecteur donc celui ci est a 24 Volts) ou 'saturé (courant plein pot dans le collecteur et la tension aux bornes du transistor tend vers zéro) ... LTSPICE en Antoane vont bien ! ..

    A plus
    C'est l'étincelle qui a fait déborder le vase !

  12. #9
    ioro

    Re : Simulation LTSpice

    Avez-vous déjà eu le message suivant dans LTSpice :

    "Port(pin) count mismatch between the definition of subcircuit "xxx" and instance "xxxx". The instance has more connection terminals than the definition"

    Je comprend qu'il y a qlq part des connections en trop mais entre le symbole (.asy) et le modèle (.lib) j'ai bien le même nombre de pins....

  13. #10
    ioro

    Re : Simulation LTSpice

    Bonjour à tous,

    C'est bon, j'ai réglé mon soucis. Pour ceux qui ont des soucis pour ajouter modèle PSpice dans LTSpice, suivez le tuto qui se trouve ici.

    Du coup, dans ma simulation, j'utilise le LMP7721 que j'alimente en +/- 2.5V.

    Normalement, l'ampli doit saturé à +/- 2.5V donc. La simulation indique que l'ampli sature à +/- 1.5288V.

    Est-ce que les limites indiquées par la simu sont les mêmes en pratique?

    Merci.

  14. #11
    Antoane

    Re : Simulation LTSpice

    Bonjour,

    Peux-tu poster ton schéma et sa simulation ?
    Où as-tu récupéré le modèle d'AOP ?
    Deux pattes c'est une diode, trois pattes c'est un transistor, quatre pattes c'est une vache.

  15. #12
    ioro

    Re : Simulation LTSpice

    Voici les fichiers.

    J'ai récupéré le modèle ici : http://www.ti.com/product/LMP7721/toolssoftware

    J'ai choisi le modèle TINA
    Images attachées Images attachées

  16. Publicité
  17. #13
    Antoane

    Re : Simulation LTSpice

    Cela me semble assez étrange, je ne l'explique pas. Quelle tension mesures-tu en sortie à vide (montage du composant en comparateur, sans charge en sortie) ?
    Sinon, toutes les tensions et courants du montage sont raisonnables ?
    Deux pattes c'est une diode, trois pattes c'est un transistor, quatre pattes c'est une vache.

  18. #14
    ioro

    Re : Simulation LTSpice

    Citation Envoyé par Antoane Voir le message
    Quelle tension mesures-tu en sortie à vide (montage du composant en comparateur, sans charge en sortie) ?
    Je mets quoi en entrée? Parce qu'avec 1V sur l'entrée + et -, j'ai un truc bien dégueu.... Qui par d'envrion 1.6V et qui descend à 0V en 1s.
    Citation Envoyé par Antoane Voir le message
    Sinon, toutes les tensions et courants du montage sont raisonnables ?
    C'est à dire?

  19. #15
    ioro

    Re : Simulation LTSpice

    Pour info, avec un autre ampli (LT1001 disponible dans LTSpice), même dysfonctionnement.

    Y a t-il un paramétrage qui peut influencer le comportement?

  20. #16
    Antoane

    Re : Simulation LTSpice

    Bonjour,
    Citation Envoyé par ioro Voir le message
    Pour info, avec un autre ampli (LT1001 disponible dans LTSpice), même dysfonctionnement.
    C'est normal : un AOP ne peut pas sortir une tension atteignant sa tension d'alimentation, il y a une "tension de déchet". Le LT1001 a une tension de déchet de l'ordre de 1V à 1.5V : http://cds.linear.com/docs/en/datasheet/1001fb.pdf (paramètre "Maximum Output Voltage Swing"), alimenté en +/-15V, il ne peut sortir que des tensions entre +/-14 V (environ).

    Le LMP7721 a des tensions de déchets plus faible (~70 mV), et ce que tu observes est effectivement étrange.

    Citation Envoyé par ioro Voir le message
    Je mets quoi en entrée? Parce qu'avec 1V sur l'entrée + et -, j'ai un truc bien dégueu.... Qui par d'envrion 1.6V et qui descend à 0V en 1s.
    Relier les entrées d'un AOP a un intérêt proche de zéro : la tension de sortie n'est fonction que des divers paramètres parasites du composant.
    Avec une entrée à la masse et l'autre à +1V, sans résistance connectée, tu devrais visualiser les tensions de saturation du composant.

    C'est à dire?
    Le courant d'alimentation du composant est conforme aux attentes ?
    Le courant de sortie de l'AOP est conforme aux attentes ?
    Les courants d'entrées de l'AOP sont conformes aux attentes ?
    etc.
    Deux pattes c'est une diode, trois pattes c'est un transistor, quatre pattes c'est une vache.

Sur le même thème :

Discussions similaires

  1. probleme simulation sur LTSPICE
    Par nunu27 dans le forum Électronique
    Réponses: 41
    Dernier message: 05/12/2014, 21h55
  2. simulation kicad=>ltspice
    Par alexmomo dans le forum Électronique
    Réponses: 2
    Dernier message: 18/04/2012, 13h46
  3. simulation ltspice
    Par maxou366 dans le forum Électronique
    Réponses: 4
    Dernier message: 07/01/2011, 06h21
  4. LTSpice Simulation ne fonctionne pas
    Par jlbrenas dans le forum Électronique
    Réponses: 5
    Dernier message: 08/02/2009, 16h56
  5. Simulation sous LTSPICE.
    Par katmai dans le forum Électronique
    Réponses: 5
    Dernier message: 12/10/2008, 10h40