Répondre à la discussion
Affichage des résultats 1 à 3 sur 3

Excel: Fonctions SI (condition) imbriqées



  1. #1
    HomoSum

    Excel: Fonctions SI (condition) imbriqées


    ------

    Bonsoir,
    en culture numérique à la fac, j'ai ce devoir à faire:

    Capture.PNG,

    j'ai donc mis ça dans la case E2:
    =SI(D2<limite_inf;"limite_inf" ;SI(D2>limite_sup;"limite_sup" ;"?????????"))

    ?????? correspond au "autrement: extraction = delta température soit E2=D2, E3=D3, E4=D4 etc et ainsi de suite seulement dans les cas où delta température est compris entre -8 et -1.

    la fonction que je tape en E2 marche, sauf que quand je mets D2 à la place des ??????, D2 reste constant pour les autres lignes (pour E8 par exemple, je ne retrouve pas la valeur de D8 mais celle de D2).


    Que dois-je mettre à la place de ???????? pour faire correspondre à chaque case E de ma colonne la valeur de la colonne D qui lui correspond (dans les cas où mon delta Température est compris dans l'intervalle [-8;-1]) ?

    Merci, j'espère être claire. Si non, laissez tomber! :}

    -----

  2. #2
    cherbe

    Re : Excel: Fonctions SI (condition) imbriqées

    Bonjour
    Tel que tu le décris, cela semble être le piège habituel des adresses relatives et des adresses absolues.
    Pour que cela fonctionne, écris ta formule dans la 1ère cellule de la colonne puis étend vers le bas en utilisant la "poignée de recopie", le petit carré noir en bas et à droite de la cellule active.
    Ainsi, ta formule sera :
    =SI(D2<limite_inf;"limite_inf" ;SI(D2>limite_sup;"limite_sup" ;D2)) en ligne 2
    =SI(D2<limite_inf;"limite_inf" ;SI(D2>limite_sup;"limite_sup" ;D3)) en ligne 3
    et ainsi de suite

  3. #3
    HomoSum

    Re : Excel: Fonctions SI (condition) imbriqées

    Bonjour,
    La "poignée de recopie" je l'avais déjà utilisée, mais grâce à votre réponse, j'ai compris mon erreur: c'était les guillemets "" en trop!

    =SI(D2<limite_inf;"limite_inf" ;SI(D2>limite_sup;"limite_sup" ;"D2")) Les guillemets entre D2 sont à supprimer!

    Merci beaucoup
    "Homo sum; humani nihil a me alienum puto.", Publius Terentius Afer

Sur le même thème :

Discussions similaires

  1. [EXCEL 2010] Liste déroulante sous condition
    Par flodrows dans le forum Programmation et langages, Algorithmique
    Réponses: 8
    Dernier message: 11/05/2016, 09h00
  2. Calcul de moyenne sous excel avec condition
    Par gdm dans le forum Programmation et langages, Algorithmique
    Réponses: 2
    Dernier message: 04/03/2016, 17h46
  3. EXCEL - Fonction SI avec condition
    Par iniesta10 dans le forum Logiciel - Software - Open Source
    Réponses: 11
    Dernier message: 11/01/2012, 09h43
  4. VBA Excel Sélection d'un cellule sous condition
    Par gwencab dans le forum Logiciel - Software - Open Source
    Réponses: 1
    Dernier message: 06/01/2011, 20h36
  5. Pb Excel: Trop de condition SI a faire
    Par maxsolo18 dans le forum Logiciel - Software - Open Source
    Réponses: 6
    Dernier message: 22/10/2010, 09h16
Découvrez nos comparatifs produits sur l'informatique et les technologies.