Répondre à la discussion
Affichage des résultats 1 à 6 sur 6

Excel : formule ou autre astuce...



  1. #1
    chocobo

    Excel : formule ou autre astuce...


    ------

    Bonjour,

    J’explique ci-dessous se que j’aimerai faire, est ce possible… je pense que oui

    Sur une 1ere feuille j’ai un tableau listing fournisseurs :

    Colonne 1 : N° du fournisseur
    Colonne 2 : Nom du fournisseur
    Colonne 3 : Contact
    Colonne 4 : Téléphone
    Colonne 5 : Fax

    Sur une autre feuille : Comment faire pour qu’en indiquant dans la case « A1 » le N° du fournisseur, les cases D5, D6,D7 et D8 se remplissent automatiquement…

    D5 = Nom fournisseur
    D6 = Contact
    D7 = Téléphone
    D8 = Fax

    (Ces 4 champs la étant sur la même ligne de mon tableau listing fournisseur)

    Merci pour votre aide
    ++
    choco

    -----

  2. Publicité
  3. #2
    EspritTordu

    Re : Excel : formule ou autre astuce...

    Bonjour,

    Pour moi, il faut recourir à la programmation VBA d'Excel.
    Voici une solution.
    On saisit bien les données dans la feuille 1 (qui sert de base donnée) en respectant bien l'ordre des colonnes.
    Dans la feuille 2, on introduit un bouton.

    Dans l'événement click du nouveau bouton, on inscrit ce code qui doit va chercher les informations :

    Dim i as long

    for i=0 to (nombre de ligne saisie dans la premiere feuille)
    if sheets(1).cells(i,1).value=she ets(2).range("A1").value then

    'Multiplier les lignes et adapter les pour les diverses colonnes
    sheet(2).range("D5").value=she ets(1).cells(i,2).value
    '...
    exit for
    end if
    next i

    Il ne reste plus qu'a saisir votre numéro dans la case A1 de la seconde feuille, presser le bouton, et vos informations s'afficheront.
    On peut faire mieux, notamment en anticipant une réaction du logiciel s'il ne trouve rien, par exemple...
    Le code doit pouvoir s'éxécuter sans avoir à ajouter un bouton, simplement en réagissant sur la validation de la cellule A1...A voir.

  4. #3
    zoup1

    Re : Excel : formule ou autre astuce...

    Il n'est pas nécessaire d'avoir recours à la programmation VBA.
    Il suffit d'utiliser les fonctions de base de données.

    J'ai une version americaine de Excel, mais la fonction DGET fait ce qu'il faut..

    Comme son fonctionnement est un peu compliqué (étrange) j'ai fait un classeur excel qui fait ce que tu demandes...
    http://zoup1.free.fr/base.xls

    Seule restriction, il doit y avoir des noms de colonnes au dessus de la 2ème feuille (enfin je crois que c'est obligatoire)

    Petit plus : on peut choisir un autre critère pour sélectionner ce que l'on souhaite..
    Je te donne une idée, tu me donnes une idée, nous avons chacun deux idées.

  5. #4
    mécano41

    Re : Excel : formule ou autre astuce...

    Bonjour,

    Sinon, tu as également :

    Tableau des fournisseurs en feuille 1 par exemple pour 12 fournisseurs la première ligne (facultative) = titres sur 5 colonnes de A1 à E1
    La première colonne contient de A2 à A13, le numéro du fournisseur (trié en ordre croissant - obligatoire), les quatre autres colonnes, les éléments de ton choix (nom....).
    Tu donnes un nom à la plage A1:E13, par exemple "Fournisseurs" (tu sélectionnes et tu fais "insertion nom")

    Sur la feuille 2 tu mets le N° du fournisseur choisi en A1

    En D5, tu met la formule "=RECHERCHEV($A$1;Fournisseur; 2)
    En D5, tu met la formule "=RECHERCHEV($A$1;Fournisseur; 3)
    En D5, tu met la formule "=RECHERCHEV($A$1;Fournisseur; 4)
    En D5, tu met la formule "=RECHERCHEV($A$1;Fournisseur; 5)

    Les données correspondant au N° inscrit en A1 s'affichent.

    Bon courage

  6. #5
    mécano41

    Re : Excel : formule ou autre astuce...

    Il faut évidemment lire :

    En D5, tu mets la formule "=RECHERCHEV($A$1;Fournisseur; 2)
    En D6, tu mets la formule "=RECHERCHEV($A$1;Fournisseur; 3)
    En D7, tu mets la formule "=RECHERCHEV($A$1;Fournisseur; 4)
    En D8, tu mets la formule "=RECHERCHEV($A$1;Fournisseur; 5)

    Désolé!

  7. A voir en vidéo sur Futura
  8. #6
    chocobo

    Re : Excel : formule ou autre astuce...

    Merci à tous je teste tout ça cet aprem et je vous dirais laquelle j'ai utilisée

    Mici bcp résultat dem1

    ++
    choco

  9. Publicité

Discussions similaires

  1. formule calcul avec excel
    Par milagro dans le forum Logiciel - Software - Open Source
    Réponses: 11
    Dernier message: 28/06/2007, 12h43
  2. Excel Formule De Calcul
    Par mag2304 dans le forum Logiciel - Software - Open Source
    Réponses: 3
    Dernier message: 01/11/2006, 17h54
  3. Formule Excel
    Par FABIENNE 974 dans le forum Logiciel - Software - Open Source
    Réponses: 1
    Dernier message: 19/03/2006, 10h34
  4. Pb de calcul et formule avec excel
    Par mimi62 dans le forum Mathématiques du supérieur
    Réponses: 5
    Dernier message: 07/12/2004, 21h39
  5. macro excel et autre logiciel...
    Par amandine22 dans le forum Logiciel - Software - Open Source
    Réponses: 1
    Dernier message: 22/07/2004, 21h20
Découvrez nos comparatifs produits sur l'informatique et les technologies.