[Divers] comment identifier panne optocoupleur et triac qui commute de moins en moins
Répondre à la discussion
Affichage des résultats 1 à 10 sur 10

comment identifier panne optocoupleur et triac qui commute de moins en moins



  1. #1
    yoyo59

    comment identifier panne optocoupleur et triac qui commute de moins en moins


    ------

    Bonjour,
    Attention je n'ai aucune pratique de l'électronique, et une courte formation vieille de 30 ans...
    Mon brûleur à granulés comporte une carte électronique qui sert d'interface entre un automate programmable et les actionneurs 220V,
    en particulier le moteur d'une vis sans fin, qui est activé de façon intermittente pour alimenter le foyer en granulés : environ 2 secondes toutes les 15 secondes,
    plus une période plus longue au démarrage.
    Le moteur de la vis sans fin tourne correctement si je le branche directement sur le réseau 220V.
    Quand il est alimenté via la carte électronique, le moteur tourne aussi correctement à froid, pendant quelques minutes,
    puis peu à peu l'alimentation devient trop brève pour faire tourner le moteur : au voltmètre je vois une brève impulsion,
    qui peu provoquer un très léger mouvement du moteur, ou rien du tout.
    Le circuit qui alimente ce moteur est basé sur un optocoupleur MOC3042 et un triac Z0409MF,
    avec en plus une résistance et une diode témoin.
    La diode est certainement du coté basse puissance, et elle s'allume correctement,
    donc pas de risque que la panne vienne de l'automate programmable.
    Ce qui est bizarre c'est que dès que je déconnecte le moteur, son alimentation redevient correcte (au voltmètre).

    Est-ce que la panne pourrait être causé par le moteur, qui demanderait trop de courant pour le triac ?
    Sinon comment est-ce que je pourrais identifier le composant en train de rendre l'âme ?
    Je ne suis pas encore suffisamment frigorifié pour tenter de remplacer les 2 composants d'un coup sans certitude...

    Merci pour tout conseil éventuel.

    -----

  2. #2
    DAUDET78

    Re : comment identifier panne optocoupleur et triac qui commute de moins en moins

    Citation Envoyé par yoyo59 Voir le message
    Le circuit qui alimente ce moteur est basé sur un optocoupleur MOC3042 et un triac Z0409MF,
    http://pdf.datasheetcatalog.com/data...la/MOC3042.pdf
    Le schéma doit être similaire à celui de la figure 8
    Peux tu relever ton schéma avec les valeurs ?

    PS : si tu remplaces ton moteur par une lampe de 40W (à filament ou halogene) , il se passe quoi ? Ca marche ?
    Si ça marche, tu mets le moteur ET la lampe en parallèle, il se passe quoi ?
    Dernière modification par DAUDET78 ; 02/02/2017 à 18h51.
    J'aime pas le Grec

  3. #3
    trebor

    Re : comment identifier panne optocoupleur et triac qui commute de moins en moins

    Bonsoir,

    Donc à froid, le moteur fonctionne normalement et à chaud il ne fonctionne plus.

    A froid mesurer la résistance sur la broche de connexion électrique sur le moteur, broche d'alimentation séparée de la carte d'alimentation et hors tension secteur.

    Puis à chaud idem, hors tension est alimentation déconnectée, mesurer la résistance du moteur.

    Il est possible qu'il y ai une coupure dans le bobinage du moteur un fois qu'il est chaud.

    Voyons d'autres avis ?

    Bonne suite
    Faire tout pour la paix afin que demain soit meilleur pour tous

  4. #4
    DAUDET78

    Re : comment identifier panne optocoupleur et triac qui commute de moins en moins

    Citation Envoyé par DAUDET78 Voir le message
    par une lampe de 40W ......
    par une lampe 230V de 40W ......
    J'aime pas le Grec

  5. A voir en vidéo sur Futura
  6. #5
    gienas
    Modérateur

    Re : comment identifier panne optocoupleur et triac qui commute de moins en moins

    Bonsoir yoyo59 et tout le groupe

    Citation Envoyé par yoyo59 Voir le message
    ... Mon brûleur à granulés comporte une carte électronique qui sert d'interface entre un automate programmable ...
    S'agissant d'un matériel de série en panne, le forum le plus adapté est celui de dépannage où la discussion va être déplacée.

    Cependant, pour avoir de bonnes idées, il faut le schèma de la structure ou analyser le fonctionnement.

  7. #6
    yoyo59

    Re : comment identifier panne optocoupleur et triac qui commute de moins en moins

    Merci pour ces conseils, je vérifie ça dès demain (vendredi) matin.

  8. #7
    yoyo59

    Re : comment identifier panne optocoupleur et triac qui commute de moins en moins

    Bonjour,
    Voici une tentative de dessin du schéma du circuit, désolé pour le manque de clarté c'est d'abord un relevé de l'implantation des circuits et des pistes.
    Ca correspond à la figure 8 du datasheet, avec des résistances plus faibles.

    L'étiquette du moteur indique 15W, 0.23A.
    Il a en parallèle un condensateur de 1.5 microF

    Je m'en vais rebrancher la carte et faire le test de la lampe 40W.

    Nom : schema-controle-moteur.jpg
Affichages : 1181
Taille : 55,4 Ko

  9. #8
    yoyo59

    Re : comment identifier panne optocoupleur et triac qui commute de moins en moins

    Hélas je ne suis pas parvenu à tester grand chose, il faut parfois longtemps avant que la panne se manifeste, et parfois la panne disparait rapidement ou bien persiste.
    Parfois j'ai eu l'impression que le comportement changeait à cause d'une tentative de tester quelque chose, mais en reproduisant la manip j'avais un résultat différent...
    Je m'y remettrai demain.

    La seule conclusion fiable jusqu'à présent est que quand la panne est absente, si je remplace le moteur par une ampoule 40W, l'ampoule clignote rapidement.
    J'ai cru d'abord que l'ampoule consommait trop de courant par rapport au moteur de 20W, alors je suis allé acheter une ampoule de 20W, mais celle là aussi clignote rapidement.
    Ce clignotement est-t-il normal ? L'ampoule est une ampoule halogène.

    Quand la panne est présente, il me semble que remplacer le moteur par l'ampoule ne change rien : l'ampoule reste éteinte, ou émet un seul éclat,
    donc même comportement que le moteur. Je ne suis pas sûr à 100% de ce test, car plusieurs fois la panne est disparue au moment où je faisais le test...

    J'ai essayé aussi de mesurer la tension en sortie de l'optocoupleur, entre les pattes 4 et 6, quand la panne est absente ça passe de 220V à 0V.
    Il faut que je re-essaye cette mesure quand la panne est présente, j'ai eu l'impression un une deux fois que ça ne passait pas à 0V, ou trop brièvement.

    La fonction ohm-metre de mon vieux multimètre analogique m'a parue donner des résultats assez farfelus sur des résistances identifiées,
    alors je suis allé acheter un multimètre plus moderne, j'essayerai demain de mesurer la résistance du moteur.

    Cependant ma première impression est que le moteur n'est pas en cause.

    Bonne soirée

  10. #9
    yoyo59

    Re : comment identifier panne optocoupleur et triac qui commute de moins en moins

    Bonjour,

    La panne s'est manifesté hier soir de façon stable et continue (peut-être définitive).
    Le moteur ne tournait plus du tout, je l'ai remplacé par l'ampoule , qui ne s'est pas allumée.

    J'ai mesuré la tension à la sortie du photocoupleur, elle restait à 220V, le photocoupleur ne réagissait plus aux signaux d'entrée.

    Je vais essayer de le faire remplacer, si je trouve un professionnel qui ne se restreint pas aux replacement de cartes complètes,
    car la carte n'est plus fabriquée.

    Une chose m'intrigue : quand je remplace le moteur par mon voltmètre, la tension est normale, elle passe bien de 0 à 220V
    pendant la durée commandée.
    Est-ce une panne plausible pour un photocoupleur, de ne fonctionner que pour des courants très faibles ?

  11. #10
    yoyo59

    Re : comment identifier panne optocoupleur et triac qui commute de moins en moins

    Une expérience pour confirmer que la panne est causée par l'optocoupleur :
    dès que je shunte sa sortie (fil entre les pattes 4 et 6, bien sûr en prenant mon temps et en cherchant la meilleure position, pour ne pas toucher d'autres fils) le moteur tourne.
    Le triac n'est donc pas en cause.

    Merci pour vos conseils, qui m'ont incité à persévérer et mobiliser de vieux souvenirs.

Discussions similaires

  1. [Thermique] Chauffe-bains ELM Leblanc Ondéo Hydropower LC10PVHY : de moins en moins d'ECS.
    Par invite24da4ce3 dans le forum Dépannage
    Réponses: 7
    Dernier message: 17/01/2010, 16h41
  2. Réponses: 7
    Dernier message: 18/01/2009, 21h09
  3. Les vaccins anti-grippe sont de moins en moins efficaces...
    Par inviteb276d5b4 dans le forum Santé et médecine générale
    Réponses: 20
    Dernier message: 24/10/2005, 13h39
Dans l'univers Maison de Futura, découvrez nos comparatifs produits sur l'univers de la maison : climatiseur mobile, aspirateur robot, poêle à granulés, alarme...