Répondre à la discussion
Affichage des résultats 1 à 11 sur 11

Probleme simulation proteus isis



  1. #1
    lrtsenar

    Probleme simulation proteus isis

    bonjour a tous,

    Voici un schema (en piece jointe) qui me pose probleme.
    La batterie 14,4 V sont en fait la pour simuler 2 pack d'accus de 7,2V (modelisme).
    Lorsque je connecte la diode D1 au collecteur de Q2 (le fait de connecter l'alim 24V entre les diodes R8 et R10 pose le meme probleme), j'ai le message d'erreur suivant :

    ...
    [SPICE] DELMIN increased to 1.38778e-17 due to lack of time precision
    [SPICE] transient GMIN stepping at time=0.100036
    [SPICE] Error 106 - TRAN: Timestep too small; time = 0.100036, timestep = 1.73472e-18: trouble with node "$IDC AMMETER#00AB_IP1#branch"
    .
    Totaliters=20613, Totalsteps=9918, Goodsteps=9556, Badsteps=362

    Real Time Simulation FAILED.


    le PIC genere juste un signal PWM avec l'instruction suivante :
    HPWM 1,duty,2000

    J'ai bien sur essayer de mettre pour le 24V un connecteur du style 'VDD' ou autre mais, rien a faire.
    J'ai egalement essayer de changer les diverses options de SPICE sans amelioratons.

    Avez-vous une idee du probleme ?

    Merci beaucoup.

    -----

    Fichiers attachés Fichiers attachés

  2. Publicité
  3. #2
    FandeMuse

    Re : Probleme simulation proteus isis

    Salut,
    connaissant un peu les déboires de ISIS,apparement les problème viendrait en gros d'un des ampéremetres qui passe trop rapidement à la valeur suivante.
    Donc pour remedier à ça essaye de changer les valeurs dans "System/Set Animation Option" et la tu change les valeurs dans les 3 cases dans la frame Simulation Speed.

    PS: Ce n'est pas pour t'embeter mais normalement il te manque des résitances entre tes transistors sauf si jme trompe bien entendu.

  4. #3
    lrtsenar

    Re : Probleme simulation proteus isis

    Merci beaucoup pour ta reponse.

    Quand j'enleve les amperementre et voltmetres, il me fait l'erreur suivante :

    ...
    [SPICE] DELMIN increased to 2.77556e-17 due to lack of time precision
    [SPICE] transient GMIN stepping at time=0.1678
    [SPICE] Error 106 - TRAN: Timestep too small; time = 0.1678, timestep = 3.46945e-18: trouble with node "PR_+24V#branch"
    .
    Totaliters=20987, Totalsteps=10172, Goodsteps=9810, Badsteps=362

    Real Time Simulation FAILED.


    Quant aux resistances qui manque entre les transistors, c'est pour faire des 'darlington'. Penses-tu que ca peut poser probleme ?

    Merci.

  5. #4
    Chimimic

    Re : Probleme simulation proteus isis

    Bonjour Irtsenar,

    il est important que toute partie du montage soit fonctionnelle et correctement cablée, sinon le moteur de simulation peut se bloquer ou tourner en rond jusqu'à surplus d'itérations.

    Dans un premier temps, commence par finir le cablage des transistors en haut à droite de ton schéma (diode D1 en l'air).

    Dans un second temps, retire les ampèremètres placés en plein dans le circuit des transistors montés en darlington (liaisons E-B), et laisse celui situé en série avec Bat1 de 14,4V, juste pour voir si cela change quelque chose.

    Cordialement.

  6. #5
    Chimimic

    Re : Probleme simulation proteus isis

    Excuse-moi, j'ai lu un peu vite ton dernier message et ai loupé le passage où tu indiquais avoir retiré les composants dédiés aux mesures. Donc premier point à suivre : compléter le schéma.

  7. A voir en vidéo sur Futura
  8. #6
    FandeMuse

    Re : Probleme simulation proteus isis

    Salut
    en comparant les résulstat du prospice et du schéma ton problème vient maintenant de ta source +24V.
    Il faut soit la configurer dans les configurations des tensions soit tu en lie un avec un générateur DC +24V.

  9. Publicité
  10. #7
    lrtsenar

    Unhappy Re : Probleme simulation proteus isis

    Merci encore pour vos aides.

    J'ai maintenant le probleme suivant (voir schema corrigé en piece jointe) et la, je cale a nouveau :

    ...
    [SPICE] transient GMIN stepping at time=0.0307
    [SPICE] DELMIN increased to 3.46945e-18 due to lack of time precision
    [SPICE] transient GMIN stepping at time=0.0307
    [SPICE] Error 106 - TRAN: Timestep too small; time = 0.0307, timestep = 4.33681e-19: trouble with node "G45D0CAB3#branch"
    .
    Totaliters=15879, Totalsteps=7424, Goodsteps=7130, Badsteps=294

    Real Time Simulation FAILED.
    Fichiers attachés Fichiers attachés

  11. #8
    Chimimic

    Re : Probleme simulation proteus isis

    Bonjour Irtsenar,

    si je peux me permettre, tu devrais peut-être utiliser des vraies bornes d'alim pour tes 12V et 24V et les nommer +12V et +24V, plutôt que d'utiliser des générateurs de tension continue.

    Cordialement.

  12. #9
    FandeMuse

    Re : Probleme simulation proteus isis

    Salut Irtsenar,
    j'ai essayé ton montage dans mon ISIS sans le pic et en ajoutant des voltmètres.J'ai juste changé la diode car je n'avait pas la tienne mais sinon ca fonctionne correctement.
    Donc essaye comme moi pour essayer cad avec des boutons pour les 4066 et un générateur de clock pour l'aop.
    Voilà ma configuration pour la vitesse de simulation:
    FPS : 20
    TPF : 50m
    SST : 50m
    Fichiers attachés Fichiers attachés

  13. #10
    lrtsenar

    Re : Probleme simulation proteus isis

    Effectivement, en deconnectant le generateur de clock CCP1 du PIC et en le remplacant par un generateur de clock, ca fonctionne tres bien.

    Je pense que le probleme vient du PIC. C'est dommage...

    Savez vous comment puis-je savoir d'ou vient ce message d'erreur (le truc en gras) :

    [SPICE] Error 106 - TRAN: Timestep too small; time = 0.101095, timestep = 1.73472e-18: trouble with node "G45D223F1#branch"

    Merci pour votre grande implication dans la tentative de resolution de mon probleme.

  14. #11
    FandeMuse

    Re : Probleme simulation proteus isis

    Essaye de faire fonctionner ton pic tout seul à savoir s'il fonctionne correctement.
    Ensuite à voir comme ça ton erreur change à chaque fois car les deux erreurs avec un code different.
    Et ce code soit il fait référence à une branche, ou circuit.
    Soit il ne fait référence à rien.
    Essaye ton pic séparement et touche au transient qui sait...

Sur le même thème :

Discussions similaires

  1. Proteus Ares Isis
    Par freepicbasic dans le forum Électronique
    Réponses: 5
    Dernier message: 05/06/2012, 18h30
  2. proteus ISIS
    Par etronics dans le forum Électronique
    Réponses: 10
    Dernier message: 02/12/2010, 08h00
  3. simulation proteus isis
    Par vinra dans le forum Électronique
    Réponses: 5
    Dernier message: 14/02/2007, 11h53
  4. Probleme Sous Proteus Isis
    Par poulail dans le forum Électronique
    Réponses: 1
    Dernier message: 30/04/2006, 15h40
  5. symbole isis et proteus
    Par zwiky dans le forum Électronique
    Réponses: 4
    Dernier message: 14/09/2004, 20h17