Répondre à la discussion
Affichage des résultats 1 à 14 sur 14

Une astuce SVP



  1. #1
    sergebertet


    Le retour du -12 sur le +5 via les LED allume les voyants sans qu'on ait besoin d'appuyer sur le bouton !

    La PCB étant câblée, je cherche un moyen de contourner le problème sans changer le switch. Possible

    Merci,

    Serge.

    -----

  2. Publicité
  3. #2
    Pierrre
    Bonjour
    a priori pas de solution auytre que de prendre un poussoir bipolaire : le +5 et le +12 peuvent rester ensemble, mais le -12 doit etre seul.

    desolé...
    A+

  4. #3
    lem pat
    Déjà une diode (1n914, 1n4148 en série avec les leds +5v +12v pour éviter le 12v allant vers le 5v
    Ensuite je réfléchis à une solution utilisant la variation de tension présente entre inter on & inter off

  5. #4
    Pierrre
    si on considere uniquement les leds +12 et +5 sans appuyer sur le poussoir:
    la led +12 est dans le sens passant mais la led +5 est dans le sens bloquant --> rien ne s'allume --> inutile de mettre des diodes en serie.
    le probleme vient uniquement de la led -12 et la j'ai envisage pas mal de solutions sans succes.

    A+

  6. #5
    Anthracite
    Ca me semble également compliqué sans grosses modif…
    0

  7. A voir en vidéo sur Futura
  8. #6
    lem pat
    Citation Envoyé par Pierrre
    si on considere uniquement les leds +12 et +5 sans appuyer sur le poussoir:
    la led +12 est dans le sens passant mais la led +5 est dans le sens bloquant --> rien ne s'allume --> inutile de mettre des diodes en serie.
    le probleme vient uniquement de la led -12 et la j'ai envisage pas mal de solutions sans succes.

    A+
    Une led peut conduire à partir de 4v en inverse (meme si ce n'est pas le sens d'utilisation). Elles n'ont pas un Vinv maxi élevé comme pour les 1n4148 1n914 (0.25A 100v)
    Sinon je pense à une soluce qui ne permettant pas d'annuler le courant, permet au moins d'éteindre les leds (par élément type zener en //)
    Je continue à imaginer

  9. Publicité
  10. #7
    Jack
    et si tu déplaçais ton interrupteur pour le mettre en série dans la branche du -12V, entre le -12V et la résistance par exemple?

    Les leds ne seraient pas toutes traversées par le même courant, mais est-ce vraiment un problème?

  11. #8
    sergebertet
    J'avais pensé à ça :



    Est-ce que ça marche dans tous les cas de figure ? Je continue de chercher (et de tester) ... comme tout le monde.

    Merci à tous pour les éléments de réponse.

    Serge.

  12. #9
    Jack
    c'est en gros la solution que je te proposais.

    L'avantage de ton amélioration, c'est que la led du -12V ne sera pas traversée par la somme des courants des deux autres leds.

    Bien vu!!!

  13. #10
    Anthracite
    Une petite amélioration consisterait à mettre une autre diode en inverse sur l’autre contact.
    Parce qu’ici, si les plus sont morts, il n’y a plus rien.
    0

  14. #11
    Pierrre
    Bonjour

    " Une led peut conduire à partir de 4v en inverse "....
    Vu datasheet led :
    V reverse : 5V Max
    Reverse current @ V reverse Max : 10 uA ......largement insuffisant pour allumer une led en serie.

    A+

  15. #12
    lem pat
    Citation Envoyé par Pierrre
    Bonjour

    " Une led peut conduire à partir de 4v en inverse "....
    Vu datasheet led :
    V reverse : 5V Max
    Reverse current @ V reverse Max : 10 uA ......largement insuffisant pour allumer une led en serie.

    A+
    12-5 = 7v > 5v
    La valeur du courant inverse reste elle à 10µA ou augmente elle avec la tension inverse ? (pour 100, 1000v je me doute bien mais pour 7 et plus )

  16. Publicité
  17. #13
    toto234
    ton bouton est un bouton normalement fermé et pour que ton circuit fonctionne tu dois avoir un normalement ouvert donc la solution la plus simple est de désouder ton bouton puis d'en souder un normalement ouvert.

  18. #14
    Pierrre
    La valeur du courant inverse reste elle à 10µA ou augmente elle avec la tension inverse ?

    Bonjour

    En principe, il ne faut pas depasser la tension inverse de la diode. Mais en pratique, j'ai alimenté une led (rouge 2mA) directement (sans R serie) en inverse sous 15V: le courant n'est pas mesurable (<1uA) et elle fonctionne toujours correctement . Alors....
    A+

Sur le même thème :

Discussions similaires

  1. Médiane, une astuce pour les Xi désordonnés ?
    Par Soliman dans le forum Mathématiques du collège et du lycée
    Réponses: 11
    Dernier message: 03/09/2006, 15h18
  2. une question svp
    Par fadwa dans le forum Biologie
    Réponses: 1
    Dernier message: 11/03/2006, 20h38
  3. Cherche une petite astuce SVP
    Par roro123 dans le forum Logiciel - Software - Open Source
    Réponses: 4
    Dernier message: 04/01/2006, 09h35
  4. [exo] Besoin d une astuce
    Par Matth.mz dans le forum Mathématiques du supérieur
    Réponses: 1
    Dernier message: 19/09/2005, 19h33
  5. Une petite astuce téléphonique sympas !
    Par zanzeoo dans le forum Électronique
    Réponses: 9
    Dernier message: 26/04/2003, 17h58
Découvrez nos comparatifs produits sur l'informatique et les technologies.