Répondre à la discussion
Affichage des résultats 1 à 7 sur 7

Montage à ampli Op



  1. #1
    frodgiem

    Montage à ampli Op

    Bonjour à tous.

    Après m’avoir très bien dépanné sur un montage à base de triacs, je fait de nouveau appel à vos compétences.

    Je suis électricien industriel de métier et pour mon travail
    j’ai suivi une formation sur les amplis Op (il y a 10 ans).

    A partir de la j’ai voulu réaliser ce montage pour l’adapté sur une voiture.
    (indicateur de température moteur) voir schéma en p.J.

    J’ai réalisé ce montage avec une alim 12v et simulé l’entrée sonde par un potentiomètre
    relié entre + et masse.

    Un étage suiveur pour prendre l’entrée sur la sonde de température (cnt).

    Un étage soustracteur (S= v1 – v2 si r1= r2= r3 =r4)
    Si R cnt max donc Ucnt max donc températur min
    Si R cnt min donc Ucnt min donc température max

    Un étage diviseur par 10 ( r6 dix fois inf à r5) et l’envoyé vers l’entrée d’un CA3161E (convertisseur A / D) qui ne supporte que 2V.

    Questions :

    En sortie du soustracteur (repère 1) je n’arrive pas à avoir 0v. Le tension varie de 1 à 12v
    En sortie du diviseur j’ai toujours même tension que la sortie soustracteur.
    Est-ce parce que l’ampli Op est alimenté avec une tension simple ?

    Merci d’avance pour vos commentaires.

    -----

    Images attachées Images attachées

  2. Publicité
  3. #2
    gienas

    Re : Montage à ampli Op

    Bonsoir frodgiem et tout le groupe

    Je décèle deux "erreurs" dans ton montage:

    1- ton différentiel, je ne suis pas sûr qu'il fonctionne jusqu'à 0V. Il doit rester dans une plage raisonnable, difficile à définir, car elle dépend des AOP. Essaye de travailler, en entrée, autour de Ualim/2. Par exemple, tu peux mettre ta CTN ou ta CTP dans un pont de Weatstone, équilibré à une extrémité de la gamme. Là, tu seras pile autour du pseudo zéro, et au milieu du Vcc.

    2- ton diviseur par 10 est en réalité un multiplicateur par 1,1. Ce doit être une erreur de formule. Pour diviser, il faut mettre un pont diviseur de tension par 10, et un suiveur derrière.
    Dernière modification par gienas ; 03/12/2007 à 17h36.

  4. #3
    frodgiem

    Re : Montage à ampli Op

    Bonjour gienas

    Merci pour tes réponses

    Pour le pont de weaston je ne sais pas comment faire. Je vais essayé de l'étalonner le mini avec un thermomètre (ce qui m'intéresse c'est plus la surchauffe moteur)

    Pour le pont diviseur suivi d'un suiveur c'est une piste. Je vais essayé.

    Encore merci et je ferais par de mes résultats.

  5. #4
    DAUDET78

    Re : Montage à ampli Op

    Il ne faut pas oublier que la tension de sortie de la sonde de température est fonction de la température ....... et de la tension batterie qui évolue de 12 à 14,7V. Il faut donc un affichage qui donne le ratio de tension (fait par un galva avec deux bobines à 90° sur la majorité des chars).
    L'age n'est pas un handicap .... Encore faut-il arriver jusque là pour le constater !

  6. #5
    gienas

    Re : Montage à ampli Op

    Bonjour frodgiem et tout le groupe

    Citation Envoyé par frodgiem Voir le message
    ... Pour le pont de weaston je ne sais pas comment faire ...
    Sur le lien suivant, c'est le premier de google sur "pont de wheatstone",

    http://www.univ-lemans.fr/enseigneme.../wheatsto.html

    tu as le principe du pont. Pour commencer, tu mets ta source à la place des 10V d'alimentation, et tes sorties aux entrées du différentiel. Quand les 4 résistances seront égales, la tension de sortie sera nulle. Tu places cet "équilibre" là où cela t'arrange le mieux.

    Comme le signale à juste titre DAUDET78, la sensibilité sera dépendante de la source d'alimentation. Si c'est un problème, il faudra stabiliser, en cherchant à rester le plus central possible entre le + et le -.

    Une possibilité simple: une diode Zener aux bornes d'alimentation du pont, et 2 résistances égales pour alimenter la Zener, une entre le + source et la cathode, l'autre entre le - source et l'anode.

  7. A voir en vidéo sur Futura
  8. #6
    DAUDET78

    Re : Montage à ampli Op

    Personellement, je suis pas chaud (c'est le cas de le dire !) pour repiquer l'information de la température d'origine (qui ne donne pas la température de la culasse). Il est préférable de prendre un LM35 ou LM335 et de le fixer avec de l'araldite sur la culasse, ou d'utiliser une autre sonde CTN automobile (qui est noyé dans un bloc d'ALU et fixée par un boulon). On peut l'alimenter avec une tension stabilisée (sans perturber l'affichage actuel) et gérer avec un ampliOP ou un comparateur pour afficher une température ou générer une alarme
    L'age n'est pas un handicap .... Encore faut-il arriver jusque là pour le constater !

  9. Publicité
  10. #7
    frodgiem

    Re : Montage à ampli Op

    Bonjour Gienas et Daudet78

    J'ai fait des essais sur une plaque d'éssais justement avec le pont de weaston
    et ce n'est pas concluant.
    Mes connaissances en électronique sont limitées.

    Mon idée était de reconvertir un compte tour électronique que j'avais fait avec la revue Electronique Pratique en thermomètre électronique en piquant
    l'info sur la sonde de la voiture.(ce n'est pas un fin en soi).
    Ce compte tour est un convertisseur fréquence / tension + voltmètre.

    Je pense que Daudet78 a raison dans le sens qu'il vaut mieux ne pas perturber le système de la voiture.

    J'essayerai plus tard avec un LM35.

    Encore merci pour votre attention et vos explications.

Sur le même thème :

Discussions similaires

  1. montage ampli-op/push-pull
    Par benjibul dans le forum Électronique
    Réponses: 9
    Dernier message: 27/08/2010, 17h14
  2. Montage ampli op
    Par gtn dans le forum Électronique
    Réponses: 5
    Dernier message: 14/12/2006, 20h42
  3. Ampli Op: Montage suiveur ?
    Par Gpadide dans le forum Physique
    Réponses: 1
    Dernier message: 08/09/2006, 19h22
  4. montage leger ampli
    Par konprenrien dans le forum Électronique
    Réponses: 7
    Dernier message: 02/07/2006, 16h39
  5. montage ampli auto
    Par dolphin dans le forum Électronique
    Réponses: 2
    Dernier message: 06/04/2003, 23h39