Répondre à la discussion
Affichage des résultats 1 à 16 sur 16

Interfacage de l'accéléromètre ADXL323



  1. #1
    PiXel20

    Interfacage de l'accéléromètre ADXL323


    ------

    salut

    j'ai fait une erreur et je n'arrive pas a la comprendre, j'ai un ampli op comparateur avec une référence de 2v, et je compare avec une autre valeur variable (potentiometre) tout va bien les comparateur fonctionne tres bien et la del allume, je remplace le pot par un accélerometer adxl 323, il devien tres chaud et il grille 16$ direct dans la poubelle... mes connection sont correct, tous alimenter en 5v, quel étais mon erreur? aurait-il fallu je pilote le 323 avec un ampli op suiveur avant de comparé la tension, si oui pk??

    -----

  2. Publicité
  3. #2
    DAUDET78

    Re : interfacage de l'accéléromètre ADXL323

    Un lien sur la spécification de l'ADXL323 et ton schéma?
    Dernière modification par JPL ; 27/02/2008 à 21h34.
    J'aime pas le Grec

  4. #3
    PiXel20

    Re : Interfacage de l'accéléromètre ADXL323

    le lien avec pdf est http://www.analog.com/en/prod/0,2877,ADXL323,00.html

    et le schéma plus bas


    merci d'avance pour votre aide
    Images attachées Images attachées

  5. #4
    Jack

    Re : Interfacage de l'accéléromètre ADXL323

    Vu le type de boîtier, à mon avis tu l'as mal orienté. Et comme Vs et COM sont en vis-à-vis, çà explique qu'il ait grillé.

  6. #5
    Jack

    Re : Interfacage de l'accéléromètre ADXL323

    Tu as vérifié l'orientation du boîtier?

  7. A voir en vidéo sur Futura
  8. #6
    gedonet

    Re : Interfacage de l'accéléromètre ADXL323

    Citation Envoyé par PiXel20 Voir le message
    salut
    mes connection sont correct, tous alimenter en 5v, quel étais mon erreur???
    Bonjour
    Peut être alimenter en 5V, un composant qui doit l'être en 3.3V (de 1.8 à 3.6V).
    Gilles

  9. Publicité
  10. #7
    Jack

    Re : Interfacage de l'accéléromètre ADXL323

    Peut être alimenter en 5V, un composant qui doit l'être en 3.3V (de 1.8 à 3.6V).
    Regarde le vrai datasheet: 1,8V to 5,25V

    A+

  11. #8
    PiXel20

    Re : Interfacage de l'accéléromètre ADXL323

    bon, juste avant de le connecter a l'entré des amplis op, j'ai tester le voltage de sorti, bien 2.5v pour x et y, donc l'orientation du boitier étais bonne, c'est une fois connecter a l'ampliop que ca marche pu et ca la grillé...

  12. #9
    Jack

    Re : Interfacage de l'accéléromètre ADXL323

    Pourtant, pour faire chauffer un circuit comme çà, çà ressemble beaucoup à un problème d'alim. Peut-être un court-circuit avec Vcc dans la liaison entre le circuit et l'ampli.

    Tu n'as pas un vrai schéma avec le typon du circuit imprimé?

  13. #10
    PiXel20

    Re : Interfacage de l'accéléromètre ADXL323

    non je n'ai pas le typon malheureusement, je l'ai fait a la main avec une plaquette préfab, mais j'ai refait le montage sur un breadboard car je me suis apercu de quelque chose de biz avec le montage souder, le meme phénomène revien avec le breadboard, si je laisse déconnecté l'entrée des l'ampli op ou l'on vien connecter l'accélérometre et que l'on vien brancher le multimètre dessus, tant et aussi longtemps que mes doigts toucheront (la gaine en plastique!), une tension de 2.40V sera lisible, (multimètre grounder) si j'éloigne mes doigt une tension de .64v et si je remet une main et je ground l'autre, la on va lire .39v or ce montage est alimenter avec du 12v dc reguler en 5v où tout le montage en sera alimenter, lorsque j'ai fait des test, j'ai connecter un pot a la place de l'accélérometre mais connecté sur le 12v non réguler, en fait le meme phénomène est apparu, dès j'ai déplacer l'alim du pot vers la source réguler du reste du circuit, le probleme étais résolu.

    Ma théorie est, si le régulateur de tension modifi a ce point la tension pour que a l'entrée des ampli-op il y ai des interférences, si je me trompe l'accéléromètre selon se que j'ai vu de sa schématique modifi aussi po mal le signal d'entré, et crérais une interférence aussi et l'ampli op renvoirais automatiquement une tension de 2.40v directement en conflit avec l'accélérometre ce qui expliquerais pk il a surchauffer au point de se détruire...

    de toute facon j'ai commandé un nouveau accélérometre mais celui ci va venir avec tout un circuit de protection contre polarité inversé, surtension et cours circuit a la sortie( ampli op buffer en sortie) , je pense que cela réglerais mon problème.

    mais je ne donne que ma théorie et je fait appel aux connaisseurs pour m'éclairé d'avantage et pk pas trouver la solution qui aurais pt éviter que mon accéléromètre ne cuit, et surtout que par malchance ne fait cuire le nouveau qui coute bien plus cher...

  14. #11
    Jack

    Re : Interfacage de l'accéléromètre ADXL323

    J'avoue que je n'ai pas trop réussi à te suivre ...

  15. #12
    PiXel20

    Re : Interfacage de l'accéléromètre ADXL323

    ok je vais essayer d'etre plus clair et résumer lol

    Sur mon montage souder, l'entré des 2 ampli op où l'on branche l'accéléromètre, si je la connecte directement au multimètre; positif sur l'entrée et negatif au ground, j'obtien 2 tensions: 2.40v si je touche avec une mains le coté de l'entrée et .60v si je n'y touche pas ou je ground une main et l'autre touche a l'entré.

    j'ai obtenu les meme résultat sur mon breadboard pour confirmer ce n'étais pas une erreur de montage

    Quand j'ai fait mes test avec un potentiomètre au lieu de l'accélérometre, j'avait 2 option pour batir mon voltage de référence, le prendre directement du 12v comme source d'alimentation ou le prendre a la meme place que le reste du montage, soit a la sortie du régulateur 5v 7805 qui est alimenter par le 12vdc, si je le prend directement sur le 12v, le résultat est instable a la sortie de la bascule mais sur le 5v reg tout est correct, pk?

    or le meme phénomène c'est produit lorsque j'ai connecter l'accéléromètre au lieu du pot, résultat instable, sortie de la bascule qui passe de 0 a 1 sans arret

    l'accélérometre reformerait-il le signal comme le régulateur et causerais des interférence...

    si je me base sur l'expérience que j'explique au tout début, serait-il possible que a cause de ce dysfonctionnement que l'ampli op ait retourner a l'accélérometre un certain voltage et aurais causer sa destruction, d'ailleur quand j,ai vu l'instabilité j'ai été lire le voltage a la sortie de l,accélérometre et ca donnais genre 3-4v alors que sans charge celui-ci est senser donner 2.50v

    j'espere que j'ai bien expliquer cette fois ci lol

  16. Publicité
  17. #13
    Jack

    Re : Interfacage de l'accéléromètre ADXL323

    Sur mon montage souder, l'entré des 2 ampli op où l'on branche l'accéléromètre, si je la connecte directement au multimètre; positif sur l'entrée et negatif au ground, j'obtien 2 tensions: 2.40v si je touche avec une mains le coté de l'entrée et .60v si je n'y touche pas ou je ground une main et l'autre touche a l'entré.
    Si les entrées de ton ampli possèdent une forte impédance, tu vas mesurer n'importe quoi. Et d'après ton schéma, c'est le cas. Le moindre bruit va faire basculer ton ampli monté en comparateur.

    Ce que je ne comprends pas non plus dans ton schéma, c'est que le capteur a une sortie différentielle. Une des deux sortie va aux comparateur. Que fais-tu de l'autre?

    Tu n'aurais pas un vrai schéma complet, avec les alim et tout et tout.

  18. #14
    PiXel20

    Re : Interfacage de l'accéléromètre ADXL323

    j'ai fait un schéma, mieu que le précédant et complet

    pour la sortie différentiel, est-ce que tu parle du X et Y du capteur, c'est deux sortie indépendante, l'une n'est juste pas connecté

    comme tu di le moindre bruit va faire basculer mon ampli op comparateur, c'est exactement ce qui fesais lorsque j'ai connecter le capteur, mais je pense a une affaire, serais-til possible qu'il basculais comme ca a cause que je n,ai pas mi de condensateur de filtration a la sortie du capteur, une fréquence de 1600hz peut etre développé, encore la je comprend pas pk il s'aurais détruit

  19. #15
    Jack

    Re : Interfacage de l'accéléromètre ADXL323

    Ce n'est effectivement pas une sortie différentielle.

    Je veux bien le voir ton schéma ...

  20. #16
    PiXel20

    Re : Interfacage de l'accéléromètre ADXL323

    oups ca l'air mon schéma est pas la, ma le mettre la...

    le capteur sur le coup de la frustration je l'ai mi aux poubelles, plus tard jl'ai repêché jsais ben pas pk lol , pi apres m'avoir tourné les pouces 2 jours de temps j'ai décidé pour le fun de remettre le multimètre dessus, pi y,avait pu de court circuit entre x et vs... j'ai tout refait les branchement des mini patte, asser rude pour 16 pattes sur une piece de 4mmx 4mm..., replogué tout ca pour le tester et il fonctionne a nouveau... fac je l'ai rebrancher a mon montage pi ah la y'a fonctionné pendant 20 min correctment sur x pi apres il ne gardait pas sa tension uniquement si y'avait une charge... une tension de 2.50v a 0g, probablement x a été endomagé lors du premier test.. mais y parcontre (juste a virer l'engin de coté, ben il fonctionne numéro 1 .
    meme si je suis certain avoir correctement tout branché la premiere fois, je croit que je vais devoir essayer de me mettre à l'idée qu'il y avait qqch de pas correct, mais je n'ai rien compris de tout ca quand meme...
    pour le moment il fonctionne...lol

    tk dsl de t'avoir dérangé pour rien mais je laisse quand meme le schéma.

    pt ca t'intéreste qui sais
    Images attachées Images attachées

Sur le même thème :

Discussions similaires

  1. interfaçage
    Par ncirMohamed dans le forum Logiciel - Software - Open Source
    Réponses: 0
    Dernier message: 20/05/2007, 19h53
  2. Interfaçage via USB
    Par cyrilsat dans le forum Électronique
    Réponses: 2
    Dernier message: 27/03/2007, 16h31
  3. l'accéléromètre
    Par Jonathan06 dans le forum TPE / TIPE et autres travaux
    Réponses: 1
    Dernier message: 09/02/2007, 14h33
  4. Interfaçage Graphique en C
    Par Dxuis dans le forum Logiciel - Software - Open Source
    Réponses: 6
    Dernier message: 28/12/2006, 00h00
  5. electronique plusieur question: interfacage pci
    Par bmn dans le forum Électronique
    Réponses: 11
    Dernier message: 12/09/2005, 11h48