Répondre à la discussion
Affichage des résultats 1 à 13 sur 13

Pb sur CNA



  1. #1
    electrome

    Pb sur CNA


    ------

    Salut ! Je viens de réaliser un montage a base de CNA. Le montage en lui-même est fonctionnel ; il me génère une tension 0-10V suivant une valeur de 8 bits. Le problème vient du fait que lorsque j'envoie cette tension sur l'entrée analogique d'un variateur de vitesse ( pour moteur asynchrone triphasé ) qui a comme impédance d'entrée 10 Kohms, cette tension s'écroule . Il y a bien un montage suiveur a la sortie du convertisseur N/A mais je pense qu'il n'est pas suffisant. L'AOP est un LF353 . Comment pourrais-je donc réaliser ou modifier les valeurs des composants pour ne plus voir cette tension s'écrouler...
    Merci pour votre aide.
    @+

    -----

  2. Publicité
  3. #2
    gienas
    Modérateur

    Re : Pb sur CNA

    Bonjour à tout le groupe

    Un AOP est en général capable d'alimenter 10k, puisque les notices préconisent de les mettre pour tester.

    Je pense que le montage n'est pas conforme, ou que l'impédance d'entrée de la "charge" n'est pas ce que tu crois. Peux-tu nous indiquer le schéma de la sortie CNA?

    Peux-tu vérifier:
    1) en chargeant ton CNA uniquement par 10k pour voir ce qui se passe?
    2) vérifier qu'il n'y a pas de problème de masse entre CNA et charge?
    3) "simuler" un CNA par une pile, gréée pour présenter une résistance de sortie d'environ 10k, pour vérifier qu'on perd bien la moitié de la tension?

    Bonnes bidouilles.

  4. #3
    electrome

    Re : Pb sur CNA

    Salut, le schéma a été réalisé suivant le livre " Mesures & PC ". Un convertisseur DAC808 pilote un AOP de type LF353 en suiveur .
    C'est la sortie IOUT du convertisseur qui " entre " dans l'entrée inverseuse de l'AOP. Son entrée non inverseuse est a la masse et il y a une résistance de 4.75K entre la sortie et l'entrée Inverseuse de l'AOP . Voila c'est tout . Je pense faire un petit schéma pour bien voir ...
    Il faut que je teste sur une charge de 10K pour voir... Je te tient au courant ...
    Pour l'impédance de la charge, c'est indiqué sur la notice du variateur...
    Merci.

  5. #4
    FC05

    Re : Pb sur CNA

    ?????

    Moi pour faire un suiveur avec un AOP, je fais entrer ma tension sur l'entrée non-inverseuse et je boucle l'entrée inverseuse sur la sortie ...

  6. A voir en vidéo sur Futura
  7. #5
    electrome

    Re : Pb sur CNA

    Salut, oui, moi aussi, mais avec une alim +/- 12V pour avoir une sortie de 0 a +10 V, je pense que cette résistance est nécessaire ...
    Salut.

  8. #6
    FC05

    Re : Pb sur CNA

    Moi, c'est l'entrée non inverseuse à la masse qui me géne ...

    Sinon, l'alim symétrique, c'est pas un problème, au contraire, les AOP en alim "normale" ne sont pas tous capables de fournir le 0V.

  9. Publicité
  10. #7
    monnoliv

    Re : Pb sur CNA

    C'est parce que le DAC a une sortie en courant (IOUT as-tu écris) qu'il y a une résistance sur l'AOP. En fait cet AOP convertit un courant en une tension (Uout = 4750*Iout). Il n'est donc pas monté en suiveur.
    Ne soldez pas grand mère, elle brosse encore.

  11. #8
    FC05

    Re : Pb sur CNA

    Oui, c'est le "détail" qui tue ... alors désolé pour ce que j'ai dit qui est complétement hors sujet

  12. #9
    electrome

    Re : Pb sur CNA

    Salut ! Donc si je mets un montage suiveur, cela devrait fonctionner ou bien je me trompe sur toute la ligne ?
    Je pense de toute façon qu'il faut essayer avec une charge de 10K ( info de GIENAS ) pour voir ce que cela donne .
    Merci.
    @+

  13. #10
    FC05

    Re : Pb sur CNA

    Le probléme, c'est que (apparement) ton DAC te donne un courant de sortie et pas une tension de sortie, du coup, il te faut un convertisseur courant-tension comme tu as décrit.

    Si il y a un problème d'impédance, alors il faut placer un (autre) ampli-op en suiveur aprés le convertisseur courant-tension ... à condition que ce soit vraiment un problème d'impédance.

  14. #11
    koaber

    Re : Pb sur CNA

    je ne comprends pas quel est l'intérêt de mettre un suiveur...
    @+, Yohann.
    et va voir mon site...

  15. #12
    gienas
    Modérateur

    Re : Pb sur CNA

    Bonjour koaber et tout le groupe

    je ne comprends pas quel est l'intérêt de mettre un suiveur...
    C'est vrai qu'à priori, un suiveur "ne sert à rien" puiqu'il ne change pas le signal.
    C'est vrai à vide quand le signal n'a pas de courant à fournir.

    En charge, avec du courant, cela peut être très différent. Pour être quoi qu'il arrive (ou presque) on met un étage suiveur, qui comme son nom l'indique recopie le signal, tout en lui permettant de fournir une puissance (presque) quelconque.

    Parfois on dit du suiveur que c'est un amplificateur de (la) puissance.

    En gros, c'est un souci de moins

  16. Publicité
  17. #13
    koaber

    Re : Pb sur CNA

    ok, merci!
    @+, Yohann.
    et va voir mon site...

Discussions similaires

  1. CAN, CNA et signaux audio
    Par odsen dans le forum Électronique
    Réponses: 12
    Dernier message: 26/10/2007, 06h17
  2. réaliser un CNA à l'aide d'un filtre passe-bas(MLI)
    Par johpascal dans le forum Électronique
    Réponses: 4
    Dernier message: 21/04/2007, 20h23
  3. Précision CNA
    Par thomasalbert1993 dans le forum Électronique
    Réponses: 11
    Dernier message: 11/03/2007, 08h34
  4. Aide pour programme PIC18F (PIC-->CNA)
    Par strat666 dans le forum Électronique
    Réponses: 1
    Dernier message: 12/06/2006, 21h54
  5. SÉRIE can-cna
    Par monster53000 dans le forum Électronique
    Réponses: 1
    Dernier message: 10/03/2005, 10h03
Découvrez nos comparatifs produits sur l'informatique et les technologies.