Répondre à la discussion
Page 1 sur 2 1 DernièreDernière
Affichage des résultats 1 à 30 sur 43

Moteur pas à pas et petite fumée transistorienne...



  1. #1
    Snivel

    Moteur pas à pas et petite fumée transistorienne...


    ------

    Bonjour à tous,

    Voulant faire tourner un moteur pas à pas unipolaire, je me suis fais un petite montage classique à l'aide d'une carte arduino / optocoupleur et transistor BDX 53 (NPN), sans oublier les diodes de roues libres

    Mon moteur pas à pas nécessite du 3A, pas contre aucune idée de la tension (c'est un moteur norme NEMA commandé sur selectronic, eux non plus n'ont pas de datasheet spécifiant la tension à appliquer...) de même, 3A pour un fonctionnement unipolaire ou bipolaire ?!

    J'ai modifié une alim ATX qui me délivre du 12V / 9A
    Les BDX 53 ont un Ic max de 8A...

    Je n'ai tester qu'une bobine en alternant les états toutes les 50ms.
    Ca tourne... quelques dizaines de secondes plus tard, un transistor crame... et comment ! ils étaient super chaud...

    Voilà mes hypothèses :
    - J'ai absolument besoin de mettre des dissipateurs sinon fumée...
    - Ma bobine "tire" du 3A, pour moi un composant consomme ce dont il a besoin .... par contre si 9A parcourt la bobine et les transistors, je comprends mieux pourquoi ça a cramé...
    - Les 2 du dessus additionnées

    Ou alors j'oublie quelque chose... ? en plus...

    Je vous remercie pour votre aide !

    -----

  2. Publicité
  3. #2
    DAUDET78

    Re : Moteur pas à pas et petite fumée transistorienne...

    Quelle est la résistance interne d'une bobine ?
    J'aime pas le Grec

  4. #3
    Snivel

    Re : Moteur pas à pas et petite fumée transistorienne...

    - Courant par phase : 3,0 A
    - Résistance : 1,0 ohms
    - Inductance : 2,1mH

    J'ai peur de ce que tu vas me dire...

  5. #4
    DAUDET78

    Re : Moteur pas à pas et petite fumée transistorienne...

    Pour piloter ton moteur pas à pas, il faut lui envoyer 3A. Si tu fonctionnes à grande vitesse, la self empêche que le courant ne grimpe trop vite. Pas de problème si tu alimentes en 9V.
    A faible vitesse ou en statique, le courant est limité uniquement par la résistance de la bobine ... et ça fume.

    Si tu ne cherches pas de performance de vitesse, tu alimentes en 3 ou 4V et basta .
    Si tu cherches de vitesse (ou de la réaction rapide), tu alimente en 9 ou 12V et tu limites le courant à 3A . Voir les circuits L296 et L297 en #7

    Le L297 possède une résistance de mesure de courant qui, avec le L296, limite par découpage le courant moyen
    J'aime pas le Grec

  6. #5
    Qristoff

    Re : Moteur pas à pas et petite fumée transistorienne...

    - J'ai absolument besoin de mettre des dissipateurs sinon fumée...
    C'est sur que tu peux déja commencer par là !
    Le BDX53 est donné pour 1,5V de VCEsat sous 3A ! ce qui fait 4,5W en crête !

  7. A voir en vidéo sur Futura
  8. #6
    Snivel

    Re : Moteur pas à pas et petite fumée transistorienne...

    Merci beaucoup pour vos réponses.
    Je ne ferai plus l'erreur des dissipateurs

    Mon choix se porte plutôt sur l'utilisation du 12V, en effet je souhaiterais utiliser par la suite une batterie de voiture... est ce que ce sera aussi simple que du plug and play ?

    J'ai "bien" regardé les datasheet des L296, L297 et L298.

    D'après ce que j'ai compris,
    je n'aurai besoin que du L296 afin de réguler l'arrivé du courant dans mon moteur, ensuite j'aurai un étage supplémentaire avec 4 transistors ou au choix l'utilisation du L298 (qui est intéressant puisque je pourrais piloter mon moteur en bipolaire !), et mes créneaux de l'arduino venant faire saturer mes transistors (jouant le rôle du L297 en faite)

    Est ce que j'ai bien tous compris ?
    Je ne connaissais pas ces petites bêtes, elles ont l'air plutôt sympas... !

    Par contre Daudet
    je n'ai pas compris cela :

    Si tu ne cherches pas de performance de vitesse, tu alimentes en 3 ou 4V et basta .
    Comment cela ce fait il que rien ne cramera dans ce cas là ?
    La sortie 3,3V d'une alim ATX fait environ 12A...

    Merci encore !

  9. Publicité
  10. #7
    DAUDET78

    Re : Moteur pas à pas et petite fumée transistorienne...

    Citation Envoyé par Snivel Voir le message
    Comment cela ce fait il que rien ne cramera dans ce cas là ?
    Parce qu'avec 3,3V (moins les saturations des transistors), le courant statique dans la bobine ne peut dépasser 2 ou 3A. Par contre, il ne faut pas demander des performances de vitesse à ton moteur
    J'aime pas le Grec

  11. #8
    Snivel

    Re : Moteur pas à pas et petite fumée transistorienne...

    Ca marche...

    Et pour le reste, c'est une bonne logique ou bien ?
    Désolé de t'embêter :P

  12. #9
    Snivel

    Re : Moteur pas à pas et petite fumée transistorienne...

    En faite, je regarde les régulateurs...
    Ce serait pas plus simple si j'utilisais quelques choses genre LT1084 ?
    Par contre j'ai un peu peur de son comportement dans les hautes fréquences... ! J'arrive pas à voir ça dans la datasheet... si quelqu'un peut m'aider !?

  13. #10
    DAUDET78

    Re : Moteur pas à pas et petite fumée transistorienne...

    Je ne vois pas pourquoi tu cherches à ré-inventer le fil à couper les pattates chaudes .... tu as la série L296 et suivant qui est fait pour ce job.
    J'aime pas le Grec

  14. #11
    Snivel

    Re : Moteur pas à pas et petite fumée transistorienne...

    Bonjour,

    Oui en effet, j'ai regardé de plus près la série LT10xx, ça m'a l'air un peu compliqué pour moi...

    J'ai donc tenté de faire un schéma, j'imagine qu'il est vraiment incomplet au niveau resistance/condo (comparé au lien que tu m'as donné précédemment )




    des pitites questions :

    - Je ne trouve pas dans la datasheet du L296 les valeurs de la résistance variable pour limiter le courant (pin 4)

    - Je ne comprends pas l'importance du L297 (qui coûte 11euros) alors que je peux générer mes créneaux avec mon micro-contrôleur...

    - Faut-il que le L296 soit synchronisé avec le micro-contrôleur ? si je n'utilise pas de L297...

    Je te remercie d'avance pour tes lumières la dessus !


    Cordialement,

  15. #12
    DAUDET78

    Re : Moteur pas à pas et petite fumée transistorienne...

    regarde la note d'application AN470 L297 L298
    J'aime pas le Grec

  16. Publicité
  17. #13
    Snivel

    Re : Moteur pas à pas et petite fumée transistorienne...

    lu..
    Je suis pas sortie de l'auberge

    Merci bien.

  18. #14
    DAUDET78

    Re : Moteur pas à pas et petite fumée transistorienne...

    Citation Envoyé par Snivel Voir le message
    Je suis pas sortie de l'auberge
    Surtout qu'on ne sait toujours pas si tu dois tourner vite ou lentement. Je crois que le couple L297-L298 est vendu en KIT
    http://cncloisirs.com/Construction/PlansDeCartes
    http://www.astrosurf.com/newton200/elec1.htm
    Kit livré avec deux moteurs http://www.electronique-diffusion.fr...ducts_id=17136
    J'aime pas le Grec

  19. #15
    Snivel

    Re : Moteur pas à pas et petite fumée transistorienne...

    Merci Daudet78 pour ces liens, ça m'a pas mal renseigné sur le fonctionnement L297 / L298

    Ma volonté est de piloter ce moteur pap de manière à le rendre le plus flexible d'utilisation possible ! Donc lent et rapide et dans les 2 sens , j'avais omis de le préciser...

    C'est pour cela aussi que je souhaite utiliser la carte Arduino (et non pas le microcontroleur du kit ERMES, qui est tous de même très intéressant ! ), pour pourquoi pas plus tard la piloter en wifi (avec carte xbee) ou encore rajouter un petit écran LCD dessus !...
    bien plus pratique non ?

    J'ai donc acheté les L297 et L298 (je dois faire 130 bornes pour...)
    il n'y avait plus de L296 ... depuis 2 ans !
    En rentrant je pense avoir mieux compris le fonctionnement
    Ne te serais-tu pas trompé avec le nom des composants ici :

    Le L297 possède une résistance de mesure de courant qui, avec le L296, limite par découpage le courant moyen
    Où il fallait lire le L298 à la place du L296 ?!

    Peux-tu me confirmer ce que je crois avoir compris et comment je vois les choses ?

    -> L297 permet d'adapter les signaux générés à l'aide des "sense input" (pin13/14) ainsi mes bobines ne tirent pas trop en fonctionnement lent et ne risque pas de grillé tous le bazar.

    -> le L298 sera directement branché à mon alim 12v / 9A

    -> Le L297 sera branché au 5v / 20A, le composant grillera-t-il ?


    Merci encore

  20. #16
    DAUDET78

    Re : Moteur pas à pas et petite fumée transistorienne...

    Citation Envoyé par Snivel Voir le message
    Où il fallait lire le L298 à la place du L296 ?!
    Errare humanum est ...... dans ma réponse #14, je causais bien du L297 et L298 , sorry
    Attention au dessin du circuit imprimé, il est critique (inspire toi de mes liens)
    J'aime pas le Grec

  21. #17
    Snivel

    Re : Moteur pas à pas et petite fumée transistorienne...

    Bonjour,

    J'ai un soucis...
    J'ai un peu tout essaié avec le L297
    J'essaie de tester voir si les sorties s'alternent bien, les visualisant à l'aide de LEDs, mais rien à faire les LEDs sont toujours à l'état HAUT
    J'ai alimenté le L297 avec une alim de pc 5v/20A, serait-il cramé ?

    -> Une bonne discution trouvée sur un forum anglais à propos du L297/L298
    http://www.edaboard.com/ftopic125423.html

  22. #18
    DAUDET78

    Re : Moteur pas à pas et petite fumée transistorienne...

    Une alimentation de PC marche (bien ??) avec une charge minimum de 2A sur le 5V. En cas de défaut, tu fais un court-jus limité à 20A ..... Tu exploses le circuit en test et les câbles de liaison. C'est une très mauvaise approche pour faire des essais
    Tu as mis des interrupteurs pour piloter ton L297? Avec des résistances de rappel ......?

    PS: il y a des bonnes discussions en Français sur L297 L298
    J'aime pas le Grec

  23. Publicité
  24. #19
    Snivel

    Re : Moteur pas à pas et petite fumée transistorienne...

    salut,

    J'ai une résistance 10 Ohm/10watts branché sur le 5v...
    Hélas je fais avec les moyens que j'ai. (le seul fil rigide que j'ai trouvé dans un rayon de 70km est du fil de fer gainé de jardin...)
    J'ai un 7805 de récup aussi, branché sur le 12v, serait-il mieux adapté pour le L297 ?

    Pas d'interrupteurs mais microcontroller/optocoupleurs...
    Et pas de resistances de rappels... non... vais essaier une nouvelle fois avec cela... il faut que je les déssoude quelques parts... !

    PS : Pas trouvé de bonnes discussions en français..

  25. #20
    DAUDET78

    Re : Moteur pas à pas et petite fumée transistorienne...

    Citation Envoyé par Snivel Voir le message
    J'ai un 7805 de récup aussi, branché sur le 12v, serait-il mieux adapté pour le L297 ?
    Ben oui, mais si tu as un µC, tu as du 5V?
    Pas d'interrupteurs mais microcontroller/optocoupleurs...
    Donc vérifie ton soft et donne un schéma de ton montage
    Et pas de resistances de rappels....
    Inutile si c'est une sortie de circuits intégrés
    J'aime pas le Grec

  26. #21
    Snivel

    Re : Moteur pas à pas et petite fumée transistorienne...

    le µC est connecté par le port USB

    Je reviens sur ton post #4
    En faite, avec le vieux schéma (juste les 4 transistors)
    Ce qui est dangereux, c'est le fonctionnement à faible vitesse
    mais pourquoi alors ne pas faire de créneaux d'un minimum syndical pour faire incrémenter le moteur, puis espacer ces créneaux afin d'avoir un fonctionnement lent ?

    Je fais un schéma pour tous à l'heure, là j'ai besoin de vider ma tête...

  27. #22
    Snivel

    Re : Moteur pas à pas et petite fumée transistorienne...

    Voilà le schéma :
    - Alim de PC 5v/20A
    - µC Arduino (la pin 2 est la masse du µC)



  28. #23
    Snivel

    Re : Moteur pas à pas et petite fumée transistorienne...

    J'ai viens de refaire le schéma avec alim 12v sur 7805 et sur un nouveau L297...
    toujours pareil, les LEDs restent allumés...
    si quelqu'un a une idée, je suis preneur !

  29. #24
    DAUDET78

    Re : Moteur pas à pas et petite fumée transistorienne...

    Sans vérifier le schéma ....
    Il manque des résistances de PullDown (10K ?) entre les émetteurs de chaque photocoupleur et le 0V.
    J'aime pas le Grec

  30. Publicité
  31. #25
    Snivel

    Re : Moteur pas à pas et petite fumée transistorienne...

    Oui, j'ai oublié de les mettre sur le schéma, mais j'y ai pensé...
    Les crénaux sortent bien, j'ai vérifié avec une LED.

  32. #26
    Snivel

    Re : Moteur pas à pas et petite fumée transistorienne...

    Bonjour,

    Je perds espoir... !
    Je viens de faire ce schéma.




    Au moment du test, j'ai mis une horloge à 1.0 kHz
    J'ai laissé les autres entrées à l'état bas.
    Lorsque j'allume, le moteur ne tourne pas et il n'y a aucun bruit... après un dizaine de seconde, y a un bruit qui vient du moteur, pas glop du tous du tous (et ça tourne pas)... ! Je coupe de suite...

    Comme avec l'histoire de mes diodes, j'aurai espérer voir mes sorties du L297 changer d'états... mais au bruit, on dirait bien que rien ne marche, ni sortie, ni la sécurité pour les pics de courant ! Je vais bien réussir à le flinguer ce moteur...

    D'après moi,
    Vref ~= 1,4V
    Et mes Résistances pour mesurer le courant font 0.5 Ohm... me laissant un pic de courant à environ 2.8A
    Mes 2 phases prennent 3A... hélas, j'aurai espéré que au moins il ait du mal à démarrer (il aurait fait du bruit...), mais rien..

    Le L298 chauffe quand même.

    Si quelqu'un a une idée, je suis (ultra) preneur !
    Merci beaucoup... !

  33. #27
    DAUDET78

    Re : Moteur pas à pas et petite fumée transistorienne...

    Pas de condensateurs de decouplage en entrée/sortie du 7805 ???
    et le 1Khz sur quelle entrée ?
    J'aime pas le Grec

  34. #28
    verdifre

    Re : Moteur pas à pas et petite fumée transistorienne...

    bonjour,
    c'est quoi les points 2 de tes connecteurs moteurs qui repartent à la masse ?
    je voudrais pas trop m'avancer mais cela me semble inquietant vu la structure interne du 298...
    fred
    On ne vient pas de nulle part et il serait souhaitable qu'on n'aille pas n'importe où !

  35. #29
    Snivel

    Re : Moteur pas à pas et petite fumée transistorienne...

    Merci pour vos réponses
    Pas de condensateurs de decouplage en entrée/sortie du 7805 ???
    et le 1Khz sur quelle entrée ?
    bhéé... non.. je vais faire ça...
    1kHz sur la cloak du L297

    c'est quoi les points 2 de tes connecteurs moteurs qui repartent à la masse ?
    Mon moteur est unipolair, c'est pour cela... est ce correcte ?

    Merci !

  36. #30
    verdifre

    Re : Moteur pas à pas et petite fumée transistorienne...

    bonjour,
    cela m'étonerai que ton moteur démarre à 1 Khz, demarres le à 100 Hz pour commencer et retires le point milieux de tes bobines, un moteur unipolaire, tu peux l'utiliser en bibolaire, il suffit de ne pas utiliser le point milieux.
    Le 298 étant une commande bipolaire, te sera reconaissant.
    fred
    On ne vient pas de nulle part et il serait souhaitable qu'on n'aille pas n'importe où !

Sur le même thème :

Page 1 sur 2 1 DernièreDernière

Discussions similaires

  1. Réponses: 25
    Dernier message: 02/03/2014, 16h52
  2. Programmer un carte Arduino pour contrôler un moteur pas à pas
    Par JFSGeneva dans le forum Électronique
    Réponses: 2
    Dernier message: 22/05/2008, 07h28
  3. pilotage de moteur pas a pas par port parralelle sans lpt
    Par arno9173 dans le forum Électronique
    Réponses: 3
    Dernier message: 18/03/2008, 23h11
  4. projet:commande moteur pas à pas par micro-ordinateur
    Par einstein11 dans le forum Électronique
    Réponses: 6
    Dernier message: 12/03/2007, 14h25
  5. Commande d'un moteur pas à pas avec L297 et L298
    Par Raton dans le forum Électronique
    Réponses: 1
    Dernier message: 14/06/2003, 00h41
Découvrez nos comparatifs produits sur l'informatique et les technologies.