Répondre à la discussion
Page 1 sur 2 1 DernièreDernière
Affichage des résultats 1 à 30 sur 56

Module GPS, problème dans les trames



  1. #1
    Tripic

    Module GPS, problème dans les trames


    ------

    Bonjour à tous,

    J'ai récupéré un module GPS que j'ai brancher via un MAX232 sur mon pc. Le module m'envoie bien des données mais des trames illisibles comme celles ci par exemple :

    Received: àxž†žž†žžàx`æàöàöà ö`öàöàö`ö
    Received: `>Àxž†žž†àààφàÿ
    Received: x€xž†žž†àààφàÿ
    Received: `
    Received: àxž†žž†àààφàÿ
    Si vous avez une idée n'hésitez pas

    Merci d'avance.

    -----

  2. Publicité
  3. #2
    KHEOPS1982

    Re : Module GPS, problème dans les trames

    Hello,

    Comment as-tu procédé pour la récupération de tes trames ?
    Via un logiciel ? Via l'hyperterminal de Windows ?
    Peux-tu nous fournir un schéma de ton montage ?
    Comme cela nous pouvons vérifier s'il y a une quelconque erreur.

    @+

  4. #3
    DAUDET78

    Re : Module GPS, problème dans les trames

    La vitesse classique, c'est 4800 Bds
    J'aime pas le Grec

  5. #4
    Tripic

    Re : Module GPS, problème dans les trames

    KHEOPS1982 > La récupération des trames pour l'instant je le fais avec le module USART de mikropascal donc de ce côté pas de soucis.

    Et pour le schéma du montage c'est tout bête, un MAX232 classique avec ses 5 capa, la broche TX du module GPS reliée à la broche 11 du MAX232 et la broche 14 du MAX232 reliée à la broche 2 du port série.

    DAUDET78 > La doc du module me donne 9600 bds, j'ai quand même essayer avec 4800 bds mais ça ne fonctionne toujours pas.

    En tout cas merci de votre aide

  6. #5
    DAUDET78

    Re : Module GPS, problème dans les trames

    Citation Envoyé par Tripic Voir le message
    La doc du module me donne 9600 bds,
    peu importe, ce qui compte, c'est d'être sur la bonne vitesse. Tu as un lien sur la DOC de ton GPS , ton schéma de câblage du MAX232 et la liaison à ton PC.
    Je sais, c'est classique, mais j'aime bien voir .....
    J'aime pas le Grec

  7. A voir en vidéo sur Futura
  8. #6
    Tripic

    Re : Module GPS, problème dans les trames

    Voici le datasheet du module : http://www.uclm.es/area/amf/gonzalo/...-Datasheet.pdf

    Et voici le schéma de câblage :



    Il manque les broches 15 et 16 du MAX232 qui sont reliées au GND et VCC (+5V).

    As tu une idée du problème ?

  9. Publicité
  10. #7
    DAUDET78

    Re : Module GPS, problème dans les trames

    Avec des signaux d'un circuit alimenté en 3,3V, il faut un MAX3232 (ou autres) alimenté en 3,3V
    J'aime pas le Grec

  11. #8
    Tripic

    Re : Module GPS, problème dans les trames

    Ok je vais essayer, mais en es tu sûr ? Quesque cela va changer dans les signaux ? J'éspère que le module gps fonctionne toujours mais je pense car je ne l'ai jamais alimenté en 5V.

    J'ai aussi essayé sans passer par le MAX232 mais ça ne fonctionne pas non plus.

    Merci de ton aide, je te tiens au courant.
    Dernière modification par Tripic ; 08/08/2009 à 15h04.

  12. #9
    DAUDET78

    Re : Module GPS, problème dans les trames

    Citation Envoyé par Tripic Voir le message
    Ok je vais essayer, mais en es tu sûr ?
    Jamais sur ! c'est ma boule de cristal qui me le dit !
    J'aime pas le Grec

  13. #10
    Tripic

    Re : Module GPS, problème dans les trames

    Bonjour à tous,

    Je viens d'essayer avec un MAX3232 et cette fois je ne reçois plus rien :s

    Merci d'avance pour votre aide.

  14. #11
    DAUDET78

    Re : Module GPS, problème dans les trames

    Regarde ton câblage ! et mesure les différentes tensions sur toutes les broches du MAX. Tu n'as pas d'oscillo ?
    J'aime pas le Grec

  15. #12
    Tripic

    Re : Module GPS, problème dans les trames

    Le câblage à l'air bon, les tensions aussi. Non je n'ai pas encore d'oscillo :s

    Ce que je ne comprends pas c'est que lorsque je branche le MAX232 je reçois quelques chose (n'importe quoi mais bon ..) alors qu'avec le MAX3232 rien dutout !

  16. Publicité
  17. #13
    DAUDET78

    Re : Module GPS, problème dans les trames

    Citation Envoyé par Tripic Voir le message
    Ce que je ne comprends pas c'est que lorsque je branche le MAX232 je reçois quelques chose (n'importe quoi mais bon ..) alors qu'avec le MAX3232 rien dutout !
    Moi, je ne suis pas voyant et ta réponse ne fait pas avancer le Scmilbilik. Je t'ai demandé des mesures (au contrôleur universel) et pas des larmes de crocodile. Tu mesures toutes les tensions sur les pattes par rapport à la pin 5 du DB9 X1
    J'aime pas le Grec

  18. #14
    Tripic

    Re : Module GPS, problème dans les trames

    Voici les tensions mesuré :

    Pin 1 : 5,791V
    Pin 2 : 6,610V
    Pin 3 : 2,48V
    Pin 4 : 5,1333V
    Pin 5 : -1,4656V
    Pin 6 : -1,7628V
    Pin 7 : 0V
    Pin 8 : 0V
    Pin 9 : 3,3553V
    Pin 10 : 0V
    Pin 11 : 3,3509V
    Pin 12 : 3,3558V
    Pin 13 : 0V
    Pin 14 : -1,4718V
    PIn 15 : GND
    Pin 16 : 3,3562V

    Merci de ton aide !

  19. #15
    DAUDET78

    Re : Module GPS, problème dans les trames

    La pin 6, ce n'est pas bon (il faut entre -5 et -7V). tu as quoi comme valeur de capa ? avec la bonne polarité?
    Tu as fait la mesure avec le cable RS232 branché ? retire le et remesure .

    PS: fait aussi un test avec un PC et Hyperterminal.
    J'aime pas le Grec

  20. #16
    Tripic

    Re : Module GPS, problème dans les trames

    Pour les capa il y a 4 x 10uF et 1 x 100nF et la polarité est OK.

    Voici la mesure de la pin 6 avec le cable RS232 débranché : -1,72V

    Le MAX3232 est alimenté en 3,3V, comme le GPS.

  21. #17
    DAUDET78

    Re : Module GPS, problème dans les trames

    Tu as un problème sur la tension négative. Remet le MAX232 pour faire les mêmes mesures
    PS: Tu as bien un 0,1µF entre les pins 15 et16 du MAX?
    J'aime pas le Grec

  22. #18
    Tripic

    Re : Module GPS, problème dans les trames

    Oui j'ai bien un 0,1uF entre 15 et 16.

    Avec le MAX232 j'ai -4,49 sur la pin 6 (cable RS232 branché) et pareil avec le cable débranché.

  23. Publicité
  24. #19
    DAUDET78

    Re : Module GPS, problème dans les trames

    Pour moi, ton MAX3232 est naze
    J'aime pas le Grec

  25. #20
    Tripic

    Re : Module GPS, problème dans les trames

    et si je l'alimente en 5V, ça ne changera rien ?

  26. #21
    DAUDET78

    Re : Module GPS, problème dans les trames

    Le MAX3232 accepte 5V d'alimentation . Si la pin 6 ne bouge pas, il est naze.
    J'aime pas le Grec

  27. #22
    Tripic

    Re : Module GPS, problème dans les trames

    Ok je vais essayer alors mais je doute que ça change quelque chose, par contre je ne comprends vraiment pas pourquoi il est naze (acheté neuf chez farnell).

  28. #23
    Tripic

    Re : Module GPS, problème dans les trames

    Je trouve -2,71V en alimentant le MAX3232 avec 5V, c'est toujours pas suffisant ?

  29. #24
    DAUDET78

    Re : Module GPS, problème dans les trames

    Tu as (???) un condensateur H.S ou branché à l'envers. regarde bien .
    J'aime pas le Grec

  30. Publicité
  31. #25
    Tripic

    Re : Module GPS, problème dans les trames

    Après vérification j'avais bien un condensateur mal branché

    Donc j'ai bien -5V sur la pin 6 du MAX3232 mais je reçois exactement la même chose qu'avec le MAX232

    Le MAX3232 est alimenté en 5V.

  32. #26
    DAUDET78

    Re : Module GPS, problème dans les trames

    Comme ton GPS est alimenté en 3,3V, tu alimentes le MAX3232 en 3,3V

    Et tu utilises HyperTerminal sur ton PC pour lire tes trames.
    J'aime pas le Grec

  33. #27
    Tripic

    Re : Module GPS, problème dans les trames

    J'ai changé l'alimentation du MAX3232 mais je reçois toujours n'importe quoi :

    Received: föØàöØföØàö
    Received: à
    Received: föØàöØföØàö
    Received: f
    Received: öØàöØföØàö
    Received: `
    Received: föØàöØföØàö
    Received: `
    Received: föØàöØàööÏÞ`
    Received: öööØàööØf
    Received: öØàö
    Received: `
    Received: žæöØàöØföØàö
    Received: x
    Received: æöØàöØföØàö

  34. #28
    DAUDET78

    Re : Module GPS, problème dans les trames

    Je t'ai demandé d'utiliser Hyperterminal ....sur un PC
    J'aime pas le Grec

  35. #29
    Tripic

    Re : Module GPS, problème dans les trames

    J'utilise USART Terminal de mikropascal, c'est pas bon ? Sinon quesqu'un Hyperterminal ?

  36. #30
    DAUDET78

    Re : Module GPS, problème dans les trames

    Citation Envoyé par Tripic Voir le message
    J'utilise USART Terminal de mikropascal,
    je ne sais pas ce que c'est
    Sinon quesqu'un Hyperterminal ?
    C'est un logiciel de lecture écriture donné (?) avec ton O.S. Windows (sauf Vista ?) .
    1. programme
    2. accessoire
    3. hyperterminal
    4. tu le paramètres sur le port COM que tu veux avec la bonne vitesse

    ensuite, tu tapes au clavier, rien ne se passe
    tu relies la pin 2/9 et 3/9 du port COM
    tu as l'écho de ton clavier sur l'écran du PC
    tu retires le strap et tu branches ton GPS sur le port COM
    J'aime pas le Grec

Sur le même thème :

Page 1 sur 2 1 DernièreDernière

Discussions similaires

  1. Réponses: 39
    Dernier message: 14/01/2017, 15h57
  2. Copier des trames rs485 dans une mmc et les restituer...
    Par Kell34 dans le forum Électronique
    Réponses: 0
    Dernier message: 01/07/2009, 15h52
  3. reception des trames GPS sur un dspic
    Par rzgos dans le forum Électronique
    Réponses: 2
    Dernier message: 18/03/2009, 11h15
  4. module GPS et GSM
    Par nanard dans le forum Électronique
    Réponses: 1
    Dernier message: 22/02/2005, 17h39
  5. module GPS
    Par gfondeville dans le forum Électronique
    Réponses: 0
    Dernier message: 06/06/2003, 23h58
Découvrez nos comparatifs produits sur l'informatique et les technologies.