Répondre à la discussion
Affichage des résultats 1 à 6 sur 6

Comportement de mon moteur pas à pas



  1. #1
    schneiderj

    Comportement de mon moteur pas à pas


    ------

    Bonjour et bonne fête de fin d'année !!

    Je dispose d'un moteur pas à pas de chez nanotech (400 pas ) que je commande en mode bipolaire et par pas entier (avec un L297/L298).

    Je constate que lors de la mise en route du système, le moteur décroche facilement (1 tour par seconde), puis après 30 à 40 secondes (à plus du tout et ceci avec le même nombre de pas à la minutes. A partir de ce moment là, je peux augmenter la vitesse de rotation d'un facteur 2 à 3 avant qu'il ne décroche à nouveau.

    Sauriez-vous pourquoi lorsque le moteur est "froid", j'ai ce comportement ?

    Merci
    Jean-Marie

    -----

  2. Publicité
  3. #2
    gienas
    Modérateur

    Re : Comportement de mon moteur pas à pas

    Bonjour schneiderj et tout le groupe

    Citation Envoyé par schneiderj Voir le message
    ... Sauriez-vous pourquoi lorsque le moteur est "froid", j'ai ce comportement ? ...
    Non, mais les causes peuvent être multiples.

    1- il peut y avoir la mécanique entre l'axe du moteur et le mobile final, la lubrification éventuelle, un dur mécanique ...

    2- la commande électrique, dont on ne sait rien, à proprement parler. Pour atteindre les vitesse de start/stop les plus élevées, il convient d'utiliser des "hautes tensions" d'alimentation et des régulations de courant. C'est le courant qui apporte de l'efficacité au moteur, et ce courant a intérêt à s'établir le plus vite possible.

    3- Comme les limites sont souvent floues sur ces moteurs, rien ne prouve que tu n'es pas en limite de vitesse start/stop, qu'un "rien" en plus ou en moins, suffit à faire sauter des pas. Là, sauter des pas, signifie bloquer.

  4. #3
    schneiderj

    Re : Comportement de mon moteur pas à pas

    Pour commencer, meilleurs vœux à tous pour cette nouvelle année !

    Merci pour ta réponse. Pour la partie mécanique, l'alignement n'est idéale, mais il ne change pas avec le temps. De même pour la partie commande.

    Mais tu m'as mis la puce à l'oreille, et il est presque sur que mon problème provient d'unz mauvais connections au niveau de alimentation puissance. Pour passer d'une carte à l'autre j'utilise des connecteurs HE14 (http://www.gotronic.fr/catalog/conne...cible=he14.htm
    ).
    Ils ne sont peut être pas idéales...

    Jean-Marie

  5. #4
    gienas
    Modérateur

    Re : Comportement de mon moteur pas à pas

    Bonsoir schneiderj et tout le groupe

    Citation Envoyé par schneiderj Voir le message
    ... meilleurs vœux à tous pour cette nouvelle année ! ...
    Merci pour tes souhaits, et bonne année à toi aussi.

    Citation Envoyé par schneiderj Voir le message
    ... il ne change pas avec le temps. De même pour la partie commande ...
    Hum! Un peu "rapide" comme jugement. As-tu la preuve que cette commande est bien suffisante?

    Le problème, avec les moteurs pas à pas, c'est que c'est binaire: cela fonctionne ou cela ne fonctionne pas. Le passage d'un "état" à l'autre, tient parfois à un cheveu. Tu es peut-être dans ce cas.

    Citation Envoyé par schneiderj Voir le message
    ... tu m'as mis la puce à l'oreille, et il est presque sûr que mon problème provient d'un mauvais connections au niveau de alimentation puissance ...
    Je ne vois pas bien ce qui, dans mes propos, te fait venir cette idée, ni même ce qui te fait penser à un problème de contact ... auquel je ne pensais pas vraiment.

    Bien sûr, en chauffant, la résistance de contact augmente, mais de là franchir le seuil du non fonctionnement ...

    Quels signaux transitent par ces contacts?

  6. A voir en vidéo sur Futura
  7. Comparatifs

    Gagnez du temps et de l'argent grâce à nos comparatifs de produits. Parmi nos sujets :
  8. #5
    schneiderj

    Re : Comportement de mon moteur pas à pas

    Citation Envoyé par gienas Voir le message
    Je ne vois pas bien ce qui, dans mes propos, te fait venir cette idée, ni même ce qui te fait penser à un problème de contact ... auquel je ne pensais pas vraiment.
    Quels signaux transitent par ces contacts?
    La réponse est toute simple : tes remarques à propos des aspects autres que le moteur mon amenées à vérifier si une soudure n'était pas en cause. Mais non elles sont correctes. Par contre après cette manipulation, le moteur fonctionnait encore moins bien. J'ai donc tester toutes les connections par câbles et finalement je suis pratiquement sûr que le problème vient de la connexion entre cette carte et l'alimentation (+5 et +24 volts).

    Je ne peux pas souder ces liaisons pour l'instant, mais est-ce que je pourrais mettre un peu de pâte thermique pour améliorer le contact ?

    Jean-Marie

  9. #6
    gcortex

    Re : Comportement de mon moteur pas à pas

    à vide et à vitesse constante, le courant doit être réduit sous peine de résonance
    la commande en demi pas est largement plus souple et presque aussi efficace

  10. Publicité

Discussions similaires

  1. réglage du pas d'un moteur pas à pas
    Par François Besson dans le forum Électronique
    Réponses: 14
    Dernier message: 11/12/2009, 10h13
  2. moteur pas à pas comportement bizarre
    Par hellwood dans le forum Électronique
    Réponses: 7
    Dernier message: 07/08/2009, 10h28
  3. [Blanc] le moteur de mon frigo ne s'arrete pas
    Par silclo dans le forum Dépannage
    Réponses: 2
    Dernier message: 04/08/2009, 20h32
  4. pilotage de moteur pas a pas par port parralelle sans lpt
    Par arno9173 dans le forum Électronique
    Réponses: 3
    Dernier message: 18/03/2008, 22h11
  5. mon moteur tourne pas avec mon capteur de lumiere
    Par alex934mas dans le forum Électronique
    Réponses: 7
    Dernier message: 21/07/2006, 21h33
Découvrez nos comparatifs produits sur l'informatique et les technologies.