Répondre à la discussion
Affichage des résultats 1 à 8 sur 8

problème,transmission de caractère ascii avec l'hyperterminal



  1. #1
    Himir

    Question problème,transmission de caractère ascii avec l'hyperterminal


    ------

    Bonjour,

    Je reposte mon annonce ici, j'aurai certainement plus de chance d'obtenir une réponse.
    J'ai un petit soucis avec l'hyperterminal, je précise que je débute avec ce programme donc ma question est peut-être un peu stupide.
    J'ai un instrument de mesure, et il me donne la possibilité d'accéder à 2 modes différents: le mode "mesure" et "programmation" (paramétrage en fait). Lorsque je branche ma RS232 j'obtiens sur l'écran les valeurs de ce qui est envoyé par l'instrument de mesure, tout va bien je suis donc en mode "mesure".
    Dans la documentation technique on me signal que je dois envoyer 2 fois le caractère ESC (1B en hex) pour accéder au mode "programmation". Le probème est là! je ne sais pas comment envoyer une information... j'ai beau envoyer "1B" mon appareil reste irrémédiablement en mode "mesure".
    Est-ce que quelqu'un pourrait m'aider, car je n'ai aucune idée ni piste pour remédier à mon problème.

    -----

  2. Publicité
  3. #2
    ftorama

    Re : problème,transmission de caractère ascii avec l'hyperterminal

    jète l'hyperterminal et utilise un terminal évoulé. Perso j'utilise Realterm qui est gratuit: http://realterm.sourceforge.net/
    Quand un homme a faim, mieux vaut lui aprendre à pecher que de lui donner un poisson.

  4. #3
    kronanberg

    Re : problème,transmission de caractère ascii avec l'hyperterminal

    Salut !

    Le problème est que si tu envoie 1B sous ton hyperterminal y va t'envoyer le caractère "1" puis "B" alors que toi tu dois envoyer le caractère "ESC".

    Essaie quand tu est sur la fenêtre de l'hyperterminal d'appuyer sur "ESC" voir si ça envoie quelque chose. Mais je ne suis pas sur.

    Sinon utilise le terminal que te propose "ftorama" il a l'air plus intéressant ou alors tu te fais un petit code en Visual Basic pour communiquer avec ta carte !!

    a+

  5. #4
    Himir

    Re : problème,transmission de caractère ascii avec l'hyperterminal

    envoyer "ESC" ça ne marche pas non plus, j'ai essayer en décimal aussi qui est 27.
    Je comprends pas pourquoi ça ne marche pas, dans la documentation on me parle du terminal de windows, donc je vois pas pourquoi ça ne fonctionnerai pas.
    Pour info c'est du 8 bits, sans bit de parité, avec un bit de STOP et 1200 bauds.

    J'ai un programme en BASIC dans la doc mais je ne sais pas comment le lire... je l'ai tapper dans le bloc note et enregistrer avec l'extension .bas...

  6. A voir en vidéo sur Futura
  7. #5
    kronanberg

    Re : problème,transmission de caractère ascii avec l'hyperterminal

    Ben le souci c'est qu'avec l'hyperterminal tu ne peux pas envoyer directement ta valeur en Hexa ou en decimal.
    Puisque en faite quand tu envoies 27 via l'hyperterminal ta carte électronique recoit l'octet "O032" puis l'octet "0x37" et elle ne trouver donc pas l'octet "0x1B" qu'elle devrait recevoir.
    Je vois pas trop d'autre solution que d'utiliser un autre terminal ou réaliser une interface en VB.

  8. #6
    ftorama

    Re : problème,transmission de caractère ascii avec l'hyperterminal

    tu peux aussi essayer en appuyant sur le "Alt" à gauche du clavier tout en tapant 27 sur le clavier numérique.
    Quand un homme a faim, mieux vaut lui aprendre à pecher que de lui donner un poisson.

  9. Publicité
  10. #7
    Himir

    Re : problème,transmission de caractère ascii avec l'hyperterminal

    Citation Envoyé par ftorama Voir le message
    tu peux aussi essayer en appuyant sur le "Alt" à gauche du clavier tout en tapant 27 sur le clavier numérique.
    J'ai essayé aussi, en touche windows et terminal.

    Je vais essayer avec un autre terminal, je vous tiens au courant dans la journée.

  11. #8
    Himir

    Re : problème,transmission de caractère ascii avec l'hyperterminal

    J'ai changé de pc et ça marche parfaitement... merci de votre aide.

Discussions similaires

  1. envoyer des caractere sur port serie avec gtk+
    Par megazed dans le forum Logiciel - Software - Open Source
    Réponses: 2
    Dernier message: 14/03/2010, 19h29
  2. Réponses: 4
    Dernier message: 16/02/2010, 21h45
  3. afficher un caractère avec mikroC
    Par nanard dans le forum Électronique
    Réponses: 20
    Dernier message: 09/11/2008, 19h50
  4. probleme base de registre et affichage caractere
    Par VIC116FR dans le forum Logiciel - Software - Open Source
    Réponses: 0
    Dernier message: 05/09/2004, 13h56
  5. Caractère ASCII sur Trame RS232
    Par JP dans le forum Électronique
    Réponses: 6
    Dernier message: 04/09/2003, 01h38
Découvrez nos comparatifs produits sur l'informatique et les technologies.