Répondre à la discussion
Affichage des résultats 1 à 21 sur 21

Problémes avec Module RF 169Mhz !



  1. #1
    dje8269

    Problémes avec Module RF 169Mhz !


    ------

    Bonjour à tous ,

    Je test actuellement des modules RF de 169Mhz afin de savoir s'ils conviennent pour une application future (télécommande RC) . En effet ces modules en 100mW sont annoncés a +10Kms dans des conditions optimales, ce qui m'intéresse fortement pour ma télécommande .

    Voici ici un lien sur le site ou je les ai achetés , et a droite vous trouverez également la DS

    Lien modules Tx
    Lien modules Rx

    J'en arrive à mon problème . Je n'arrive absolument pas à les faire communiquer tant par voie radio que par fil ! . Je m'explique :

    Mes modules sont reliés a des µC afin d'envoyer de la data dans un message simple en Manchester . si le Rx reçoit une info il allume une led . tout simplement .

    Vous me direz vérifie ton programme ! Oui je l'ai déjà fait , j'ai même fais mieux . j'ai testé avec d'autres modules équivalent ( ou presque apparemment) et ça fonctionne parfaitement avec des modules 869mHz qui possède les même caractéristiques, les même broches, en gros on peut les inter-changés sans bouger les connexions ( a part les antennes pour les pros).
    lien vers modules 869Mhz :
    Lien modules TX en 869Mhz
    Lien modules RX en 869Mhz

    Donc avec mes modules 869Mhz ça fonctionne parfaitement par voie radio et par fil .
    j'inter-change mes modules pour mettre les 169Mhz et rien ne se passe , aussi bien par RF qu'en filaire . ( je change quand même les antennes pour des fils monobrins de 421mm de long par voie radio).
    En filaire , je relie la sortie du TX a l'entrée du RX par le biais d'une résistance de 1K .

    Je précise aussi, que je dispose de deux couples TX/RX , Enfin d'être sur qu'un ne soit pas mort.

    Auriez vous une idée du pourquoi la communication ne passe pas ? la seule différence se trouve dans les fréquences mais en filaire on s'en fou un peu , et le taux de transfert de données ; 64kbps pour les 869Mhe et 3kbps pour les 169Mhz .

    Merci de m'avoir lu .

    -----
    Dernière modification par dje8269 ; 04/11/2014 à 13h32.
    C'est en faisant des erreurs; que l'on apprend le mieux !!

  2. Publicité
  3. #2
    PIXEL

    Re : Problémes avec Module RF 169Mhz !

    il faudrait connaitre le débit des infos.

    les 3 kHz ne sont peut être pas suffisants.

    toutefois , le 169 mHz n'est pas autorisé en Europe

  4. #3
    dje8269

    Re : Problémes avec Module RF 169Mhz !

    Merci pour ta réponse rapide PIXEL,

    il faudrait connaitre le débit des infos.
    Pourrais tu me dire comment se calcul .

    J'envoie 8 octets toutes les secondes pour mes test . Pourquoi 8 , car mon µC ( un picaxe) en prend obligatoirement 8 dans sa commande RFout ( qui code en machester) .
    Je met donc par exemple 123 dans un octet genre b1 . j'envoie 8 fois b1 , je fais une pause de 1 seconde et je renvoie . A la réception si b1=123 alors j'allume une led .

    T'ai-je donné des indications ?
    C'est en faisant des erreurs; que l'on apprend le mieux !!

  5. #4
    PIXEL

    Re : Problémes avec Module RF 169Mhz !

    tout dépend de l'horloge des 8 bits...

    où tu le sais par les specs de ton codeur.

    où tu les mesures à l'oscilloscope

  6. A voir en vidéo sur Futura
  7. Comparatifs

    Gagnez du temps et de l'argent grâce à nos comparatifs de produits. Parmi nos sujets :
  8. #5
    dje8269

    Re : Problémes avec Module RF 169Mhz !

    Humm.... par le biais du codeur ca risque d'être dur .

    Par contre a l'oscillo je peux te dire ca .

    donc 3kbps = 3000 bytes par secondes = 3 bytes par milli-seconde .

    je mets 37ms pour envoyer mes 8 bits , mais ça c'est avec les préambules , les check sum et tout le toutim .....

    Je vais essayer déterminé cela ; si je met tout a 1 , je devrais avoir une partie continue a l'oscillo qui serait mes datas ?
    C'est en faisant des erreurs; que l'on apprend le mieux !!

  9. #6
    PIXEL

    Re : Problémes avec Module RF 169Mhz !

    Citation Envoyé par dje8269 Voir le message
    si je met tout a 1 , je devrais avoir une partie continue a l'oscillo qui serait mes datas ?
    euuuuhhhhh révise le codage manchester dont tu causes en #1 !!!

    il est JUSTEMENT fait pour qu'il n'y ait pas de composante continue

  10. Publicité
  11. #7
    dje8269

    Re : Problémes avec Module RF 169Mhz !

    il est JUSTEMENT fait pour qu'il n'y ait pas de composante continue
    exact , suis je bête ! j'ai parlé trop vite . Bon je vais demandé aux experts des Picaxes alors ;
    C'est en faisant des erreurs; que l'on apprend le mieux !!

  12. #8
    PIXEL

    Re : Problémes avec Module RF 169Mhz !

    une mesure lèvera le doute...

    c'est indispensable en développement

  13. #9
    dje8269

    Re : Problémes avec Module RF 169Mhz !

    une mesure lèvera le doute...
    Je veux bien mais je suis pas sur d'avoir tout saisi , sur ce que je dois mesurer ; je relève un envoi a l'oscillo ( composé de plein de pic) , comment déterminé le nombre de bytes par secondes ?
    C'est en faisant des erreurs; que l'on apprend le mieux !!

  14. #10
    PIXEL

    Re : Problémes avec Module RF 169Mhz !

    en apprenant à se servir d'un oscillo...

    http://www.web-sciences.com/oscillo/oscillo.php

  15. #11
    dje8269

    Re : Problémes avec Module RF 169Mhz !

    en apprenant à se servir d'un oscillo...

    Ok comme ça on avance bien ! . tu copie DAUDET pour les sarcasmes ?

    bon allez je retourne essayer d'allumé mon oscillo .
    C'est en faisant des erreurs; que l'on apprend le mieux !!

  16. #12
    PIXEL

    Re : Problémes avec Module RF 169Mhz !

    bon , les mec vous êtes gentil....

    y'avait aucun sarcasme , à part votre parano !

    ##### supprimé
    Dernière modification par JPL ; 04/11/2014 à 16h09.

  17. Publicité
  18. #13
    dje8269

    Re : Problémes avec Module RF 169Mhz !

    en apprenant à se servir d'un oscillo...
    Ben PIXEL désolé mais ca pour moi c'est un sarcasme . Je sais me servir d'un oscillo , et tu le sait trés bien . Par contre je ne sais pas interpreté les resultats , par rapport a ta demande . Ca oui je le confesse !

    J'ai donc relevé mon signal , au max j'ai 3 état haut et deux etat bas , en une milli-secondes . en codage Manchester ca fait 2 bit et demi non ? 1/0 , 1/0 , 1
    Maintenant il me faut 8 bit pour faire un octet . Donc un peu plus de 3ms ( 3x2.5 = 7.5 ) pour faire un octet .

    j'en déduis donc que je suis loin des 3 bytes par ms , car je suis plutot a 3 bit par ms .

    Ma déduction est elle bonne ?
    C'est en faisant des erreurs; que l'on apprend le mieux !!

  19. #14
    dje8269

    Re : Problémes avec Module RF 169Mhz !

    Bon ben j'ai foiré .

    J'etais persuadé que kbps , voulais dire Kilo bytes par seconde . et en fait ca signifie kilo BIT par seconde . je suis donc dans les choux , car trop rapide ou juste à la limite . Je pense que cela doit venir de la !
    C'est en faisant des erreurs; que l'on apprend le mieux !!

  20. #15
    richard 31
    Modérateur

    Re : Problémes avec Module RF 169Mhz !

    bonjour,
    restez calme s'il vous plait il est inutile de s’énerver,
    dje n'oubliez pas que pixel vous apporte son aide donc évitez de l’exciter
    cordialement
    richard 31

    la nature nous a doté du meilleur outil "LE CERVEAU" (+ le net)

  21. #16
    dje8269

    Re : Problémes avec Module RF 169Mhz !

    Petit retour d'expérience, si ça peut servir a quelqu'un .
    Le picaxe code et decode avec un module NKM2401 . La DS dis 200µs pour l'envoie d'une bit .
    donc 5 bit par milli-seconde ( 5 x 200µs) .
    soit 5000 bit par seconde. donc 5kbps.

    donc mon Tx est dans les choux , et n'as pas le temps de lite quoi que ce soit

    Le codage manchester divise la fréquence par deux , comme il faut deux bit pour faire un "1" ou un "0" . ( 10 ou 01).
    C'est en faisant des erreurs; que l'on apprend le mieux !!

  22. #17
    annjy

    Re : Problémes avec Module RF 169Mhz !

    Citation Envoyé par dje8269 Voir le message
    .............
    Le codage manchester divise la fréquence par deux , comme il faut deux bit pour faire un "1" ou un "0" . ( 10 ou 01).
    divise, ou multiplie ?

  23. #18
    dje8269

    Re : Problémes avec Module RF 169Mhz !

    divise, ou multiplie ?
    Ca sent le piége ta question . je dirais divise , car il faut deux fois plus de bit pour obtenir le même octet !.

    donc sans machester : 1 bit=200µs soit 5000bit / seconde
    Avec Manchester : 1 bit = 400µs soit 2500 / seconde

    Je dirais divise et c'est mon dernier mot jean-pierre Euh .... pardon Anjy
    C'est en faisant des erreurs; que l'on apprend le mieux !!

  24. Publicité
  25. #19
    annjy

    Re : Problémes avec Module RF 169Mhz !

    bonsoir,

    une image:


    bonne nuit,
    JY
    Images attachées Images attachées

  26. #20
    nornand

    Re : Problémes avec Module RF 169Mhz !

    Citation Envoyé par PIXEL Voir le message
    le 169 mHz n'est pas autorisé en Europe


    Erreur cher amis, désolé de vous contredire.

    " désolé une partie est en Anglais" je vous est traduit l'essentiel. mais vous pouvez zapper pour consulter le texte

    20011: source :EUROPEAN COMMISSION Information Society and Media Directorate-General Electronic Communications Policy Radio Spectrum Policy

    Subject:Review of Commission Decision 2005/928/EC (169 MHz Decision) –

    "En ce qui concerne la sous-bande de forte puissance dans la bande C 169 MHz(Decision 2005/928/EC), France : confirme qu'il n'y a pas plus autorisation délivrée dans cette bande (169.6125 – 169.8125 MHz). donc , this part of the band is free..(cette portion de bande est libre) "


    en 2013 plus d'info ici http://eur-lex.europa.eu/LexUriServ/...17:0036:FR:PDF voir les bandes 37 a,b,c . consultés l'article.

    la Bulgarie est même condamnée pour n'avoir pas appliqué les directives européennes.

  27. #21
    dje8269

    Re : Problémes avec Module RF 169Mhz !

    tout schéma est explicite , mais me laisse un gout amer .
    On peut pas reelement dire que ca multiplie la fréquence . la fréquence est determiné par l'horloge du µC . cela divise par le debit par deux, par ce qu'il faut deux fois plus de temps pour écrire la même chose ( etant donnée qu'il faut 2 bit pour en écrire 1) ;

    c'est difficile a expliquer par ecrit . mais je comprends ce que tu veux dire . et je me comprends aussi, c'est l'essentiel . J'aurais encore appris pas mal de truc avec mes recherches .
    C'est en faisant des erreurs; que l'on apprend le mieux !!

Discussions similaires

  1. Problèmes module flexion des plaques RDM 6
    Par jmed dans le forum Technologies
    Réponses: 4
    Dernier message: 18/08/2015, 14h37
  2. configurer un module xbee avec un autre module - appairage
    Par ti7bo7 dans le forum Électronique
    Réponses: 0
    Dernier message: 27/08/2012, 09h57
  3. Utilisation du module ADC avec le module PWM du PIC
    Par heri91 dans le forum Électronique
    Réponses: 8
    Dernier message: 25/09/2009, 12h40
Découvrez nos comparatifs produits sur l'informatique et les technologies.