Répondre à la discussion
Affichage des résultats 1 à 24 sur 24

Bruit et AOP



  1. #1
    kevin8z

    Bruit et AOP

    Bonjour,

    Je viens vers vous car je ne trouve pas de solution à mon problème. J'espère que vous allez pouvoir m'aider.

    Voici le schéma :
    Schéma.png

    Ce montage sert à amplifier le signal d'un micro-electret et de le centré sur 2.5V, pour ensuite faire une FFT avec un µC, mais le problème est qu'il y a beaucoup (pour ne pas dire qu'il n'y a que du bruit) de bruit en sortie de U1B et je ne comprend pas pourquoi.

    J'alimente la carte par une alim de labo.

    Je relève déjà une anomalie aux bornes de C5, il y a beaucoup de bruit, qui pourtant n'est pas présent en sortie de l'alim de labo.
    Alim.png

    En sortie de U1B j'obtient ce signal : j'ai relier la masse sur C1 (relié les 2 bornes du connecteur de gauche)
    Masse-entree.png

    Lorsque je relie le micro electret au connecteur j'obtient en sortie de U1B ce signal : (pourtant aucun son n'est présent)
    micro.png

    Je ne comprend vraiment pas d'ou viens ce problème.

    -----


  2. Publicité
  3. #2
    f.blavier

    Re : Bruit et AOP

    Les problèmes de mesures sont vite difficiles à cerner.
    Je peux te faire apparaitre du bruit de 50-100mV sans problème sur ton oscillo alors qu'il n'est peut être même pas réel...

    QQ chose de perturbant dans le local ? (une alim à découpage ? etc)
    Boucles de masses ? La terre de ton scope est coupée ou pas ?
    Probes ? Longueur des masses de probes ?

    Et on ne parle que de mesure - pas encore de la réalisation soigneuse ou non de la carte; des composants; réglages ampli; etc...

    Souvent, une mesure de la masse donne une bonne idée du bruit inventé par le scope (masse du probe sur masse alim; probe sur une masse ailleurs sur ton circuit)

  4. #3
    PIXEL

    Re : Bruit et AOP

    u1a ne sert à rien , sinon à amener du bruit

  5. #4
    Zenertransil

    Re : Bruit et AOP

    Bonjour,

    Je dois passer à côté d'un truc, mais là, le schéma, je vois pas bien comment il est censé fonctionner... U1:A sort une tension ~égale à la tension d'entrée, mais avec un offset de Vcc/2. Jusque là tout va bien (même si U1:A est inutile, en effet). Si la fréquence est suffisamment importante, l'entrée non-inverseuse de U1:B est à la masse : on retrouve un amplificateur inverseur (avec un pôle en "HF")

    Et là, moi, je vois deux incohérences!

    1) L'entrée + étant à 0 et non à Vcc/2, tu amplifies aussi l'offset ! C'est-à-dire que tu retrouverais à la sortie, avec un gain absolu A pour cet étage, A.Ve + A.Vcc/2. Déjà là, tu es sûr de faire saturer ton AOP si le gain réglé est plus grand que deux, hors dans ton cas il est au minimum de ~9 !
    2) Tu as un amplificateur inverseur, tu entres quelque chose d'absolument positif (offset + signal utile, avec |signal utile| << offset), tu auras en sortie quelque chose d'absolument négatif. Et tu es en alimentation asymétrique!

    J'ai raté un truc?
    Choisis un travail que tu aimes, et tu n'auras pas à travailler un seul jour de ta vie

  6. #5
    Zenertransil

    Re : Bruit et AOP

    Une solution

    schematic.GIF

    L'amplification, le centrage sur 2.5V, et les fréquences de coupure haute et basse sont toujours là. Il suffit de bien choisir les composants...
    Choisis un travail que tu aimes, et tu n'auras pas à travailler un seul jour de ta vie

  7. A voir en vidéo sur Futura
  8. #6
    kevin8z

    Re : Bruit et AOP

    Citation Envoyé par f.blavier Voir le message
    QQ chose de perturbant dans le local ? (une alim à découpage ? etc)
    Non à par une piste sur le circuit imprimé qui se trouve à environ 5cm ou il y a un signal de 800KHz.
    Et 112 leds WS2812B qui sont sur la même alimentation, peut êter que leurs commutation génère du bruit

    Citation Envoyé par f.blavier Voir le message
    Boucles de masses ? La terre de ton scope est coupée ou pas ?
    Probes ? Longueur des masses de probes ?
    Je vois pas ce qu'est une boucle de masse. Normalement oui la terre du scope est relié à la terre
    Mesure faîte avec une sonde réglée en 1/10, et l'oscillo est en mode AC. La longueur est d'environ 3cm

    Citation Envoyé par f.blavier Voir le message
    Et on ne parle que de mesure - pas encore de la réalisation soigneuse ou non de la carte; des composants; réglages ampli; etc...
    La carte ou se trouve ce circuit a était réalisée.

    Citation Envoyé par Zenertransil Voir le message
    Je dois passer à côté d'un truc, mais là, le schéma, je vois pas bien comment il est censé fonctionner... U1:A sort une tension ~égale à la tension d'entrée, mais avec un offset de Vcc/2. Jusque là tout va bien (même si U1:A est inutile, en effet). Si la fréquence est suffisamment importante, l'entrée non-inverseuse de U1:B est à la masse : on retrouve un amplificateur inverseur (avec un pôle en "HF")
    Pour moi U1A permet d'adapter l'impédance. S'il est inutile je le retirai sur la prochaine carte.
    Et R4 C2 forme un filtre passe bas, pour garder uniquement la composant continue les 2.5V, donc même si présence d'un signal HF, la composant continu elle sera toujours présente sur l'entrée non inverse, et donc l'AOP U1B pourra amplifier uniquement la composante alternative se situant autour du point 2.5V.

  9. Publicité
  10. #7
    Zenertransil

    Re : Bruit et AOP

    Euh... Tu as lu tout mon message? Le point 2) ne te tracasse pas plus que ça ?

    Dans ton cas, U1:A est "indispensable" car le schéma est mal foutu. Avec un schéma correct, un AOP suffit...
    Choisis un travail que tu aimes, et tu n'auras pas à travailler un seul jour de ta vie

  11. #8
    kevin8z

    Re : Bruit et AOP

    Citation Envoyé par Zenertransil Voir le message
    Euh... Tu as lu tout mon message? Le point 2) ne te tracasse pas plus que ça ?
    Si l'AOP U1B est polarisé à VCC/2, alors en sortie j'aurai la demi composant alternative positive supérieur à VCC/2, amplifier et qui se retrouverai en dessous de VCC/2.
    Donc l'AOP amplifie tout ce qui est autour de VCC/2. Si il aurai été polarisé à 0V la je suis d'accord tout la partie positive du signal se retrouverai en négatif chose impossible car je suis en asymétrique.

    Citation Envoyé par Zenertransil Voir le message
    Dans ton cas, U1:A est "indispensable" car le schéma est mal foutu. Avec un schéma correct, un AOP suffit...
    Pourtant ce schéma je l'ai utilisé dans mon projet de bts, sauf qu'en entrée de U1A j'avais la sortie d'un accéléromètre qui variait autour du point 2.5V. Ce qui ne ma pas empêcher d'avoir la note maximal sur la présentation de fin d'année du projet + le rapport.
    Donc je ne comprend pas très bien pourquoi il est mal foutu, j'attend que te fichier soit validé par les modos

    PS : je signal d'ailleurs que lorsque l'amplification est à sont minimum, et que je colle une enceinte au microelectret et que je fait la FFT j'obtient ce qui faut car dans ce cas le bruit est très peut amplifier. Mais il me faut amplifier au maximum pour éviter d'avoir cette enceinte de coller à mon micro.

    PS2: à la place du micro j'ai mis un GBF, je retrouve bien en sortie de U1B le signal du GBF inverser et amplifier, qui ne sature pas.
    Dernière modification par kevin8z ; 01/02/2015 à 16h16.

  12. #9
    PIXEL

    Re : Bruit et AOP

    le micro est mal branché....

  13. #10
    kevin8z

    Re : Bruit et AOP

    Citation Envoyé par PIXEL Voir le message
    le micro est mal branché....
    Oui mes même si je relie la masse sur C1 (les 2 bornes du connecteur de gauche reliées ensembles) j'ai quand même du bruit, voir la 2ième photo d'oscilloscope sur mon premier poste.

  14. #11
    PIXEL

    Re : Bruit et AOP

    y sort quelque chose du micro ?

  15. #12
    kevin8z

    Re : Bruit et AOP

    Oui y'a bien quelque chose qui sort du micro.
    Mais pourtant comme je l'ai dis si je relie la masse à la place du micro, je devrais trouver en sortie de U1B 2.5V. Mais non j'ai du bruit amplifié

    D'ailleurs on voit que le bruit aux bornes de C5 (alimentation) a une forme proche du bruit retrouvé en sortie de U1B lorsque je relie la masse en entrée.
    Cela pourrait-il être dérivé de celui-ci?
    Rajouter un gros condo de filtrage pourrai amélioré la chose?
    Dernière modification par kevin8z ; 01/02/2015 à 16h33.

  16. Publicité
  17. #13
    Zenertransil

    Re : Bruit et AOP

    Citation Envoyé par kevin8z Voir le message
    Donc je ne comprend pas très bien pourquoi il est mal foutu, j'attend que te fichier soit validé par les modos
    Question d'impédance d'entrée! Quand on est juste, on évite l'ampli inverseur...
    Choisis un travail que tu aimes, et tu n'auras pas à travailler un seul jour de ta vie

  18. #14
    PIXEL

    Re : Bruit et AOP

    où est branchée la référence de la sonde ?

    attention aux fautes de mesures !

  19. #15
    kevin8z

    Re : Bruit et AOP

    Citation Envoyé par Zenertransil Voir le message
    Question d'impédance d'entrée! Quand on est juste, on évite l'ampli inverseur...
    Je ne comprend pas se que tu veut dire.

    Citation Envoyé par PIXEL Voir le message
    où est branchée la référence de la sonde ?
    Elle est relié à la masse, pour voir la variation autour du 2.5V
    L'oscillo est en mode AC pour mieux zoomer sur la composante alternative.

  20. #16
    PIXEL

    Re : Bruit et AOP

    la masse du montage ? au plus court ?

  21. #17
    Kissagogo27

    Re : Bruit et AOP

    Bonsoir, et la photo du montage, c'est possible de l'avoir ?

  22. #18
    kevin8z

    Re : Bruit et AOP

    Je viens de voir le schéma de zenertransil, il rempli exactement la même fonction que le miens avec un AOP en moins... Mais moi je vois comme un problème qui peut mener à une dérive importe, avec ce schéma nous n'aurons pas exactement 2.5V identique sur V+ et V- du à la précision des résistances, si je fait une amplification par 100, je vais avoir cette différence 100 fois plus importe en sortie et donc risque de partir en saturation.
    Avec mon schéma, la tension à l'entrée non inverseuse est exactement la valeur moyenne donné par le pont diviseur, donc pas de dérive en sortie du à une valeur moyenne non identique.

    Citation Envoyé par PIXEL Voir le message
    la masse du montage ? au plus court ?
    L'alim est juste à coté de l'aop et j'ai fait un plan de masse juste au niveau de l'aop, je joint le routage.

    Citation Envoyé par Kissagogo27 Voir le message
    Bonsoir, et la photo du montage, c'est possible de l'avoir ?
    Voila

    routage .png

    Me demandai pourquoi je n'est pas fait un plan de masse sur tout la carte, je ne sais pas... De toute façon je compte refaire une carte.

  23. Publicité
  24. #19
    Biname

    Re : Bruit et AOP

    Hello,

    Alimentation de Labo ? Il y a toujours une ondulation résiduelle.

    Le fusible a une résistance interne (di=100mA sur 0.1 ohms donnent dV=10mV), si la charge est variable, la tension sur C5 est variable aussi.

    Personne n'a dit que la source du bruit est l'alimentation 5V stabilisée par une simple zener, elle alimente directement le micro électret (1ere source de bruit) ensuite l'entrée + de U1A est polarisée par un pont diviseur sur cette alimentation pas très stable (2eme source de bruit), le gain de U1B est de min 10 max 100 amplifie ce bruit.

    Un micro électret n'est jamais alimenté directement par l'alimentation, on place toujours, au moins, une filtre RC dans son l'alimentation.
    https://www.google.be/search?q=micro...w=1417&bih=814

    Cette amplification est mal conçue.

    Biname

  25. #20
    kevin8z

    Re : Bruit et AOP

    La diode zener ne sert pas à stabilisée la tension, elle est juste la pour conduire et griller le fusible si une tension de plus de 5.6V est présente en entrée de la carte.

    Donc pour polarisée l'entrée il faudrait que je mette un condo entre l'entrée + et la masse?
    Pour le micro je vais faire ça mieux, 2 résistances avec un condo entre les 2.

    Je vais refaire un schéma, je le posterai et vous me direz s'il est mieux conçu.

    Si vous avez d'autre idée par rapport à ce bruit, je suis toujours à l'écoute

  26. #21
    kevin8z

    Re : Bruit et AOP

    Enfaite pour ce qui est du bruit le problème est tout trouvé, j'avais mal interprété certaine qu'avais dis Biname. Mais oui vue que sur le 5V il y a du bruit, donc le bruit se report sur l'entrée V+ de U1A et donc ensuite amplifié par U1B.

    En faite il faudrait un filtre RC qui alimenterait tout le montage d'amplification, plus un filtre RC qui alimenterait le micro, dites mois si je me trompe?
    Comme sur le schéma 10b : http://www.sonelec-musique.com/elect...micro_010.html

    Ou enlever le fusible pour ne plus avoir la variation de tension, tout en gardant le filtre RC allant au micro?
    Quand j'y pense bien le fusible ne sert pas à grand chose dans ce que je souhaite faire.... Je le supprimerai à la prochaine version de la carte

    Je viens de regarder dans la doc du fusible utilisé, sa résistance série vaut 0.5ohm, c'est énorme je trouve
    Dernière modification par kevin8z ; 01/02/2015 à 21h58.

  27. #22
    Biname

    Re : Bruit et AOP

    Hello,

    10B
    electronique_preampli_micro_010b.gif
    Oui, le 10B de chez Sonelec semble bon, sauf qu'il est inutile de filtrer l'alimentation de U1A, R8-C3 devraient plutôt être placé juste avant R6 ???

    Le fusible, s'il est placé avant les filtres, ne devrait pas poser e problème, ça se simule/calcule.
    0.5 ohms, faut que ça chauffe pour griller (di=100mA >>> dV=50mV).

    Sinon en voici quelques uns
    https://www.google.be/search?q=ampli...h=798#imgdii=_

    Biname
    Dernière modification par Biname ; 02/02/2015 à 17h21.

  28. #23
    kevin8z

    Re : Bruit et AOP

    J'ai réfléchi cette nuit, vue que je dispose de 3.3V sur ma carte, qui elle est continu puisque le fusible est en entrée du régulateur, j'alimente tout mon montage d'amplification en 3.3V. J'aurai donc en sortie au max un signal de 3.3V au lieu de 5V, mais ça me pose pas de problème

  29. #24
    kevin8z

    Re : Bruit et AOP

    D'ailleurs une question, C1 et R2 forme bien un filtre passe haut, de fc = 1/(2*pi*R2*C1)?

  30. Publicité

Sur le même thème :

Discussions similaires

  1. Estimer la variance du bruit d'une image scintigraphique corrompue par un bruit poissonnien
    Par faat dans le forum Programmation et langages, Algorithmique
    Réponses: 0
    Dernier message: 30/09/2013, 16h59
  2. TIPE anti-bruit (réducteur de bruit actif)
    Par Tcharly94 dans le forum Physique
    Réponses: 3
    Dernier message: 30/05/2013, 08h20
  3. Réponses: 0
    Dernier message: 12/12/2012, 16h14
  4. Réponses: 7
    Dernier message: 24/09/2010, 20h50