Répondre à la discussion
Affichage des résultats 1 à 22 sur 22

besoin d'aide pour fonction électronique.



  1. #1
    eloman_75017

    besoin d'aide pour fonction électronique.

    Bonjour,
    je vous explique mon problème.
    Je cherche à faire un amplificateur. En entrée de celui-ci une exponentielle entre 0 et 5V, une tension de 150V et en sortie de cet ampli je veux récupérer une exponentielle entre 0 et 150V.
    J'ai pensé à un montage de transistor à base commune... Est-ce une bonne idée ? Si oui, je ne sais pas comment calculer les valeurs des composants...

    Merci d'avance pour votre aide .

    Cordialement.
    GuYoM.

    -----


  2. Publicité
  3. #2
    invite14532198711
    Invité

    Re : besoin d'aide pour fonction électronique.

    Salut,
    le montage base commune est un systeme à faible impédance d'entrée, donc tout dépend de la source du signal.
    Je te conseillerais plus un AOP suivi d'un transistor. Au moins la fidelité de la sortie est garantie, et cela necessite peut de composants externes avec un resultat garanti.

  4. #3
    invite14532198711
    Invité

    Re : besoin d'aide pour fonction électronique.

    Voila un semblant de schéma qui pourrait marcher (avec d'autre transistor du moins!).
    A oui j'ai oublié de mettre la (les masses) commune au 160 et 12V, tu relies tout ça à la 11 du 324.
    Images attachées Images attachées

  5. #4
    eloman_75017

    Re : besoin d'aide pour fonction électronique.

    Merci beaucoup pour votre aide.
    Je suis nouveau sur ce forum, les piéces jointes mettent combien de temps à être validées ?
    Je vais attendre de voir ton montage mais cet AOP ne pourra être alimenté qu'en 0-5V... Cela pose-t-il problème ?

  6. #5
    invite14532198711
    Invité

    Re : besoin d'aide pour fonction électronique.

    Pas de probleme, le 324 peut travailler dans sa plage totale d'alimentation. c'est toujours plus confortable d'avoir un peu de marge. En sortie la tension n'exedera jamais 1V.

  7. A voir en vidéo sur Futura
  8. #6
    gebog75

    Re : besoin d'aide pour fonction électronique.

    Bonsoir Alex et eloman..

    Citation Envoyé par alex.com
    Voila un semblant de schéma qui pourrait marcher (avec d'autre transistor du moins!).
    A oui j'ai oublié de mettre la (les masses) commune au 160 et 12V, tu relies tout ça à la 11 du 324.
    Je me permets d'intervenir sur ce post car il y a risque de casse : le BC557 comme le BC547 ont des VCE max de 45V.
    Avec une tension d'entrée de 160V, et une commande initiale du montage à 0V, les transistors ont toutes les chances de mourir en surtension.
    @+

  9. Publicité
  10. #7
    eloman_75017

    Re : besoin d'aide pour fonction électronique.

    Aurais-tu quelques explications au sujet de ton schéma ? Est-ce un schéma connu parce que je n'arrive pas comprendre comment il fonctionne vraiment... A quoi sert l'AOP exactement ? Pourquoi la sortie (ou) est-elle rebouclé sur l'entrée de l'ampli ? Comment calcules-tu les valeurs des résistances ?
    Merci.
    Dernière modification par eloman_75017 ; 19/06/2006 à 14h33.

  11. #8
    Pr Shadoko

    Re : besoin d'aide pour fonction électronique.

    bonjour,
    va voir ici tu as plein d'eplications sur les ampli-op.

    http://etronics.free.fr/index2.htm

    bon courage
    Quand il n'y a pas de solution, c'est qu'il n'y a pas de problème !

  12. #9
    eloman_75017

    Re : besoin d'aide pour fonction électronique.

    Citation Envoyé par Pr Shadoko
    bonjour,
    va voir ici tu as plein d'eplications sur les ampli-op.

    http://etronics.free.fr/index2.htm

    bon courage
    Ben en fait, le probléme ce n'est pas tant l'ampli OP en lui même, je connais bien le fonctionnent de ces p'tites bêtes mais là j'ai du mal à cause des 2 transistors qui jouent un rôle dans la boucle de retour...Voilà, voilà.
    Merci.

  13. #10
    eloman_75017

    Re : besoin d'aide pour fonction électronique.

    J'ai essayé de simuler ce schéma sous une version de demo de orcad et cela ne donne pas les résultats escomptés... En mettant une tension sinusoïdale en entrée la sortie reste à 160V... Est-ce moi ou le schéma ne convient pas ?
    Merci.

  14. #11
    eloman_75017

    Re : besoin d'aide pour fonction électronique.

    up !!
    Ce montage a-t-il un nom particulier ? Je n'arrive pas à le simuler correctement sous une demo d'orcad...

  15. #12
    eloman_75017

    Re : besoin d'aide pour fonction électronique.

    Comment sont calculées les valeurs des composants ? Pouvez-vous m'aider ?

  16. Publicité
  17. #13
    invite14532198711
    Invité

    Re : besoin d'aide pour fonction électronique.

    Citation Envoyé par gebog75
    Bonsoir Alex et eloman..



    Je me permets d'intervenir sur ce post car il y a risque de casse : le BC557 comme le BC547 ont des VCE max de 45V.
    Avec une tension d'entrée de 160V, et une commande initiale du montage à 0V, les transistors ont toutes les chances de mourir en surtension.
    @+
    Bonsoir,
    merci de préciser que le 557 ne tient que 45V, je l'ai précisé dans le post 2 qu'il fallait d'autre transistors pour que sa marche. J'ai pris un 547 et un 557 dans la bibliotheque pour avoir le dessin d'un PNP et NPN. Evidement que vu les tensions sa va pas aller. Notre amis saura bien trouver un bestiaud NPN qui tient les 200V, j'ai pas de reference en tete en ce moment et sa dépendra du courant qu'il veut tirer pour le Ic max et Ptot max.

  18. #14
    invite14532198711
    Invité

    Re : besoin d'aide pour fonction électronique.

    Salut,
    tu as fais la simul avec quel transistor? Il faut qu'il tiennent les 160V minimum tout les 2.
    L'ampli recevant une tension positive à l'instant T, fait passer sa sortie à un niveau plus élevé jusqu'à atteindre sa tension d'entrée + sur son entrée inverseuse. de ce fait, il fait conduire Q1 qui controle la tension de collecteur de Q2. Cette tension est renvoyé sur l'AOP via un diviseur (il ne peut pas recevoir 160V) dimensionné au format de tes signaux. A supposer que tu ai une sinus se baladant entre 0 et 2V, l'AOP va s'arranger pour agir sur sa sortie jusqu'a ce qu'il ai la meme chose sur son entré inverseuse, donc si tu veux 160V, le facteur du diviseur doit etre de 80, ainsi sur ton collecteur quand tu as 160V, tu as 2V sur ton entrée -, comme sur l'entrée +.
    si par hazard tu as 3V sur l'entrée - alors qu'il y a 2V sur l'entrée +, il y désequilibre, donc il va moins faire conduire Q1 donc Q2 se qui fera baisser la valeur de la tension utile (160V) qui etait pour le coup à 3 x 80 = 240V (si la tension en emmeteur de Q2 permet de monter jusque là). C'est une régulation toute simple, contre réaction par le diviseur R4/R3.
    Pour la simulation essais de mettre une charge sur le collecteur de Q2 genre une resistance de 10K.
    C'est imparable et basique comme montage, sa doit marcher.

  19. #15
    eloman_75017

    Re : besoin d'aide pour fonction électronique.

    ben c'est bizarre en fait, parce que maintenant j'arrive à simuler correctement le montage en prenant des transistors 2n3904 et 2n3906 et dans leur doc il est préciserque le VCE0max est de 40V... Le simulateur ne me dit rien... Est-ce normal ? Le problème avec cette version de demo de orcad, c'est qu'il n'y a pas beaucoup de référence de composant...
    Lorsque je simule avec un signal sinusoidal en entrée, tout va bien. Mais lorsque je mets un signal de forme exponentielle cela ne va plus...

  20. #16
    eloman_75017

    Re : besoin d'aide pour fonction électronique.

    oulà, je viens de remarquer quelque chose de bizarre, j'ai simulé ton schéma en inversant l'emetteur et le collecteur de Q2 et cela marche mieux que quand je fais exactement comme ton schéma, est-ce normal ou bien as-tu inversé l'emetteur et le collecteur ?

  21. #17
    eloman_75017

    Re : besoin d'aide pour fonction électronique.

    Voilà, les 2 simulations que j'ai faite !
    le première avec Q2 comme sur ton schéma et la 2eme avec le collecteur et l'emetteur de Q2 inversés entre eux.
    C'est étrange, non ?
    Images attachées Images attachées

  22. #18
    invite14532198711
    Invité

    Re : besoin d'aide pour fonction électronique.

    Salut,
    alors sa oui c'est bizare, je ne pense pas m'etre planté dans un montage aussi simple et avec si peu de composants. Comment peut-il simuler un courant qui viendrait de la sortie? Q2 est en émetteur commun, la sortie 160V ne peu débiter aucun courant de base, seule un courant venant de la source peu circuler. Coté Vce il y a soucis effectivement. Si tu ne compte pas tirer beaucoup de jus (quelques mA) essais de mettre une source de tension de 200V en entrée, et regarde la sortie. Ou essais directement sur labdec avec oscillo, ou change de simulateur.

    As tu bien placé les masses? et la résistance de charge entre le collecteur de Q2 et la masse?

  23. Publicité
  24. #19
    eloman_75017

    Re : besoin d'aide pour fonction électronique.

    En effet c'est ça !! Je n'avais pas mis de résistance de charge entre le collecteur de Q2 et la masse ! Mais le problème qui se pose maintenant, c'est que si je mets plus de 1kOhms en résistance de charge, la sinusoïde est déformé...

  25. #20
    eloman_75017

    Re : besoin d'aide pour fonction électronique.

    Je viens de simuler ton montage pour voir sa réponse en fréquence selon la charge que je lui applique et cela varie beaucoup...
    La charge varie de 1k à 10kOhms par pas de 2k...
    Images attachées Images attachées

  26. #21
    eloman_75017

    Re : besoin d'aide pour fonction électronique.

    N'existerait-il pas des composants complétement integré qui pourrait réaliser cette fonction que je souhaite faire ?

  27. #22
    invite14532198711
    Invité

    Re : besoin d'aide pour fonction électronique.

    Salut,
    ton simulateur tient pas compte des Vce de transistors, ni des puissances dissipée dans les charges, de plus je ne voit pas comment il trouve un pic à certaines fréquence alors qu'il n'y a ni condos ni bobines. Ni d'ailleur comment le montage pourrais marcher en inversant C et E de Q2. Je doute de la fiabilité de ce simulateur. Un montage comme ça, c'est obligé que sa marche, je fais des montages bien plus complexes et je me trompe rarement, surtout si c'est pour filer un tuyaux sur le forum, j'aurais l'air con!
    Pour ce qui est d'un montage intégré, je ne connais rien de tel. Imagine si il existait un boititer pour chaque fonction possible en éléctronique, ça représenterais des milliards de milliards de possibilités, et de tels boitiers seraient constituées de résistances, transistors, AOP, condos...! Désolé, il faudra te contenter de ce que je t'ai proposé, je ne vois pas comment faire avec d'autre chose pour atteindre le résultat escompté. Fait un essais tu risques rien avec un montage comme ça (à part un coup de jus si tu mets tes mains sur l'émetteur de Q2)
    Dernière modification par invite14532198711 ; 13/07/2006 à 17h42.

Sur le même thème :

Discussions similaires

  1. besoin d'aide pour fonction
    Par lissa69 dans le forum Mathématiques du collège et du lycée
    Réponses: 16
    Dernier message: 22/03/2007, 20h02
  2. Réponses: 11
    Dernier message: 07/02/2007, 14h40
  3. SVP besoin d'aide pour tracer une fonction 2D en Tecplot
    Par phy4me dans le forum Logiciel - Software - Open Source
    Réponses: 0
    Dernier message: 01/11/2006, 11h43
  4. besoin d'aide en électronique
    Par jef83400 dans le forum Électronique
    Réponses: 7
    Dernier message: 16/10/2006, 17h29
  5. Réponses: 7
    Dernier message: 07/01/2006, 10h14