Répondre à la discussion
Affichage des résultats 1 à 14 sur 14

Carte SD en SPI avec un Pic, problèmes de signaux en pique



  1. #1
    Saiqui

    Carte SD en SPI avec un Pic, problèmes de signaux en pique

    Bonjour,
    pour un projet je veux enregistrer des données sur une carte microSD de 2 GB en Fat32 grâce à un pic18F26K22.
    Pour le montage j'ai mis des ponts diviseurs pour abaisser la tension à ~ 3V (au lieu des 5V du µC) et j'alimente la carte sd avec un régulateur 3.3V.

    J'ai suivit un projet GitHub à la lettre cependant il ne fonctionne pas. J'ai odnc regardé les signaux à l'oscilloscope et j'ai remarqué que tous mes signaux étaient en piques (photos jointes).
    Mon programme à aussi fonctionner à un instant T alors que je n'avais rien changé et pour le coup je ne comprends pas le pourquoi du comment.
    Si jamais vous avez des pistes que je devrais suivre pour trouver la solution à mon problème je suis preneur

    Merci

    lien github : https://github.com/mondul/fatfs_pic18

    IMG_20190611_115157.jpg
    IMG_20190611_115002.jpg

    -----


  2. Publicité
  3. #2
    Blue Sn4ke

    Re : Carte SD en SPI avec un Pic, problèmes de signaux en pique

    Bonjour,
    Concernant les pics, il semblerait que ce ne soit qu'une erreur de mesure et qu'ils n'existent pas en réalité : on dirait que tu as zoomé sur la trace après l'avoir capturée et que par conséquent, la fréquence d'échantillonnage de l'oscillo au moment de la capture n'est pas du tout adaptée aux signaux que tu veux visualiser.

  4. #3
    Saiqui

    Re : Carte SD en SPI avec un Pic, problèmes de signaux en pique

    Je pensais aussi à une erreur de mesure au début, mais la trame est irrégulière et si je mesure en diminuant la base temps j'ai toujours des pics.
    J'ai fais un calcul par rapport à ça (sauf erreur de ma part) qui donne :
    2 GS/s soit 2.10⁹ échantillons par seconde, on a 2.10⁶ échantillons par ms ce qui devrait être suffisant pour un signal qui a une période de 0,0005 ms (2MHz)

  5. #4
    Saiqui

    Re : Carte SD en SPI avec un Pic, problèmes de signaux en pique

    UPDATE :
    j'avais tord le signal est bien carré si je zoom avant le run/stop.
    Il faut que je trouve d'ou peut venir le problème de non fonctionnement de ma carte.
    merci !

  6. #5
    jiherve

    Re : Carte SD en SPI avec un Pic, problèmes de signaux en pique

    bonsoir,
    des ponts diviseurs sur les signaux c'est possible mais par curiosité quelles sont les valeurs utilisées?
    JR
    l'électronique c'est pas du vaudou!

  7. A voir en vidéo sur Futura
  8. #6
    Saiqui

    Re : Carte SD en SPI avec un Pic, problèmes de signaux en pique

    Bonjour,
    les deux valeurs de résistances sont 2.2k et 3.3k pour avoir un signal de sortie de 3V

  9. Publicité
  10. #7
    jiherve

    Re : Carte SD en SPI avec un Pic, problèmes de signaux en pique

    bonsoir,
    donc voilà sans doute une origine possible du probleme, il faut charger en limite de sortance des signaux!
    JR
    l'électronique c'est pas du vaudou!

  11. #8
    Saiqui

    Re : Carte SD en SPI avec un Pic, problèmes de signaux en pique

    Bonsoir,
    J'ai utilisé le montage utilisé dans ce tutoriel : https://www.studentcompanion.net/fr/...oleur-pic-xc8/
    je n'es aucune autre idée de montage sinon...

  12. #9
    antek

    Re : Carte SD en SPI avec un Pic, problèmes de signaux en pique

    C'est câblé sur une planche à pain ?
    Le Diable a inventé l'Administration afin que les Hommes perdent tout espoir à jamais.

  13. #10
    Saiqui

    Re : Carte SD en SPI avec un Pic, problèmes de signaux en pique

    Oui c'est ca

  14. #11
    antek

    Re : Carte SD en SPI avec un Pic, problèmes de signaux en pique

    Citation Envoyé par Saiqui Voir le message
    Oui c'est ca
    Alors c'est peut-être ça aussi . . .
    Essaie de visualiser les signaux avec une charge résistive, en enlevant les fils.
    Le Diable a inventé l'Administration afin que les Hommes perdent tout espoir à jamais.

  15. #12
    jiherve

    Re : Carte SD en SPI avec un Pic, problèmes de signaux en pique

    bonsoir
    le soucis c'est que ce sont des signaux assez rapides et l’impédance du pont sera peut être trop grande et les fronts un peu ramollis. Il faudrait baisser tout çà vers 390/620 ce qui correspond au max supportable par le PIC.
    JR
    l'électronique c'est pas du vaudou!

  16. Publicité
  17. #13
    Saiqui

    Re : Carte SD en SPI avec un Pic, problèmes de signaux en pique

    antek, au final ke vois très bien les signaux au scope et les séquences ont l'air d'être bien mais il ne me permet pas de tous recupérer

    JR, je n'es pas ces valeurs la je vais essayer en les diminuants

  18. #14
    Saiqui

    Re : Carte SD en SPI avec un Pic, problèmes de signaux en pique

    Bonjour,
    j'ai changé de système j'utilise un 74HC4050 pour avoir une tension de 3.3V où il faut cependant impossible de faire fonctionner les microSD (j'en ai un lot donc ce n'es pas de la le problème) donc je pense peut etre à un mauvais formatage? j'ai l'air d'avoir les bons signaux en SPI...

Sur le même thème :

Discussions similaires

  1. Insecte minuscule qui pique, avec photos
    Par tia547 dans le forum Identification des espèces animales ou végétales
    Réponses: 9
    Dernier message: 31/10/2018, 18h12
  2. Insecte minuscule qui pique, avec photos
    Par Namnam2 dans le forum Identification des espèces animales ou végétales
    Réponses: 1
    Dernier message: 27/10/2018, 20h50
  3. Insecte bizarre, avec une pique rouge à l'arrière
    Par dilanz dans le forum Identification des espèces animales ou végétales
    Réponses: 3
    Dernier message: 31/05/2012, 09h34
  4. Problèmes avec carte ZL180 Came pour portails battants ! [résolu]
    Par philou4985 dans le forum Bricolage et décoration
    Réponses: 2
    Dernier message: 21/11/2011, 17h21
  5. Problemes 16 Couleurs Avec Carte Mere Optiplex G1 350l+
    Par mecano1 dans le forum Logiciel - Software - Open Source
    Réponses: 0
    Dernier message: 01/04/2007, 11h03