Répondre à la discussion
Page 1 sur 2 1 DernièreDernière
Affichage des résultats 1 à 30 sur 60

Problème d'amplificateur qui démodule la HF



  1. #1
    MatthieuW31

    Problème d'amplificateur qui démodule la HF


    ------

    Bonjour à tous,

    Je vous écris car je rencontre depuis plusieurs jours au travail un problème sur mon montage (application audio). Comme c'est dans un cadre professionnel je ne peux pas donner le schéma complet mais je vais donner les infos de la fonction qui fait défaut.

    Le problème: lors des essais CEM, nous avons été perturbés par des interférences injectées sur le rack en question. Nous avons pu reproduire une de ces interférences en labo afin d'investiguer dessus: nous émettons sur une antenne un signal de 1kHz sur une porteuse à 160MHz (modulation en fréquence). Ce signal se mêle à notre signal utile provenant d'un micro et atteint un AOP (montage en amplificateur non inverseur passe-bande). Le problème est que l'AOP démodule ce signal parasite au lieu de le filtrer. Au final, en plus du signal utile, on retrouve également en sortie le signal parasite à 1kHz.

    Voici le schéma:


    Les valeurs des composants ne sont pas écrites car je n'ai pas le schéma devant les yeux mais la configuration est la suivante:
    AOP utilisé: LM358 (qui dispose d'un RF filter, je me pensais à l'abri).
    - U1-1: adaptation du 12V en 6V afin de fournir un offset à l'étage suivant
    - U1-2: amplification de gain 1/2 + passe bande entre 40Hz et 4kHz

    J'ai essayé de filtrer en amont du montage avec des filtres RC et LC (fc vers 10kHz, plusieurs configurations essayées au niveau des composants + filtrage par rapport à la masse électronique et masse mécanique) mais soit aucun effet, soit le signal parasite ainsi que le signal utile étaient atténués en gardant le même rapport signal/bruit.
    J'ai également mis une capacité entre les entrées inverseuse et non-inverseuse de l'AOP U1-2 afin de ne pas amplifier la HF mais ça n'a rien donné non plus.
    Enfin j'ai testé avec 2 autres AOP (modèles différents) que j'avais sous la main.

    Auriez-vous une idée pour me débarrasser de ce signal HF en amont de l'AOP? Sinon connaissez-vous des AOP qui ne démodulent pas la HF mais la bloquent?

    -----

  2. Publicité
  3. #2
    penthode

    Re : Problème d'amplificateur qui démodule la HF

    phénomène assez courant
    les AOP démodulent la porteuse par non linéarité

    reste à savoir su c'est gênant ou pas selon les conditions d'utilisation

    un dessin convenable du PCB, des entrées filtrées et un coffret bien blindé règlent le problème.
    Dernière modification par penthode ; 05/01/2022 à 21h42.
    le vent se lève, il est temps de vivre

  4. #3
    penthode

    Re : Problème d'amplificateur qui démodule la HF

    je ne vois pas l'intérêt de U1 ,
    qui ne fait qu'ajouter une non-linéarité

    d'autant que rien ne le filtre en HF
    Dernière modification par penthode ; 05/01/2022 à 21h50.
    le vent se lève, il est temps de vivre

  5. #4
    MatthieuW31

    Re : Problème d'amplificateur qui démodule la HF

    Merci Penthode pour ces réponses.
    Concernant le blindage du rack ainsi que le routage du PCB, nous sommes assez confiants.

    En revanche, nous n'arrivons effectivement pas à filtrer efficacement la HF passant par ce signal malgré plusieurs tentatives d'associations (bobines, condensateurs et ferrites).

    Concernant la non-linéarité apportée par le suiveur, je peux faire un essai demain sans cette partie mais je doute que ça change grand chose.

  6. A voir en vidéo sur Futura
  7. #5
    penthode

    Re : Problème d'amplificateur qui démodule la HF

    d'autre part ....

    d'où vient ce signal BF

    quel est son niveau ?

    longueur de la ligne ?

    quid de l’équipotentielle de cette liaison ?

    c'est bien gentil le confidentiel défonce mais sur quoi s'appuyer pour donner des avis censés ?
    Dernière modification par penthode ; 05/01/2022 à 22h06.
    le vent se lève, il est temps de vivre

  8. #6
    Vincent PETIT
    Animateur Électronique

    Re : Problème d'amplificateur qui démodule la HF

    Bonjour,
    Citation Envoyé par MatthieuW31 Voir le message
    Le problème: lors des essais CEM
    Le quel a échouer ?

    Citation Envoyé par MatthieuW31 Voir le message
    Auriez-vous une idée pour me débarrasser de ce signal HF en amont de l'AOP? Sinon connaissez-vous des AOP qui ne démodulent pas la HF mais la bloquent?
    C'est quoi comme liaison entre le micro et C1 ? C'est une piste sur le PCB ? Un câblage filaire ? Si oui il faudrait aussi voir la photo.
    Là où il n'y a pas de solution, il n'y a pas de problème.

  9. Publicité
  10. #7
    MatthieuW31

    Re : Problème d'amplificateur qui démodule la HF

    Je me suis rendu compte d'une erreur dans le schéma que j'ai posté : pour l'AOP U1-2 j'ai inversé le + et le -.

  11. #8
    penthode

    Re : Problème d'amplificateur qui démodule la HF

    les lecteurs ont corrigé d'eux même...

    et les autres questions ?
    le vent se lève, il est temps de vivre

  12. #9
    Gwinver

    Re : Problème d'amplificateur qui démodule la HF

    Bonsoir.

    Une signal interféreur trouve toujours des chemins surprenants.
    Avez-vous bien découplé les alimentations?

    Certains composants, comme les condensateurs ne se comportent pas forcément comme prévu à 160 MHz. Les condensateurs de découplage et les ferrites doivent être adaptés à ces fréquences.
    Il faut aussi penser au routage. Un condensateur de découplage doit se situer au plus près possible du blindage de l'ensemble, de sorte que le courant ne "boucle" pas à l'intérieur du montage.

    Attention lors de ce genre de manip, il faut arriver à se mettre dans les conditions du test, et ne pas monter une manip plus exigeante que le test, voir le message de Vincent Petit.

  13. #10
    f6bes

    Re : Problème d'amplificateur qui démodule la HF

    Citation Envoyé par MatthieuW31 Voir le message
    En revanche, nous n'arrivons effectivement pas à filtrer efficacement la HF passant par ce signal malgré plusieurs tentatives d'associations (bobines, condensateurs et ferrites).

    .
    Bjr à toi,
    On ne sait rien de cette "HF" (s(a fréquence en particulier) ?
    Ni quelles "bobines", "condensateurs"... ont été utilisés ?

    Une photo du montage serait tout de meme un plus...pour VOIR comment cela a été conçu et cablé.
    Sans savoir le MINIMUM...difficile de porter un diagnostic.
    A+
    Vide pour l'instant

  14. #11
    penthode

    Re : Problème d'amplificateur qui démodule la HF

    c'est secret défense !

    une telle technologie de pointe , ça se comprend !
    le vent se lève, il est temps de vivre

  15. #12
    MatthieuW31

    Re : Problème d'amplificateur qui démodule la HF

    une telle technologie de pointe , ça se comprend !
    Effectivement, je pense que le problème vient de là!!

    Désolé pour le silence, je n'ai pas eu le temps de répondre plus tôt car on a fait pas mal de nouveaux tests!
    Au final, l'ajout de capacités de découplages supplémentaires aux bons endroits (dont certaines côté microphone entre +/GND et -/GND) améliorent la qualité sonore (signal/perturbation).

    Je n'ai pas encore testé la suppression de l'AOP U1.1 mais je garde ce test en tête pour voir si je peux empêcher la démodulation par l'AOP.

    Merci à tous pour vos suggestions!

  16. Publicité
  17. #13
    jiherve

    Re : Problème d'amplificateur qui démodule la HF

    bonjour
    un petit condensateur(qqs pF mais de bonne qualité) entre les entrées des AOP.
    JR
    l'électronique c'est pas du vaudou!

  18. #14
    penthode

    Re : Problème d'amplificateur qui démodule la HF

    un mikro....! ça s'éclaircit ...

    quel genre ?
    quelle liaison ?
    le vent se lève, il est temps de vivre

  19. #15
    Vincent PETIT
    Animateur Électronique

    Re : Problème d'amplificateur qui démodule la HF

    Citation Envoyé par MatthieuW31 Voir le message
    l'ajout de capacités de découplages supplémentaires aux bons endroits (dont certaines côté microphone entre +/GND et -/GND) améliorent la qualité sonore (signal/perturbation).
    En effet ça s'éclaircie, ce sont des courants de mode commun qui mettent le bazar. Ca pourrait être une boucle de masse dans une liaison filaire entre deux éléments
    Là où il n'y a pas de solution, il n'y a pas de problème.

  20. #16
    penthode

    Re : Problème d'amplificateur qui démodule la HF

    Je subodore une liaison asymétrique
    le vent se lève, il est temps de vivre

  21. #17
    penthode

    Re : Problème d'amplificateur qui démodule la HF

    en ces temps où tout passe par des bits

    on oublie les fondamentaux

    à propos de piqure de rappel , en voici une autre

    http://voyard.free.fr/textes_audio/s...m/sym_asym.htm
    Dernière modification par penthode ; 07/01/2022 à 08h22.
    le vent se lève, il est temps de vivre

  22. #18
    Patrick_91

    Re : Problème d'amplificateur qui démodule la HF

    Bonjour,
    Pour que le signal 1kHz soit audible à la sortie du montage (a cause de non linéarités décrites plus haut dans ce fil), il faut que l'indice de modulation FM
    ou que l’excusions de phase soit importants.
    Vous devriez essayer de couper la modulation et de vérifier le point de polarisation a la sortie du montage des l'application de la RF , la tension de sortie doit être modifiée certainement dès sa présence.
    Les pistes d'alimentation (masse et Vcc) font souvent office de collecteur, les filtres a Fréquence de coupure trop basses ne fonctionnent en général pas bien car leurs composants (en fonction des valeurs) ne se comportent pas toujours bien a 160 MHz. Le choix des composants est important (capa résiduelle pour les selfs et inductance pour les capas). Même chose pour les entrées + et - du dernier ampli-op .
    Bref , a se demander si un blindage en taule d'acier ne serait pas nécessaire (condensateur bypass pour l'alim, l'entrée du montage et la sortie).
    A plus
    C'est l'étincelle qui a fait déborder le vase !

  23. Publicité
  24. #19
    MatthieuW31

    Re : Problème d'amplificateur qui démodule la HF

    Bonjour et merci pour ces réponses.

    un petit condensateur(qqs pF mais de bonne qualité) entre les entrées des AOP.
    J'ai déjà mis un condensateur entre ces 2 broches hier, mais je crois que c'était plutôt de l'ordre du nF. Je vais refaire l'expérience avec des capas d'environ 10pF. Un MLCC ferait l'affaire je pense?

    un mikro....! ça s'éclaircit ...

    quel genre ?
    quelle liaison ?
    Effectivement, mais je ne sais pas trop comment m'y prendre. J'ai fait un filtre au plus proche du micro:
    - 2 capas 150nF entre micro+ et GND micro et entre micro- et GND micro
    - 2 capas 100pF entre micro+ et GND micro et entre micro- et GND micro

    Ca pourrait être une boucle de masse dans une liaison filaire entre deux éléments
    Oui je pense aussi, d'où les filtrages des 2 côtés du câble mais je ne suis pas sûr de la marche à suivre. Pour info, côté micro on a le filtre cité précédemment et côté carte on a 2 capas de 470pF entre micro+ et GND micro et entre micro- et GND micro.

  25. #20
    MatthieuW31

    Re : Problème d'amplificateur qui démodule la HF

    Penthode et Patrick_91, nos messages se sont croisés.
    Merci pour ces nouvelles précisions, je vais regarder tout ça également.

  26. #21
    penthode

    Re : Problème d'amplificateur qui démodule la HF

    quelle est la longueur du fil du micro ?

    marque et modéle ?

    c'est dur d'avoir des précisions !
    Dernière modification par penthode ; 07/01/2022 à 08h39.
    le vent se lève, il est temps de vivre

  27. #22
    MatthieuW31

    Re : Problème d'amplificateur qui démodule la HF

    quelle est la longueur du fil du micro ?

    marque et modéle ?

    c'est dur d'avoir des précisions
    Désolé, j'allais justement ajouter un post car j'ai oublié de le mentionner! (cette info n'est pas top secrète!! )

    Il s'agit du ECM-10/SW de chez MONACOR.
    Les câbles entre le micro et le rack font environ 10m.

  28. #23
    penthode

    Re : Problème d'amplificateur qui démodule la HF

    c'est donc un micro basse impédance ( 600 Ω) à sortie symétrique ( XLR )

    le relier à une entré haute impédance par une ligne asymétrique est l'exemple de ce qu'il ne faut pas faire
    sauf si tu veux inventer la radio , mais c'est déjà fait !

    il faut tirer une ligne symétrique : cordon blindé à DEUX FILS
    et désymétriser avant l'aop.

    le plus simple : le transfo idoine

    https://www.toutlehautparleur.com/ca...r-ltr-110.html

    lis mon lien #17, tout y est
    Dernière modification par penthode ; 07/01/2022 à 09h03.
    le vent se lève, il est temps de vivre

  29. #24
    MatthieuW31

    Re : Problème d'amplificateur qui démodule la HF

    Je vais encore me faire gronder car je n'en ai pas parlé avant (), mais j'ai effectivement un transfo audio (Bourns SM-LP-5001) en entrée de la carte, avant l'AOP.

    J'ai testé l'ajout d'une capa MLCC de 22pF entre les 2 entrées de l'AOP mais ce dernier démodule toujours.

  30. Publicité
  31. #25
    penthode

    Re : Problème d'amplificateur qui démodule la HF

    ras le bol !

    les animateurs ont des jobs , familles , loisirs , etc....

    alors les demandeurs constipés du clavier qui nous font perdre du temps : démerdez vous !
    le vent se lève, il est temps de vivre

  32. #26
    Vincent PETIT
    Animateur Électronique

    Re : Problème d'amplificateur qui démodule la HF

    En plus des conseils de Gwinver, Patrick, JR et Penthode, si c'est 10m de fils ramassent du courant mode commun (qui va essayer de se sauver à la masse) il faudrait voir une photo car les capa de dérivation ne sont peut être pas à placer n'importe où.

    Il faut que tu donnes vraiment toutes les informations sinon le risque de tourner en rond est fort.
    Dernière modification par Vincent PETIT ; 07/01/2022 à 09h33.
    Là où il n'y a pas de solution, il n'y a pas de problème.

  33. #27
    f6bes

    Re : Problème d'amplificateur qui démodule la HF

    C'est dur de se faire comprendre !!
    Ce serait si simple...mais
    Bonne journée
    Vide pour l'instant

  34. #28
    MatthieuW31

    Re : Problème d'amplificateur qui démodule la HF

    Désolé pour le manque d'informations. Je me suis focalisé sur les 2 problèmes suivants:
    - filtrage inefficace en entrée du rack par les 2 capas de 170nF
    - démodulation faite par l'AOP

    D'où l'omission du transformateur audio.


    Bon cette fois, je donne (j'espère) plus de détails. Voici le schéma de l'installation du micro jusqu'à l'étage AOP (non représenté car sur une autre page). L'étage AOP correspond à celui que j'ai dessiné dans mon 1er post.


  35. #29
    f6bes

    Re : Problème d'amplificateur qui démodule la HF

    Remoi, Les découplages ( condo ) c'est pas au bornes du micro qu'il vaut mieux les prévoir, MAIS aux bornes
    de l'élément sensible (AOP). De meme des SELFS d'arrét en série (juste à l'entrée de l'AOP), seraient peut etre
    bénéfique (encore faudrait avoir une idée de la fréquence à éliminer ).
    Et une PHOTO de ce beau montage....c'est...possible ??
    Bonne soirée
    Vide pour l'instant

  36. #30
    MatthieuW31

    Re : Problème d'amplificateur qui démodule la HF

    L'alimentation de l'AOP est équipée de capas de découplages. J'avais ajouté des selfs et filtres LC entre les câbles micro et le connecteur de la carte mais ça n'avait rien donné.
    Après, peut-être qu'effectivement je peux tenter de mettre des selfs à l'entrée de l'AOP ou à l'entrée de la carte, cette fois sur le PCB.
    Concernant les fréquences à éliminer, on était perturbé sur plusieurs bandes de fréquences allant de 150MHz à 800MHz.

Page 1 sur 2 1 DernièreDernière

Discussions similaires

  1. Problème amplificateur
    Par Kais-94 dans le forum Électronique
    Réponses: 7
    Dernier message: 04/04/2015, 15h41
  2. Réponses: 3
    Dernier message: 16/04/2012, 20h09
  3. Problème amplificateur
    Par Pilou81 dans le forum Électronique
    Réponses: 4
    Dernier message: 01/06/2010, 13h55
  4. probleme amplificateur
    Par titicom dans le forum Dépannage
    Réponses: 12
    Dernier message: 07/08/2006, 07h27
  5. Problème Amplificateur
    Par Trando dans le forum Dépannage
    Réponses: 0
    Dernier message: 13/06/2005, 15h59
Découvrez nos comparatifs produits sur l'informatique et les technologies.