Répondre à la discussion
Affichage des résultats 1 à 14 sur 14

[Excel]Moyenne par partie



  1. #1
    ABN84

    [Excel]Moyenne par partie


    ------

    Bonjour,
    j'ai une colonne comportant quelques 20 000 valeurs, je cherche à faire les moyennes de chaque 100 valeurs, est ce possible sans les faire à la main une par une?
    merci

    -----
    "Engineering is the art of making what you want from what you get"

  2. Publicité
  3. #2
    ProgVal

    Re : [Excel]Moyenne par partie

    Bonjour,

    Supposons que tu aies les valeurs dans la colonne A et les moyennes dans la colonne B.
    Dans B1, tu demandes à faire la moyenne des champs A1 à A100.
    Ensuite, tu sélectionnes les champs B1 à B100, et tu étires jusqu'à la fin de la colonne.

    Cordialement,
    ProgVal

  4. #3
    ABN84

    Re : [Excel]Moyenne par partie

    Euh non!
    dans B1 t'auras moy(A1:A100)
    B2=moy(A2:A101)
    ect...
    ça n'a aucune signification
    ce que je cherche c'est moy(1:100);moy(101:200)...
    c'est pas aussi simple. Je sais qu'il y avait un truc qui fesait ça dans l'onglet "Données" mais je ne sais plus quoi
    "Engineering is the art of making what you want from what you get"

  5. #4
    lolokiapp

    Re : [Excel]Moyenne par partie

    Si tu étire après avoir sélectionner les 100 première cellules, ça fonctionne. Après la façon automatique je ne la connai pas.

  6. A voir en vidéo sur Futura
  7. #5
    ProgVal

    Re : [Excel]Moyenne par partie

    Citation Envoyé par lolokiapp Voir le message
    Si tu étire après avoir sélectionner les 100 première cellules, ça fonctionne. Après la façon automatique je ne la connai pas.
    C'est ce que j'avais dit de faire

  8. #6
    ABN84

    Re : [Excel]Moyenne par partie

    non ça ne marche pas. vous avez qu'à essayer. tu etire "=moyenne(A1:A100)" tu obtiens "moyenne(A2:A101)"
    "Engineering is the art of making what you want from what you get"

  9. Publicité
  10. #7
    ABN84

    Re : [Excel]Moyenne par partie

    Y a des fonctions faites pour l'etudes de grands nombres de données, mais je ne sais pas ou trouver ça. y a une histoire de classes il me semble
    "Engineering is the art of making what you want from what you get"

  11. #8
    lolokiapp

    Re : [Excel]Moyenne par partie

    Tan pis, pourtant si tu étire "B1:B100" et non pas seulement "B1" ça fonctionne mais c'est pas beau je l'avoue, ça fait une moyenne toutes les 100 cellules. Je l'ai fait sur 40 cellules pour ne pas dire de bétises.

  12. #9
    ABN84

    Re : [Excel]Moyenne par partie

    Ok, mais 20000/100 ça fait 200 valeur qu'il faut encore organiser
    Je vais continuer à chercher Si je retrouve cette satanée fonction je vous informe
    "Engineering is the art of making what you want from what you get"

  13. #10
    ProgVal

    Re : [Excel]Moyenne par partie

    Faire la moyenne des champs A1 à A100 dans B1, puis la moyenne de A101 à A200 dans B2.
    Sélectionner B1 et B2, et étirer

    J'ai toujours été admiratif devant l'intelligence d'Excel pour trouver une logique dans ce qu'on lui donne à étirer

  14. #11
    mécano41

    Re : [Excel]Moyenne par partie

    Bonjour,

    Un exemple, en supposant tes valeurs dans la colonne A à partir de A1 et avec une moyenne à faire toutes les 10 valeurs, cela donne cette formule à mettre par copier / coller en C1 et à étirer vers le bas du nombre de valeurs divisé par le nombre de valeurs par moyenne (dans mon essai, j'avais mis 40 valeurs, il y a donc des moyennes dans les cellules C1 à C4 :

    Code:
    =MOYENNE(INDIRECT("A"&LIGNE($A$1)+(LIGNE(C1)-2+LIGNE(C1)-LIGNE($A$1)+1)*10-(LIGNE($A$1)-2+LIGNE(C1)-LIGNE($A$1)+1)*10 &":A"&LIGNE($A$1)+(LIGNE(C1)-2+LIGNE(C1)-LIGNE($A$1)+1)*10-(LIGNE($A$1)-2+LIGNE(C1)-LIGNE($A$1)+1)*10+9))
    Pour 100 valeurs par moyenne, tu remplaces tous les "10" dans la formule par des "100" et le "9" par "99"

    Si tu le mets ailleurs qu'en C, en B par exemple, tu remplaces tous les "C1" par des "B1" (ce n'est pas indispensable mais c'est plus logique)

    Cordialement

  15. #12
    TiClic

    Re : [Excel]Moyenne par partie

    Très simple. Si tes 20000 valeurs sont dans la première colonne, tu appliques la macro suivante :
    Code:
    Sub Macro1()
      Dim Cellule As String
      Dim Total As Double
      Dim I, J As Integer
      
      
      For J = 0 To 199
        Total = 0
        For I = 1 To 100
          Cellule = "A" & Trim(Str(J * 100 + I))
          Total = Total + ActiveSheet.Range(Cellule).Value
        Next I
        Cellule = "B" & Trim(Str((J + 1) * 100))
        ActiveSheet.Range(Cellule).Value = Total / 100
      Next J
    End Sub
    Toutes les 100 cellules, la moyenne sera calculée dans la 2e colonne.

  16. Publicité
  17. #13
    TiClic

    Re : [Excel]Moyenne par partie

    Cela dit, la solution proposée par progval fonctionne très bien. Dans la cellule B100 tu tapes la formule =MOYENNE(A1:A100)
    Tu fais un copier de la plage B1:B100
    tu sélectionnes ensuite la plage B1:B20000 et tu colles dedans le contenu du presse-papiers. L'avantage de la macro : le jour où tu auras 40000 cellules, tu remplaceras 199 par 399.

  18. #14
    ABN84

    Re : [Excel]Moyenne par partie

    ça marche tres bien merci à tous
    "Engineering is the art of making what you want from what you get"

Discussions similaires

  1. Consommation moyenne d'électricité par foyer
    Par spynel dans le forum TPE / TIPE et autres travaux
    Réponses: 2
    Dernier message: 26/03/2012, 17h10
  2. Macro Excel : Calcul d'une moyenne
    Par lolo66000 dans le forum Logiciel - Software - Open Source
    Réponses: 5
    Dernier message: 19/08/2009, 08h51
  3. integration par partie
    Par clochette34 dans le forum Mathématiques du supérieur
    Réponses: 4
    Dernier message: 13/02/2009, 16h48
  4. Calcul de moyenne sous excel
    Par Igothigh dans le forum Logiciel - Software - Open Source
    Réponses: 3
    Dernier message: 14/06/2006, 10h52
  5. Intégration par partie
    Par somnambulie dans le forum Mathématiques du supérieur
    Réponses: 16
    Dernier message: 15/01/2006, 22h03
Découvrez nos comparatifs produits sur l'informatique et les technologies.