Répondre à la discussion
Affichage des résultats 1 à 2 sur 2

macro-excel: positionner des éléments selon leur valeur



  1. #1
    sansfoiniloi

    macro-excel: positionner des éléments selon leur valeur


    ------

    bonjour,
    je souhaiterais agencer une liste discontinue de nombres situés dans une colonne A de telle sorte que:
    la valeur 1 se retrouve à la ligne 1 de la colonne B,
    la valeur 3 à la ligne 3 de la colonne B,
    la valeur x à la ligne x de la colonne B etc...

    j'ai essayé d'écrire une macro de bonne foie mais celle-ci n'est pas correcte:
    Code:
        For i = 1 To 250
        
        Cells([i], [1]).Select
        Selection.Cut
        
        Cells([i=Value[Cells([i], [1])]], [2]).Select
        ActiveSheet.Paste
        
          Next i
    Ça serait sympa si vous pouviez m'aiguiller pour la synthaxe
    merci

    -----

  2. #2
    danyvio

    Re : macro-excel: positionner des éléments selon leur valeur

    Il existe une solution purement formules d'Excel que j'ai expérimentée
    Si j'ai bien bien compris l'énoncé :

    Si A1:A100 contient des valeurs à visualiser en colonne C au bon endroit

    On remplit la colonne auxiliaire B des valeurs successives 1,2,3...,100
    En C1 on entre la formule :

    =SI(ESTNA(RECHERCHEV(B1;$A$1:$ A$100;1;FAUX));" ";B1)

    qu'on copie dans C2 à C100

    Et ça marche !

    Si la colonne A contient quelque part 17, alors C17 affiche..17 sinon un blanc

    A+
    On trouve des chercheurs qui cherchent ; on cherche des chercheurs qui trouvent !

Discussions similaires

  1. Débutant : choix des composants et de leur valeur
    Par Harkonnen dans le forum Électronique
    Réponses: 6
    Dernier message: 08/05/2009, 12h36
  2. macro Excel
    Par gwendoline dans le forum Logiciel - Software - Open Source
    Réponses: 8
    Dernier message: 11/10/2008, 20h06
  3. Comment remplacer des mots dans un PDF selon leur taille ?
    Par fidel castor dans le forum Logiciel - Software - Open Source
    Réponses: 6
    Dernier message: 18/09/2008, 17h49
  4. [EXCEL VBA] => Lister des combobox et écrire leur contenu
    Par catsur dans le forum Logiciel - Software - Open Source
    Réponses: 3
    Dernier message: 20/05/2008, 10h13
  5. macro excel
    Par squall18 dans le forum Logiciel - Software - Open Source
    Réponses: 1
    Dernier message: 09/05/2006, 08h55
Découvrez nos comparatifs produits sur l'informatique et les technologies.