Répondre à la discussion
Affichage des résultats 1 à 9 sur 9

Fonction SI partielle dans Excel



  1. #1
    Dark Shadow

    Lightbulb Fonction SI partielle dans Excel


    ------

    Bonjour,

    Je souhaite faire un questionnaire à choix multiple sur Excel, dont la notation doit se faire automatiquement. Comme les participants pourront entrer librement les réponses aux questions, la casse ne sera pas respectée.

    Exemple : si la bonne réponse à la question est "cerise", ils pourront écrire "cerises" ou "une cerise" ou faire un espace avant ou après. Bref, il existe des dizaines de façon de l'écrire mais je souhaite que la formule de calcul comptabilise une bonne réponse à partir du moment où le mot "cerise" sera écrit dans la cellule, peu importe ce qu'il y a avant ou après.

    Donc, notre bonne vieille formule =SI(A1="cerise";"exact";"faux" ) ne pourra pas fonctionner.

    Avez-vous connaissance d'une formule pouvant parvenir à ce que je veux ?

    Merci d'avance pour vos réponses.

    -----

  2. Publicité
  3. #2
    Jack
    Modérateur

    Re : Fonction SI partielle dans Excel

    Il faut forcer la casse quelque part. Je ne maîtrise pas spécialement excel, mais il faudrait un truc du genre:
    =SI(MAJUSCULE(A1)="CERISE";"EX ACT";"FAUX" )

    A+

  4. #3
    Jack
    Modérateur

    Re : Fonction SI partielle dans Excel

    Bon, bein on dira que ce n'était pas vraiment urgent

  5. #4
    whoami

    Re : Fonction SI partielle dans Excel

    Bonjour,

    Et comme la réponse ne résout pas vraiment la question.

    En effet, la question inclut des variations possibles pour la réponse:
    Citation Envoyé par Dark Shadow Voir le message
    Bonjour,

    Je souhaite faire un questionnaire à choix multiple sur Excel, dont la notation doit se faire automatiquement. Comme les participants pourront entrer librement les réponses aux questions, la casse ne sera pas respectée.

    Exemple : si la bonne réponse à la question est "cerise", ils pourront écrire "cerises" ou "une cerise" ou faire un espace avant ou après. Bref, il existe des dizaines de façon de l'écrire mais je souhaite que la formule de calcul comptabilise une bonne réponse à partir du moment où le mot "cerise" sera écrit dans la cellule, peu importe ce qu'il y a avant ou après.

    Donc, notre bonne vieille formule =SI(A1="cerise";"exact";"faux" ) ne pourra pas fonctionner.

    Avez-vous connaissance d'une formule pouvant parvenir à ce que je veux ?

    Merci d'avance pour vos réponses.

  6. A voir en vidéo sur Futura
  7. #5
    Jack
    Modérateur

    Re : Fonction SI partielle dans Excel

    c'était un début. Sans entrer dans la programmation, on pourrait ajouter les orthographes possible avec des OU logiques.

  8. #6
    whoami

    Re : Fonction SI partielle dans Excel

    Bonjour,

    Je ne pense pas que ce soit une bonne solution, puisque, a priori, toutes les réponses contenant le mot cerise devrait être acceptées.

    Comme je n'ai jamais eu ce problème (dans Excel !), je jette un coup d'œil.

  9. Publicité
  10. #7
    whoami

    Re : Fonction SI partielle dans Excel

    Bonjour,

    Bien : dans la cellule B4 : =SI(NB.SI(A4;"*cerise*");"ceri se";"")

    Et si dans A4, il y a le mot cerise,
    peu importe la casse, la présence d'autres caractères ...
    la cellule B4 affiche bien cerise

    Testé avec, par exemple
    cerise
    CERISE
    Cerise
    Bonjour, tu me portes la ceriSE.
    ...


  11. #8
    Jack
    Modérateur

    Re : Fonction SI partielle dans Excel

    Belle maîtrise d'EXCEL

  12. #9
    Dark Shadow

    Re : Fonction SI partielle dans Excel

    Bonjour à vous, Jack et Whaomi,

    Après un week-end prolongé (et quelques difficultés à m'identifier), je constate avec plaisir que vous vous êtes occupés de mon cas.

    En effet Jack, whoami possède une belle maîtrise d'Excel, cette formule fonctionne parfaitement.

    Avec mes remerciements à vous deux.

    Bonne journée.

Discussions similaires

  1. Problème à propos d'une fonction dans excel
    Par Shark_13 dans le forum Programmation et langages, Algorithmique
    Réponses: 5
    Dernier message: 09/12/2011, 17h52
  2. Appel d'une fonction Excel dans une macro
    Par Calia_Eowyn dans le forum Programmation et langages, Algorithmique
    Réponses: 8
    Dernier message: 26/10/2011, 10h01
  3. Réponses: 3
    Dernier message: 15/06/2010, 07h18
  4. Recherche fonction MAX SI dans excel
    Par Santépub dans le forum Logiciel - Software - Open Source
    Réponses: 7
    Dernier message: 09/11/2008, 09h41
  5. fonction "tant que" dans Excel
    Par mumbly9b dans le forum Logiciel - Software - Open Source
    Réponses: 5
    Dernier message: 13/12/2007, 18h48
Découvrez nos comparatifs produits sur l'informatique et les technologies.