Répondre à la discussion
Affichage des résultats 1 à 2 sur 2

Openoffice fonction =texte()



  1. #1
    loran2407

    Unhappy Openoffice fonction =texte()


    ------

    Bonjour,
    j'ai un problème avec la fonction =texte(Nombre;Format), surtout avec le Format.
    Je veux convertir en texte un nombre décimal au millième (ex : 0,045). Comment doit-on écrire le texte qui décrit le format.

    -----

  2. #2
    jepoirrier

    Re : Openoffice fonction =texte()

    Bonjour,

    (La fonction que tu veux est dans OOo Calc : dans OOo, il y a aussi Writer, Impress, etc.)

    Admettons que tu aies 0,045 dans la case A1. Dans la case A2, la formule que tu cherches est : =TEXT(A1;"0,000")

    Il faut faire attention au séparateur de décimale. Il dépend de la configuration de ton système (chez moi, c'est le point, par exemple).

    En mettant des zéros dans la formule, OOo Calc va indiquer un "0" s'il ne trouve pas de nombre. Par exemple, il va transformer (sans les guillemets) ",45" en "0,450" avec la formule donnée ci-dessus. Si tu veux que OOo Calc ne mette rien s'il n'y a rien (transforme le chiffre 0,45 en texte 0,45 et pas 0,450), tu peux utiliser la formule =TEXTE(A1;"#,###")


Sur le même thème :

Discussions similaires

  1. Dans WORD, texte horizontal + texte vertical comment ?
    Par Cornemuse dans le forum Logiciel - Software - Open Source
    Réponses: 6
    Dernier message: 24/01/2010, 07h28
  2. OpenOffice
    Par poetic_boy972 dans le forum Logiciel - Software - Open Source
    Réponses: 3
    Dernier message: 26/10/2006, 23h41
  3. OpenOffice : des barrettes grises partout dans mon texte !
    Par LicenceXP dans le forum Logiciel - Software - Open Source
    Réponses: 3
    Dernier message: 05/09/2006, 11h17
  4. OpenOffice
    Par Hogoerwen'r dans le forum Logiciel - Software - Open Source
    Réponses: 2
    Dernier message: 12/07/2006, 09h24
  5. OpenOffice
    Par tethys dans le forum Logiciel - Software - Open Source
    Réponses: 30
    Dernier message: 14/06/2005, 18h28
Découvrez nos comparatifs produits sur l'informatique et les technologies.