Répondre à la discussion
Affichage des résultats 1 à 4 sur 4

Formules excel copie entre 2 fichiers

  1. #1
    PtiBruno

    Formules excel copie entre 2 fichiers

    Bonjour à tous,
    j’espère poster ce message au bon endroit.

    je cherche à récupérer des infos d'un fichier excel (Fichier1.xlsx) vers un autre fichier (Fichier2.xlsx).
    J'ai trouvé sur un forum la formule suivante qui fonctionne bien : =[Classeur1.xls]Feuil1!A1
    elle copie la case A1 de l'onglet Feuil1 du classeur1.xls


    jusque la tout vas bien, mais dans mon exemple je cherche à faire varier la colonne de la case à copié du fichier2 en fonction d'une valeur contenue dans une case du fichier1
    par exemple :
    - si je tape dans la case N3 de mon fichier1 la valeur 1 je récupère la case A1 du fichier2
    - si je tape dans la case N3 de mon fichier1 la valeur 2 je récupère la case A2 du fichier2

    J'ai essayé d'utiliser la fonction INDIRECT mais il semble y avoir une erreur de syntaxe ou bien la formule ne va pas du tout, j'ai essayé la formule suivante
    ='[fichier2.xlsx]Feuil1'!=INDIRECT("A"&N3)

    mais elle ne fonctionne pas j'ai excel qui m'indique une erreur de syntaxe, avez vous une idée du problème?
    Cordialement
    Bruno

    -----


  2. Publicité
  3. #2
    cherbe

    Re : Formules excel copie entre 2 fichiers

    Bonjour
    J'ai toujours galéré avec la fonction INDIRECT que l'on utilise trop rarement pour qu'elle soit familière. C'est plus simple avec des SI :
    (non testé car je n'ai pas Excel sous la main mais ça doit fonctionner à moins qu'il manque des apostrophes autour des références)
    en A1 du fichier2 :
    =SI(Classeur1.xls]Feuil1!N1=1;Classeur1.xls]Feuil1!A1;"")
    en A2 du fichier2
    =SI(Classeur1.xls]Feuil1!N1=2;Classeur1.xls]Feuil1!A1;"")
    Pour avoir de l'argent devant soi, il faut en mettre de côté ! (proverbe lorrain)

  4. #3
    PtiBruno

    Re : Formules excel copie entre 2 fichiers

    Bonjour Cherbe,
    Merci pour ta réponse, mais je n'ai pas tout compris, j'ai fait un test j'arrive à bien récupérer l'info du fichier2 mais je suis obligé d'avoir une formule par égalité?
    J'ai fait la formule suivante :
    =SI(N3=1;'[fichier2.xls]feuil1'!A1;"")

    -> si j'ai mets dans la case N3 la valeur 1 je récupère la case A1

    mais est-il possible de récupérer la valeur contenu dans la case N3 et d'utiliser cette valeur comme ligne de la colonne A?

  5. #4
    cherbe

    Re : Formules excel copie entre 2 fichiers

    Citation Envoyé par PtiBruno Voir le message
    mais est-il possible de récupérer la valeur contenu dans la case N3 et d'utiliser cette valeur comme ligne de la colonne A?
    Je ne comprends pas ?
    Pour avoir de l'argent devant soi, il faut en mettre de côté ! (proverbe lorrain)

Discussions similaires

  1. Copie de donnée excel vers un autre excel
    Par alt 10 001 dans le forum Logiciel - Software - Open Source
    Réponses: 6
    Dernier message: 16/03/2017, 09h23
  2. Comment couper le lien entre deux fichiers Excel
    Par Zozo_MP dans le forum Logiciel - Software - Open Source
    Réponses: 3
    Dernier message: 09/01/2017, 16h35
  3. Transfert Automatique de cellules Excel vers plusieurs fichiers Excel
    Par Choub18 dans le forum Logiciel - Software - Open Source
    Réponses: 2
    Dernier message: 16/03/2016, 11h06
  4. Excel: comparaison de cellules et copie de données entre 2 classeurs
    Par chrisgnomes dans le forum Logiciel - Software - Open Source
    Réponses: 15
    Dernier message: 23/05/2015, 15h46
  5. Problème conversion fichiers excel PC vers excel MAC
    Par Pallmall37 dans le forum Logiciel - Software - Open Source
    Réponses: 4
    Dernier message: 14/11/2007, 21h31