Répondre à la discussion
Affichage des résultats 1 à 13 sur 13

note maximale et note minimale



  1. #1
    dalida1111

    note maximale et note minimale


    ------

    salut
    j'ai un exo à faire svp
    exo : ecrire un programme qui trouve la plus grande et la plus petite valeur d'une succession de notes ( nombre entiers entre 0 et 20) fournies en données ainsi que le nombre de fois ou ce maximum et minimum ont été attribués .on supposera que les notes en nombre nonn connu à l avance seront terminées par une valeur négative .

    Code:
    Algorithme : max_min;
    
    var n , max ,min : réels;
    var  nbmax<- 0,nbmin <-0 : entiers;
    
    debut
    max<-20 ;
    min<-0;
    faire 
    afficher (" donner une note svp ");
    lire(n);
    si ( n> max ) alors
    max<-n;
    nbmax<-nbmax+1;
    fin si 
    si ( n<min) alors 
    min<-n;
    nbmin<-nbmin+1;
    fin si
    tant que ( n<0 ou n>20);
    fin tant que 
    afficher ( max,"est la note maximale,attribuée",nbmax,"fois");
    afficher (min,"est la note minimale,attribuée",nbmin,"fois");
    fin
    c bien ça? merci d 'avance de m'avoir aidée

    -----

  2. #2
    photon57

    Re : note maximale et note minimale

    Hello,

    indente ton code (mets des espaces) pour le rendre plus lisible et inciter les gens à t'aider

    Code:
    Algorithme : max_min;
    
    var n , max ,min : réels;
    var  nbmax<- 0,nbmin <-0 : entiers;
    
    debut
        max<-20 ;
        min<-0;
        faire 
            afficher (" donner une note svp ");
            lire(n);
            si ( n> max ) alors
                max<-n;
                nbmax<-nbmax+1;
            fin si 
            si ( n<min) alors 
                min<-n;
                nbmin<-nbmin+1;
            fin si
        tant que ( n<0 ou n>20);
        //fin tant que  : inutile car le bloc est délimité par faire ... tant que
        afficher ( max,"est la note maximale,attribuée",nbmax,"fois");
        afficher (min,"est la note minimale,attribuée",nbmin,"fois");
    fin
    Ton algo n'est pas bon, essaye avec les notes 10,11,12

  3. #3
    whoami

    Re : note maximale et note minimale

    Bonjour,

    Pour mettre au point des algorithmes, la meilleure solution est : papier + crayon.

    Quand tu as bien réfléchi, et que tu as enfin écrit ton algorithme, il faut le tester manuellement :

    Tu le suis ligne à ligne, en suivant l'évolution des variables pas à pas, en testant avec différentes valeurs pour les entrées (au moins chacune des valeurs limites, si limites il y a, une valeur dans la fourchette admise, et une valeur hors limites).

    Tu détecteras ainsi la plupart des problèmes des algorithmes que tu as écrits, et tu prendras une bonne habitude, qui est de contrôler ton travail, au lieu de compter sur le travail des autres.

  4. #4
    Dormeur74

    Re : note maximale et note minimale

    Sauf résultat d'une grosse fête hier soir, tes variables min et max sont initialisées à l'envers.

  5. A voir en vidéo sur Futura
  6. #5
    danyvio

    Re : note maximale et note minimale

    Citation Envoyé par Dormeur74 Voir le message
    Sauf résultat d'une grosse fête hier soir, tes variables min et max sont initialisées à l'envers.
    C'est exact, mais aussi (et surtout) ça compte le nombre de fois où la note max (resp. min) a évolué , alors que probablement il voulait dire que la note max (resp. min) trouvée a été attribuée n fois.
    Il lui faut donc modifier un peu son algo et tester si la note en cours = la note max (resp. min) en cours et faire ce qu'il faut...
    On trouve des chercheurs qui cherchent ; on cherche des chercheurs qui trouvent !

  7. #6
    photon57

    Re : note maximale et note minimale

    Oui, tout ça se remarque assez facilement si on teste l'algo avant, surtout sur des algos pas compliqués du tout comme celui proposé.
    Je pense, mais c'est un avis paersonnel, que l'on apprend plus en débuggant son algo qu'en attendant qu'on le fasse pour vous.

  8. #7
    dalida1111

    Re : note maximale et note minimale

    Code:
    Algorithme : max_min;
    
    var n , max ,min : réels;
    var  nbmax<- 0,nbmin <-0 : entiers;
    
    debut
    max<-0 ;
    min<-20;
    faire 
    afficher (" donner une note svp ");
    lire(n);
    
    si (n>=0 et n<=20)
    
    si ( n>= max ) alors
    
    si(n>max)alors
    max<-n;
    nbmax<-1;
    sinon    // si note=max
    nbmax<-nbmax+1;
    fin si 
    fin si
    
    si ( n<=min) alors 
    
    si(n<min)alors
    min<-n;
    nbmin<-1;
    sinon // si note = min
    nbmin<-nbmin+1;
    fin si
    fin si
    
    fin si
    
    tant que ( n>0);
    fin tant que 
    afficher ( max,"est la note maximale,attribuée",nbmax,"fois");
    afficher (min,"est la note minimale,attribuée",nbmin,"fois");
    fin
    voilà
    Dernière modification par dalida1111 ; 05/12/2011 à 12h22.

  9. #8
    dalida1111

    Re : note maximale et note minimale

    faut pas que j ajoute fin tant que !

  10. #9
    photon57

    Re : note maximale et note minimale

    Hello,

    formatte ton code :
    * insère le dans des balises codes
    * indente ton code = met des espaces pour rendre visible les différents blocs

    remarque : si tu trouves une nouvelle note max (resp. min) il faut réinitialiser le nombre d'occurences de la note max (resp. min)

    important : teste ton code avant de le poster ... ça évitera que nous nous répétions

  11. #10
    whoami

    Re : note maximale et note minimale

    Bonjour,

    Bon, malgré les répétitions de différents membres, je ne vois aucun effort pour la mise en forme, ni les tests des algorithmes proposés à notre sagacité.

    J'en conclus que dalida1111 compte surtout sur notre travail plutôt que sur le sien.

    En conséquence, je laisse tomber toute aide pour dalida1111, et je n'ouvrirai même plus les sujets créés avec ce pseudo.

  12. #11
    Jack
    Modérateur

    Re : note maximale et note minimale

    Ca fait un moment que j'étais arrivé à cette conclusion

  13. #12
    Dormeur74

    Re : note maximale et note minimale

    Je trouve certaines réactions un peu sévères avec notre ami dalida1111 qui n'a peut-être pas compris à quoi servait le bouton "Mode avancé" ; le plus grand nombre ayant tôt ou tard besoin d'une fonction "avancée", on peut se demander pourquoi deux modes.

    Maintenant, il me semble indispensable, comme l'a suggéré photo57, que tu apprennes à mettre des points de contrôle dans ton code (1). Avec ton premier jus, si tu avais placé un simple test au niveau des sorties, tu te serais vite rendu compte de l'inversion, dans leur initialisation, de tes variables. En gros : tu entres une valeur quelconque et ta sortie est mauvaise. Tu en conclues que ton code est à revoir. Mais pas sur un forum : sur ton écran. Et là, je comprends ceux que cela a irrité.

    Côté algo, tu peux améliorer ton minimax dans une même boucle, ce qui optimisera ton code en temps machine.

    (1) la fonction PHP que j'utilise le plus est exit("$variable"). Je pense que cela est vrai dans la plupart des autres langages de programmation. Avec un technique de points d'arrêts que j'ai beaucoup appréciée chez Microsoft.

  14. #13
    dalida1111

    Re : note maximale et note minimale

    Merci pour vos conseils précieux et votre aide.
    j'ai traduit mon algo en c et ca marche .

Discussions similaires

  1. note
    Par luger11 dans le forum Orientation après le BAC
    Réponses: 2
    Dernier message: 23/06/2009, 09h40
  2. Note de calcul
    Par samos051 dans le forum Physique
    Réponses: 9
    Dernier message: 09/12/2008, 16h03
  3. Actu - Melodyne, un logiciel pour retoucher la musique note par note
    Par RSSBot dans le forum Commentez les actus, dossiers et définitions
    Réponses: 18
    Dernier message: 05/05/2008, 18h30
  4. note tpe
    Par sensor dans le forum TPE / TIPE et autres travaux
    Réponses: 8
    Dernier message: 18/05/2005, 18h39