Répondre à la discussion
Page 1 sur 2 1 DernièreDernière
Affichage des résultats 1 à 30 sur 32

Problème avec redresseur de tension et transistors.



  1. #1
    momo194

    Problème avec redresseur de tension et transistors.


    ------

    Bonjour,

    Afin d'alimenter une picoPSU(http://www.cartft.com/support/doku [...] 120-EN.pdf) j'ai décidé de réaliser un CI imprimé qui me pond du 12V avec un ampèrage de 10A Max.

    J'ai donc trouvé ce lien:
    12V 30A Power Supply

    Et commandé tout les composants et en utilisant un LM2940 comme régulateur de tension.

    Seulement problème:
    Quand je mets un, ou plusieurs de transistors en // comme indiqué sur le site, c'est comme si mon régulateur de tension n'agissait plus, ça me sort une tension redressé de 15,5V(soit une tension redressée mais pas régulée). Sans les transistors, parfait: 12,02V !!!, mais je perds alors tout le bénéfice des transistors nécessaires pour faire passer les 8-9A dont j'ai besoin.

    Si quelqu'un pouvait m'aider.
    Merci d'avance.

    Momo.

    -----

  2. #2
    f6bes

    Re : Problème avec redresseur de tension et transistors.

    Bjr momo..
    Pour ma part j'utilise cela:
    Le 7812 drive les bases des 2 ou 3 2N3055 (NPN).
    Cordialement
    Images attachées Images attachées  
    Ne tiens pas a etre puching ball... (penser à regarder vos MP, )

  3. #3
    momo194

    Re : Problème avec redresseur de tension et transistors.

    OK, Le schéma est très semblable au mien.

    Mais avec mes TIP2955(PNP), je sais pas pourquoi ça me fait du 15,5; comme si mon LM2940 était obsolète alors que seul il marche parfaitement bien.

  4. #4
    gienas
    Modérateur

    Re : Problème avec redresseur de tension et transistors.

    Bonjour Momo et tout le groupe

    Citation Envoyé par momo194 Voir le message
    ... Quand je mets un, ou plusieurs de transistors en // comme indiqué sur le site, c'est comme si mon régulateur de tension n'agissait plus, ça me sort une tension redressé de 15,5V(soit une tension redressée mais pas régulée). Sans les transistors, parfait: 12,02V !!!, mais je perds alors tout le bénéfice des transistors nécessaires pour faire passer les 8-9A dont j'ai besoin ...
    Commence déjà par faire fonctionner avec un seul transistor.

    Quelle est la tension redressée? Ne serait-elle pas au voisinage des 16V?

    J'ai dans l'idée que les transistors que tu tentes de mettre sont en court circuit.

    Peux-tu vérifier, qu'avec un seul, base déconnectée, cela fonctionne comme si le transistor n'était pas là?

    Le principe est "tout simple". Dès que le régulateur passe un peu trop de courant, il se fait "aider" par les transistors, grâce à la chute de tension dans la résistance R7. Encore faut-il que le transistor soit capable de se bloquer, ce dont je doute. Il est probablement mal monté, ou plus simplement inadapté.

  5. A voir en vidéo sur Futura
  6. #5
    momo194

    Re : Problème avec redresseur de tension et transistors.

    Re, la suite des aventures.

    La tension redressée est affectivement de 16V, puis après passage dans le régulateur elle passe à 12V: bon point !

    J'ai fais le test que tu m'a conseillé gienas:

    Emetteur du TIP2955 connecté directement sur le + du pont diode(même potentiel que mes 2 gros condos de redressements) et collecteur connecté au fil rouge de mon multimètre. Verdict: pas de tension. La base du PNP étant donc non connectée pour le test.(En fonctionnement normal je la connectais au Vin du régulateur).

    Je crois avoir bine suivi le Pinout de la datasheet, de face et de droite à gauche: Base, Collecteur, Émetteur.

    je ne vois toujours pas le problème:s

    Merci.

  7. #6
    gienas
    Modérateur

    Re : Problème avec redresseur de tension et transistors.

    Citation Envoyé par momo194 Voir le message
    ... Emetteur du TIP2955 connecté directement sur le + du pont diode(même potentiel que mes 2 gros condos de redressements) et collecteur connecté au fil rouge de mon multimètre ...
    C'est pas exactement cela que je suggère. Laisser le transistor à sa place, mais débrancher sa base.

    A faible courant, le régulateur se suffit à lui-même, c'est quand la chute dans R7 dépasse le Vbe, que le transistor prend aussi "la main".
    Images attachées Images attachées

  8. #7
    momo194

    Re : Problème avec redresseur de tension et transistors.

    Ok,

    Alors quand je fais le montage que tu préconises, ça m'affiche 12V, donc c'est plutôt bien.

    Quand je vais un peu plus loin et que je connecte la base au Vin du régulateur qui est aussi le pin droit de R7, ça monte à 15. si je mets sur sur le pin gauche, ça reste à 12V.

    Et ej ne vosi tourjours pas le problème.

    Merci.

  9. #8
    gienas
    Modérateur

    Re : Problème avec redresseur de tension et transistors.

    As-tu une charge "sérieuse" en sortie du montage régulateur? Il serait illusoire de vouloir faire fonctionner l'ampli tout en restant à vide.

    Quelle est la valeur de la résistance R7? Là, j'ai "peur" que la valeur de 100 proposée, ne sature le premier transistor, sur le simple courant de repos du régulateur. Essaye plutôt 10. J'ai même ce schéma dans mes archives avec 1!

  10. #9
    momo194

    Re : Problème avec redresseur de tension et transistors.

    Alors voilà quelques améliorations:

    J'ai réussi à faire démarrer ma machine avec un PNP. Mais on reste toujours très loin du but.

    Pour la faire démarrer j'ai mis une charge (3 ventilateurs 80mm), de façon à ce que la tension descende de 15,5V à +/-13V ce qui permet à ma machine de démarrer(Elle se coupe en effet au dessu de 13-13,5V).

    Quand la machine démarre le potentiel tombe à 10,8V. Mai cela ne pose pas de problème.

    Mes questions:
    1)Comment avoir directement un voltage de 12-13V(c'était quand même bien le but du régulateur et là je vois plus à quoi il sert)?
    2) Je n'ai pas compris ta remarque sur la valeur de la résistance. Est-ce que je peux mettre une résistance de 0,1 Ohm, je n'ai que ça en stock.

    Merci beacoup.

    Momo.

  11. #10
    momo194

    Re : Problème avec redresseur de tension et transistors.

    Je crois que j'ai compris ta remarques sur la saturation du transistor.

    Je l'explique comme ça: la résistance est trop grande et le courant suffisament grand pour faire apparaître uen tension suffisament grande que pour saturer le TIP2955.

    Ma question est s'agit-il bien de la tension V E-B, qu'est-ce que la saturation(physiquement) et quel est son effet ? Justement que la tension au collecteur soit celle de l'émetteur(15,5V) et pas celle du Vout du régulateur(12V).

    Tu confirmes?

    Merci bcp et bonne soirée !!!

  12. #11
    gienas
    Modérateur

    Re : Problème avec redresseur de tension et transistors.

    Citation Envoyé par momo194 Voir le message
    ... Tu confirmes? ...
    En gros, oui. Si la résistance est trop grande,le peu de courant passe plutôt dans la jonction base/émetteur du transistor, pour le saturer, et du coup, mettre "hors service" le régulateur.

    Ce qui est plus troublant, c'est que les charges n'y changent rien

    0,1 est trop faible pour faire fonctionner les transistors. Il faudrait que le régulateur fournisse 0,6/0,1=6A pour "prendre la main", ce qui est bien trop. 1 me semble bien, que tu peux obtenir en mettant 10 résistances de 0,1 en série.

  13. #12
    momo194

    Re : Problème avec redresseur de tension et transistors.

    Bonsoir,

    Encore du nouveau!
    Finalement j'ai essayé avec R7 = 50 Ohm et la machine démarre.
    Seul problème: la tension descend à 11V et le disque dur ne s'allume donc pas(il y a une perte de 1V à l'allumage), crois-tu qu'avec un régulateur variable que je règlerais sur 13V mon problème sera règlé?

    Est-ce que la valeur de R7 joue sur la tension finale obtenue aux collecteurs. Je demande comme ça je ne devrai peut-être pas rajouté de régulateur variable?

    Merci.

  14. #13
    gienas
    Modérateur

    Re : Problème avec redresseur de tension et transistors.

    Citation Envoyé par momo194 Voir le message
    ... Est-ce que la valeur de R7 joue sur la tension finale obtenue aux collecteurs ...
    Elle ne doit pas jouer. Mais il faut pour cela que le régulateur soit amené à travailler, et à fournir un courant "raisonnable". Les transistors additionnels sont là pour "aider" et "accompagner" le régulateur.

    Pourquoi s'obstiner à ne pas vouloir ramener R7 à quelque chose de plus raisonnable? 50 me semble encore bien élevé.

    Tu me donnes des types de charges, mais pas des intensités, qui sont les critères de fonctionnement ou de non fonctionnement.

    Non, un régulateur variable ne résoudra pas le problème, sauf si la tension doit être réglée de manière très critique.

  15. #14
    momo194

    Re : Problème avec redresseur de tension et transistors.

    OK.

    Mais alors comment je peux règler le problème de cette chute de tension de 1V au démarrage de la machine?

    R7 à 1 Ohm changerait-il le problème? Si oui, je ne vois pas pourquoi.

    Sinon, quelle est l'alternative?

    Merci de ton suivi !!!

    Momo.

  16. #15
    gienas
    Modérateur

    Re : Problème avec redresseur de tension et transistors.

    Bonjour momo194 et tout le groupe

    Citation Envoyé par momo194 Voir le message
    ... Mais alors comment je peux règler le problème de cette chute de tension de 1V au démarrage de la machine? ...
    Je ne vois pas bien ce que démarrage vient faire ici

    Citation Envoyé par momo194 Voir le message
    ... R7 à 1 Ohm changerait-il le problème? Si oui, je ne vois pas pourquoi ...
    Ce n'est pas impossible.

    Je n'ai pas d'idée de consommation, comme déjà demandé. Tu signales des "gros condos" de filtrage en entrée. C'est combien, comparé au courant demandé? Le filtrage dépend du courant demandé à l'alim, et je n'exclus pas que le filtrage soit insuffisant, et du coup, les mesures fausses. Un examen à l'oscilloscope serait très instructif.

    Tu souhaites sortir 12V, avec une alim non régulée qui sort 15V, sans savoir quel est l'état du filtrage à ce point. Cela me paraît faible. Je verrais un peu plus de marge pour la régulation.

  17. #16
    momo194

    Re : Problème avec redresseur de tension et transistors.

    Bonjour tout le monde.

    Alors en fait je ne sais pas pourquoi mais j'observe que quand j'allume le PC le potentiel qui était jusque là à 12V tombe à 10,95V et je ne sais pas pourquoi. Est-ce que tu crois que je pourrais régler cela avec telle ou telle diode ?

    f6bes me signalait que son montage marchait avec l'équivalent NPN de mes transistors serait-ce la solution ?

    Pour répondre à ta question: les condo sont 3*10 000µF chimiques en //. La consommation oscille entre 5 et 7,5A.

    Merci

  18. #17
    gienas
    Modérateur

    Re : Problème avec redresseur de tension et transistors.

    Citation Envoyé par momo194 Voir le message
    ... Alors en fait je ne sais pas pourquoi mais j'observe que quand j'allume le PC le potentiel qui était jusque là à 12V tombe à 10,95V et je ne sais pas pourquoi ...
    Je comprends par là qu'à faible débit, la régulation s'opère, mais que cela chute en forte charge. Ai-je raison?

    Citation Envoyé par momo194 Voir le message
    ... Est-ce que tu crois que je pourrais régler cela avec telle ou telle diode ? ...
    Je ne comprends pas la question

    Citation Envoyé par momo194 Voir le message
    ... f6bes me signalait que son montage marchait avec l'équivalent NPN de mes transistors serait-ce la solution ? ...
    Son montage, simple, ne peut pas faire de miracle. En outre, on perd (en tension de sortie), le Vbe du transistor, et en fait on ne régule pas la sortie, ce qui se veut le cas de ton montage initial.

    Citation Envoyé par momo194 Voir le message
    ... Pour répondre à ta question: les condo sont 3*10 000µF chimiques en //. La consommation oscille entre 5 et 7,5A ...
    Ce qui donne quand-même une ondulation de 2,5V, à 7,5A, si le redressement est bien double alternance.

    Peux-tu mesurer la tension non régulée dans tous les cas de figure: avant de démarrer (avec 12V en sortie) et après démarrage (avec les 10,95V en sortie). Je pense que le problème est là.

    Tu peux avoir une "idée" de l'ondulation, en mesurant, au même point, la tension en mode alternatif. Si ton voltmètre est numérique, tu "isoles" le continu avec un condensateur de liaison, pour ne mesurer, faussement, qu'une composante alternative, probablement supérieure au volt, qu'il faut plus que doubler pour avoir une idée de l'ondulation crête à crête.

    Ce que je pense, c'est que ta source en tête de filtre s'écroule en charge, et ne permet plus la régulation normale, le mauvais filtrage venant aggraver la situation.

  19. #18
    momo194

    Re : Problème avec redresseur de tension et transistors.

    Re,

    Alors voilà j'ai fait le petit test que tu m'a demandé:

    1)Machine éteinte: 15,5V.
    2)Machine allumée: 11,95V.

    Donc si je comprends bien, même si mon régulateur est un low drop, il perd la boule car on lui demande de sortir quelque chose supérieur à ce qu'il y a en entrée?

    Est-ce que l'achat d'un transformateur de tension plus élevé 15V par Ex. règlerait définitivement le problème?

    J'entend par là "Est-ce que la chute de tension de R7 est directement dépendante de la charge et donc la même quelque soit la tension du secondaire?"

    SI l'achat d'un transformateur est la solution, Est-ce que pour les besoins du test je peux brancher mon montage et une batterie de voiture en série ?

    Merci

  20. #19
    gienas
    Modérateur

    Re : Problème avec redresseur de tension et transistors.

    Citation Envoyé par momo194 Voir le message
    ... 2)Machine allumée: 11,95V ...
    Bingo!

    Citation Envoyé par momo194 Voir le message
    ... Donc si je comprends bien, même si mon régulateur est un low drop, il perd la boule car on lui demande de sortir quelque chose supérieur à ce qu'il y a en entrée? ...
    Exactement.

    Citation Envoyé par momo194 Voir le message
    ... Est-ce que l'achat d'un transformateur de tension plus élevé 15V par Ex. règlerait définitivement le problème? ...
    C'est la solution.

    Citation Envoyé par momo194 Voir le message
    ... J'entend par là "Est-ce que la chute de tension de R7 est directement dépendante de la charge et donc la même quelque soit la tension du secondaire?" ...
    Pas très clair, là

    La chute de tension dans R7, est principalement dépendante du courant fourni par le régulateur, qui ne doit pas être nul, et ne pas dépasser ses capacités. Cette valeur n'est pas critique, mais il faut garder en mémoire que lorsque la tension sera plus forte, la puissance dissipée dans les transistors (et dans le régulateur), sera plus importante, et que le refroidissement sera nécessaire. Plusieurs transistors, montés sur radiateur, le régulateur aussi.

    Citation Envoyé par momo194 Voir le message
    ... SI l'achat d'un transformateur est la solution, Est-ce que pour les besoins du test je peux brancher mon montage et une batterie de voiture en série ? ...
    Dans le principe, oui, mais dans la pratique, il en va tout autrement.

    12V de plus, cela va donner 24V, soit une perte de puissance de 12*7,5=90W, ce qui n'est pas une mince affaire. C'est un peu casse cou. Il faudrait assurer 16V en creux d'ondulation, à 7,5A. Cela donne, à la louche, 16+1,5=17,5V au lieu des 11,95 actuels. Une batterie de 6V serait sûrement mieux adaptée.

  21. #20
    momo194

    Re : Problème avec redresseur de tension et transistors.

    Bon voilà je me suis arrangé pour avoir du 20V mais dès que je connecte la base du transistor ça me donne ce 20V au collecteur, sans la base, parfait ça donne du 12V.

    Je comprends plus rien :s

    Merci encore.

  22. #21
    gienas
    Modérateur

    Re : Problème avec redresseur de tension et transistors.

    Citation Envoyé par momo194 Voir le message
    Bon voilà je me suis arrangé pour avoir du 20V mais dès que je connecte la base du transistor ça me donne ce 20V au collecteur, sans la base, parfait ça donne du 12V ...
    Quelle charge? Quelle valeur de R7?

  23. #22
    momo194

    Re : Problème avec redresseur de tension et transistors.

    Avec une charge(un petit ventilateur 12V)

    J'ai mis R7 = 500Ohm et j'observe que en mettant 50 Ohm la tension chute à 14V, pas mal.

    Mais sans charge tout va mal: la tension est à 21V ce qui ne permet pas à ma machine de démarrer :s

    Je crois que il y a une tension trop importante à l'émetteur du transistor mais je ne comprends pas pourquoi cela ne marche pas.

    Je susi perdu.

    Tu pourrais m'aiguiller encore un peu ?

    Merci

  24. #23
    momo194

    Re : Problème avec redresseur de tension et transistors.

    Je crois que je vais me tourner vers une autre alimentation miniature.

    Je viens en effet de griller ma picoPSU et je crois que j'étais sur la mauvaise voie en voulant faire cette alimentaiton régulée puissante.

    Merci encore !

  25. #24
    gienas
    Modérateur

    Re : Problème avec redresseur de tension et transistors.

    Citation Envoyé par momo194 Voir le message
    ... mais je ne comprends pas pourquoi cela ne marche pas ...
    Charge trop faible et R7 trop fort!

    C'est quoi picoPSU?

  26. #25
    momo194

    Re : Problème avec redresseur de tension et transistors.

    OK.

    C'est(c'était) une mini-alimentation pour PC de 120Watts.

    A bientôt.

  27. #26
    momo194

    Réalisation d'un circuit de commutation.

    Bonjour,

    Je vais essayer de vous détailler mon problème parce que mes connaissances ne me permettent pas de trouver une solution moi-même.

    Je voudrais que si dans une branche AB de mon circuit le courant est < que x mA à un instant le composant que je cherche connecte les points 1 et 2 de mon circuit, Si le courant est > que x mA alors le composant connecte 1 et 3. La commutation devrait se faire instantannément ou du moins le plus rapidement électroniquement parlant.

    J'imagine que je vais avoir besoin de transistors mais je ne sais comment les connecter. Un schéma, une idée ?

    Merci.

    Momo.

  28. #27
    gienas
    Modérateur

    Re : Réalisation d'un circuit de commutation.

    Bonsoir momo194 et tout le groupe

    Citation Envoyé par momo194 Voir le message
    ... branche AB ... courant ... composant connecte 1 et 3 ...
    Rien qu'en lisant cela, je "flaire" un problème de références. Je crois que tu dois nous donner des précisions supplémentaires.

    Comment se situent ces branches AB et 123, par rapport à une masse, qui devrait être commune?

    Quelles doivent être les capacités de commutation (courant et tension) du composant miracle?

    Pour détecter le courant, et le comparer, il faut le faire passer dans une résistance, pour le transformer en tension. Est-ce possible?

  29. #28
    momo194

    Re : Réalisation d'un circuit de commutation.

    Bonsoir Gienas:

    En fait, c'est toujours mon monfameux circuit dont je ne retrouve plus le topic. Mais la base est ceci:
    Alimentation 12 V 30A

    J'avais donc remarqué certaines choses dans le circuit:
    1)avant LM2940(sans charge) : 16,5V
    2)avant LM2940(avec charge) : 12V
    3)après LM2940(sans charge) : 12V
    4)après LM2940(avec charge) : 10V

    Je voudrais donc utiliser les tension des états 2) et 3) car il faut absolument du 12V à la picoPSU.

    Merci.

  30. #29
    gienas
    Modérateur

    Re : Réalisation d'un circuit de commutation.

    Citation Envoyé par momo194 Voir le message
    ... En fait, c'est toujours mon monfameux circuit dont je ne retrouve plus le topic ...
    Serait-ce ceci?

    http://forums.futura-sciences.com/thread124951.html

    Tu n'as pas dû beaucoup chercher

    Veux-tu fusionner les deux topics?

    L'erreur que tu as faite dans tes manips de l'époque, c'est de travailler avec des charges réelles, avec un circuit pas au point. Il faut toujours faire ces manips sur des charges fictives, sans risque.

  31. #30
    momo194

    Re : Réalisation d'un circuit de commutation.

    Salut,

    Oui ça sera bien de les fusionner.

    En effet une charge fictive c'est mieux Là j'utilise des ampoules halogène 50W

    Mais je suis toujours en quête de 12V

    Merci.

Page 1 sur 2 1 DernièreDernière

Discussions similaires

  1. Tension Gate sur les Transistors MOS
    Par Olivier_34 dans le forum Électronique
    Réponses: 13
    Dernier message: 21/04/2007, 18h17
  2. probleme tension avec lecteur cd
    Par sofiene2005 dans le forum Électronique
    Réponses: 1
    Dernier message: 26/11/2006, 19h14
  3. Redresseur de courant alternatif avec charbon
    Par Rai12 dans le forum Électronique
    Réponses: 4
    Dernier message: 14/11/2006, 15h46
  4. [MP] Redresseur de tension
    Par Eric78 dans le forum Physique
    Réponses: 7
    Dernier message: 08/10/2005, 13h00
Découvrez nos comparatifs produits sur l'informatique et les technologies.