Répondre à la discussion
Affichage des résultats 1 à 9 sur 9

panne thermique



  1. #1
    mat64

    panne thermique


    ------

    Bonjour,

    j'ai un problème avec un circuit que nous fabriquons en petites séries. Sur certains exemplaires, j'ai un problème de démarrage, qui ne se manifeste qu'a froid. Si je laisse la carte sous tension quelques minutes, ça démarre à tous les coups.

    Que peut-on soupçonner dans de tels cas ? un composant défaillant ? Une soudure mal faite, qui deviendrais conductrice dès que la broche se dilate ? Je sais qu'il existe des bombes réfrigérantes, est-ce qu'avec ça on peut refroidir seulement une partie de la carte pour cerner le problème ? Bref, toutes les idées ou les témoignages de problèmes similaires sont les bienvenus...

    Pour ceux qui ont quelques secondes de plus à me consacrer, quelques détails :
    - la carte comprends quelques petits convertisseurs à découpage et quelques convertisseurs linéaires. Bien sur j'ai regardé les tensions d'alim et le signal de reset lors du démarrage des cartes capricieuses, tout est OK.
    - 95% des composants sont CMS.
    - l'élément qui ne démarre pas est un processeur. Pour être précis, le processeur démarre à tous les coups, car il charge le bootloader toujours avec succès. C'est la deuxième phase (démarrage de linux) qui plante. C'est ce qui me fait penser à une soudure qui serait douteuse, mettant alors une broche dans un état qui déplait au noyau. Bien sur j'ai vérifié le log de démarrage de linux, RAS.

    -----

  2. Publicité
  3. #2
    DAUDET78

    Re : panne thermique

    Si tu stockes ta carte à 45° (de température) hors tension. Elle démarre nickel, du premier coup, quand tu la mets sous tension?
    J'aime pas le Grec

  4. #3
    mat64

    Re : panne thermique

    Citation Envoyé par DAUDET78 Voir le message
    Si tu stockes ta carte à 45° (de température) hors tension. Elle démarre nickel, du premier coup, quand tu la mets sous tension?
    Bonne question, j'ai même pas fait l'essai. J'ai supposé que c'était un problème de température car les démarrages sont OK après quelques minutes de mise sous tension. Mais après tout ça peut être du à autre chose, comme une charge de condo.... Le test que tu proposes permettra de valider que c'est bien une question de température. J'essaye dans la journée et je reviens !

    bon j'ai pas d'étuve... PME petits moyens tout ça.... je vais laisser le bouzin sur la plage arrière de la voiture de 13h à 15h, ça devrai suffire !

  5. #4
    ibtihel

    Re : panne thermique

    bonjour
    Citation Envoyé par mat64 Voir le message
    je vais laisser le bouzin sur la plage arrière de la voiture de 13h à 15h, ça devrai suffire !
    t'as pas de sèche cheveux chez toi ? c'est + rapide !
    A+

  6. A voir en vidéo sur Futura
  7. #5
    jiherve

    Re : panne thermique

    Bonsoir
    le processeur serait il un BGA ?
    L'alim n'aurait elle pas une faiblesse lors du passage en mode opérationnel?
    Y aurait il un watchdog dépendant d'un oscillateur RC?
    Y aurait il un mix de famille logique ?
    Y aurait il une entrée en l'air (un grand classique)?
    L'activation du noyau induirait elle un accès sur un périphérique encore indisponible (FPGA type ram en cours de configuration)?
    JR
    l'électronique c'est pas du vaudou!

  8. #6
    annjy

    Re : panne thermique

    Citation Envoyé par mat64 Voir le message
    Bonjour,

    j'ai un problème avec un circuit que nous fabriquons en petites séries. Sur certains exemplaires, j'ai un problème de démarrage, qui ne se manifeste qu'a froid. Si je laisse la carte sous tension quelques minutes, ça démarre à tous les coups.
    Bsr,
    à froid, ça veut dire quoi ?
    pour moi ça va de l'ambiante à au moins - 55°C.......voire moins.

    peux-tu faire des essais en mettant le montage dans une étuve à température régulée ?

    Amicalement,
    JY

  9. Publicité
  10. #7
    DAUDET78

    Re : panne thermique

    Citation Envoyé par annjy Voir le message
    peux-tu faire des essais en mettant le montage dans une étuve à température régulée ?
    C'est ce que j'ai proposé en #2. Par contre, il faut faire une collecte parmi les forrummeurs vu sa réponse #3 ....
    J'aime pas le Grec

  11. #8
    mat64

    Re : panne thermique

    Citation Envoyé par DAUDET78 Voir le message
    C'est ce que j'ai proposé en #2. Par contre, il faut faire une collecte parmi les forrummeurs vu sa réponse #3 ....
    si vous saviez avec quoi je travaille, vous me croiriez pas....

    Bon, il pleuvait hier, il faisait pas trop chaud dans la voiture... je ramènerais un sèche-cheveux de chez moi ! Néanmoins, sur les 2 cartes que j'avais mises à "tiédir", celle qui n'était pas en boitier (qui était un peu plus chaude que l'autre) à démarré du 1er coup. ça tendrais à confirmer un problème lié à la température. OK, c'est un peu bricolo comme test, je confirmerais l'impression en réchauffant mes cartes de manière plus nette.

    Par ailleurs, les questions de jiherve m'interpellent :
    le processeur serait il un BGA ?
    oui. Pourquoi, cette techno est sensible aux variations de température ? Cependant dans mon cas ce n'est pas ça : le processeur est sur une carte fille, et j'ai donc pu faire des échanges, ce qui confirme que le problème est sur la carte mère. Ce n'est pas une soudure du processeur qui est en cause dans mon cas.

    L'alim n'aurait elle pas une faiblesse lors du passage en mode opérationnel?
    comment m'en rendre compte ? j'ai regardé les tensions d'alim à l'oscillo (oui, j'ai quand même un oscillo )et elles ne bougent pas pendant le démarrage (ou le non-démarrage).

    Y aurait il un watchdog dépendant d'un oscillateur RC?
    il y en a un, mais sur la carte fille, qui a été mise hors de cause.

    Y aurait il un mix de famille logique ?
    oui, j'ai mis des 74LCX245 entre le processeur en 3.3v et un périphérique en 5v. Quelle influence cela peut-il avoir ?

    Y aurait il une entrée en l'air (un grand classique)?
    ça c'est bien possible. je vérifie, je test avec des pull-up le cas échéant, et je posterais le résultat. (ça va me prendre un petit moment, la carte fille a 144 broches et je dois vérifier lesquelles sont sur des I/O du proc.)

    L'activation du noyau induirait elle un accès sur un périphérique encore indisponible (FPGA type ram en cours de configuration)?
    je ne crois pas. J'ai passé en revue tous mes périphériques, il n'y en a aucun qui soit lent à s'activer (pas de FPGA ni d'autre composant programmable qui aurait besoin de "booter"). De plus le bootloader à une tempo de 2 s. avant de lancer le noyau, c'est une éternité pour tous mes périphériques il me semble.

  12. #9
    jiherve

    Re : panne thermique

    Bonsoir
    Je suis flatté de t'avoir interpellé (en fait le contraire m'eut étonné )
    pour l'alim es tu sur qu'il n'y a aucun glitche ?
    Pour en revenir aux BGA oui c'est une techno extraordinaire mais très sensible, cela ne pardonne rien, le crépuscule de l'électronique.
    J'ai déjà vu beaucoup de problèmes avec les translateurs(164245), oscillations et bizarreries diverses, solution par résistances série.
    JR
    l'électronique c'est pas du vaudou!

Discussions similaires

  1. transfert thermique : puissance thermique
    Par exam dans le forum Physique
    Réponses: 10
    Dernier message: 06/10/2008, 02h25
  2. Inertie thermique VS conductivité thermique
    Par yvonic dans le forum Habitat bioclimatique, isolation et chauffage
    Réponses: 30
    Dernier message: 15/09/2008, 15h12
  3. Inertie thermique VS conductivité thermique
    Par yvonic dans le forum Physique
    Réponses: 10
    Dernier message: 29/10/2007, 19h19
  4. [THERMIQUE]panne chaudiere sintex
    Par jo27 dans le forum Dépannage
    Réponses: 0
    Dernier message: 25/09/2007, 14h29
  5. panne thermique televiseur 16/9
    Par oligo dans le forum Dépannage
    Réponses: 0
    Dernier message: 28/12/2005, 09h06
Découvrez nos comparatifs produits sur l'informatique et les technologies.