Répondre à la discussion
Page 1 sur 2 1 DernièreDernière
Affichage des résultats 1 à 30 sur 38

tension d'alimentation en sortie de l'amplificateur



  1. #1
    Langfinger

    tension d'alimentation en sortie de l'amplificateur


    ------

    Bonsoir à tous,

    alors vu que c'est mon premier message j'essaye d'être précis:
    en ce moment je réalise un montage amplificateur non-inverseur avec lequel j'essaye d'amplifier un signal rectangulaire d'environ 30mV.
    Mon composant est un TL084 et j'alimente en +10V/0V.
    Je réalise le montage exactement comme jele trouve sur Internet.
    Sauf que quand je met tout en marche quand je met mon multimètre en sortie, je trouve 9.88V DC ou pas loin de là. Donc quasiment la tension d'alimentation et non pas le signal amplifié.
    C'est également le cas quand je polarise l'entrée non-inverseuse sur 10/2=5V avec un pont diviseur, et aussi quand je mets un condensateur en sortie pour supprimer la compsante continue.
    Est ce que vous avez une idée comment je pourrais améliorer ceci.
    Voici mon schéma:

    Lien vers 02-amplificateur_de_tension_non-inverseur_03.png supprimé

    .

    -----
    Dernière modification par gienas ; 06/07/2009 à 15h06. Motif: Supprimé le lien vers un serveur tiers

  2. Publicité
  3. #2
    jiherve

    Re : tension d'alimentation en sortie de l'amplificateur

    Bonsoir,
    lien pourri!
    sans schéma pas de réponse possible.
    JR
    l'électronique c'est pas du vaudou!

  4. #3
    renardhino

    Re : tension d'alimentation en sortie de l'amplificateur

    Bonsoir,
    Vu que ton AO sature, tu as peut-être interverti la borne - de l'AO avec la borne +

  5. #4
    gcortex

    Re : tension d'alimentation en sortie de l'amplificateur

    déja le 84 a besoin d'un minimum de 3V sur les entrées
    condensateur AVANT et APRES

    2 exemples page 3 :
    http://www.gcopin.perso.cegetel.net/pdf/Ampli_audio.pdf

    on n'aime pas mon site, mais il répond à pas mal de questions

  6. #5
    Langfinger

    Re : tension d'alimentation en sortie de l'amplificateur

    Bonjour,

    merci premièrement pour vos reponses.
    Désolé pour le lien.

    Alors j'ai refait le schéma avec des condensateurs ctd. un en entrée et un en sortie. Tous les deux valent 47uF.
    J'amplifie de 12 fois. R boucle=110k et R qui va à la masse vaut 10k.
    Cependant le problème y est toujours. J'ai 8.46V en sortie quand je me mets en position V DC et calibre 20V sur mon multimètre. Si je me mets sur la position V AC du même calibre, il y a 0Volt.
    En fait j'amplifie le signal dans un premier amplificateur qui est un
    LM358 environ de 18 fois et j'attaque ensuite le TL084. En sortie du LM358, j'ai ce signal de 30mV en position V DC calibre 200mV.
    Vu que la seconde partie du LM358 est déjà prise, je me suis mis sur le TL084.
    Voici donc mon schéma:
    Dernière modification par Langfinger ; 04/07/2009 à 14h53.

  7. A voir en vidéo sur Futura
  8. #6
    Langfinger

    Re : tension d'alimentation en sortie de l'amplificateur

    Le schema:
    Images attachées Images attachées

  9. Publicité
  10. #7
    Tropique

    Re : tension d'alimentation en sortie de l'amplificateur

    Ton problème, c'est que l'entrée inverseuse est référencée à la masse, alors qu'elle devrait l'être à V/2, comme l'entrée +.
    Il y a plusieurs options pour s'en sortir, l'une étant de splitter R1 en 2x 20K, entre V+ et masse.
    Pas de complexes: je suis comme toi. Juste mieux.

  11. #8
    Langfinger

    Re : tension d'alimentation en sortie de l'amplificateur

    Bonsoir,

    merci beaucoup pour le conseil.
    J'ai donc polarisé l'entrée inverseuse sur 5V avec un pntdiviseur avec 2résistances de 10k.
    J'obtiens aux environs de 4V en sortie.
    Ce qui reste bizarre c'est que quand je fais varier la tension d'entrée de 30mV à 40mV, la sortie BAISSE de 20mV environ. (de 4.3 à 4.1 V), au lieu d'aumenter.
    De plus, si je laisse branché mon multimètre sur la sortie pendant un bon moment (1 à 2 min), la tension baisse très lentement mais elle baisse (environ 10mV tous les 3 sec)
    Vous avez une idée?

  12. #9
    Tropique

    Re : tension d'alimentation en sortie de l'amplificateur

    C'est soit un effet thermique (court-jus....?), soit une broche laissée en l'air.
    Vérifier ce qui qu'est-ce?
    Pas de complexes: je suis comme toi. Juste mieux.

  13. #10
    gcortex

    Re : tension d'alimentation en sortie de l'amplificateur

    Ton problème, c'est que l'entrée inverseuse est référencée à la masse, alors qu'elle devrait l'être à V/2, comme l'entrée +.
    j'en avais déjà parlé :

    déja le 84 a besoin d'un minimum de 3V sur les entrées
    c'est triste d'être pris pour un trisomique...


  14. #11
    Langfinger

    Re : tension d'alimentation en sortie de l'amplificateur

    j'ai refait le montage avec un TL081.
    J'ai fait cette fois ci un montage inverseur et j'ai polarisé également les entrées sur Vcc/2.
    Est ce que celui ci a besoin aussi une tension d'entrée de 3V?

  15. #12
    Tropique

    Re : tension d'alimentation en sortie de l'amplificateur

    La tension minimale est de 3V également, tous les T08x sont identiques.
    Mais dans ton cas ça ne devrait pas être un problème puisqu'avec 10V d'alim, tes entrées sont à 5V.
    As tu fait exactement comme j'ai dit: enlever la 10K d'origine et la remplacer par deux de 20K?
    Pas de complexes: je suis comme toi. Juste mieux.

  16. Publicité
  17. #13
    renardhino

    Re : tension d'alimentation en sortie de l'amplificateur

    Bonsoir,

    J'aimerais donner un son de cloche différent de celui entendu sur la valeur minimum d'une tension à l'entrée du TL084 .

    Je viens de réaliser un montage amplificateur non inverseur x10 classique avec un TL084CN de chez ST avec un signal d'entrée à peu près carré d'amplitude 0.48V et de valeur moyenne 0.38V , j'obtiens en sortie un signal d'amplitude 5.1V et de valeur moyenne 3.75 V , autrement dit ça marche pile poil .

    J'ai simplement fait le montage avec deux résistances : une entre Vs et V-, l'autre entre V- et
    la masse , V+ étant relié au signal .

    Ai-je le seul TL084 qui amplifie près de 0V ?

    Si des experts peuvent m'éclairer ...

    Bonne soirée

    J'ai jeté un oeil aux datasheet, il n'est écrit nulle part que l'amplification démarre à Vin >=3V .

  18. #14
    gcortex

    Re : tension d'alimentation en sortie de l'amplificateur

    là c'est bien écrit
    http://www.datasheetcatalog.org/data...onics/2301.pdf

    voir "Input Common Mode Voltage Range"


  19. #15
    renardhino

    Re : tension d'alimentation en sortie de l'amplificateur

    Bonjour,
    La nuit porte conseil ,
    j'alimente l'AO en -15V/+15V voilà pourquoi j'ia aucun soucis pour amplifier autour de 0V .
    A plus

  20. #16
    Langfinger

    Re : tension d'alimentation en sortie de l'amplificateur

    oui, j'ai réalisé un pont diviseur avec deux résistances de 22K parceque 20K... ça y est pas dans la série E12.
    Bref donc du coup j'ai arrangé les choses à ce que j'ai plus 30mV mais 1.084V a peu près en sortie du LM358 parce que j'ai polarisé l'entrée non-inverseuse sur Vcc/2.
    Ensuite j'ai donc polarisé l'entrée inverseuse du second amplificateur TL081avec ces 2 résisances de 22k chacune, et en sortie, j'ai 1.45V environ alors que j'ai un Av de 13.
    Concernant les condos qu'il faut mettre en entrée et en sortie de chaque ampli
    je prends quelle valeur, et comment on choisit ça?

  21. #17
    Tropique

    Re : tension d'alimentation en sortie de l'amplificateur

    Faudrait que tu postes un schéma complet actualisé, parce que là, on perd le fil.
    Pas de complexes: je suis comme toi. Juste mieux.

  22. #18
    Langfinger

    Re : tension d'alimentation en sortie de l'amplificateur

    Bon j'ai finalemnt tout refait avec deux amplis non-inverseur.
    Voici le schéma actualisé:
    Ce qui est bizarre c'est que quand je mets le condo 10uF en entrée du LM358, en sortie de ce dernier j'ai 8.54V DC.
    Et sortie du TL081 j'ai ensuite 4.5V qui ne varient pas avec le singal d'entrée Vin du LM358.
    Pour ce cas là voici le schéma avec "Cas n. 1"
    Par contre si j'enlève tous les condensateurs voilà ce qui donne le schéma du "Cas n. 2"
    Sur ce dernier schéma, j'ai la tension de sortie du Tl091 qui varie en fonction de Vin.
    Images attachées Images attachées

  23. Publicité
  24. #19
    gcortex

    Re : tension d'alimentation en sortie de l'amplificateur

    logique : tu n'as pas respecté le schéma de mon pdf (il manque un condensateur)

    pourquoi tu nous fais pas confiance ??


  25. #20
    Tropique

    Re : tension d'alimentation en sortie de l'amplificateur

    Au niveau du 358, tu as le même problème qu'avec le TL: il faut dédoubler R1, que ce soit pour le cas 1 ou 2.
    Normalement, le 2 est plus avantageux, puisque tu peux te passer d'un condensateur, mais il est évident que R4 et R5 sont superflues, elles ne font qu'ajouter une charge supplémentaire en sortie d'ampli.
    Et quand tu fais une mesure de tension DC derrière un condo, tu ne peux trouver que 0: dans le cas 1, tu trouves 4.5V vraisemblablement parce que tu fais la mesure avec un voltmètre à haute impédance. Si p.ex. il fait 10M, il va falloir un certain nombre de constantes de temps, càd un certain nombre de fois 47*10=470s avant que la mesure ne se stabilise vers sa valeur finale. Il faudrait que tu gardes tes pointes de mesure en place pour une heure, ce qui n'est pas très réaliste.
    Pas de complexes: je suis comme toi. Juste mieux.

  26. #21
    Langfinger

    Re : tension d'alimentation en sortie de l'amplificateur

    Je suppose que dédoubler signifie faire un pont diviseur avec Vcc/2 et enlver R1 qui vallait 3k.
    Est ce que ça a l'air mieux maintenant?
    Images attachées Images attachées

  27. #22
    Tropique

    Re : tension d'alimentation en sortie de l'amplificateur

    Non, c'est catastrophique, il faut juste altérer les résistances: dans le cas 2, remplacer R1 par R1'= R1"=6K, enlever R4 et R5. Si Vin n'est pas couplée en AC, rajouter un condensateur en série, mais pas ailleurs.
    Pas de complexes: je suis comme toi. Juste mieux.

  28. #23
    Langfinger

    Re : tension d'alimentation en sortie de l'amplificateur

    j'ai enlevé R4 et R5 du L358 et remplacé R1 sur chaque ampli par une résistance de 6k. (2.7+3.3)
    J'amplifie un signal qui ressemble à la première image attachée.
    Ce que j'ai compris c'est si j'amplifie en AC j'ai pas besoin des condos qui suivent les R1 c'est ça?
    En étant pas sûr, j'ai posté les deux cas avec et sans condos.
    Images attachées Images attachées

  29. #24
    Tropique

    Re : tension d'alimentation en sortie de l'amplificateur

    On ne va pas y arriver...

    Aah, Langfinger, le préféré des jouvencelles, mais le désespoir des professeurs.

    J'ai corrigé directement un des schémas, on gagnera du temps.
    Il serait aussi possible de créer une fausse masse avec un diviseur de tension commun, et y ramener toutes les résistances.
    Images attachées Images attachées
    Pas de complexes: je suis comme toi. Juste mieux.

  30. Publicité
  31. #25
    Langfinger

    Re : tension d'alimentation en sortie de l'amplificateur

    désolé pour ma lenteur.
    J'ai ainsi réalisé le schéma comme vous m'aviez dit.
    En sortie du LM358, je trouve 2.8V et en sortie du Tl j'ai 4V environ.
    Mais ça varie que de peu par rapport à l'entrée. Genre de 50mV est ce normal?

  32. #26
    Tropique

    Re : tension d'alimentation en sortie de l'amplificateur

    En théorie, en sortie du 358, il faudrait 5V. Mais 2.8V n'est pas choquant, compte tenu des tolérances, courants de polar,etc. En tous cas, il fonctionne en régime linéaire. Idem pour le TL.
    Et si tu regardes la variation en DC par rapport à l'entrée, en principe, ça ne doit pas varier du tout; les 50mV sont probablement dus au courant de fuite du condo.
    Donc, tout est normal, puisque tu dois amplifier un signal carré: tu n'as pas besoin du DC. Le gain en AC doit être de 4000, ce qui devrait être plus que suffisant pour saturer la sortie avec le signal d'entrée.
    Pas de complexes: je suis comme toi. Juste mieux.

  33. #27
    Langfinger

    Re : tension d'alimentation en sortie de l'amplificateur

    Je diminue donc l'amplification du TL pour plus faire saturer le circuit?
    Et comment j'augmente le gain à 4000?

  34. #28
    Tropique

    Re : tension d'alimentation en sortie de l'amplificateur

    Actuellement, tu as un gain de ~4000 (produit du gain des deux étages). Donc, avec en entrée un carré de 30mV càc, tu aurais 12V en sortie. Mais avec une alimentation de 10V, ce n'est pas possible.
    Conclusion, le circuit doit saturer. Si ce n'est pas le but, tu peux diminuer le gain, de préférence au niveau du premier étage, puisque c'est là que la plupart du gain est concentré. Ou tu élimines le deuxième étage, tu tomberas un peu en-dessous de 400.
    Pas de complexes: je suis comme toi. Juste mieux.

  35. #29
    Langfinger

    Re : tension d'alimentation en sortie de l'amplificateur

    Avec un condos de 10nF en entrée du LM, et avec l'ancienne résistance de boucle qui vallait 470k, je trouve 2.4V en sortie. Mais ça varie pas mal en fonction du condo que je mets.
    De plus si je diminue Rboucle, genre 82k, j'ai 4.36V en sortie qui varient environ 60mV en fonction de l'entrée.
    Pourquoi ça augmenterais alors que j'ai diminué le gain?

  36. #30
    Tropique

    Re : tension d'alimentation en sortie de l'amplificateur

    Tes mesures, tu les fais comment? Avec un oscillo? Et ta tension d'entrée, c'est le carré de 30mV?
    Pas de complexes: je suis comme toi. Juste mieux.

Sur le même thème :

Page 1 sur 2 1 DernièreDernière

Discussions similaires

  1. Mesurer la tension d'alimentation
    Par Toufinet dans le forum Électronique
    Réponses: 17
    Dernier message: 03/07/2008, 16h27
  2. chute de tension d'alimentation
    Par mystic.electronique dans le forum Électronique
    Réponses: 2
    Dernier message: 17/05/2006, 22h32
  3. Tension d'alimentation d'un PC
    Par konkombre dans le forum Matériel - Hardware
    Réponses: 3
    Dernier message: 11/01/2005, 17h07
  4. tension d'alimentation usb...
    Par jeyro dans le forum Électronique
    Réponses: 3
    Dernier message: 11/08/2004, 00h05
Découvrez nos comparatifs produits sur l'informatique et les technologies.