Répondre à la discussion
Affichage des résultats 1 à 26 sur 26

problème alim LED comprends pas ??



  1. #1
    Dizuite

    problème alim LED comprends pas ??

    Bonjour,

    Voila j'ai construit un circuit pour avoir 4 sources lumiseuses IR et 2 sources lumiseuses bleues. Ci-joint mon schéma de principe (surement faux, mais ou ?) avec les réferences des LEDs utilisées.

    A la première mise sous tension, tout a très bien fonctionné du premier coup.

    J'ai ensuite mesuré quelques tensions pour vérifier ce que j'avais prévu à l'aide d'un multimètre Chauvin Arnoud type ordinaire. A mon grand étonnement (je n'y connais pas grand-chose), j'ai fait les mesures suivantes:
    U = 3,6 V
    U2 = U3 = 1,8 V

    Depuis cette mesure, une série de 2 LEDs IR s'est arreté de fonctionner sans motif apparent. Puis en essayant de comprendre pourquoi, l'autre série s'est arrêté d'emettre également.
    Maintenant impossible de faire briller les LED IR, les mesures sont maintenant les suivantes:
    U = 4.95 V
    U2 = 4.1 V
    U3 = 0.8 V

    C'est bizarre je ne comprends pas. Je n'ai rien touché d'autre, je n'ai pas provoqué de court-jus avec les pines du voltmètre en prenant la mesure. A noter que les LEDs bleues fonctionnent toujours et ont toujours fonctionné.

    Merci pour votre aide

    -----

    Images attachées Images attachées

  2. Publicité
  3. #2
    Dizuite

    Re : problème alim LED comprends pas ??

    En fait j'ai bien une idée de ce qu'il s'est passé, mais ça me fait peur...

    J'aurais ptete dû mettre un resistor R2 = 1 ohm en série avec chacune des séries de 2 LEDs IR ?

    Mes LEDs sont mortes ? Dites-moi que non svp !

  4. #3
    DAUDET78

    Re : problème alim LED comprends pas ??

    Mettre deux LED en série et les brancher directement sur de l'USB .... tu as de la chance de n'avoir pas cramé ta prise USB !
    Tes LEDs IR sont mortes.
    Pour faire passer 20 mA, dans les deux diodes en série, il faut une résistance série de 100 ohms

    Pour info, on ne peux pas tirer plus de 100 mA sur l'USB
    L'age n'est pas un handicap .... Encore faut-il arriver jusque là pour le constater !

  5. #4
    PA5CAL

    Re : problème alim LED comprends pas ??

    Bonsoir
    Citation Envoyé par Dizuite Voir le message
    En fait j'ai bien une idée de ce qu'il s'est passé, mais ça me fait peur...

    J'aurais ptete dû mettre un resistor R2 = 1 ohm en série avec chacune des séries de 2 LEDs IR ?
    Il aurait effectivement fallu mettre une résistance ou tout autre dispositif de limitation du courant.

    Cependant je ne pense pas qu'une résistance de seulement 1 Ω puisse avoir une quelconque efficacité dans le cas présent.

    Mes LEDs sont mortes ? Dites-moi que non svp !
    La led aux bornes de laquelle tu mesures plus de 4V est bonne à jeter.

    Quant aux autres que tu as branchées sans résistance en série, elle ont dû été malmenées. Elles risquent d'avoir été fragilisées et de ne plus présenter exactement les mêmes caractéristiques. Toutefois, si ton montage n'est pas d'une extraordinaire importance, tu peux tout de même continuer à les utiliser.

    EDIT: grillé

    EDIT bis: le courant maximum pour le bus USB est 500 mA. La limite sur une prise dépend de ce qui est consommé sur les autres prises du bus.
    Dernière modification par PA5CAL ; 25/10/2009 à 17h32.

  6. #5
    Qristoff

    Re : problème alim LED comprends pas ??

    Bonsoir,
    Mes LEDs sont mortes ? Dites-moi que non svp !
    c'est sûr, elles marcheront mons bien, maintenant...
    Pourquoi ne pas avoir mis de résistance de limitation ?
    estime toi heureux de ne pas avoir pété ton port usb !
    Tout existe, il suffit de le trouver...!

  7. A voir en vidéo sur Futura
  8. #6
    DAUDET78

    Re : problème alim LED comprends pas ??

    Citation Envoyé par PA5CAL Voir le message
    EDIT bis: le courant maximum pour le bus USB est 500 mA. La limite sur une prise dépend de ce qui est consommé sur les autres prises du bus.
    FAUX ! Le courant max est de 100 mA. Après la phase d'énumération, la prise USB peut accorder 500 mA à un demandeur ... si elle peut.

    Dans son truc, il n'y a rien de branché sur les fils de data, donc 100 mA
    L'age n'est pas un handicap .... Encore faut-il arriver jusque là pour le constater !

  9. Publicité
  10. #7
    Dizuite

    Re : problème alim LED comprends pas ??

    Mettre deux LED en série et les brancher directement sur de l'USB .... tu as de la chance de n'avoir pas cramé ta prise USB !
    Tes LEDs IR sont mortes.
    Pour faire passer 20 mA, dans les deux diodes en série, il faut une résistance série de 100 ohms
    pourquoi 20mA ? je voudrais y faire passer le maximum pour avoir la plus longue portée possible. Intuitivement je pensais que le maximum était de 90mA pour 2,5 V
    après cette remarque:
    Pour info, on ne peux pas tirer plus de 100 mA sur l'USB
    le maximum serait limité par l'alim USB à savoir:
    (100 - 2 x 10) / 2 = 40 mA

    Si comprends bien la notice de la LED IR SFH486, c'est soit au minimum 1.35 V et 50 mA de consomation, soit elle s'allume pas, ou alors je comprends pas la datasheet.

    Finalement, comment dois-je réaliser mon montage pour tirer le meilleur de mes LEDs en terme de portée d'éclairage ?

    (j'en ai encore une dizaine de reserve)

  11. #8
    DAUDET78

    Re : problème alim LED comprends pas ??

    100 mA, c'est la garantie de la norme USB. En pratique, on a plus (à preuve, la destruction de tes LEDs I.R.)

    Elle commence à émettre pour quelques mA.
    Pour 100 mA, le Vf de la diode est plus petit que 1,8V
    http://www.datasheetdir.com/SFH486+I...Emitting-Diode
    Tu as mis deux LEDs en séries sur du 5V ... elles sont explosées !
    Pour 50 mA dans deux LEDs en série, R=(5-1,6-1,6)/0,050= 33 ohms

    PS: le mieux, pulsé le courant LED
    L'age n'est pas un handicap .... Encore faut-il arriver jusque là pour le constater !

  12. #9
    PA5CAL

    Re : problème alim LED comprends pas ??

    Citation Envoyé par DAUDET78 Voir le message
    FAUX ! Le courant max est de 100 mA. Après la phase d'énumération, la prise USB peut accorder 500 mA à un demandeur ... si elle peut.

    Dans son truc, il n'y a rien de branché sur les fils de data, donc 100 mA
    Oui, c'est exact.

    Si la norme est bien respectée, des courants supérieurs à 100 mA (= 1 unité de puissance USB) ne devraient pouvoir être délivrés qu'après une autorisation logicielle.


    Toutefois on trouve des appareils bon marché qui ne respectent pas ce point de la norme, et qui délivrent d'emblée les 500 mA aux circuits qui le demandent, sans faire disjoncter le port USB correspondant comme cela devrait arriver normalement.

    C'est d'ailleurs dans ce cas de figure que le port USB aurait vraiment risqué de griller à cause des leds.

  13. #10
    Dizuite

    Re : problème alim LED comprends pas ??

    Elle commence à émettre pour quelques mA.
    Pour 100 mA, le Vf de la diode est plus petit que 1,8V
    http://www.datasheetdir.com/SFH486+I...Emitting-Diode
    En fait dans la datasheet il est bien dit :
    pour If = 100 mA à t = 20 ms 1,5<Vf<1,8 V
    ce qui implique un signal periodique traversant la LED.

    Dans mon cas c'est du courant continu, et je pense que j'aurais pas la place dans mon boitier de placer les éléments nécessaires pour, je cite, : "pulser le courant d'alim"

    Quand je mets 1,35 V aux bornes d'une LED avec une alim générateur de tension continue, je mesure 50 mA

    Quand je mets 2.8 V aux bornes d'une LED avec une alim générateur de tension continue, je mesure 100 mA

    C'est ce qui m'a fait penser qu'en mettant 5 V aux bornes d'une série de 2 LEDs j'aurais 2,5 V aux bornes de chacune, et donc un peu moins de 100 mA les traversant. (Je vous ai dit que j'étais nul en éléctronique ?)



    Tu as mis deux LEDs en séries sur du 5V ... elles sont explosées !
    Pour 50 mA dans deux LEDs en série, R=(5-1,6-1,6)/0,050= 33 ohms
    Donc si je veux tirer le meilleur des mes LEDs en courant continu, je doit leur faire passer à travers 100 mA c'est juste ? Si oui, ça fonctionnerait comme ça ?
    R = (5 - 1,6 - 1,6) / 0.1 = 18 ohms
    sachant que je dispose de resistors 20 ohms

    Sachant que mon objectif c'est la portée lumineuse

  14. #11
    DAUDET78

    Re : problème alim LED comprends pas ??

    Citation Envoyé par Dizuite Voir le message
    Quand je mets 2.8 V aux bornes d'une LED avec une alim générateur de tension continue, je mesure 100 mA
    Ca ne présente aucun intérêt ce genre de mesure. Ce qui compte, c'est ce qui est garantie par la spécification

    Et alimenter une LED en tension !, je vais faire un infarctus juste avant mon départ en vacances
    C'est ce qui m'a fait penser qu'en mettant 5 V aux bornes d'une série de 2 LEDs j'aurais 2,5 V aux bornes de chacune,
    et que tes LEDs ont cramés. On ne pense pas, monsieur, on lit.
    L'age n'est pas un handicap .... Encore faut-il arriver jusque là pour le constater !

  15. #12
    Qristoff

    Re : problème alim LED comprends pas ??

    Bonjour,
    une led (de couleur ou IR) se commande en ajustant le courant et JAMAIS en appliquant une tension !!
    Le courant permanent max acceptable de cette led est 100mA et sous certaines conditions (température ambiante < 25°C, longueur de pattes inférieures à 10mm).
    Elles sont plus généralement utilisées en impulsion et dans ce cas pour un pulse:
    - de 100µs avec un rapport cyclique dc de 50%, tu peux monter à 200mA
    - de 100µs avec un rapport cyclique dc de 5%, tu peux monter à 1A ! (toujours à 25°C !)


    Mais si t'as pas la place de mettre un NE555...tant pis

    L'autre solution est de mettre un générateur de courant constant à transistor. Ce qui fait rajouter un transistor, une diode zener et deux résistance. Là, le courant serait stable dans les diodes IR quelque soit la tension d'alimentation.

    Dernière solution, la résistance seule. Mais il faut prendre Vf=1,5V à 100mA. Ce qui fait (5 - 2 x 1,5)/0,1= 20 ohms qui doivent encaisser au minimum 200mW.
    Tout existe, il suffit de le trouver...!

  16. Publicité
  17. #13
    PA5CAL

    Re : problème alim LED comprends pas ??

    Citation Envoyé par Dizuite Voir le message
    En fait dans la datasheet il est bien dit :
    pour If = 100 mA à t = 20 ms 1,5<Vf<1,8 V
    ce qui implique un signal periodique traversant la LED.
    Non. Dans la datasheet, IF=100 mA correspond bien à un courant continu, même s'il s'agit d'une valeur maximale. D'ailleurs, le graphe « Permissible Pulse Handling Capability » le prouve.

    L'indication tp=20 ms provient du fait que les caractéristiques de la led changent instantanément avec la température interne. Or, malgré la température ambiante indiquée dans les conditions de mesure (TA=25°C), la mise en fonctionnement de la led provoque son échauffement rapide, puis une stabilisation de sa température au bout d'un certain temps qui dépend de la capacité calorifique des différentes parties du composant, des résistances thermiques qui les lient et des conditions de dissipation extérieures. Dans l'intervalle, et à défaut d'une connaissance précise des caractéristiques thermiques, il est impossible de prédire la température instantanée qui règne au niveau de la jonction. Celle-ci ne peut être ni mesurée ni déterminée avec précision, et le calcul de la température moyenne (régime impulsionnel) ou finale (régime continu) n'est d'aucune utilité pour y parvenir.

    Les constructeurs en viennent donc à spécifier certaines caractéristiques mesurables, correspondant à une situation survenant un bref court instant après le début du fonctionnement (ici tp=20 ms). On ne connaît pas la température de jonction correspondant à ces valeurs, mais cela n'empêche pas d'en tenir compte et de les exploiter.

    Citation Envoyé par Dizuite Voir le message
    Dans mon cas c'est du courant continu, et je pense que j'aurais pas la place dans mon boitier de placer les éléments nécessaires pour, je cite, : "pulser le courant d'alim"
    C'est inquiétant... Auras-tu assez de place pour garantir une ventilation correcte afin de refroidir convenablement tes leds ? Parce que la température ambiante dans le boîtier conditionne directement le courant moyen maximum que tu pourras injecter dans la led.

    Par exemple, si tu ne peux pas garantir que la température à l'intérieur du boîtier restera toujours inférieure à 50°C, malgré tout ce qui chauffe dedans et même en plein été, alors ton courant IF ne devra pas dépasser 65 mA (reporte-toi au graphe « Max. Permissible Forward Current », ou considère les données TJmax=100°C et RthJA=375 K/W).

    Citation Envoyé par Dizuite Voir le message
    Quand je mets 1,35 V aux bornes d'une LED avec une alim générateur de tension continue, je mesure 50 mA

    Quand je mets 2.8 V aux bornes d'une LED avec une alim générateur de tension continue, je mesure 100 mA

    C'est ce qui m'a fait penser qu'en mettant 5 V aux bornes d'une série de 2 LEDs j'aurais 2,5 V aux bornes de chacune, et donc un peu moins de 100 mA les traversant. (Je vous ai dit que j'étais nul en éléctronique ?)
    L'erreur que tu as faite est de penser que la led était un composant linéaire (i.e. tension évoluant proportionnellement au courant), ce qui n'est pas du tout le cas.

    S'agissant avant tout d'une diode, sa caractéristique est exponentielle. Pour simplifier, on pourrait même en venir à considérer que :
    - en dessous de VF≈1,5V on a IF≈0 ,
    - pour tout courant IF>0 on a VF≈1,5V .
    De plus, la tension caractéristique VF varie d'un composant à l'autre, et évolue également en fonction de la température.

    C'est la raison pour laquelle on ne commande jamais une led à l'aide d'un générateur de tension, mais plutôt à l'aide d'un générateur de courant, ou qui présente une forte pente (géné. tension + forte résistance).

  18. #14
    Antoane

    Re : problème alim LED comprends pas ??

    Bonjour,
    Merci à Pa5cal pour ces histoires de température .

    Juste une question : lorsque l'on parle d'une caractéristique exponentielle, c'est valable dans le premier cadrant uniquement (mais dans tout le premier cadrant - tant que le composant ne grille pas), et ça ne prend pas en compte la résistance série de la diode, qui elle, dépend de la température, mais pas de If ?
    Merci pour vos explications.
    Deux pattes c'est une diode, trois pattes c'est un transistor, quatre pattes c'est une vache.

  19. #15
    PA5CAL

    Re : problème alim LED comprends pas ??

    Citation Envoyé par Antoane Voir le message
    lorsque l'on parle d'une caractéristique exponentielle (...) ça ne prend pas en compte la résistance série de la diode, qui elle, dépend de la température, mais pas de If ?
    Tu parles de la résistance dynamique interne de la led, ou bien de la résistance externe rajoutée en série avec la led par tes soins ? Ou encore d'une autre résistance ?

    Pour la première (interne), la résistance dynamique (ΔV/ΔI) dépend du courant IF et de la température de jonction TJ.

    Pour la seconde (externe), la variation de la résistance avec la température est suffisamment faible devant les autres variations du circuit pour considérer qu'elle reste constante.

  20. #16
    Antoane

    Re : problème alim LED comprends pas ??

    C'est bien de la résistance interne de la diode dont je veux parler.
    Donc Vf=A.exp(B.If)+R(If).If ; avec A et B des constances positives variant avec la température, et If->R(If) une fonction... de quel type (j'ai pas saisi le dv/di) ?
    Merci.
    Deux pattes c'est une diode, trois pattes c'est un transistor, quatre pattes c'est une vache.

  21. #17
    PA5CAL

    Re : problème alim LED comprends pas ??

    Je vois... En fait cette modélisation est tout juste bonne à être utilisée dans un simulateur.

    En pratique, pour calculer les circuits, on ne l'utilise pas. Tu remarqueras d'ailleurs que les datasheets des constructeurs ne font jamais référence à aucune des valeurs intervenant dans cette formule.

    Lorsqu'on s'intéresse à la résistance interne de la led, on parle de la résistance dynamique globale Rd, c'est-à-dire du rapport entre une petite variation de la tension et la petite variation du courant correspondante, à un point de fonctionnement donné.

    Si l'on fait un parallèle avec la formule que tu as donnée, on devrait avoir :
    ¨¨¨ Rd(IF) = ΔVF/ΔIF = A/B + R(IF)

    Mais la difficulté, c'est que pour un composant donné, les constantes A et B et la fonction R(IF) (une fois fixées des conditions supplémentaires pour garantir l'unicité de la représentation) sont difficiles à déterminer... Alors que Rd(IF) est quant à elle directement mesurable par le premier venu.

  22. #18
    Antoane

    Re : problème alim LED comprends pas ??

    Merci beaucoup !
    Deux pattes c'est une diode, trois pattes c'est un transistor, quatre pattes c'est une vache.

  23. Publicité
  24. #19
    PA5CAL

    Re : problème alim LED comprends pas ??

    Oups... j'ai écrit trop rapidement. Ta formule est fausse. C'est le courant qui est une fonction exponentielle de la tension, et pas l'inverse.

  25. #20
    PA5CAL

    Re : problème alim LED comprends pas ??

    Tu devrais donc plutôt avoir en formule du genre :

    ¨¨ VF = A.ln(1+B.IF) + R(IF).IF

    ce qui correspond à :

    ¨¨ Rd(IF) = A/(IF+1/B) + R(IF)

    .
    Dernière modification par PA5CAL ; 26/10/2009 à 10h00.

  26. #21
    Dizuite

    Re : problème alim LED comprends pas ??

    Ok j'ai tout compris l'explication Merci P45CAL j'ai compris d'ou venais mon erreur de raisonnement.

    Je pense que je vais opter pour la solution convenue avec Qristoff, à savoir:
    Dernière solution, la résistance seule. Mais il faut prendre Vf=1,5V à 100mA. Ce qui fait (5 - 2 x 1,5)/0,1= 20 ohms qui doivent encaisser au minimum 200mW.
    Donc si je veux tirer le meilleur des mes LEDs en courant continu, je doit leur faire passer à travers 100 mA c'est juste ? Si oui, ça fonctionnerait comme ça ?
    R = (5 - 1,6 - 1,6) / 0.1 = 18 ohms
    sachant que je dispose de resistors 20 ohms
    Pour se rendre compte des conditions de dissipation de chaleur, les LEDs sont montées dans des ptits trous de 5 mm percés aux extrémités d'un morceau de tuyau de pvc de 300 mm de long Phi 25 mm.

    ci-joint un ptit croquis afin d’illustrer

    Je comptais fixer le tout en bourrant de colle en baton à faire fondre dans un pistolet à colle... peut-être n'est-ce pas une bonne idée du coup ? niveau conduction thermique la colle .... :S ?
    Images attachées Images attachées
    Dernière modification par Dizuite ; 26/10/2009 à 10h32.

  27. #22
    Dizuite

    Re : problème alim LED comprends pas ??

    Ce que je n'ai pas dit, ni dessiné non plus, c'est qu'en fait il y a 2 morceaux de tuyau PVC l'un dans l'autre, et que je me suis cassé la tête à faire un système télescopique afin de pouvoir régler l'espacement entre les groupes de LED's. Ce système télescopique prend presque toute la place dans le tuyau, ajouté à cela les conditions de brasure difficiles (à l'intérieur d'un tuyau en plastoc !).

    Pour ces raisons je me vois mal ajouter encore d'autres éléments, comme le suggérait Qristoff, qui seraient techniquement difficiles à incorporer au système :
    Mais si t'as pas la place de mettre un NE555...tant pis

    L'autre solution est de mettre un générateur de courant constant à transistor. Ce qui fait rajouter un transistor, une diode zener et deux résistance. Là, le courant serait stable dans les diodes IR quelque soit la tension d'alimentation.

  28. #23
    PA5CAL

    Re : problème alim LED comprends pas ??

    J'attends la validation de ta pièce jointe.
    Citation Envoyé par Dizuite Voir le message
    Je comptais fixer le tout en bourrant de colle en baton à faire fondre dans un pistolet à colle...
    Il faut éviter que la led soit fixée mécaniquement par son boîtier en plus de la liaison rigide de ses connexions avec le circuit imprimé qui l'alimente. Les contraintes internes provenant de l'hyperstatisme de cette situation pourraient tout bonnement casser la led de façon interne.

  29. #24
    Dizuite

    Re : problème alim LED comprends pas ??

    re

    J'attends la validation de ta pièce jointe.
    Je crois qu'elle a été validée, est-elle assez Claire ?

    Crois-tu (P45CAL ou qq'un d'autre) que ça va chauffer au-dessus de 50°c ? moi je pense que non, étant donné le faible nombre de LEDs (6 en tout, 4 IR et 2 bleues), séparées en 2 groupes de 3. Dois-je selon toi (vous) revenir sur mon envie de boucher les extrémités des tubes ? (c'est moche)
    Mais si c'est vraiment nécessaire de les laisser ouverts pour extraire les calories, je m'y resoudrai.

    En ce qui concerne l'hyperstatisme, aucune crainte, je veille a laisser un degré de liberté en translation selon l'axe vertical de le LED. (le circuit à l'intérieur du tube n'est pas complètement fixe).

  30. Publicité
  31. #25
    Dizuite

    Thumbs up Re : problème alim LED comprends pas ??

    Ok j'ai tout refait avec un resistor de 20 ohms en série dans chacune des 2 branches de 2 LEDs IR. Ca à l'air de bien fonctionner. Ca chauffe pas.

    Merci pour votre aide.

    ci-joint le schéma final, et des photos IR et des photos normales.

    Je clos le sujet si je trouve comment on fait.
    Images attachées Images attachées

  32. #26
    Dizuite

    Re : problème alim LED comprends pas ??

    Je pense que c'est pertinent de donner cette info ici, au cas ou ça puisse servir à quelqu'un.

    Les LEDs IR que j'ai acheté et mise en oeuvre (OSRAM SFH486) ne se montent pas conventionellement comme les autres LEDs.

    C'est à dire que d'habitude (par convention) on a la borne (+) sur la patte la plus longue, et la borne (-) sur la patte la plus courte, du coté du méplat. (voir http://fr.wikipedia.org/wiki/Diode_%...roluminescente)

    Et bien sur ce modèle c'est l'inverse, à savoir le coté du méplat et de la patte courte est le (+), et la longue patte est le (-).

    Quand on le sait pas on galère un moment... j'ai même appelé la hotline de farnell en leur disant que leurs LEDs ne fonctionnaient pas !! La datesheet n'est pas claire du tout sur ce point.

Sur le même thème :

Discussions similaires

  1. Alim pour led 6W
    Par bidouille37 dans le forum Électronique
    Réponses: 2
    Dernier message: 24/03/2009, 06h42
  2. alim led
    Par darek dans le forum Électronique
    Réponses: 8
    Dernier message: 08/12/2007, 13h30
  3. Comprends pas
    Par elsouchka dans le forum Mathématiques du collège et du lycée
    Réponses: 9
    Dernier message: 12/11/2007, 17h33
  4. petit problème où je ne comprends pas grand chose
    Par tassin59 dans le forum Physique
    Réponses: 14
    Dernier message: 15/09/2006, 12h54