Répondre à la discussion
Affichage des résultats 1 à 10 sur 10

probleme de comparateur



  1. #1
    snap63

    probleme de comparateur


    ------

    bonjour,

    je solicite votre aide car je rencontre un petit problème pour la conception d'un petit circuit électronique.
    Alors j'ai en possession un petit système qui est composé d'une photodiode et d'un système d'amplification établi à l'aide d'ampliop lf442. j'ai donc conçu pour l'alimenter une petite alim qui délivre du -15 ; +15 et du -5 ; +5 V. celle ci marche très bien. Ensuite, après l'amplification des lf442, je souhaite comparer la tension qui en sort à une tension de référence afin d'allumer un led au dela d'un certain seuil.

    Mais en passant à la pratique sur une plaque d'essai, j'ai un petit problème: la comparaison ne se fait pas convenablement. Quand je veux comparer un petite tension, de l'ordre de 0.2V, le lm311 me force cette tension à plusieurs volts et donne n'importe quoi en sortie (même pas du +VCC ou -VCC mais 0.5 V par exemple). C'est quand je veux comparer une tension un peu plus grosse (de l'ordre de 1 ou 2 V) que le montage fonctionne bien. j'ai essayer de faire la comparaison avec le tl082, celui-ci ne m'éleve pas le tension à ses entrées mais donne quand même n'importe quoi en sortie quand la tension d'entrée est faible. Pouvez vous me dire quel est le problème svp? faut-il un comparateur spécifique pour comparer des petites tension?

    merci de m'aider, j'espere avoir été clair !

    -----
    Images attachées Images attachées  

  2. Publicité
  3. #2
    PA5CAL

    Re : probleme de comparateur

    Bonjour

    Quelques remarques rapides concernant ton schéma:
    - Le TL082 n'est absolument d'aucune utilité. Tu peux l'enlever.
    - Compte tenu de ton utilisation, la broche 7 du LM311 devrait être reliée au +5V.
    - Le LM311 n'étant alimenté qu'en ±5V, il faut que tu limites la tension d'entrée à des valeurs comprises entre -4,5V et +3V environ. Il risque de mal supporter les tensions plus élevées que peut lui fournir ton montage (AOP précédent alimenté en ±15V).

    .
    Dernière modification par PA5CAL ; 26/04/2010 à 11h24.

  4. #3
    snap63

    Re : probleme de comparateur

    Citation Envoyé par PA5CAL Voir le message
    Bonjour

    Quelques remarques rapides concernant ton schéma:
    - Le TL082 n'est absolument d'aucune utilité. Tu peux l'enlever.
    - Compte tenu de ton utilisation, la broche 7 du LM311 devrait être reliée au +5V.
    - Le LM311 n'étant alimenté qu'en ±5V, il faut que tu limites la tension d'entrée à des valeurs comprises entre -4,5V et +3V environ. Il risque de mal supporter les tensions plus élevées que peut lui fournir ton montage (AOP précédent alimenté en ±15V).

    Par ailleurs, la différence entre le -15V et la masse n'apparaît pas très clairement au niveau des symboles. Mieux vaudrait préciser.

    .
    tout d'abord, merci de me repondre,

    pour répondre à tes remarques:
    -j'ai conscience que le suiveur est ici d'aucune utilité mais en fait je souhaite connecter un pont diviseur en sortie de celui-ci. de toute façon j'ai essayé le montage sans cabler le suiveur et ça ne règle pas mon problème
    -j'ai également relié la broche 7 au + de l'alimentation via un resistance, c'est un oubli sur le shéma!
    -tu me conseillerais donc d'alimenter le lm311 en + et -15 V ... je viens d'essayer, ça a le mérite de ne plus forcer ses entrées à une tension .. merci. mais le problème en sortie reste !
    -effectivement c'est peu etre pas très net mais il y a marqué VSS pour le -15V, -5V pour le -5V, et rien pour la masse ...

  5. #4
    PA5CAL

    Re : probleme de comparateur

    Citation Envoyé par snap63 Voir le message
    -j'ai conscience que le suiveur est ici d'aucune utilité mais en fait je souhaite connecter un pont diviseur en sortie de celui-ci.
    Même avec un pont diviseur, on peut s'en passer.
    Citation Envoyé par snap63 Voir le message
    -j'ai également relié la broche 7 au + de l'alimentation via un resistance, c'est un oubli sur le shéma!
    Pas besoin de résistance. Une connexion directe convient parfaitement puisque tu limites le courant sur la sortie #1.
    Citation Envoyé par snap63 Voir le message
    le problème en sortie reste !
    Comme le principe est correct une fois les modifications effectuées, il faudrait vérifier qu'on a bien les valeurs de tension et de courant auxquelles on doit s'attendre tout le long de la chaîne, depuis l'entrée du premier AOP du LF442 jusqu'à l'entrée du LM311.

    Les courants de sortie (ou plus exactement les puissances dissipées) et les tensions d'entrée et de sortie ne doivent pas dépasser les limites prévues.

    Un oscilloscope ou un voltmètre alternatif permettraient de vérifier que le montage n'entre pas en oscillation.

    Si le problème n'apparaît pas clairement (saturation, oscillation, erreur de câblage), alors il est probable que l'un des composants soit défectueux (c'est d'autant plus plausible que le LF442 est très sensible aux décharges électrostatiques, et que l'entrée du LM311 a peut-être été malmenée).

  6. A voir en vidéo sur Futura
  7. #5
    snap63

    Re : probleme de comparateur

    Citation Envoyé par PA5CAL Voir le message
    Pas besoin de résistance. Une connexion directe convient parfaitement puisque tu limites le courant sur la sortie #1.
    http://www.datasheetcatalog.org/data...onics/4848.pdf
    la broche 7 du lm311 c'est la sortie, je ne vais pas la relier au +VCC direct ??!!
    Dernière modification par snap63 ; 26/04/2010 à 12h43.

  8. #6
    PA5CAL

    Re : probleme de comparateur

    Citation Envoyé par snap63 Voir le message
    http://www.datasheetcatalog.org/data...onics/4848.pdf
    la broche 7 du lm311 c'est la sortie, je ne vais pas la relier au +VCC direct ??!!
    Si !

    Sur le LM311, la sortie est composée de deux broches, reliées de part et d'autre d'un transistor NPN en interne. La broche #7 correspond au collecteur, et la broche #1 à l'émetteur.

    On peut donc relier #1 à un potentiel négatif et se servir de #7 comme sortie absorbant un courant (<-), ou bien relier #7 à un potentiel positif et se servir de #1 comme sortie produisant un courant (->).

    L'utilisation que tu fais de la sortie du comparateur correspond à ce second cas de figure, qui apparaît notamment sur la première page de cette autre datasheet (deuxième ligne de schémas, à gauche).

    .
    Dernière modification par PA5CAL ; 26/04/2010 à 13h02.

  9. Publicité
  10. #7
    snap63

    Re : probleme de comparateur

    Citation Envoyé par PA5CAL Voir le message
    Si !

    Sur le LM311, la sortie est composée de deux broches, reliées de part et d'autre d'un transistor NPN en interne. La broche #7 correspond au collecteur, et la broche #1 à l'émetteur.

    On peut donc relier #1 à un potentiel négatif et se servir de #7 comme sortie absorbant un courant (<-), ou bien relier #7 à un potentiel positif et se servir de #1 comme sortie produisant un courant (->).

    L'utilisation que tu fais de la sortie du comparateur correspond à ce second cas de figure, qui apparaît notamment sur la première page de cette autre datasheet (deuxième ligne de schémas, à gauche).

    .
    ok je viens de tester ta solution => même comportement

    mais je viens de remarquer quelque chose:
    -quand le montage ne fonctionne pas correctement, la valeur de la tension en sortie évolue en fonction de se qu'il y a en entrée, je m'explique: la tension en sortie évolue proportionnellement à la tension en entrée quand je tourne le potar. dans ce cas le montage ne fonctionne donc pas du tout en comparateur...
    -de plus, le comparateur fonctionne bien (c'est à dire donne une tension de sortie égale à +VCC ou à 0V) dès lors que je lui déconnect soit le pond diviseur, soit la sortie du lf442. Mais si ces deux signaux sont connéctés simultanément, ca fait n'importe quoi...

    bon c'est pas simple a expliquer, je n'arrive pas a croire que je n'arrive pas à faire fonctionner un simple comparateur !!!

  11. #8
    Qristoff
    Animateur Électronique

    Re : probleme de comparateur

    Bonjour,
    le fonctionnement le plus simple étant de mettre la broche 1 à la masse et de placer la led (dans le bon sens !) et sa résistance entre le +5V et la sortie pin 7.

    Le LM311 est branché entre +5V et -5V, c'est ça ?

    Quelles sont les valeurs des résistances du pont R4/R5/RV2 ?
    Tout existe, il suffit de le trouver...!

  12. #9
    snap63

    Re : probleme de comparateur

    Citation Envoyé par Qristoff Voir le message
    Bonjour,
    le fonctionnement le plus simple étant de mettre la broche 1 à la masse et de placer la led (dans le bon sens !) et sa résistance entre le +5V et la sortie pin 7.

    Le LM311 est branché entre +5V et -5V, c'est ça ?

    Quelles sont les valeurs des résistances du pont R4/R5/RV2 ?
    bonjour,

    le lm311 était effectivement branché en +5 et -5 V mais après les conseils de PA5CAL je l'alimente en -15V +15V finalement. J'avais essayé aussi le montage que tu proposes mais sans résultats!

    R4=680
    rv2=2k
    R5=24k

  13. #10
    snap63

    Re : probleme de comparateur

    J'ai trouvé !!! Enfin PA5CAL a trouvé!!!

    en fait comme il me l'a dit le montage entrait en oscillation (en sortie des lf442 j'avais 12.5V AC sur le voltmètre)

    J'ai donc mis un filtre et comme par magie plus de problèmes

    MERCI à vous deux pour m'avoir aidé

    bonne journée !!!

Discussions similaires

  1. problème de comparateur
    Par snap63 dans le forum Électronique
    Réponses: 1
    Dernier message: 23/04/2010, 17h19
  2. Comparateur
    Par michielsce dans le forum Électronique
    Réponses: 1
    Dernier message: 25/04/2009, 20h13
  3. Problème à propos d'un comparateur
    Par faucon_de_fer dans le forum Électronique
    Réponses: 6
    Dernier message: 13/04/2008, 17h11
  4. comparateur
    Par tatia27 dans le forum Électronique
    Réponses: 2
    Dernier message: 26/02/2006, 16h40
  5. Comparateur ???
    Par flyingman dans le forum Électronique
    Réponses: 1
    Dernier message: 31/01/2005, 21h09
Découvrez nos comparatifs produits sur l'informatique et les technologies.