Répondre à la discussion
Affichage des résultats 1 à 5 sur 5

Parasite sur capteur niveau d'eau



  1. #1
    graindemais

    Parasite sur capteur niveau d'eau


    ------

    Bonjour,

    J'ai réalisé un automate pour gérer un aquarium, éclairage, température, filtre, brassage et osmolation programmé en Mikropascal (voir post "Horloge DS1307 (Résolu)").

    L'ensemble fonctionne correctement lors de la phase de test, mais une fois mis en place sur l'aquarium, je constate que le capteur de niveau a un fonctionnement erratique du à la proximité de la rampe d'éclairage (2 tubes T5 de 39w avec ballast électronique).

    Le capteur est constitué de deux électrodes en carbone, environ 1.5m de câble électrique jusqu'à l'automate et un transistor (voir schéma ci-joint).

    Comment est-il possible de protéger le capteur contre les parasites émis par la rampe d'éclairage ?

    Merci pour votre aide.

    -----
    Images attachées Images attachées

  2. Publicité
  3. #2
    DAUDET78

    Re : Parasite sur capteur niveau d'eau

    Pas génial ton schéma ...... c'est une antenne à parasite
    Tu peux mettre un 0,47µF entre tes deux sondes carbones. Ca devrait le calmer !
    J'aime pas le Grec

  4. #3
    gienas

    Re : Parasite sur capteur niveau d'eau

    Citation Envoyé par graindemais Voir le message
    ...
    Comment est-il possible de protéger le capteur contre les parasites émis par la rampe d'éclairage ? ...
    Bonsoir à tous

    Tu pourrais commencer par 100 nF en parallèle sur R1.

    Tu peux continuer par 100 nF à 470nF sur R2.

    Si cela ne suffit pas, tu peux essayer entre 0,1 et 1 microfarad aux bornes d'arrivée du capteur sur le montage.

    Si cela ne résoud rien, il faudra se résoudre à modifier le schéma et peut-être le câblage.

  5. #4
    graindemais

    Re : Parasite sur capteur niveau d'eau

    Bonsoir,

    Merci pour ces réponses rapides.
    Je vais voir demain ce que j'ai en stock sinon, je passe chez mon fournisseur local demain soir.
    Et je vous tiens au courant des résultats...

  6. #5
    graindemais

    Re : Parasite sur capteur niveau d'eau (Résolu)

    Bonsoir,

    J'ai essayé ce soir avec un 0,47µF au niveau des deux électrodes et les premiers résultats sont concluants.

    Je ferais remettrais tous en place ce weekend pour les essais définitifs.

    Merci pour votre aide. simple et rapide.

  7. A voir en vidéo sur Futura

Sur le même thème :

Discussions similaires

  1. Capteur niveau d'eau
    Par sfaxienskiller dans le forum Électronique
    Réponses: 6
    Dernier message: 21/02/2012, 09h49
  2. Capteur niveau d'eau
    Par Lucas41 dans le forum TPE / TIPE et autres travaux
    Réponses: 2
    Dernier message: 21/02/2012, 00h38
  3. Capteur CO2, Temp, Niveau liquide, éléctroaimant sur relai ?
    Par mlevain dans le forum Électronique
    Réponses: 2
    Dernier message: 04/02/2008, 21h42
  4. [Blanc] Niveau d'eau sur Miele G660
    Par bilot dans le forum Dépannage
    Réponses: 1
    Dernier message: 15/01/2007, 17h40
  5. probleme de niveau d'eau sur ml baucknet was1400
    Par ciel dans le forum Dépannage
    Réponses: 6
    Dernier message: 13/01/2005, 22h02
Découvrez nos comparatifs produits sur l'informatique et les technologies.